pm-utils Conflicts with laptop-mode-tools, so installing laptop-mode-tools breaks suspend

Bug #638307 reported by manequin on 2010-09-14
240
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Laptop Mode Tools
Undecided
Unassigned
laptop-mode-tools (Ubuntu)
High
Unassigned
Natty
High
Unassigned
pm-utils (Debian)
Fix Released
Unknown
pm-utils (Ubuntu)
Low
Martin Pitt
Natty
Undecided
Unassigned

Bug Description

->for natty we should merge l-m-t, that has renamed its file.

--

Binary package hint: laptop-mode-tools

When I try to install laptop-mode-tools on Maverick, I have to remove pm-utils (which is recommended package for laptop-mode-tools), and if I do this, I can't put laptop into suspend, because scripts needed to do that were removed with pm-utils package.

When trying to suspend without pm-utils package I get this error:

Computer failed to suspend.
Failure was reported as: Failed to spawn: Failed to execute child process "/usr/sbin/pm-suspend" (No such file or directory), stdout:(null), stderr:(null)

manequin (manequin89) on 2010-09-14
description: updated
Alex Jones (alex.jones) wrote :

Until this is fixed, a workaround is to downgrade pm-utils to the version in Lucid:

1) uninstall pm-utils
2) install the Lucid version from http://packages.ubuntu.com/lucid/all/pm-utils/download
3) install laptop-mode-tools as normal

Clint Byrum (clint-fewbar) wrote :

Marking as Confirmed, as this happened to me, and it also has at least one duplicate bug report.

In discussing this with Martin Pitt, he felt that it would be better to move any functionality l-m-t has that pm-utils does not have into pm-utils, and remove laptop-mode-tools

Also, setting Importance of this bug to High. Upon installing laptop-mode-tools, this totally breaks suspend which is bad enough. I recently did so, and then closed the lid, not thinking that suspend would be affected, and put the laptop in my backpack. 20 minutes later the aluminum case of the laptop was so hot it nearly burned my fingers pulling it out to shut the power down.

Changed in laptop-mode-tools (Ubuntu):
status: New → Confirmed
importance: Undecided → High

On 11/15/2010 01:15 PM, Clint Byrum wrote:
> In discussing this with Martin Pitt, he felt that it would be better to
> move any functionality l-m-t has that pm-utils does not have into pm-
> utils, and remove laptop-mode-tools
>

As the Maintainer, I would like to know what is wrong with l-m-t ?

--
Ritesh Raj Sarraf | http://people.debian.org/~rrs
Debian - The Universal Operating System

It seems that l-m-t conflicts with pm-utils, and so, it must be a reimplementation of some of the pieces of pm-utils.

Therefore, it would probably make more sense to merge the two rather than carry on a parallel effort.

While that is being considered, a good reason to suggest removing it from Ubuntu is to prevent against people accidentally disabling suspend capabilities on their systems while trying to do something as simple as improving battery life by installing something that sounds pretty good (laptop tools, cool!).

I don't think the problem is with the laptop-mode-tools. I think this
the problem is with the pm-utils. I say this because the only way that i
can run NVIDIA proprietary drivers is removing the pm-utils 1.4.1-3
(because crashes wiht this drive when in battery mode even without
laptop-mode-tools installed). But pm-utils 1.3.0-1 work fine with NVIDIA
proprietary drivers (on my asus with a Geforce GT 320M) even with
laptope-mode-tools installed (solution by Adam Bull in #1)

Ter, 2010-11-16 às 04:55 +0000, Ritesh Raj Sarraf escreveu:
> On 11/15/2010 01:15 PM, Clint Byrum wrote:
> > In discussing this with Martin Pitt, he felt that it would be better to
> > move any functionality l-m-t has that pm-utils does not have into pm-
> > utils, and remove laptop-mode-tools
> >
>
> As the Maintainer, I would like to know what is wrong with l-m-t ?
>
> --
> Ritesh Raj Sarraf | http://people.debian.org/~rrs
> Debian - The Universal Operating System
>

I don't think the problem is with the laptop-mode-tools. I think this
the problem is with the pm-utils. I say this because the only way that i
can run NVIDIA proprietary drivers is removing the pm-utils 1.4.1-3
(because crashes wiht this drive when in battery mode even without
laptop-mode-tools installed). But pm-utils 1.3.0-1 work fine with NVIDIA
proprietary drivers (on my asus with a Geforce GT 320M) even with
laptope-mode-tools installed (solution by Adam Bull in #1)

On 11/16/2010 11:55 AM, Clint Byrum wrote:
> It seems that l-m-t conflicts with pm-utils, and so, it must be a
> reimplementation of some of the pieces of pm-utils.
>

As part of Debian, we have a dependency on pm-utils to inovke lmt on
resume. I am not sure why Ubuntu put a conflict on lmt.

Since it is the broken dependency that breaks user's suspend, not lmt,
it is upto Ubuntu to decide if they want to ship or not.

The bug title is incorrect. LMT does NOT break suspend. It is the broken
packaging.

Ritesh

--
Ritesh Raj Sarraf | http://people.debian.org/~rrs
Debian - The Universal Operating System

Ritesh, I see your point, thanks for the feedback.

I've altered the title to make it clear that the conflict with pm-utils in the packaging causes the issue.

summary: - Laptop-mode-tools breaks suspend
+ Conflict with pm-utils makes laptop-mode-tools package break suspend
dunsun (dunsun-seznam) wrote :

I was hit by this bug too.
Wanted to install laptop-mode-tools but could not.

andre vion (gcu-grey-area) wrote :

I'm experiencing the same issues.

I have laptop-mode-tools already installed.

Even if I try to install lucid pm-utils (1.3.0), apt wants to remove laptop-mode-tools.

Would removing lmt first, instal lucid pmu then re-install lmt work?

I'm hesitant as I've fully setup lmt *.conf files. (took me 3 hours *newb alert.)

James (loope) wrote :

I re-rolled the pm-utils package to not conflict with laptop-mode tools. It's just an ugly hack, but it's working on my machine.

andre vion (gcu-grey-area) wrote :

It still wants to remove lmt on my machine. Should I let it, then try re-install?

James (loope) wrote :

I just uninstalled pm-utils, installed laptop-mode-tools, and then 'dpkg -i pm-utils_1.4.1-3_all.deb'.

I removed the conflict from the control file and deleted power.d/laptop-mode-tools from the installation (which is provided by lmt).

I tested on 10.10 64bit

Sundberg Pauli (susundberg) wrote :

Confirm that the 1.4.1-3_all.deb trick works also on 10.10 32bit

On 12/19/2010 12:00 AM, James wrote:
> I re-rolled the pm-utils package to not conflict with laptop-mode tools.
> It's just an ugly hack, but it's working on my machine.
>
> ** Attachment added: "pm-utils_1.4.1-3_all.deb"
> https://bugs.launchpad.net/ubuntu/+source/laptop-mode-tools/+bug/638307/+attachment/1769623/+files/pm-utils_1.4.1-3_all.deb
>

And may be you might want to put an automated pm-utils ppa kind of stuff.
Do PPAs track new package releases and do an auto build ?

And like I mentioned earlier, currently we do rely on pm-utils during
swsusp resume.
Hopefully I will change it soon.

Ritesh

--
Ritesh Raj Sarraf | http://people.debian.org/~rrs
Debian - The Universal Operating System

The package James posted works well for me as well, on Ubuntu 10.10 64bit. Suspend works again on my HP Envy 14. My battery life has not improved dramatically, but I haven't yet tried to optimize laptop-mode.conf.

Chad

Bryce Harrington (bryce) on 2011-01-12
tags: added: maverick natty
Changed in laptop-mode-tools (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2011-01-12
summary: - Conflict with pm-utils makes laptop-mode-tools package break suspend
+ Please remove/blacklist laptop-mode-tools. Conflict with pm-utils makes
+ laptop-mode-tools package break suspend

I too got hit by this and lost a few hours in debugging it.

laptop-mode-tools is old cruft... its description makes it sound much more useful than I gather it actually is, and given that this particular bug has been open for over a year indicates it's not likely to get fixed.

Since installation of this package has rather severe consequences (which I've verified on two of my own machines), I think we should go ahead and just drop it from the archive.

If there are any other bits in lmt worth retaining, I suppose people can file bugs to get them moved into pm-utils as appropriate.

Bryce Harrington (bryce) wrote :

FWIW, I notice there has been an out-standing merge request in progress for newer lmt:
https://bugs.launchpad.net/ubuntu/+source/laptop-mode-tools/+bug/602881

May want to review before dropping the package.

Sundberg Pauli (susundberg) wrote :

To point out why laptop mode tools is essential for me:

I originally had to install the laptop-mode-tools to spin-down my non-flash HD on my laptop. Root file system and /home are installed on separate flash HD that is installed on cd-rom slot. Without laptop mode tools the sda (non flash) kept spinning, making (loud) noise and consuming battery. It was unacceptable.

IF pm-utils can handle this, mayby we should also update wiki pages:
https://wiki.ubuntu.com/PowerManagement#How%20to%20get%20disks%20to%20spin%20down%20and%20idle%20correctly%20%28without%20excessive%20load%20cycling%29

Colin Watson (cjwatson) wrote :

Ritesh, the conflict was in fact added in Debian experimental:

pm-utils (1.4.1-2) experimental; urgency=low

  [ Matt Zimmerman ]
  * debian/control: Conflicts/Replaces: laptop-mode-tools, as both ship
    /usr/lib/pm-utils/power.d/laptop-mode and the changelog below indicates
    these two packages should not be used together anyway. (LP: #606160)

 -- Martin Pitt <email address hidden> Sun, 22 Aug 2010 17:21:49 +0200

pm-utils (1.4.1-1) experimental; urgency=low

  [ Michael Biebl ]
  * New upstream release. (Closes: #588587)
    The main improvement is that this ships some generally useful power
    management hooks by default. Note that this conflicts with similar
    packages such as laptop-mode-tools or pm-utils-powersave-policy, so you
    should not enable them and pm-utils at the same time.
[...]

Thus this is going to have to be resolved in Debian as well at some point ...

summary: - Please remove/blacklist laptop-mode-tools. Conflict with pm-utils makes
- laptop-mode-tools package break suspend
+ pm-utils Conflicts with laptop-mode-tools, so installing laptop-mode-
+ tools breaks suspend
Colin Watson (cjwatson) wrote :

Retitling and unsubscribing ubuntu-archive, since with all due respect to Bryce the correct course of action is not clear to me yet. There is clearly a problem, but since some users are still reporting that they need laptop-mode-tools, I'm uncomfortable with simply removing the package.

pdxMobile (luv2whitewater) wrote :

I am also having the same problem with my ThinkPad T60. Without LMT, the battery life is horrendous. I am sure I can tweated the system without LMT to act like LMT exist. However, after a day of configuring the system with just pm-utils didn't produce any positive result like LMT provides.

Conflict is as follow:
  - Try installing LMT but Software Centre advise to remove pm-utils.
  - Remove pm-utils will disable suspense mode which is also very important.

So basically only either one tool is not a solution for ppl with a laptop (or at least my laptop). Do ppl just use Ubuntu for their laptop?! Would love to see the "urgency" set to higher.

Thanks for listening to my mumbling.

Alex Jones (alex.jones) wrote :

Same here. Installing and configuring LMT on my Eee PC 1005HA significantly improved battery life over the stock pm-utils. I was actually surprised it wasn't installed by default. Possible solutions:

1) Implement the battery-saving tricks of LMT in pm-utils.
2) Include the pm-utils suspend script in the LMT package.
3) Just don't mark them as conflicted: I have LMT installed with pm-utils 1.3.0, and haven't noticed any problems.

Changed in laptop-mode-tools (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
cement_head (andorjkiss) wrote :

I also think this bug is definitely with pm-utils, if pm-utils is meant to replace l-m-t. Using 10.04.1 LTS and NOT having l-m-t installed, I cannot suspend with the lid on AC power. If I install l-m-t and choose enable acpi-support and configure laptopmodetools.conf to use acpi on ac and with lid closed on AC everything works as per Karmic.

Here's my bug information attached to this bug report: https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/372824

This bug is just a reflection of what has also been done in debian. I'd
suggest users to comment there too. Debian bug #612710
By splitting pm-utils we can fix this problem.

I also released 1.56 which now better relies on udev for its invocation.

Sent from Galaxy S Android
On Feb 17, 2011 7:07 PM, "cement_head" <email address hidden> wrote:
> I also think this bug is definitely with pm-utils, if pm-utils is meant
> to replace l-m-t. Using 10.04.1 LTS and NOT having l-m-t installed, I
> cannot suspend with the lid on AC power. If I install l-m-t and choose
> enable acpi-support and configure laptopmodetools.conf to use acpi on ac
> and with lid closed on AC everything works as per Karmic.
>
> Here's my bug information attached to this bug report:
> https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/372824
>
> --
> You received this bug notification because you are subscribed to laptop-
> mode-tools in ubuntu.
> https://bugs.launchpad.net/bugs/638307
>
> Title:
> pm-utils Conflicts with laptop-mode-tools, so installing laptop-mode-
> tools breaks suspend
>
> Status in “laptop-mode-tools” package in Ubuntu:
> Triaged
> Status in “laptop-mode-tools” source package in Natty:
> Triaged
>
> Bug description:
> Binary package hint: laptop-mode-tools
>
> When I try to install laptop-mode-tools on Maverick, I have to remove
> pm-utils (which is recommended package for laptop-mode-tools), and if
> I do this, I can't put laptop into suspend, because scripts needed to
> do that were removed with pm-utils package.
>
> When trying to suspend without pm-utils package I get this error:
>
> Computer failed to suspend.
> Failure was reported as: Failed to spawn: Failed to execute child process
"/usr/sbin/pm-suspend" (No such file or directory), stdout:(null),
stderr:(null)
>
>

Robbie Williamson (robbiew) wrote :

Re-assigning to Desktop

Changed in laptop-mode-tools (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

We don't support laptop-mode-tools. Let's get this handled on the Debian side.

Changed in laptop-mode-tools (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Triaged → Won't Fix
Changed in pm-utils (Debian):
status: Unknown → Won't Fix
John Cordey (cap86) wrote :

On 12/19/2010 12:00 AM, James wrote:
> I re-rolled the pm-utils package to not conflict with laptop-mode tools.
> It's just an ugly hack, but it's working on my machine.
>
> ** Attachment added: "pm-utils_1.4.1-3_all.deb"
> https://bugs.launchpad.net/ubuntu/+source/laptop-mode-tools/+bug/638307/+attachment/1769623/+files/pm-utils_1.4.1-3_all.deb
>

before doing this, i had lmt installed without pm-utils and with no possibility to suspend. After installing this package together with lmt caused on my computer a 1-2W higher need of power. means my 9-cell battery lastes instead up to 10-11h only up to 8-9h.

James (loope) wrote :

I'm not sure what impact pm-utils may have on battery life. I made no modification of the package besides removing a conflicting script (that existing in the other package as well).

dfalk (dfalk) wrote :

This is still broken in 11.04 as of alpha3. My laptop refuses to suspend with Natty installed because of this.

John Cordey (cap86) wrote :

I just noticed that the significant higher power consumption only happens after my computer wakes up from suspend modus. Before going to Suspend Modus it's only little difference, if there is some.

Martin Pitt (pitti) wrote :

dfalk [2011-03-11 16:24 -0000]:
> This is still broken in 11.04 as of alpha3. My laptop refuses to
> suspend with Natty installed because of this.

Can you please also report this as a kernel bug? Everything that
pm-utils or lmt can do here is just a workaround..

Thanks,

Martin

ceg (ceg) wrote :

Laptop-mode-tools is a well tested, supported and proven package to configure the system wide power management.

However, instead of using/extending system wide power management solutions ubuntu lets gnome apps call powermanagent functions directly. And then they cripple down the system wide power management configuration facilities, to not work as designed.

I don't know why ubuntu devs do repeatedly try to copy some stuff from it and implement a session-only, desktop-only "replacements". They failed everytime. If not in making a fully functional release without the infamous excessive load cycle bug, then in maintaining it over time.

Make use of l-m-t, make a frontend, improve it, add a dbus feature to it or whatever.
But please stop to come up with those dumbed down "replacements" and breaking the regular behavior leading to bugloads of problems.

No GUI (or Desktop Power Manager) tool should ever assume it is taking care of all power saving measures itself exclusively and warrant to disable other cripple down other packages.

ceg (ceg) wrote :

There is nothing wrong with laptop-mode-tools.

There should be a pm-utils-base package that should be designed to cooperate in the usual way with other solutions.
And there may be a pm-utils-laptop_mode package that may conflicts with laptop-mode-tools, but can be seamlessly replaced by the full laptop-mode-tools. (reopen debbugs #612710)

Martin Pitt (pitti) wrote :

ceg [2011-03-17 16:01 -0000]:
> I don't know why ubuntu devs do repeatedly try to copy some stuff from
> it and implement a session-only, desktop-only "replacements".

We didn't. upower is used in all major distros these days, and it
uses pm-utils (which again all major distros use). l-m-t is not a
replacement for pm-utils, they just overlap on one thing right now.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Martin Pitt (pitti) wrote :

Closing natty task of pm-utils. The pm-utils side of this is to remove the Conflicts to l-m-t once l-m-t drops the conflicting power management hooks. So this is blocked on l-m-t.

Changed in pm-utils (Ubuntu Natty):
status: New → Won't Fix
Changed in pm-utils (Ubuntu):
status: New → Triaged
importance: Undecided → Low
ceg (ceg) wrote :

Looking forward, what specific hook are you suggesting l-m-t to drop?

If pm-utils and l-m-t don't overlap, why is the l-m-t package in ubuntu patched to have incomplete hooks and have so many "not-working" bugs?

Do the ubuntu tools installed by default do any power management if nobody is logged in?

Where do the ubuntu tools allow to configure all system wide settings that compose a decent laptop-mode operation like l-m-t allows it? Note that the optimal config is different according to the use-case.

On 03/17/2011 10:14 PM, Martin Pitt wrote:
> Closing natty task of pm-utils. The pm-utils side of this is to remove
> the Conflicts to l-m-t once l-m-t drops the conflicting power management
> hooks. So this is blocked on l-m-t.
There's only one hook that we install in pm-utils. And that was to
trigger lmt on resume with the help of pm-utils.
With 1.57, I've already dropped that reliance on pm-utils (and also
acpid). The pm-utils hook is still shipped and depending on what
infrastructure is available (pm-utils/acpid/kernel events), we trigger
lmt (with proper locking and not triggering the same again).

Whether to use lmt or not is a choice you and your users should make.
Same goes in Debian too. I have no plans to re-open that bug (612710).
lmt has been around for quite some time and is very customizable. I
didn't like the idea of putting a Conflicts on lmt. Both do similar jobs
but in different ways.
pm-utils assumes a user is dumb so shouldn't customize anything. We go
with sane defaults but leave it to the user to change as he/she wants.

--
Ritesh Raj Sarraf
RESEARCHUT - http://www.researchut.com
"Necessity is the mother of invention."

ceg (ceg) wrote :

There is http://bugs.debian.org/614861 as well.

Laptop-mode-tools provides a very well maintained, configurable and supported solution for the laptop_mode. It also provides valuable diagnostic tools to identify the origins of disk activity.

How could a real integration of the system and desktop world look like, here?

A switch that determines if the laptop-mode tools settings or the settings of the active desktop session should have precedence?
(The pm-utils laptop_mode script used to check for l-m-t and let it take care, however, at the same time l-m-t package was patched to not be triggerd as designed.)

L-m-t using gconf settings, if available?

The desktop service to access l-m-t settings?

Ritesh Raj Sarraf (rrs) wrote :

On 03/18/2011 07:10 PM, ceg wrote:
> There is http://bugs.debian.org/614861 as well.
>
Thanks ceg. I didn't know of this bug report. :-)
I'm glad lmt users are asking for this conflict to be removed.

--
Ritesh Raj Sarraf
RESEARCHUT - http://www.researchut.com
"Necessity is the mother of invention."

ceg (ceg) wrote :

> With 1.57, I've already dropped that reliance on pm-utils ... depending on what
> infrastructure is available (pm-utils/acpid/kernel events), we trigger
> lmt (with proper locking and not triggering the same again).

Then what is the conflict here?

Pm-utils ships a suspend infrastructure and scripts (directory tree for hooks), and l-m-t hooks into them providing sensible human-readable configuration options.

Pm-utils also includes a bare-bone laptop_mode script (like ubuntu-laptop and acpi-support did before, and have dropped again before). Did the pm-util laptop_mode script stop to check whether the laptop-mode-tools is installed?

How can there be a confict between the pm-utils package that provides the hooking facilities and any package that installs hooks into it?

Shouldn't this be avoidable by the ordering of the hooks (i.e. by providing an early 00-build-in-pm-utils-laptop_mode that gets overridden by later hooks, or no-ops). Or alternatively, by l-m-t installing its hooks under /etc/ overriding the hooks under /lib?

Martin Pitt (pitti) wrote :

> Then what is the conflict here?

First the functional one (both pm-utils and l-m-t configure power saving stuff, and some of this overlaps. However, I can drop the conflicts for this part.

More importantly there's the file conflict on /usr/lib/pm-utils/power.d/laptop-mode which is still an issue in current natty. It was fixed in l-m-t 1.55, so I versioned the conflicts in Debian packaging now so that in sid the two are co-installable again.

Note that I do not give any guarantees that the two packages will actually work together sensibly, but it seems that you tested this already.

Changed in pm-utils (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

So for natty we should merge l-m-t.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pm-utils - 1.4.1-7

---------------
pm-utils (1.4.1-7) unstable; urgency=low

  * debian/control: Version the laptop-mode-tools conflicts to << 1.55, as
    from that version on the /usr/lib/pm-utils/power.d/laptop-mode was
    renamed, thus avoiding the file conflict. (Closes: #612710, LP: #638307)

pm-utils (1.4.1-6) unstable; urgency=low

  * Upload to unstable.
 -- Martin Pitt <email address hidden> Fri, 18 Mar 2011 17:25:56 +0100

Changed in pm-utils (Ubuntu Natty):
status: Won't Fix → Fix Released
ceg (ceg) wrote :

Then again, maybe the conflict is justified and l-m-t should just provide a drop in replacement for the /etc/pm/ and /usr/lib/pm hook directory structure. While pm-utils-core provides suspend functions, and might even suggest l-m-t for as a functional and configurable alternative.

ceg (ceg) wrote :

My last comment obviously crossed with yours Martin. I'm sure any functional conflicts or optimizations (locking) can be sorted out as well over time.

Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package laptop-mode-tools - 1.57-1ubuntu1

---------------
laptop-mode-tools (1.57-1ubuntu1) natty; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/rules: Do not ship acpi/apm scripts (we handle that ourselves)
  * Drop previous Ubuntu changes for /etc/default/laptop-mode. We don't
    install this package by default any more for a long time, so if people
    install it manually they presumably want to install it. 1.53 added its own
    global enable/disable switch, so this is obsolete, too.
  * This version removes the file conflict with pm-utils. (LP: #638307)

laptop-mode-tools (1.57-1) unstable; urgency=low

  * New Upstream Release
    + Pass calling application's arguments to the main function. Thanks to
      Radek for the report and the patch
    + Use governor policy from the config file. Thanks to Michael Orlov for
      the report.
    + Enable ENABLE_AUTO_MODULES by default. When a user installs the package,
      the first immediate expectation is to see some changes
    + USB suspend interface has changed with kernels 2.6.35 and above.
      (Closes: #589000)
    + Add support for Linux Runtime Power Management (Closes: #592661)
    + On many other distributions, wireless-tools packages is still old and
      does not return proper exit status on failures. Thanks to Luca Landolfi
      for the patch.
    + Add support to blacklist USB Devices by types. Thanks to Simon Que for
      the patch
    + Re-initialize dev_path before the next iteration. Thanks to Faustus for
      the bug report and the patch (LP: #662924)
    + ENABLE_LAPTOP_MODE_TOOLS was ignore because of wrong check. Thanks to
      Matus Harvan for reporting this. (Closes: #602278)
    + Add support to invoke laptop-mode-tools with hotplug events. This
      currently only has support for the usb-autosuspend module.
      Thanks to Simon Que for the patch
    + Add locking support using flock. (Closes: #566613)
    + Add 99-laptop-mode.rules to trap multiple kernel events
  * Drop pm-utils from recommends since it conflicts with us (Closes: #614024)
  * Bump Standards Version to 3.9.1 (No changes required)

laptop-mode-tools (1.55-1) unstable; urgency=low

  * Change address to my official Debian address
  * New Upstream Release
    + On Intel HD Audio, revert power saving changes when switching back to AC.
      Thanks to Christoph Langguth for the report and the patch
    + Install the pm-utils hook as 01laptop-mode to ensure proper execution in
      reverse ordering
    + Add wireless-power module, for generic non-Intel wireless interfaces that
      support the iwconfig "power" option.
    + Fixed upgrade path for configurations which didn't have the LM/NOLM
      options in the Intel SATA Power Management module config.
    + Add flush-* to ignored programs for lm-profiler, because it is the
      successor to pdflush.
    + Fix WoL regression introduced by DISABLE_ETHERNET_ON_BATTERY. Thanks
      to Matthias Dienstbier for the report and the patch
    + Update comments in wireless-iwl-power.conf. (Debian BTS: #580730)
    + Check for old hook in pm-utils and remove it
    + Update manpage for al...

Read more...

Changed in laptop-mode-tools (Ubuntu Natty):
status: Won't Fix → Fix Released
ceg (ceg) wrote :

can you please reopen the natty task for l-m-t

description: updated
Changed in laptop-mode-tools:
status: New → Fix Released
ceg (ceg) wrote :

wow, fast! thumbs up

Martin Pitt (pitti) wrote :

(Sorry about the noise -- trying to unconfuse Launchpad)

Changed in pm-utils (Ubuntu Natty):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in pm-utils (Debian):
status: Won't Fix → Fix Released
Wes Titus (wjtitus) wrote :

If the pm-utils conflict is fixed, why can I not install one without uninstalling the other? I updated l-m-t to the new version and it still tries to unistall l-m-t when I try to install pm-utils and vice-versa.

Chris Conway (cconway) wrote :

Wes, The fix has been released for Natty. If you're running Maverick or earlier you can try installing the Natty packages manually:
    http://packages.ubuntu.com/natty/all/pm-utils/download
    http://packages.ubuntu.com/natty/all/laptop-mode-tools/download

I was able to install them on my Maverick laptop with no problem, but I haven't verified yet that they fix the bug.

Victoid (djvictoid) wrote :

I suspect this is broken again on a Toshiba R705 BIOS v. 2.10. Installing laptop-mode-tools in Natty 11.04 breaks eth0 (permanently) and brightness control after resume. 2.6.38-8-generic-pae

Rolf Leggewie (r0lf) on 2014-09-28
Changed in laptop-mode-tools (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.