Restricted Manager fails to start with Russian, Finnish, Romanian, Japanese or Turkish localization packs.

Bug #154214 reported by Andrey Zaitsev on 2007-10-19
172
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-pack-fi-base (Ubuntu)
Undecided
Martin Pitt
language-pack-ja-base (Baltix)
Undecided
Unassigned
language-pack-ja-base (Ubuntu)
Undecided
Martin Pitt
language-pack-ro-base (Ubuntu)
Undecided
Adi Roiban
language-pack-ru (Ubuntu)
Undecided
Russian Ubuntu Translators
language-pack-tr-base (Ubuntu)
Undecided
Unassigned
language-pack-uk-base (Ubuntu)
Undecided
Ubuntu Ukrainian Translators
restricted-manager (Ubuntu)
Undecided
Ushakov Maksym

Bug Description

Binary package hint: language-pack-ru-base, language-pack-fi-base, language-pack-ja-base, language-pack-tr-base

Release: Ubuntu 7.10
Package version: 7.10+20071012
Steps to reproduce: Try to use restricted-manager with Finnish, Russian, Romanian, Japanese or Turkish localization

This bug is caused by errors in translations in restricted-manager.po. There are two messages in po-file that have inline dictionary key 'os'. In all 5 translations this key causes bug, the correct usage of the key in translated text should be '%(os)s'

In Finnish and Japanese translation key misses format specifier 's', in Russian the key itself is missed, there is %(s) instead. I've uploaded file patches.tar.gz which contains three debdiffs with patches that fix po-files in each of language-pack-*-base file.

Changed in restricted-manager:
assignee: nobody → restricted-manager-hackers
Andrey Vihrov (andrey.vihrov) wrote :

I can confirm I have exactly the same situation - upgrade from feisty to gutsy, amd64 and ru_RU locale. Indeed, restricted-manager operates normally with LANG=C.

Andrey Zaitsev (a-zaitsev) wrote :

The same thing happens with finnish locale. See bug https://bugs.launchpad.net/ubuntu/+source/restricted-manager/+bug/153220

As I can see from source package of restricted-manager there is now translation in the file ru.po for the following text:
-----------
#: ../restricted-manager:476
msgid ""
"Proprietary drivers do not have public source code that %(os)s developers "
"are free to modify. They represent a risk to you because they are only "
"available on the types of computer chosen by the manufacturer, and security "
"updates to them depend solely on the responsiveness of the manufacturer. "
"%(os)s cannot fix or improve these drivers."
msgstr ""

#: ../restricted-manager:499
-----------------------
So the key 'os' in "% {'os' : get_os_name())" becomes invalid in RestrictedManagerCommon.py line 242. In finnish case there is an error in translations (see the link i've provided).

So the quick workaround is to copy-paste the contetnts of msgid secton i've provided to msgstr section of ru.po.

I will provide a patch with translated text soon.

Timo Karhu (nalle-karhulitos) wrote :

Confirming the same (Andrey mentioned finnish already but here it comes again):

xx@yy:~$ restricted-manager
  File "/usr/bin/restricted-manager", line 42, in <module>
    rm = RestrictedManager()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 53, in __init__
    RestrictedManagerCommon.__init__(self,args,opts)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerCommon.py", line 197, in __init__
    self.launch_manager()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 151, in launch_manager
    self.ManagerWindow(self.xml, self.handlers, self)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 209, in __init__
    self.reset_model()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 262, in reset_model
    self.parent.set_title_label(self.xml.get_widget('label_heading'), any_enabled)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 122, in set_title_label
    (bold, normal) = RestrictedManagerCommon.title_label(self, in_use)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerCommon.py", line 242, in title_label
    'these drivers.') % {'os': get_os_name()}
ValueError: unsupported format character 'k' (0x6b) at index 82
xx@yy-laptop:~$ locale
LANG=fi_FI.UTF-8

After saying LANG=C I could run restricted-manager! Thank you Andrey!

Hippu (teemu-heinamaki) on 2007-10-20
description: updated
Changed in restricted-manager:
status: New → Confirmed

OK. Here is a patch that probably fixes (I've not tried yet, I'll do if I will have time to build the package) restricted manager for Finnish and Russian locale. I think it's a good idea to search all of po-files in restricted manager source for similar bugs.

Andrey Vihrov (andrey.vihrov) wrote :

I wonder how could this get through the development cycle and beta testing - Russian/Finnish localisations and restricted-manager are widely used.

Andrey Zaitsev (a-zaitsev) wrote :

>> I wonder how could this get through the development cycle and beta testing - Russian/Finnish localisations and restricted-manager are widely used.

Hmm, well, many things are broken in this release. Just look at the bugs related to fgrlx drivers, and framebuffer bugs (setting the "vga" kernel parameter to something different from "normal" breaks tty's I/O :)).

I guess this bug will not be fixed soon. :( As it was in 7.04, "domestic" bugs don't get much attention to. It's sad. One thing is obvious - you don't use restricted-manager often (once or twice maybe), so this does not become annoying :)

Andrey Vihrov (andrey.vihrov) wrote :

Yes, there's plenty of bugs. I've personally encountered the fb bug since I had vga=795 option thas was added to every kernel command line by grub-update.

Fumihito YOSHIDA (hito) wrote :

This problem cause in Japanese locales too.
Please update description "Russian or Finnish or Japanese" .

I'll post a .po patch at soon.

Fumihito YOSHIDA (hito) wrote :

Fumihito, your patch reverses normal code to buggy, nevertheless I've corrected it, and post a patch that accumulates bugfixes for Japanese, Finnish and Russian locales. Soon (I think tomorrow) I'll build a package and upload it to PPA for everyone to test.

Andrey Vihrov (andrey.vihrov) wrote :

I just took a brief view on the patch, it contains some mistakes in the Russian translation :>

Andrey Zaitsev (a-zaitsev) wrote :

:) Found one

Andrey Vihrov (andrey.vihrov) wrote :

I've corrected the remaining :)

Changed in language-pack-fi-base:
assignee: nobody → pitti
Changed in language-pack-ja-base:
assignee: nobody → pitti
Changed in language-pack-ru-base:
assignee: nobody → pitti
Changed in language-pack-fi-base:
status: New → Confirmed
Changed in language-pack-ja-base:
status: New → Confirmed
Changed in language-pack-ru-base:
status: New → Confirmed
Andrey Zaitsev (a-zaitsev) wrote :

Patching and building restricted-manager-core, restricted-manager and restricted-manager-kde doesn't make much sense, because *.mo files aren't generated during the build process. Quick investigation shows, that localized messages for restricted-manager are contained in language-pack-*-base packages, so they need to be patched instead of restricted-manager-* and our "big" pacth should be divided to 3 lesser ones: for ru, fi, and ja locales respectively.

I've added affected packages, and assigned the bug to the language-pack-*-base maintainer - Marin Pitt.

I'll post new patches soon.

Changed in language-pack-ja-base:
status: New → Invalid
Andrey Zaitsev (a-zaitsev) wrote :

Fill free to patch language-pack-*-base with attached pacth

description: updated
description: updated
Martin Pitt (pitti) wrote :

Not a bug in restricted-manager, this needs to be fixed in Rosetta's translations:

  https://translations.launchpad.net/ubuntu/gutsy/+source/restricted-manager

Changed in restricted-manager:
status: Confirmed → Invalid
Andrey Zaitsev (a-zaitsev) wrote :

Thank you Martin!

Everything is correct in current translations, so waiting for update!

Changed in language-pack-ru-base:
status: Confirmed → Fix Committed
Changed in language-pack-ja-base:
status: Confirmed → Fix Committed
Changed in language-pack-fi-base:
status: Confirmed → Fix Committed
Serhiy Kachaniuk (serzholino) wrote :

Same problem here with Ukrainian locale, see aslso bug# 156559. Should i mark it as duplicate of this bug?

Andrey Zaitsev (a-zaitsev) wrote :

Hello, Serhiy!

Yes, please mark bug #156559 as a duplicate of this one. Also goto to the link that Martin Pitt provided three posts above and correct the translation (if it's not already corrected). When done, please change the status of this bug.

Thank you!

Changed in language-pack-uk-base:
assignee: nobody → ubuntu-l10n-uk
status: New → Confirmed
Changed in language-pack-ro-base:
assignee: nobody → ubuntu-l10n-ro
status: New → Confirmed
Bohdan Kmit' (mit) wrote :

I have fixed Ukrainian translation.

Changed in language-pack-uk-base:
status: Confirmed → Fix Committed
Juksu (jluostar) wrote :

Still no restricted manager...

description: updated

I have updated the Romanian key. I was the one translating '%(os)s' to '%os'.

Should I send a patch, or it is of if the key is updated in rosetta?

Changed in language-pack-ro-base:
status: Confirmed → In Progress
Adi Roiban (adiroiban) on 2007-10-29
Changed in language-pack-ro-base:
assignee: ubuntu-l10n-ro → adiroiban
Andrey Zaitsev (a-zaitsev) wrote :

No, there is no need to send the patch.

Freezen (niko-volanen) wrote :

excuse for being such a noob, but how do i exactly apply the patch? step by step instructions would be nice.. where to put the patch file, from where to apply the patch etc..

Juksu (jluostar) wrote :

sorry but i do not catch the meaning of "fix committed"? This has been the status for quite some time now!
I still get no restricted manager. Although my bug was marked as a duplicate of this?
Or are we supposed to do something ourselves?
I can help right away with the finnish translation if needed.

Juksu (jluostar) wrote :

This is a fresh crash report from network manager. It never starts, only crashes. And then apport crashes when trying to report.
Why is this bug marked as fixed? Or is my bug report NOT a duplicate of this after all?

Andrey Zaitsev (a-zaitsev) wrote :

>> This is a fresh crash report from network manager.

You should open a bug on network manager.

>> sorry but i do not catch the meaning of "fix committed"?

It means that fix is commited but not released yet. Wait for lang-packs update with fixed translations.

Sergiu Bivol (sergiu-bivol) wrote :

I can confirm this bug for a Romanian system for even more applications: Login Window, Shared Folders (when navigating to the needed folder), Synaptic (when selecting Generate package download script), About Me (navigating to a custom folder makes the application crash).

Adi Roiban (adiroiban) wrote :

> Sc0rpi0n
> I can confirm this bug for a Romanian system for even more applications:
> Login Window, Shared Folders (when navigating to the needed folder),
>Synaptic (when selecting Generate package download script), About Me (navigating to a custom folder makes the application crash).

Thank you for your report. I will investigate this problem.

Hope the language-package will be updated soon.

Timo Jyrinki (timo-jyrinki) wrote :

The updated Finnish language packs now fixed this for Finnish.

Changed in language-pack-fi-base:
status: Fix Committed → Fix Released
Adi Roiban (adiroiban) wrote :

fix released and tested. everything is ok now

Changed in language-pack-ro-base:
status: In Progress → Fix Released
Changed in language-pack-uk-base:
status: Fix Committed → Fix Released
Evgeny Kuznetsov (nekr0z) wrote :

Fix may be released, but a problem with Russian locale persists up till the latest Hardy.

balcis (stadatyum) wrote :

Same problem exists for Turkish, too. I have a system of amd64 processor, ubuntu gutsy (for i386) clean install, and it's localized for Turkish. The same problem, is there any fix or something?

Martin Pitt (pitti) wrote :

There are new language packs in gutsy/feisty/edgy/dapper-proposed. Can you please enable proposed and check if they fix the issue?

Hello, Martin!

Members of russian translation team are morons - that's all that I can
say. Russian translation is not fixed after update.

В Чтв, 21/02/2008 в 15:49 +0000, Martin Pitt пишет:
> There are new language packs in gutsy/feisty/edgy/dapper-proposed. Can
> you please enable proposed and check if they fix the issue?
>

i've searched "propose" in sources.list but i couldn't find it; how can i enable them?

Andrey Zaitsev (a-zaitsev) wrote :

Changing status back to confirmed for russian lang-pack. Recent update of the package didn't fix the bug. Damn, don't those guys in russian translation team use restricted manager or what?

Changed in language-pack-ru-base:
status: Fix Committed → Confirmed
assignee: pitti → ubuntu-l10n-ru
Martin Pitt (pitti) wrote :

balcis: System -> Administration -> Software Sources -> Updates

But the new packages are in -updates now, so you should get them anyway.

Ushakov Maksym (mmx-dimitrov) wrote :

Sorry for slow reaction on the bug in russian translation team.

Thanks to all. Fix committed.

Ushakov Maksym (mmx-dimitrov) wrote :

Sorry for slow reaction on the bug in russian translation team.

Thanks to all. Fix restricted-manager committed. Hardy & Gutsy

Changed in restricted-manager:
assignee: restricted-manager-hackers → msincster
status: Invalid → Fix Committed
Martin Pitt (pitti) wrote :

Not a bug in r-m itself, it's in the language packs. Closing r-m task.

Changed in restricted-manager:
status: Fix Committed → Invalid
Martin Pitt (pitti) wrote :

I hope this is fixed in the current automatically created weekly updates in my PPA. Can you please try to install

  http://ppa.launchpad.net/ubuntu-langpack/ubuntu/pool/main/l/language-pack-ru/language-pack-ru_7.10+20080229_all.deb

and report back whether it fixes the problem for you?

Changed in language-pack-ru-base:
status: Confirmed → Fix Committed
Peter Matulis (petermatulis) wrote :

Martin, the PPA package proved successful in the Montreal office; the restricted-manager opened up for a Russian system.

Andrey Zaitsev (a-zaitsev) wrote :

I confirm, restricted manager now works! Thank you Martin.
I hope we won't have such stupid bugs in future.

Hardy got new language packs now, too, should be fixed.

Changed in language-pack-ru:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Can anyone please test and report about the Japanese language packs?

Martin Pitt (pitti) wrote :

Setting to incomplete until someone gives feedback about the Japanese langpacks.

Changed in language-pack-ja-base:
status: Fix Committed → Incomplete

Hi Martin,

I've tested it in newest Japanese Langupacks, and works fine!

Thanks,

Status changed to "In Progress"

Changed in language-pack-ja-base:
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :

Thanks for the feedback! Closing then.

Changed in language-pack-ja-base:
status: In Progress → Fix Released
emre. (emre.) wrote :

Restricted Manager in Turkish doesn't work either because of "%(os)s" changing. Also Totem and some other programs either. Can't we make a function to check these wrong translations? I wrote this to Brainstorm too: http://brainstorm.ubuntu.com/idea/5134/

emre. (emre.) on 2008-04-02
description: updated
Emrah Ergin (erginemr) wrote :

For those who are still having problems in launching these two applications, you may try this workaround until the release of Hardy. This workaround works especially for Turkish, but may also apply to other languages:

1. Right-click on Gnome's main menu and select "Edit Menus" to start Alacarte menu editor.

2. Find "Movie Player" under "Sound & Video", and "Restricted Drivers Manager" under "Administration" (or their equivalents in Russian, Finnish, Romanian, Japanese or Turkish.)

3. Right click on the corresponding items and add the following line as a prefix to the text box titled "Command" (i.e. to the beginning part of the command line supposed to run the program):
env LC_CTYPE=en_US.UTF8

For instance, for Totem Media Player, this line should read as follows:
env LC_CTYPE=en_US.UTF8 totem %U

4. Close the dialogs and then, the menu editor. Both applications should run and, do so in your local language, now.

Timo Jyrinki (timo-jyrinki) wrote :

Looks fixed, checked 9.04 sources. 7.10 is not anymore supported.

Changed in language-pack-tr-base (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers