Update notification never appears

Bug #472518 reported by Jan Schneider on 2009-11-03
144
This bug affects 29 people
Affects Status Importance Assigned to Milestone
kpackagekit (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Montblanc
Nominated for Maverick by Fabio Puddu
packagekit (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Montblanc
Nominated for Maverick by Fabio Puddu

Bug Description

Binary package hint: update-manager

The icon that should notify me about available updates in the notification area, only flashes shortly for a fracture of a second and disappears immediately. Not that I would be surprised, but I thought that one of the Kubuntu Karmic features was an improved KPackageKit. Actually it got worse because now I don't even know when I have to fire aptitude. Beside that KPackageKit still doesn't show changelogs. Again, not a surprise.

ProblemType: Bug
Architecture: amd64
Date: Tue Nov 3 12:10:12 2009
DistroRelease: Ubuntu 9.10
Package: update-manager-kde 1:0.126.9
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-14-generic x86_64

Jan Schneider (yunosh) wrote :
Jan Schneider (yunosh) wrote :

Btw, this sounds pretty similar to bug #342017, but that was supposed to be fixed upstream with KDE 4.3, plus the icon doesn't even stay for a few seconds.

Jonathan Thomas (echidnaman) wrote :

The icon itself isn't the notification for package updates. You should get a tray popup for that sort of thing.

affects: update-manager (Ubuntu) → kpackagekit (Ubuntu)
Jan Schneider (yunosh) wrote :

So, there's not supposed to be an tray icon if packages are outdated? Anyway, I don't get a popup either.

Sheng Yang (yasker) wrote :

I also got this problem. I never noticed that there is a notification or icon for update, but if I ran aptitude, I know there is some... The notification didn't work, no matter there should be a icon, or some other persistent thing which should be there until dismiss manually.

summary: - Update notification disappears immediately
+ Update notification never appears

I've noticed this too, on both 64-bit and 32-bit versions of Kubuntu Karmic.

This is actually quite serious. No notification of security updates means that Kubuntu users most likely won't notice these. Furthermore if an update to kpackagekit is required to get the notification working, the user won't be notified of this either.

Rob Hasselbaum (rhasselbaum) wrote :

There's a lengthy thread about this bug in the forums, which gives some background:

http://kubuntuforums.net/forums/index.php?topic=3107644

Heimen Stoffels (vistaus) wrote :

I can confirm this on Kubuntu 9.10 32-bit.

tnorris (tnorris) wrote :

I put this in the discussion on kubuntu forums, but I'll put it here as well. I don't get notifications either on 9.10. What I've found is if there are updates waiting before a reboot, and then I reboot, I will eventually get a notification. If updates subsequently become available however, I won't get a notification until I reboot again.

Rominet7777 (fred-schaer) wrote :

OK, Just fixed that locally...

As root, change in /usr/lib/update-notifier/apt_check.py , on line 84 :

"if options.security_updates_unattended:"

to :

"if options and options.security_updates_unattended:"

Then kill update notifier, restart it... and icon magically appears
Cheers

Rominet7777 (fred-schaer) wrote :

Hmmm...

Also, you need to change in the autostart command file to check for *something* to upgrade, otherwise the notifier will apparently never attempt to update anything...
Change in /etc/xdg/autostart/update-notifier-kde.desktop :

Exec=update-notifier-kde

To

Exec=update-notifier-kde -c

Unlog, come back to KDE... and finally, the update icon finally appears !
Why was this so broken ans so unhandled ?

Cheers

tnorris (tnorris) wrote :

I don't think that's correct. Update notification is supposed to be happening through KPackageKit in KK, not through update-notifier-kde anymore. update-notifier-kde is only kept around for codec install notifications (and similar notifications).

Rominet7777 (fred-schaer) wrote :

Well, I don't know what's really correct or not, but when I have updates ready, I have this little green icon popping up (now).
And when this is the case, I can see in the processes list : /usr/lib/kde4/libexec/kpackagekitsmarticon

If I do remove a repository (I used ppa), then icon disappears, and I do not see that kpackagekitsmarticon in the processes list...

Montblanc (montblanc) wrote :

I did what juulpasgaard and Rominet7777 suggested and the kpackagekit tray icon finally popped up. I haven't tried waiting for real-time updates and seeing if it still pops up, because a few people complain about update-notifier-kde working just at login.

The strange thing is that I remember upgrading to 4.4 RC1 (still no tray icon), then I created a new ~/.kde folder and restarted the session. I clearly remember kpackagekit tray icon working as it should, but when I turned back to my old ~/.kde folder (old KDE settings), I had to use this workaround to make it pop up. Bah!

Sebastian Heinlein (glatzor) wrote :

This seems to be a bug in kpackagekit only.

Fell free to reopen the bug against packagekit if the ouput of "pkcon get-updates" is mallicious.

Cheers!

Changed in packagekit (Ubuntu):
status: New → Invalid
Montblanc (montblanc) on 2011-01-25
Changed in kpackagekit (Ubuntu):
status: New → Confirmed
Montblanc (montblanc) wrote :

kpackagekit is still not triggering new updates. I applied Rominet7777's fix to /usr/lib/update-notifier/apt_check.py one more time, but update-notifier-kde is a dummy package in maverick, leading to kubuntu-notification-helper, which doesn't seem to have any executables (please, correct me if I'm wrong), so I still have to check whether it works or not.
I will wait for new updates and will keep you updated on the tray icon behaviour.

$ apt-cache policy kpackagekit
kpackagekit:
  Installato: 0.6.2-0ubuntu1
  Candidato: 0.6.2-0ubuntu1
  Tabella versione:
 *** 0.6.2-0ubuntu1 0
        500 http://it.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers