Ubuntu

KMilo/Volume Hotkeys regression

Reported by QuinnStorm on 2007-06-05
122
Affects Status Importance Assigned to Milestone
kdeutils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kmilo

On Gutsy with the latest KMilo packages, the volume control is failing to work properly. This is due to it attempting to use the old setAbsoluteVolume on channel 0 instead of the new setMasterVolume (and the equivalent absoluteVolume/masterVolume 'get's) I've attached a patch which fixes kmilo here (I'm sure the format isn't right, but at least its a starting point). I hope to see this fixed soon, its a minor issue but important.

QuinnStorm (livinglatexkali) wrote :

I think I stripped out everything unimportant in it, this is the patch that fixes kmilo (at least for the generic case, which mine is)

Richard Spiers (dksaarth) wrote :

Hi guys

Just letting you know that i've also found out that my laptop's multimedia keys have stopped working. Anybody know of a place that has a nice tutorial for installing patches like the above?

Thanks
Rich

Kishore (kitts) wrote :

I am facing a similar issue. Volume Up/Down keys work in Feisty. In Gutsy, ever since the OSD changed to the smaller one the hot keys have stopped working. Pressing the Volume Down button sets the OSD to show 0% and Volume Up button sets OSD to show 11%! Neither affect the actual volume though.

Mute button works but the light colour does not change. This did not work in feisty either.

Mike Hix (mike-musl) wrote :

I'm experiencing this issue on my X61. (Type # 7675-CTO)

The mute button actually mutes the sound and updates the OSD. The volume buttons turn the mute off, but they do not cause the volume to increase or decrease properly. As described in an earlier comment, it's either 0% or 11%. The volume buttons do not actually change the output of the sound card, simply the value displayed on the OSD.

I've also experienced other issues with kmilo that used to work. The Blue "ThinkVantage" button and some of the Fn-Key combinations (Screen brightness, hibernate, sleep, etc...) have ceased to work with updates to the kmilo package.

Mike Hix (mike-musl) wrote :

After searching for additional information on the KMilo package, I found kmilo-legacy. this adds the "ThinkPad Laptop" section to the Control Center, and provides the additional functionality I noted missing in my last comment.

In the description of the package, it mentions that I should file a bug. It felt it would suffice to comment on this already open bug.

Thanks for everyone's work so far.

Lothar (lothar-tradescape) wrote :

I experience the same 0% 11% problem that Mike reported on my T61

Jaco (jacotb) wrote :

Same prob here.

laga (laga) wrote :

Same problem here, using a Cherry keyboard with multimedia keys. olume bar is stuck between 0% and 11%, while the volume doesn't actually change.

This bug was opened over three months ago. How can I help to fix it?

Changed in kdeutils:
status: New → Confirmed
whyhankee (paul-paulsplace) wrote :

Same here on a microsoft Natural Keyboard,

just upgraded from Feisty to Gutsy and now the volume is stuck between 0-11%

Maze12 (willymaze) wrote :

same on acer aspire 9815wkmi i upgraded from feisty in gutsy and the volume stay berween 0-11%

Mark Veinot (vmark) wrote :

Can confirm this here on my Acer TM4202WLMi. Volume OSD shows 0-11%

whyhankee (paul-paulsplace) wrote :

assigned it to kubuntu-team on advice of others, hope it's ok, and hoping on some more love & attention to this ticket :p

Changed in kdeutils:
assignee: nobody → kubuntu-team
Alvin (alvind) wrote :

0-11% confirmd on Lenovo T61p. (gutsy)

tlc (tlc) wrote :

I see this too on a Lenovo T61. kmilo-legacy does *NOT* fix it for me.

-troy

Mike Hix (mike-musl) wrote :

It didn't *fix* the issue for me either, but did provide some of the missing functionality.

tlc (tlc) wrote :

Would you mind saying which functionality.
I didn't see any difference adding kmilo-legacy on my T61.

Thanks

Michael Gefen (gefenm11) wrote :

confirm on acer aspire 5045 (kubuntu gutsy)

Carlos Cáceres (betomadrid) wrote :

Confirmed on:

*-multimedia
       description: Audio device
       product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=HDA Intel latency=0 module=snd_hda_intel

I can confirm that the patch fixes the volume control. The only minor gripe I have is that the dialog for changing volume with the buttons is the large, ugly one from Feisty and earlier. Any way to keep the newer dialog after installing the patched version of kdeutils?

PouletFou (pouletfou) wrote :

Confirm bug on Acer Aspire 5630 (Kubuntu Gutsy)

Due to issues with my sound on my laptop (HP tx1003AU), i compiled alsa driver
v1.0.15. Now i have sound working properly with headphones, jack sense and
kmilo volume problem are also solved.

But i have another problem that the volume keys always control only the
headphone volume no matter which i select as the master in kmix. I would
ideally want it to control either the current output source or the PCM
channel that applies to both the speakers and the headphone.
--
Cheers!
kitts

Borahshadow (codyregister) wrote :

Confirm on Averatec 2370

Confirming the problem on Asus F3J series running Gutsy (all worked well on Feisty). I'd like to use the patch, but don't know how. Would appreciate somehow explaining how to apply the patch.

Here are some basic instructions on how to use this patch (or patch anything from source):

0) Since you're using apt to get the source for these packages, might as well switch the session to root by running 'sudo -s -H' for these steps.
1) Use 'apt-get source <package name>' to download the source for kmilo (in this case, it's under kde-utils)
2) You can also use 'apt-get builddep <package name>' to get the build dependencies for the package, but sometimes it doesn't get everything. You'll find out in "Step 5" what it missed when './configure' fails because it's missing a package name.
3) Extract the source (it should have been downloaded to your home directory).
4) Download the above .patch file to the ./kmilo directory and run 'patch -p1 < kmilofix.patch' in the same directory.
5) Run './configure'. You may need to specify where the X libraries are with a switch; they are in /usr/lib, but I can't remember what the exact syntax of the command is (doing this off the top of my head right now) but it should looke like './configure --use-libs=/usr/lib'.
6) After all the build dependencies have been met and the build autoconfigured, run 'make' and 'make install'
7) Reboot and post your results :)

Side note: Here is a patch to get the slimmer dialog for volume control back: http://downloads.guillermoamaral.com/linux/kde/kmilo/3.5.5-defaultwidget-compact.patch

Thanks for the explanation on patch installation. Not sure that it's worth it. I am first going to try a fix I read on the Ubuntu forums:

http://ubuntuforums.org/showthread.php?t=558286&highlight=kmilo

The suggestion is to not start kmilo when KDE starts (disable it in the Services section of System Settings/Advanced). Then, try to get the volume raise and lower keys to be implemented in global shortcuts in kmix.

laga (laga) wrote :

Randall Cooper wrote:
> Thanks for the explanation on patch installation. Not sure that it's
> worth it. I am first going to try a fix I read on the Ubuntu forums:
>
> http://ubuntuforums.org/showthread.php?t=558286&highlight=kmilo
>
> The suggestion is to not start kmilo when KDE starts (disable it in the
> Services section of System Settings/Advanced). Then, try to get the
> volume raise and lower keys to be implemented in global shortcuts in
> kmix.
>

Rather than applying workarounds found in forums or telling users how to
patch stuff, this could have been fixed four months ago when the ticket
was first opened.

I know there are way too many bug reports and I also know that Canonical
prefers Gnome over KDE, but having such a simple thing not working is a
shame especially when there's been a patch for quite some time. Does
anyone have a suggestion who needs to be asked to fix this?

BeSt (steph-belardi) wrote :

kmilo is out for hardy (8.04) in a version more recent than the gutsy one.
http://packages.ubuntu.com/hardy/utils/kmilo
Maybe you could try (I'm not with my computer right now, so I can't test it, but I have the same problem !)

BeSt (steph-belardi) wrote :

Don't try the method I wrote in my last message, it doesn't work...

tlc (tlc) wrote :

Thanks zs! That worked.

Maze12 (willymaze) wrote :

confirm kmilo_3.5.6-0ubuntu2_i386.deb work fine with gutsy and kde 3.5.8, it's necesary block update with /etc/apt/preferences :

Package: kmilo
Pin: version 4:3.5.6*
Pin-Priority: 1001

My configuration :

Acer 9815kwmi
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

BeSt (steph-belardi) wrote :

If like me, you are on a 64-bit architecture (so you can't use zs's .deb), or if you don't trust zs, you can download the old package (from Feisty) here
http://packages.ubuntu.com/feisty/utils/kmilo
and with the "sudo dpkg -i the_package_name.deb"
It works

zs (nzs-reg) wrote :

This is not my ".deb", trust me :D
I found on kde-apps.org
And it is worked for me, only have to lock the package (like Maze12)
http://www.kde-apps.org/content/show.php?content=56287&forumpage=0

socketbind (socketbind) wrote :

Patched .deb package for Gutsy. It is up to you if you trust me. I hoped a patched version would be released soon but I just can't wait and this is annoying.

tlc (tlc) wrote :

Above I said that zs' deb worked for me. I realized later that volume up and down work with it, but not mute.

I just tried socketbind's patched deb and it behave's the same; volume up and down work but not mute.

In both cases, mute on/off displays on the OSD, but no muting.

BeSt (steph-belardi) wrote :

@troycable: What is the result with my method (Feisty package) ?

socketbind (socketbind) wrote :

Muting is just a DCOP call to kmix "setMasterMute", I think it is an ALSA issue. The master channel that you have chosen in kmix can be muted troycauble?

arboc (dcobra) wrote :

Confirmed on an Asus A8Js with Kubuntu 7.10: Tray icon's volume slider has no effect on the speakers' volume. Fn volume and mute keys cause the OSD to pop up correctly, but the speakers' volume is unaffected.

Guys: I think this bug deserves at least a Medium importance classification. It seems a lot of people have been left with no control of their speakers' volume.

Please make available ASAP updated packages with the necessary fixes for kmix and kmilo (which, from the discussions in the bug lists, seem to be quite easy to implement).

Wouter Horré (wouterh) wrote :

I can confirm that the patched deb of socketbind is working.

Mute also works (it always has) if you set the correct master volume in Kmix (right click tray icon - Select Master Channel).

tlc (tlc) wrote :

@socketbind, my Master Channel is PCM and mute does not work (kubuntu, thinkpad t61).

As I said above volume up/down worked but not mute on zs' and socketbind's debs.
This is the opposite of the my unmodified gutsy where mute worked, but not up/down.

Sorry @BeSt, I haven't tried your's yet.

I've tried a few things along the way. I suppose it's possible I've mucked things up somewhere else.

laga (laga) wrote :

I finally got around to trying the patch posted by QuinnStorm (thanks!). However, I'm getting this error:

user@box:~/dev/kmilo/kdeutils-3.5.8/kmilo$ patch -p0 < kmilofix.patch
patching file generic/generic_monitor.cpp
patch: **** malformed patch at line 12: @@ -92,7 +109,7 @@

Anyone else seen this?

Hey, it's now been more than five months! Yay!

Daedalus (osd-daedalus) wrote :

I can confirm this bug on an Acer Aspire 5602, but with socketbind's deb all works correctly.
Nice work socketbind!!

And so, what are you think about? We can say this bug is fixed?

Michael Gefen (gefenm11) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

we can say it's fixed when the fix is committed to the upstream.

by the way i confirm the bug and the solution (socketbind's)
on Acer Aspire 5045 (32 bit version)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: http://firegpg.tuxfamily.org

iQCVAwUBRzyELYzl7/hn5cm4AQKNFAP/WC1DjwWpjMX6d7I3puxCgnkngPMmp11O
Hj7j4VMtcT+pitcFKFrWMkRVZr6ShlIt8rx18Q/0ku2BNJwiu2xwJX1Pd7B1SZVS
w8OV7swHL4Cvfg1MIuCwsnLZMYcWMMzDVvGxc0AOQ4wkitO3O1NLhaT8fTiS7Dym
bloxMq9f2pM=
=Mqkn
-----END PGP SIGNATURE-----

BeSt (steph-belardi) wrote :

Is the socketbind's patch working for 64 bits architecture ?
Thanks

socketbind (socketbind) wrote :

@BeSt: I don't think the deb works, the patch I used is essentially the same as QuinnStorm's and is architecturally neutral.

I don't think kmix needs to be fixed, this seems to be a problem with sound card drivers for me.

The current state of this in my case is kind of confusing. My channels behave like this:
Front - Affects every channel, headphones too, I guess in reality this is the hardware "Master" channel?
Headphone - Doesn't work at all, does nothing
PCM - Unmutable, affects everything
Everything else works as intended.

I know it is hard to develop drivers without spec, but this needs to be fixed somehow.

I can confirm that socketbind's patched deb is working for kubuntu 32-bit on my T61p

Is there a kmilo-fix for amd64 users somewhere?

If I use the feisty-kmilo my 0%-11% problem switch to a 0%-10% problem. I can confirm this on an ASRock ALiveNF7G-HDready with Gutsy and Heron alpha1.

timbl (timbl) wrote :

still not fixed in hardy
socketbind's deb does work

Paul Koshevoy (paul-aragog) wrote :

Same issue here -- (x86_64 Ubuntu 7.10 on Lenovo T61p)
If I uninstall kmilo I can configure kmix to use my apple keyboards volume up/down/mute buttons.
The up/down shortcuts work, the mute doesn't. I believe this is because I've set PCM to be the master channel, but the PCM channel doesn't support muting (although I can mute by turning off the headphones switch in kmix).

The annoying thing is that these same shortcuts work great under GNOME. If I uninstall kmix and kmilo and run gnome-keybinding-properties -- I can use the keyboard to adjust the volume as expected. Of course, I don't want to run gnome-keybinding-properties every time I login.

With kmilo I get the 0%-11% volume problem. I think I can live without mute for now, I'll just uninstall kmilo.

Danni Matzk (dannilion) wrote :

Confirmed on Acer Aspire 5630 Gutsy and Hardy.
I can also confirm that socketbind's deb works.

I'd really like to see this fixed by Hardy's release.

Does somebody know a patch for a 64bit architecture ? I would like it to be fixed **before** Hardy's release !

This bug is still present in hardy, at least on my Amilo Pi 1505. The only difference in my case is that the value shown when I press fn+vol up is 9% and not 11%. I'm going to try building kmilo with QuinnStorm's patch, and will post the results here.

ChrisDesjardins (cddesjardins) wrote :

socketbind's .deb works great here too. it would be really nice to see this patch included in the next kmilo release ... either in the kde3 or kde4 series. it seems crazy that a known fix isn't going to be applied because kmilo is a default package on a kubuntu install. the only reason i could see for not including the patch would be if it broke this package for others ... which doesn't seem to be the case. so please can someone patch kmilo and send it upstream to the upstream author ... who i believe is Riddel anyways.

Fathi Boudra (fboudra) wrote :

Fixed upstream. Available for upcoming KDE 3.5.9.

Daedalus (osd-daedalus) wrote :

I tried Hardy for a short time. I had the impression that socketbind's deb *doesn't* work in Hardy.
Someone can have a look on this? (I'm asking because I'm returned to Gutsy).

As was just mentioned, this will be fixed in KDE 3.5.9. Hardy has 3.5.8 and
therefore won't have this fix until 3.5.9 is released. Glad to see this
made it's way upstream.

On Feb 8, 2008 12:38 PM, Daedalus <email address hidden> wrote:

> I tried Hardy for a short time. I had the impression that socketbind's deb
> *doesn't* work in Hardy.
> Someone can have a look on this? (I'm asking because I'm returned to
> Gutsy).
>
> --
> KMilo/Volume Hotkeys regression
> https://bugs.launchpad.net/bugs/118723
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

pepster (jheled) wrote :

So, I have to choose between volume control and Mute? Is there another way to get the mute going on some KB combination with the patched kmilo?

Luka Renko (lure) wrote :

Marking as Fix commited as KDE 3.5.9 has the fix and this will be included for Hardy Beta.

Changed in kdeutils:
importance: Undecided → Medium
milestone: none → ubuntu-8.04-beta
status: Confirmed → Fix Committed
Mateusz Kaduk (mateusz) wrote :

Confirmed bug with sound volume. I am using Gnome, it works with metacity when I change to compiz the OSD pop up correctly, but the speakers' volume is unaffected.

Anish Bhatt (anish7) wrote :

KDE 3.5.9 is available for Kubuntu but seems to be missing kmilo.

I confirm that using Gutsy+KDE 3.5.9 from PPA doesn't solve the issue.
KMilo was removed instead of being fixed.
Sound keyboard shortcuts still doesn't work.

KeKc (kekcfx) wrote :

I use Hardy and there is master channel now in 3.5.9.
Unfortunately splash is missing then I increase/decrease/mute volume.

Daedalus (osd-daedalus) wrote :

It seems fixed now in Hardy Alpha 6. Someone could confirm that?

Richard Johnson (nixternal) wrote :

Everyone, it seems a lot of you are reporting this with an Intel HDA audio controller. If this is the case, then KMilo is not your issue. The issue was in alsa and some of the quirks they included. I have an HDA audio controller myself and it hasn't worked since Edgy/Feisty, but it is now fixed in Hardy.

Can people verify that it is working on Hardy now? Also, if you are using an Intel HDA device, then KMilo is not your issue once again.

Changed in kdeutils:
status: Fix Committed → Incomplete
Emilio Scalise (emisca) wrote :

HDA sound cards are based on a combination of many chipsets and audio codecs. Many of them don't have hardware mixer controls, or there is no documentation on how to use them.
Alsa in the snd-hda-driver has a big list of quirks that enable specific controls for many chipset/codec combinations, but not all of them.
Newer versions of alsa have more support for these combinations. The problem in Kmilo perhaps is that you can choose an arbitrary mixer channel to control, and the mechanism to get that channel from kmix seems to be broken.

I hope that this clarify the situation about this bug report.

I haven't tested the current hardy situation with kmilo 3.5.9, so I can't say if they have fixed the problem or not.

danda (dan-osc) wrote :

I am still seeing this problem with a T61 and Hardy.

Peter (sunspots) wrote :

Volume up/down & mute are working on Fujitsu S6410 and Hardy Alpha-6 with all updates as of 15 Mar.

Hi.

I've got the same problem in my Vaio TX3, but, as it works fine in gnome, I assume it's a kde problem.

Running Gutsy w backports & 3.5.9 up to date.

What may I post to help? 8-?

Steve Langasek (vorlon) wrote :

It was claimed that the original issue was fixed in kmilo 3.5.9, which is now available in hardy. As Richard mentions, there was a separate kernel issue which may explain some of the symptoms, unrelated to kmilo; and that bug is also now fixed. If anyone is still able to reproduce the problem of non-functional volume keys with a fully up-to-date hardy (including a current kernel), please provide that information; in the meantime, I'm un-milestoning this bug based on the 'incomplete' status.

Changed in kdeutils:
milestone: ubuntu-8.04-beta → none
Sebastian Goth (seezer) wrote :

Working again "out of the box" with kmilo Version: 4:3.5.9-0ubuntu2 (current Hardy) and the following Intel card:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
        Subsystem: Micro-Star International Co., Ltd. Unknown device 7238
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at fbff8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0

Stopped working around gutsy release (worked fine in gutsy beta for me)

nopoles (paul-2byteconsulting) wrote :

I too had the same 0-11% problem. Mute would work, the volume controls would un-mute but not change volume.
Installing the version form Feisty as suggested in this tread fixed the problem. The display is bigger and uglier, but at least the keys work. ;)

http://packages.ubuntu.com/feisty/utils/kmilo

kmilo-legacy also doesn't seem necessary on my X61.

Still can't test, because of bug #192382. :(

I had the volume working for me for about one day, then it stopped working
again. This was on Hardy.

On Thu, Mar 20, 2008 at 10:48 AM, Jose Bernardo <email address hidden> wrote:

> Still can't test, because of bug #192382. :(
>
> --
> KMilo/Volume Hotkeys regression
> https://bugs.launchpad.net/bugs/118723
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
-Ahmed Osman

Finally alsa can be fixed building from source. Now that I can get kmix to work, I finally tested kmilo and it is still broken. Volume only varies 10% from the current position using hotkeys. If the volume is at 0, the max I can get using the hotkeys is 10%. If it is at 100% (using the kmix sliders) I can only lower it to 90%.

TD-Linux (bztdlinux) wrote :

I can confirm the new, broken behavior with Ubuntu Hardy.

In Ubuntu Gutsy, the 0%-11% problem existed, however KMix was fully functional.

When I upgraded to Ubuntu Hardy, the KMix panel changed. I think a Master channel was added (I don't remember it being there before), and PCM no longer has a Mute button (Master does though). KMilo still has the bug, but now instead of 0-11 percent, the percentage is related to where the Master slider in KMix is set.

Another, possibly related, bug is that wehn I click the KMix applet, the slider that pops up isn't master and doesn't seem to do anything - it has a headphone icon above it, but it doesn't seem to do anything (I'll test with headphones later). KMilo does not touch any of the sliders, including this headphone one.

KeKc (kekcfx) wrote :

What will come first: fix of this problem or KDE4.2?)

Kishore (kitts) wrote :

On Wednesday 27 Aug 2008 10:04:41 am KeKc wrote:
> What will come first: fix of this problem or KDE4.2?)

KDE4 as yet, does not appear to have kmilo replacement.
--
Cheers!
Kishore

KeKc (kekcfx) wrote :

> KDE4 as yet, does not appear to have kmilo replacement.

What is it then?
https://launchpad.net/ubuntu/hardy/+package/kmilo-kde4

Kishore (kitts) wrote :

On Wednesday 27 Aug 2008 10:29:09 am KeKc wrote:
> > KDE4 as yet, does not appear to have kmilo replacement.
>
> What is it then?
> https://launchpad.net/ubuntu/hardy/+package/kmilo-kde4

Interesting! I have never seen that in action. Anyway, I hope i am wrong. I am
not well aware after all.
--
Cheers!
Kishore

KeKc (kekcfx) wrote :

2kitts:
Yeah, I'm not well aware too.
Waiting for 4.2 anyway..

Anish Bhatt (anish7) wrote :

Volume control works perfectly in the Hardy Live CD, but controls the wrong channel upon install. Need to do Ctrl + Vol Up/Down to change volume. Why the changing behaviour between install & Live CD I wonder (in KDE 3.5.9) ?

Anish Bhatt (anish7) wrote :

Works fine in Intrepid Alpha 5, but Kmix needs to be restarted every time master channel is changed.

Rafael Belmonte (eaglescreen) wrote :

Multimedia keys and other hotkeys are not working for me on a fresh install of Kubuntu Intrepid 20080915 snapshot.
I have these hotkeys:
*Mail (shoud start kmail --composer) -> Not working.
*Find (should start kfind) -> Not working.
*Calculator (should start speedcrunch) -> Not working

Multimedia keys:
*Volume up: Works but volume splash indicator always display volume in 0%.
*Volume down: Works but volume splash indicator always display volume in 0%.
*Mute: Does not work, i think it is related with bug #130067.

Egbert van der Wal (eggie) wrote :

Same as Eaglescreen.

Mute does not work, volume up and down works and display is always at 0%.

This is on a Creative Soundblaster Audigy 2 ZS.

Peter (sunspots) wrote :

This is still a problem in Fujitsu Lifebook S6410P using released Intrepid Ibex 8.10 with all updates as of 16 Nov 2008.

It has actually degraded since Hardy. Found the following not working:
- Mute (either pressing FN+f3 or clicking Mute on control panel)
- Up/Down volume (Fn + F9 / F8)
- speaker icon does not show that mute is active
- Front (selection) : volume is not loud
- Change Master Channel from Front to PCM allows vol to be adjust through icon. Still mute and Fn key adjustments do not work.

The issue with sound coming from speakers when headphones are plugged in has been fixed.

Rafael Belmonte (eaglescreen) wrote :

Please check if this bug is still present in up-to-date Kubuntu 8.10 and Kubuntu 9.04 if possible.
Thanks.

On a aspire one with kubuntu 8.10 and kde 4.2 from the ppa, and with non-ubuntu kernel 2.6.28, everything works, after changing the master channel from PCM to Master. If I have the master channel as PCM there is no mute option.
I'll test later on a fujitsu amilo pi 1505, with kubuntu's kernel.

Egbert van der Wal (eggie) wrote :

For me this bug is still unchanged, volume up/down work but display always show 0%

Mute still does not work, display shows 0% but nothing changes.

Joan Tur (joantur) wrote :

El dv 30 de 01 de 2009 a les 14:34 +0000, en/na EagleScreen va escriure:
> Please check if this bug is still present in up-to-date Kubuntu 8.10 and Kubuntu 9.04 if possible.
> Thanks.

I'm sorry I'm no longer using KDE.

Thanks,

--
Joan Tur (aka Quini), Eivissa-Spain
    Jabber: <email address hidden>
        www.ClubIbosim.org
  Linux #190.783 - Ubuntu #15.255

Egbert van der Wal (eggie) wrote :

Oh, this is on Kubuntu 8.10 by the way, I haven't tried in 9.04, if I have time next week I'll see if I can find out.

Kishore (kitts) wrote :

On Friday 30 Jan 2009 8:04:10 pm EagleScreen wrote:
> Please check if this bug is still present in up-to-date Kubuntu 8.10 and
> Kubuntu 9.04 if possible. Thanks.

This bug is partially solved for me in intrepid. I have to change channel from
PCM to master and it works fine.
--
Cheers!
Kishore

Egbert van der Wal (eggie) wrote :

I have just downloaded the 9.04 alpha 3 to try this. Volume up and down works fine in Kubuntu 9.04 Alpha 3, but mute still does not work. But this is most likely caused by there not being a mute option on the PCM channel of my sound card driver (Soundblaster Audigy 2 ZS). I still do not see why kmix cannot just store the volume and set the volume to 0 when pressing mute, and resetting the volume to the stored value when pressing mute again, but that is not related to this bug.

Anyway, in Jaunty, volume up and down display is fixed for me.

Jonathan Thomas (echidnaman) wrote :

I am closing this bug as fixed since the original regression has been fixed.

Changed in kdeutils:
status: Incomplete → Fix Released
assignee: kubuntu-bugs → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers