KDM resets system settings from customized to default value

Bug #766145 reported by Stefan T. on 2011-04-19
This bug affects 7 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Kubuntu Default Settings
One Hundred Papercuts
kdebase (Ubuntu)

Bug Description

Binary package hint: kdebase

Kubuntu 11.04 beta 2 (and 10.10)
KDE 4.6.2

Steps to reproduce the bug:

1) Open systemsettings
2) Click on "Login Screen"
3) Close systemsettings

Actual result: some system settings were changed from customized value to default, e.g. Fonts and Main toolbar text (in Fine Tuning)

I have reported this bug on bugs.kde.org. There is no response there, but there is another user with this issue and he thinks that the problem could be in Kubuntu packages...

Thank you.

Created attachment 52586
I ran "systemsettings 2>&1 | tee systemsettings.log"

Version: 1.0 (using KDE 4.5.1)
OS: Linux

I just enter Login Screen in systemsettings and close systemsettings.
Then, system font is initialized whether login screen is changed or not.

I use Kubuntu 10.10 so my system system font is "ubuntu".

Reproducible: Always

Steps to Reproduce:
1. Enter Login Screen in systemsettings.
2. Just close it.

Actual Results:
Font is initialized.

OS: Linux (x86_64) release 2.6.35-22-generic
Compiler: cc

Distribution : Kubuntu 10.10

At my computer I also have to re-open systemsettings for the font being set systemwide. I also get “ubuntu” set to every font. Really annoying. Also it resets the *emoticon* theme to default o.O

Stefan T. (stefan-ubuntu) wrote :

Bug report on bugs.kde.org with more detail:


description: updated
description: updated
avlas (avlas) wrote :

This is also affecting to me. It may be something similar to this other bug https://bugs.kde.org/show_bug.cgi?id=264200 , so apparently it seems a bug related to downstream packaging.

avlas (avlas) wrote :

This bug has been marked as duplicate of bug #798091, but I'm not so sure they refer to the same issue. Let me explain the issue that is affecting to me in this bug:

Whenever you try to leave the kdm settings in the systemsettings, whether or not you changed anything you receive a warning message that says if you want to apply the changes. Irrespective of whether you say yes or not, this makes that part of your personal configuration changes to some kde or kubuntu default, in my case this refers to the font sizes in the desktop, and the use of text in the toolbars by the default.

I too have this bug with KDE 4.7.1 (Kubuntu 11.10 Beta). Note that not only font family and size are reset, but also anti-aliasing settings.

This report is a duplicate of bug 264200

May someone mark the report accordingly?

Jean-Philippe Fleury (jpfle) wrote :

Salva is right: the current report (go to "System Settings > Login Screen" resets some settings) is not a duplicate of bug #798091 (manually apply "Defaults" doesn't revert to real default settings).

Changed in kdebase (Ubuntu):
status: New → Confirmed
summary: - KDM resets system settings from custimized to defult value
+ KDM resets system settings from customized to default value
Jean-Philippe Fleury (jpfle) wrote :

I too have this bug on Kubuntu 11.10 Beta 2.

description: updated
tags: added: natty oneiric
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: papercut (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → hundredpapercuts
Changed in kde-baseapps:
importance: Unknown → Medium
status: Unknown → Invalid
Timothy Arceri (t-fridey) wrote :

Does this still exist now that the Kubuntu 11.10 is out of beta?

avlas (avlas) wrote :

I won't be able to test this as I'll stay in natty at least until next LTS because of Kmail2

*** Bug 264200 has been marked as a duplicate of this bug. ***

*** Bug 286911 has been marked as a duplicate of this bug. ***

*** Bug 288989 has been marked as a duplicate of this bug. ***

*** Bug 290709 has been marked as a duplicate of this bug. ***

Kubuntu 11.10, KDE 4.7.4. This is also resetting the default Web Browser (in Default Applications) for me.

I get 3 resets: Font resetting, emoticon resetting, and default Web Browser resetting.

*** This bug has been confirmed by popular vote. ***

Also appears in the KDE 4.8.0

Kubuntu 11.10 x86

BrainFucker (retratserif) wrote :

Still exists in 11.10, KDE 4.7.4 and 4.8.

Turbid (turbidit) wrote :

I confirm this bug

*** Bug 293132 has been marked as a duplicate of this bug. ***

Changed in kde-baseapps:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in kde-baseapps:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 299662 has been marked as a duplicate of this bug. ***

Present in:

KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

Chris Wilson (notgary) on 2012-06-14
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → quantal-12-kubuntu

*** Bug 304529 has been marked as a duplicate of this bug. ***

Any dev input on this ? Still present in kde 4.9.0

This bug has been reported in 2010, and hasn't moved since, despite being easily reproducible

According this upstream bug report: https://bugs.kde.org/show_bug.cgi?id=291998

/etc/kde4rc shoudn't be used to provide default settings.

humm actually /etc/kde4rc seems to have on effect on this issue. The only work around that I've found is to remove: /usr/share/kubuntu-default-settings/kde4-profile/default/share/kdeglobals

avlas (avlas) wrote :

Thanks Bruno, this workaround also worked for me, although in my case the file was located in this path:


I preferred to move it to /usr/share/kubuntu-default-settings/kde4-profile/default/share/config/kdeglobals.mvd as I guess this file may be necessary for new users, so I can revert the change if needed

Changed in kde-baseapps:
status: Confirmed → Unknown
Changed in kdebase (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in kdebase (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)

Created attachment 80257
Patch to fix KCM KDM damaging kdeglobals

Fixed in ROSA & OpenMandriva, see the attached patch.

*** Bug 322612 has been marked as a duplicate of this bug. ***

Confirmed in openSUSE 12.3 KDE 4.10.5. Entering the "Login Screen" menu causes color scheme to be permanently reset for my user (possibly to root's). Simply applying my desired color scheme again fixes it, but it's still annoying.

Git commit 89384880deab1ff387ece84c2711063ca4e0f81d by Oswald Buddenhagen.
Committed on 29/10/2013 at 07:57.
Pushed by ossi into branch 'KDE/4.11'.

fix kcm botching unrelated user settings

M +1 -1 kdm/kcm/main.cpp


Changed in kde-baseapps:
status: Unknown → Fix Released
Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.