kded4 (lucid, amd64) defunct on latop

Bug #515138 reported by Mark Schmidt on 2010-01-31
148
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Kubuntu Notification Helper
Fix Released
Undecided
Unassigned
kdelibs
Unknown
Medium
kde4libs (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned
kubuntu-notification-helper (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Closing and reopening the laptop lid leads to a problem with kded4 on lucid amd64. kded4 gets defunct and therefore a new kded4 is respawn all the time. So after a while there are lots of kded4 with state defunct. A ps waux | grep kded4 gives lots of lines like
<user> 26217 0.0 0.0 0 0 ? Z 13:42 0:00 [kded4] <defunct>
Because of that i had an idle cpu load of about 80% cpu-usage on both cores of a core2duo.
After a killall -9 kded4 and manually restarting kded4 the system behaves normal again.

Mark Schmidt (schmidtm) on 2010-01-31
description: updated
Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

affects: kubuntu-meta (Ubuntu) → kde4libs (Ubuntu)
Changed in kde4libs (Ubuntu):
status: New → Invalid

Version: (using KDE 4.4.3)
OS: Linux
Installed from: Ubuntu Packages

I always have a defunct kded4 process since some time around the 4.3 to 4.4 transition.
I have the Kubuntu 10.4 packages with 4.4.3 from their PPA.

$ ps waux | grep kded4
falken 2183 0.0 1.2 132324 25500 ? Sl 18:56 0:08 kdeinit4: kded4 [kdeinit]
falken 2383 0.0 0.0 0 0 ? Z 18:57 0:00 [kded4] <defunct>
falken 5615 0.0 0.0 3324 820 pts/1 S+ 21:46 0:00 grep kded4
$

Amongst other things, this breaks the ACPI power button script Ubuntu uses, causing power off regardless of what KDE has configured.
Their bug : https://bugs.launchpad.net/ubuntu/+source/acpid/+bug/553557

Not exactly the same, I only ever have one.

Changed in kdelibs:
status: Unknown → New

Same over here on two different AMD64 machines (both Kubuntu 10.04 too, but with default packages):

machine1$ ps -eHo pid,ppid,stat,cmd | grep kded4 | egrep -v grep
 1495 1 Sl kdeinit4: kded4 [kdeinit]
 1704 1495 Z [kded4] <defunct>
 3706 1495 Z [kded4] <defunct>
 3819 1495 Z [kded4] <defunct>
 3905 1495 Z [kded4] <defunct>
 4020 1495 Z [kded4] <defunct>
 7629 1495 Z [kded4] <defunct>

machine2$ ps -eHo pid,ppid,stat,cmd | grep kded4 | egrep -v grep
 1975 1 Sl kdeinit4: kded4 [kdeinit]
 2268 1975 Z [kded4] <defunct>

Same at another AMD64 machine:

machine3$ ps -eHo pid,ppid,stat,cmd | grep kded4 | egrep -v grep
 2200 1 Sl kdeinit4: kded4 [kdeinit]
 2607 2200 Z [kded4] <defunct>

Same here after some hours. Kubuntu 10.04 32bits - ATI drivers.

I'm using Intel graphics drivers, so it's not that.
'cpuid' claims I've a single Intel CPU (with 2 hyperthreads).
I'm fairly sure it's a 32bit CPU (certainly all the packages are) but dunno how to check for sure.

Ralph Janke (txwikinger) on 2010-06-22
Changed in kde4libs (Ubuntu):
status: Invalid → Triaged
importance: Undecided → High
status: Triaged → Invalid

Same problem here, sometimes it just make keyboard work slow, sometimes mouse pointer moves slow, last time it thought that ctrl is pressed down. Always ps ax shows that kded4 defunct. Sometimes it can happen after 3 days, sometimes after some hours, like today. Boot fixes it for a while.

Using Kubuntu 10.04, KDE 4.4.4, kernel 2.6.32-020632, cpu is intel q6600 and graphics card is ATI HD3650 AGP.

(In reply to comment #7)
> Same problem here, sometimes it just make keyboard work slow, sometimes mouse
> pointer moves slow, last time it thought that ctrl is pressed down. Always ps
> ax shows that kded4 defunct. Sometimes it can happen after 3 days, sometimes
> after some hours, like today. Boot fixes it for a while.
>

Apparently kded4 is defunct right from the start, so maybe that is not the cause for these other things.

> Using Kubuntu 10.04, KDE 4.4.4, kernel 2.6.32-020632, cpu is intel q6600 and
> graphics card is ATI HD3650 AGP.

Still occurs with KDE 4.5 rc1 (packages from Kubuntu beta PPA):
$ ps -efw|grep kded
falken 1977 1 0 08:53 ? 00:00:06 kdeinit4: kded4 [kdeinit]
falken 2241 1977 0 08:54 ? 00:00:00 [kded4] <defunct>
falken 2719 1977 0 08:57 ? 00:00:00 [kded4] <defunct>
falken 2720 1977 0 08:57 ? 00:00:00 [kded4] <defunct>

Still present in RC2 :-/

> Still present in RC2 :-/

Same thing here with KDE SC 4.5RC2 from the Kubuntu PPA on my lucid system:
I see 2 defunct processes just after starting a KDE session.

This may be related to something in power manager and or power profile switching. I've noticed that when I unplug/replug the power adapter for my laptop, I end up with 2 new zombies, 1 for the unplug, 1 for the replug. If I have some time I'll dig into this deeper, but figured I'd note it here as this seems to be an on going issue (at least for me)

I don't get additional defunct process' no matter how many times I plug and unplug - Kubuntu's KDE 4.5 RC2 packages

As for my system:

 - sometimes I get 2 processes and no or a small growth of the number of processes
 - sometimes I get a very fast growth of the number of processes (several hundred in a few minutes and thousands after a few hours of work)

So far I have not been able to find what causes those different behaviours.

No, suspend and resume does not trigger extra ones, but something must, as I now have 3 defunct and one running kded4:
$ ps -efww|grep kded
falken 1800 1 0 Jul21 ? 00:00:37 kdeinit4: kded4 [kdeinit]
falken 2179 1800 0 Jul21 ? 00:00:00 [kded4] <defunct>
falken 15754 1800 0 09:16 ? 00:00:00 [kded4] <defunct>
falken 15755 1800 0 09:16 ? 00:00:00 [kded4] <defunct>
falken 19773 18636 0 16:08 pts/2 00:00:00 grep kded
$
July 21 was two days ago, I have hibernated several times since, and definitely had a few 'power at 15%' alerts too.

On Fri, 2010-07-23 at 17:11 +0200, Tom Chiverton wrote:

> No, suspend and resume does not trigger extra ones
[...]
> I have hibernated several times since

suspend and hibernate are not the same thing. Did you really try both ?

Comment #16: Yes.

*** This bug has been confirmed by popular vote. ***

Changed in kdelibs:
status: New → Confirmed

I have the same issue in my kubuntu 10.04 system, KDE version 4.4.2 .
I found that my issue may due to I'm using encrypted home directory. I used encryptfs bring by ubuntu. I found that each time when I'm doing login to my encrypted-home accounts, it left a [kded4] defunct process. When using su to this user and logout, it printed 'Sessions still open, not unmounting' .
I found that encryptfs used a pam plugin to function that auto mount/unmount home . In the pam config, there is line like

session optional pam_ecryptfs.so unwrap

When I commented these line out and login again, the defunct process went away. And when I uncommented them, the problem happened again.

Hope this information will help the debugging.

I don't have an encrypted /home, though it is on a different partition it's just configured in /etc/fstab as normal.

Even so, I do have a similar line:
falken@wopr:~$ grep pam_ecr /etc/pam.d/* /etc/pam.conf
/etc/pam.d/common-auth:auth optional pam_ecryptfs.so unwrap
/etc/pam.d/common-password:password optional pam_ecryptfs.so
/etc/pam.d/common-session:session optional pam_ecryptfs.so unwrap
/etc/pam.d/common-session-noninteractive:session optional pam_ecryptfs.so unwrap
falken@wopr:~$

I wonder what the effect of removing them is ?

I'm running a fairly new kubuntu 10.04 installation on a new netbook, and I get thousands of defunct kded4 processes. I rebooted about 4 hours ago and just now ran "ps aux | grep kded4 | wc" which shows 1,561 lines. My /home directory is encrypted. kde is version 4.4.2, and kernel is 2.6.32-24

I've posted the above to https://bugs.kde.org/show_bug.cgi?id=239965 which seems a better place. I'm not sure if the two are related or not, but suggest letting the folks responsible for that one look first.

Could you please fix it? I get more and more zombies:

Tasks: 398 total, 2 running, 188 sleeping, 0 stopped, 208 zombie

$ ps faux | grep -c kded4
209

Still happens with 4.5.4

Same here on kubuntu 10.10/kde 4.5.1

MMlosh (mmlosh) wrote :

just that few?

I have currently

$ ps -A | grep kded4\ \<defunct\> | wc -l
8274

and their count increases with time, no lid closing or suspend happened..

but I let it to turn off the display.

MMlosh (mmlosh) wrote :

also: it happens on 32bit too... using encryptfs (kde bug indicates strong corelation)

MMlosh (mmlosh) wrote :

update: although I am using XLock screen locker, those zombies are created automatically....

possibly related to messages like this in /var/log/auth.log (are those zombies over critical mass and multiplicating themselves??)

Jan 2 20:59:58 computer su[24373]: pam_unix(su:session): session closed for user username
Jan 2 21:00:24 computer su[24527]: Successful su for username by root
Jan 2 21:00:24 computer su[24527]: + ??? root:username
Jan 2 21:00:24 computer su[24527]: pam_unix(su:session): session opened for user username by (uid=0)
Jan 2 21:00:24 computer su[24527]: pam_unix(su:session): session closed for user username
Jan 2 21:00:52 computer su[24694]: Successful su for username by root
Jan 2 21:00:52 computer su[24694]: + ??? root:username
Jan 2 21:00:52 computer su[24694]: pam_unix(su:session): session opened for user username by (uid=0)
Jan 2 21:00:52 computer su[24694]: pam_unix(su:session): session closed for user username
Jan 2 21:01:19 computer su[24857]: Successful su for username by root
Jan 2 21:01:19 computer su[24857]: + ??? root:username
Jan 2 21:01:19 computer su[24857]: pam_unix(su:session): session opened for user username by (uid=0)
Jan 2 21:01:19 computer su[24857]: pam_unix(su:session): session closed for user username
Jan 2 21:01:46 computer su[25017]: Successful su for username by root
Jan 2 21:01:46 computer su[25017]: + ??? root:username
Jan 2 21:01:46 computer su[25017]: pam_unix(su:session): session opened for user username by (uid=0)
Jan 2 21:01:46 computer su[25017]: pam_unix(su:session): session closed for user username

It's not happening here on a clean install of Kubuntu 10.10 x64 and straight upgrade to KDE 4.6 from PPA.

falken@wopr:~$ ps -efw|grep kded4
falken 2037 1 0 Jan28 ? 00:00:08 kdeinit4: kded4 [kdeinit]
falken 2321 2037 0 Jan28 ? 00:00:00 [kded4] <defunct>
falken 5892 2257 0 13:40 pts/0 00:00:00 grep kded4
falken@wopr:~$

This is 32bit Kubutnu 10.10 (upgraded every 6 months from 9.4) with 4.6 from their backports PPA.

Changed in kdelibs:
importance: Unknown → Medium

I don't know if anybody noticed this but turning off notifications such as popups and sounds on system events, drastically reduces the zombies at least on my laptop.

Tais P. Hansen (taisph) wrote :

I think I may have found the culprit. Stopping and disabling the "Notification Helper" in the KDE Services Configuration seems to prevent further defunct kded processes.

I think I may have found the culprit. Stopping and disabling the "Notification Helper" in the KDE Services Configuration seems to prevent further defunct kded processes.

*** Bug 239965 has been marked as a duplicate of this bug. ***

I can confirm Tais P. Hansen's findings. A quick google search shows Notification Helper as a Kubuntu app so it's a downstream issue.

But doing so kills
"Notifications for upgrade information, when available.
...
Notifications for when upgrades require a reboot to complete." according to http://packages.ubuntu.com/lucid/kubuntu-notification-helper so isn't a viable work around :-(

Be aware doing so kills
"Notifications for upgrade information, when available.
...
Notifications for when upgrades require a reboot to complete." according to http://packages.ubuntu.com/lucid/kubuntu-notification-helper

Tais P. Hansen (taisph) wrote :

sudo rm /var/lib/update-notifier/user.d/ecryptfs-record-passphrase

... and the defunct processes are gone. At least on my laptop for a while now anyway.

It's a symlink to /usr/share/ecryptfs-utils/ecryptfs-record-passphrase which is an update-notifier "script" which seems to be a reminder for the user to make a note of the key used to encrypt the home directory. For some reason kubuntu-notifier-helper seems to choke on this file and cause defunct processes.

There is a catch though. Certain actions trigger the symlink to reappear. Ie. unplugging/replugging the AC power and the symlink is back.

Jonathan Thomas (echidnaman) wrote :

I've recently commited a fix for this in kubuntu-notification-helper's bzr branch.

Changed in kubuntu-notification-helper (Ubuntu):
status: New → Fix Committed
Manuel Bärenz (turion) wrote :

I would like to test it. But the latest version on https://launchpad.net/kubuntu-notification-helper is 0.4.90 from Juny 2010. Where can I get the latest version?

MMlosh (mmlosh) wrote :

Also: A lot of kded4 zombies are spawned when I run XLock (usually in transparent mode), possibly combined with closing laptop lid OR screen blank.

Is (K)Ubuntu aware of the issue, i.e. is this reported in their launchpad system?

Yes. It initially started in launchpad and was sent upstream.

There's apparently now a fix buried in a bzr tree somewhere.

Salva Ferrer (salva-ferrer) wrote :

Hello,

Jonathan, I tested the bzr branch today. Downloaded the branch, checked that apportevent had commit 227 in apportevent.cpp and build the package with dpkg-buildpackage, installed the resulting kubuntu-notification-helper_11.04ubuntu3_i386.deb. Exited kde, cleaned the zombies I had around and logged in kde.

As it started I had 1 zombie. I closed the lid and opened again and zobies increased. I stopped k-n-h, closed the lid and opened again and zombies remained stable. Started again k-n-h and zombies grew after closing and opening the lid.

I realized that line 65 in distupgradeevent.cpp is similar to the one in apportevet.cpp that you modified in commit 227, maybe that one requires modification as well.

In my case at least the current bzr branch still shows the issue.

Salva Ferrer (salva-ferrer) wrote :

Please, forget my previous comment (wish I could delete it :( ) I did a mistake during the build and my installation was not correct and still running the old daemon.

I'll check better before commenting again ;)

Salva Ferrer (salva-ferrer) wrote :

Ok, I did it right this time. I confirmed that the compilation was right and that the version installed was the new one (tagged 11.04ubuntu3).

The results are the same, closing the lid and opening it again creates kded4 zombies. This happens only if k-n-h is running.

As said before, there are other files that might require checking, like distupgradeevent.cpp.

I am using kubuntu 10.10 updated to the backports ppa.

Virus (lanchpad) wrote :

Same shit on 4:4.6.1-0ubuntu1~maverick1~ppa1 (Ubuntu 10.10 amd64)

Any fix available?

Daniel Eckl (daniel-eckl) wrote :

Could you please tell me, which version of pulseaudio you have? Open a console and type:

apt-cache policy pulseaudio

I'm not sure about that, but I think it could be related to some ppa versions of pulseaudio 0.9.23 that have been pushed out one day over ricotz/unstable PPA but have been withdrawn since. But if you did get this version, it won't automatically downgrade.

Virus (lanchpad) wrote :

pulseaudio:
  Installed: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1
  Candidate: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1
  Version table:
 *** 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1 0
        500 http://ua.archive.ubuntu.com/ubuntu/ maverick-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21 0
        500 http://ua.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

Daniel Eckl (daniel-eckl) wrote :

I see. Sorry, no hit this time.

Moritz (moritz89) wrote :

The crash is caused by this script:

/usr/share/ecryptfs-utils/ecryptfs-record-passphrase

which is linked to by:

/var/lib/update-notifier/user.d/ecryptfs-record-passphrase

What the script does is to check if the user has already written down the random pass-phrase that was generated for the encrypted HDD. A simple work-around is to just make the script believe that the user has already done this. The work-around is creating this file:

sudo touch $HOME/.ecryptfs/.wrapped-passphrase.recorded

It seems the file "/var/lib/update-notifier/user.d/ecryptfs-record-passphrase" is rewritten each time an ACPI (power-related) event is sent.

BTW. to record your HDD encryption password run:

ecryptfs-unwrap-passphrase

Jonathan Riddell (jr) on 2011-03-25
Changed in kubuntu-notification-helper (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
tags: added: kubuntu
Jonathan Riddell (jr) on 2011-03-31
Changed in kubuntu-notification-helper (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Jonathan Riddell (jr) wrote :

11.04ubuntu3 now uploaded for anyone running 11.04 Beta 1. Upgrade to kubuntu-notification-helper 11.04ubuntu3, log out and in again then test.

This bug was specific to Kubuntu and has been fixed in natty.

Not fixed in Natty for me:

falken@wopr:~$ ps -efw|grep kded
falken 1975 1 0 21:34 ? 00:00:05 kdeinit4: kded4 [kdeinit]
falken 2287 1975 0 21:36 ? 00:00:00 [kded4] <defunct>

This is after I went back and re-enabled the notification service.

"11.04ubuntu3 now uploaded for anyone running 11.04 Beta 1. Upgrade to kubuntu-notification-helper 11.04ubuntu3, log out and in again then test."

Still there after a reboot.

falken@wopr:~$ ps -efw|grep kded
falken 1977 1 0 21:04 ? 00:00:01 kdeinit4: kded4 [kdeinit]
falken 2338 1977 0 21:05 ? 00:00:00 [kded4] <defunct>
falken 4513 3782 0 21:15 pts/1 00:00:00 grep kde
falken@wopr:~$ dpkg -l |grep ii|grep notification-helper
ii kubuntu-notification-helper 11.04ubuntu3 Kubuntu system notification helper
falken@wopr:~$

Here it is appearing shortly after a reboot and relogin, after I unplugged the laptop's power. Not sure if that was the trigger.
falken@wopr:/tmp$ ps -efw|grep kded
falken 1976 1 1 22:19 ? 00:00:00 kdeinit4: kded4 [kdeinit]
falken 2274 2210 0 22:20 pts/0 00:00:00 grep kded
falken@wopr:/tmp$ ps -efw|grep kded
falken 1976 1 1 22:19 ? 00:00:00 kdeinit4: kded4 [kdeinit]
falken 2276 2210 0 22:20 pts/0 00:00:00 grep kded
falken@wopr:/tmp$ ps -efw|grep kded
falken 1976 1 0 22:19 ? 00:00:00 kdeinit4: kded4 [kdeinit]
falken 2321 2320 0 22:21 ? 00:00:00 su - falken -c DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-v8ONC9gn9i,guid=49d7688ed98556dc196d48eb00000039 dbus-send --print-reply --dest=org.kde.kded /kded org.kde.kded.loadedModules
falken 2345 2321 0 22:21 ? 00:00:00 dbus-send --print-reply --dest=org.kde.kded /kded org.kde.kded loadedModules
falken 2371 2210 0 22:21 pts/0 00:00:00 grep kded
falken@wopr:/tmp$ ps -efw|grep kded
falken 1976 1 1 22:19 ? 00:00:00 kdeinit4: kded4 [kdeinit]
falken 2321 2320 0 22:21 ? 00:00:00 su - falken -c DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-v8ONC9gn9i,guid=49d7688ed98556dc196d48eb00000039 dbus-send --print-reply --dest=org.kde.kded /kded org.kde.kded.loadedModules
falken 2345 2321 0 22:21 ? 00:00:00 dbus-send --print-reply --dest=org.kde.kded /kded org.kde.kded loadedModules
falken 2377 2210 0 22:21 pts/0 00:00:00 grep kded
falken@wopr:/tmp$ ps -efw|grep kded
falken 1976 1 1 22:19 ? 00:00:00 kdeinit4: kded4 [kdeinit]
falken 2379 1976 0 22:21 ? 00:00:00 [kded4] <defunct>
falken 2417 2210 0 22:21 pts/0 00:00:00 grep kded

Not resolved. See comment at your link.

Jonathan Riddell (jr) on 2011-04-15
Changed in kubuntu-notification-helper (Ubuntu):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.10
Jonathan Riddell (jr) on 2011-04-15
Changed in kubuntu-notification-helper (Ubuntu):
milestone: ubuntu-11.10 → ubuntu-11.04
Felix Geyer (debfx) on 2011-04-17
Changed in kubuntu-notification-helper (Ubuntu):
status: Fix Committed → Confirmed
Changed in kubuntu-notification-helper (Ubuntu Natty):
status: New → Confirmed
Changed in kubuntu-notification-helper (Ubuntu):
milestone: ubuntu-11.04 → natty-updates
Changed in kubuntu-notification-helper (Ubuntu Natty):
milestone: none → natty-updates
Jonathan Thomas (echidnaman) wrote :

Could those still experiencing this bug pinpoint which notification is causing these zombies? You can enable/disable notifications using this pane in System Settings. If all are disabled and the zombies are still there, we will know that it is a different bug with the same symptoms somewhere else.

Changed in kubuntu-notification-helper (Ubuntu):
status: Confirmed → Incomplete

I have disabled notification helper on my kubuntu and there is no zombies anymore.

Alexander (roth-a) wrote :

Same here. I disabled all^(except "Required reboots"). And there are no zombies.

Robert Simmons (rsimmons0) wrote :

After disabling each of those notifications in the screen capture above one-by-one there was no effect on the creation of the kded zombies. Still every time I close the lid of the laptop I get a new zombie or two. However, there is a notification that occurs: "KDE Power Management System" "The screen is being locked"

After a few days of use opening and closing the screen on the laptop I must reboot or the groans and incessant calls for "braaaaaains!" from the zombies becomes too much to handle. ;)

Robert Simmons (rsimmons0) wrote :

Also, I am using Kubuntu 11.04 with KDE 4.6.4.

Peter Antoniac (pan1nx) wrote :

Ping: any fix for this?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

What is the status of this bug? Does it still happen with a recent KDE version, such as 4.6.5 or 4.7.x? Please add a comment.

I'm using KDE 4.7.0 (4.7.1 has not yet been packaged for Natty) and the problem is still there.
I had to disable all my cronjobs.

Yup, still busted here in 11.04 Kubuntu:

falken@wopr:/tmp$ ps -efww|grep kded ; dpkg -l|grep kdebase-workspace
falken 2833 1 0 Sep14 ? 00:00:08 kdeinit4: kded4 [kdeinit]
falken 3530 2833 0 Sep14 ? 00:00:00 [kded4] <defunct>
falken 10386 3378 0 16:12 pts/0 00:00:00 grep kded
ii kdebase-workspace 4:4.6.5-0ubuntu1~ppa2 KDE Plasma Workspace components

Still occurs with Kubuntu 11.10 beta 2 (version 4:4.7.1-0ubuntu2) !
falken@wopr:/tmp$ ps -efww|grep kded
falken 2316 1 0 11:28 ? 00:00:02 kdeinit4: kded4 [kdeinit]
falken 2714 2316 0 11:29 ? 00:00:00 [kded4] <defunct>
falken 3778 2598 0 13:05 pts/0 00:00:00 grep kded
falken@wopr:/tmp$

Still occurs with Kubuntu 11.10 beta 2 (version 4:4.7.1-0ubuntu2) !
falken@wopr:/tmp$ ps -efww|grep kded
falken 2316 1 0 11:28 ? 00:00:02 kdeinit4: kded4 [kdeinit]
falken 2714 2316 0 11:29 ? 00:00:00 [kded4] <defunct>
falken 3778 2598 0 13:05 pts/0 00:00:00 grep kded
falken@wopr:/tmp$

Tom, does comment #29 fix it for you? If not, you probably would have to go through http://kdepepo.wordpress.com/2011/05/11/troubleshooting-kded4-bugs/ to find the culprit.

#29 fixed it in earlier KDEs, it appears to have been turned back on for me. I've turned it off and will report back.

Disabling this service isn't a proper fix, of course, just identifying the cause.

Yeah, work around seems to work.

The "Notification Helper" is a Ubuntu-specific package. Please report this problem to https://launchpad.net/ubuntu/+source/kubuntu-notification-helper

Already reported (https://bugs.launchpad.net/ubuntu/+source/kubuntu-notification-helper/+bug/515138) - are you and Ubuntu co-ordinating a fix ? This is moderately important because the defunct processes confuses an ACPI script, which cause an unconditional shutdown, and so data loss, instead of hibernate when the power button is pressed.

tags: added: dataloss oneiric

The kubuntu-notification-helper package is not part of the KDE repositories, so I doubt any KDE developer can help here. Additionally, following the downstream report, the information which of the notifications is causing the error requested in comment 24 is still unclear (comment 26 and 27 are contradicting).

Reading all comments I see no indication that this bug is present without the kubuntu-notification-helper. Resolving accordingly.

By quickly looking at the source for the mentioned package, it leaks KProcess instances everywhere.

According to KDE, the code "leaks KProcess instances everywhere". This is not a good sign.

Changed in kdelibs:
status: Confirmed → Unknown
Changed in kubuntu-notification-helper:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-notification-helper - 11.10ubuntu1

---------------
kubuntu-notification-helper (11.10ubuntu1) oneiric; urgency=low

  [ Jonathan Thomas ]
  * Check the result of QApt Batch in InstallEvent before we triumphantly
    declare success. (LP: #745133)
  * Make sure to initialize the KStatusNotifierItem object's pointer with 0,
    otherwise crashes will occur when trying to delete it due to the undefinied
    behavior of accessing an un-initialized pointer. Fixes a crash that occurs
    when k-n-h is configured to show only popup icons. (LP: #780718)
  * Use HIG-compliant labels for radio buttons. (No double negatives)

  [ Harald Sitter ]
  * Properly KProcess DisplayIf hook conditions as shell commands.
    Trying to evaluate a complex expression as program will make the process
    die and return as zombie! OMG! (LP: #515138)
  * If a hook is not valid and a notification is not required schedule the
    hook for deletion via event loop to save memory.
  * Use QLatin1String when useful in HookEvent
  * In unused distupgradevent do not leak KProcess on availability checks.
  * Nice fact about KProcess... when starting detached you can actually
    throw away the KProcess right away (or reuse it). Consequently do not
    heap the KProcess for terminal Hook invocation, but keep it on the stack.
  * Bump standards version to 3.9.2
 -- Harald Sitter <email address hidden> Sun, 25 Sep 2011 20:10:33 +0200

Changed in kubuntu-notification-helper (Ubuntu):
status: Incomplete → Fix Released

Appears fixed here.

Tom, at least apportevent.cpp needs to be fixed, too.

*** Bug 282490 has been marked as a duplicate of this bug. ***

Marius B. Kotsbak (mariusko) wrote :

Could anyone please confirm if this is fixed in Natty now?

Changed in kubuntu-notification-helper (Ubuntu Natty):
status: Confirmed → Incomplete
Changed in kde4libs (Ubuntu Natty):
status: New → Incomplete
dino99 (9d9) wrote :
Changed in kubuntu-notification-helper (Ubuntu Natty):
status: Incomplete → Invalid
Changed in kde4libs (Ubuntu Natty):
status: Incomplete → Invalid

This bug still exists on Gentoo with KDE 4.14.3. I see no notification-helper packages installed.

thud ~ # date
Thu Aug 27 20:29:20 EDT 2015
thud ~ # equery list kde-apps/kdebase-meta
 * Searching for kdebase-meta in kde-apps ...
[IP-] [ ] kde-apps/kdebase-meta-4.14.3:4
thud ~ # ps aux | grep Z
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 948 0.0 0.2 10836 2216 pts/0 S+ 20:29 0:00 grep --colour=auto Z
jim 11078 0.0 0.0 0 0 ? Z Aug20 0:00 [kded4] <defunct>
jim 22581 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 22692 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 22727 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 22785 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 22823 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 23014 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 23022 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 23060 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 23122 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 23125 0.0 0.0 0 0 ? Z Aug23 0:00 [kded4] <defunct>
jim 30718 0.0 0.0 0 0 ? Z Aug16 0:00 [kded4] <defunct>
jim 30791 0.0 0.0 0 0 ? Z Aug16 0:00 [kded4] <defunct>
jim 30866 0.0 0.0 0 0 ? Z Aug16 0:00 [kded4] <defunct>
thud ~ # equery list '*helper*'
 * Searching for *helper* ...
[IP-] [ ] net-libs/libnetfilter_cthelper-1.0.0:0
thud ~ #

Download full text (22.9 KiB)

FYI, this box does not run a local X. I run some KDE apps (konsole, konqueror) under icewm in an x2go session. However, right now there is no x2go server running, either. Here's my full process list. I note lots of dbus-daemon and kdeinit4 processes running as well.

thud ~ # ps aux
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 1 0.0 0.1 4208 1024 ? Ss Aug09 0:33 init [3]
root 2 0.0 0.0 0 0 ? S Aug09 1:14 [kthreadd]
root 3 0.0 0.0 0 0 ? S Aug09 2:16 [ksoftirqd/0]
root 5 0.0 0.0 0 0 ? S< Aug09 0:00 [kworker/0:0H]
root 7 0.0 0.0 0 0 ? S Aug09 14:09 [rcu_sched]
root 8 0.0 0.0 0 0 ? S Aug09 0:00 [rcu_bh]
root 9 0.0 0.0 0 0 ? S Aug09 0:09 [migration/0]
root 10 0.0 0.0 0 0 ? S Aug09 0:08 [migration/1]
root 11 0.0 0.0 0 0 ? S Aug09 2:05 [ksoftirqd/1]
root 13 0.0 0.0 0 0 ? S< Aug09 0:00 [kworker/1:0H]
root 14 0.0 0.0 0 0 ? S Aug09 0:08 [migration/2]
root 15 0.0 0.0 0 0 ? S Aug09 2:12 [ksoftirqd/2]
root 17 0.0 0.0 0 0 ? S< Aug09 0:00 [kworker/2:0H]
root 18 0.0 0.0 0 0 ? S Aug09 0:10 [migration/3]
root 19 0.0 0.0 0 0 ? S Aug09 2:08 [ksoftirqd/3]
root 21 0.0 0.0 0 0 ? S< Aug09 0:00 [kworker/3:0H]
root 22 0.0 0.0 0 0 ? S< Aug09 0:00 [khelper]
root 23 0.0 0.0 0 0 ? S Aug09 0:00 [kdevtmpfs]
root 24 0.0 0.0 0 0 ? S< Aug09 0:00 [netns]
root 25 0.0 0.0 0 0 ? S< Aug09 0:00 [perf]
root 26 0.0 0.0 0 0 ? S< Aug09 0:00 [writeback]
root 27 0.0 0.0 0 0 ? SN Aug09 0:00 [khugepaged]
root 28 0.0 0.0 0 0 ? S< Aug09 0:00 [crypto]
root 29 0.0 0.0 0 0 ? S< Aug09 0:00 [kintegrityd]
root 30 0.0 0.0 0 0 ? S< Aug09 0:00 [bioset]
root 31 0.0 0.0 0 0 ? S< Aug09 0:00 [kblockd]
root 32 0.0 0.0 0 0 ? S< Aug09 0:00 [ata_sff]
root 33 0.0 0.0 0 0 ? S< Aug09 0:00 [devfreq_wq]
root 34 0.0 0.0 0 0 ? S Aug09 1:41 [kworker/0:1]
root 39 0.1 0.0 0 0 ? S Aug09 37:56 [kswapd0]
root 40 0.0 0.0 0 0 ? S Aug09 0:00 [fsnotify_mark]
root 47 0.0 0.0 0 0 ? S< Aug09 0:00 [kthrotld]
root 48 0.0 0.0 0 0 ? S< Aug09 0:00 [acpi_thermal_pm]
root 49 0.0 0.0 0 0 ? S< Aug09 0:00 [bioset]
root 50 0.0 0.0 0 0 ? S< Aug09 0:00 [deferwq]
root 107 0.0 0.0 0 0 ? S Aug09 1:25 [kworker/1:2]
root 366 0.0 0.5 83532 5516 ? Ss 20:17...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.