Various KDE apps crash with signal 7 in KPixmapCache::Private::mmapFile()

Bug #321281 reported by spinstartshere
This bug affects 142 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
kde4libs (Ubuntu)
High
Jonathan Thomas
Karmic
Medium
Unassigned
Lucid
High
Jonathan Thomas

Bug Description

*Added by Jonathan Thomas*
This crash usually occurs when desktop effects are turned on and off or the Plasma theme changes.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/krunner
Package: kdebase-workspace-bin 4:4.1.96-0ubuntu5
ProcCmdline: /usr/bin/krunner
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 7
SourcePackage: kdebase-workspace
StacktraceTop:
 KPixmapCache::Private::mmapFile ()
 KPixmapCache::Private::mmapFiles ()
 KPixmapCache::Private::init () from /usr/lib/libkdeui.so.5
 KPixmapCache::discard () from /usr/lib/libkdeui.so.5
 KPixmapCache::deleteCache () from /usr/lib/libkdeui.so.5
Title: krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()
Uname: Linux 2.6.28-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv netdev plugdev powerdev pulse pulse-access pulse-rt sambashare scanner vboxusers video

Revision history for this message
spinstartshere (spinstartshere) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:KPixmapCache::Private::mmapFile (this=0x9020590,
KPixmapCache::Private::mmapFiles (this=0x9020590)
KPixmapCache::Private::init (this=0x9020590)
KPixmapCache::discard (this=0x96869f8)
KPixmapCache::deleteCache (name=@0xbfd23cc8)

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Changed in kdebase-workspace:
importance: Undecided → Medium
Revision history for this message
Jonathan Thomas (echidnaman) wrote : Re: krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()

Hi,
Any idea how or when this crash happened? Thanks in advance!

Changed in kdebase-workspace:
status: New → Incomplete
Revision history for this message
spinstartshere (spinstartshere) wrote :

Sorry, I don't remember. It may have just been a seemingly random occurrence.

Changed in kdebase-workspace:
importance: Medium → Low
status: Incomplete → Confirmed
Changed in kdebase:
status: Unknown → Confirmed
Changed in kdebase-workspace:
status: Confirmed → Triaged
Revision history for this message
j.adredz (j-adredz) wrote :

I experienced this too. It happened after I launched System Settings using Krunner. But prior to that, I tried to launch it using raptor-menu but nothing happened so I used Krunner instead...

Changed in kde4libs (Ubuntu):
importance: Low → Medium
Revision history for this message
Benpro (benpro82) wrote :

Hello there, for me the bug hapenned when The plasmaoid "Last peripheral USB plugged" detect my external HDD, strange...
Sorry for my english.

Revision history for this message
vic (kvic45) wrote : Re: [Bug 321281] Re: krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()

Hi!
Well, I don't think I was doing anything with USB when it crashed, if I
remember correctly. Anyway, it happened only once so far and might have
already been fixed in Qt4 or KDE libs, which have been updated recently (and
there was a large update this morning as well). I will keep watching.

Good luck!

2009/4/9 Benpro <email address hidden>

> Hello there, for me the bug hapenned when The plasmaoid "Last peripheral
> USB plugged" detect my external HDD, strange...
> Sorry for my english.
>
> --
> krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()
> https://bugs.launchpad.net/bugs/321281
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in KDE Base Components: Confirmed
> Status in “kde4libs” source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: kdebase-workspace
>
>
>
> ProblemType: Crash
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/krunner
> Package: kdebase-workspace-bin 4:4.1.96-0ubuntu5
> ProcCmdline: /usr/bin/krunner
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> Signal: 7
> SourcePackage: kdebase-workspace
> StacktraceTop:
> KPixmapCache::Private::mmapFile ()
> KPixmapCache::Private::mmapFiles ()
> KPixmapCache::Private::init () from /usr/lib/libkdeui.so.5
> KPixmapCache::discard () from /usr/lib/libkdeui.so.5
> KPixmapCache::deleteCache () from /usr/lib/libkdeui.so.5
> Title: krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()
> Uname: Linux 2.6.28-5-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv
> netdev plugdev powerdev pulse pulse-access pulse-rt sambashare scanner
> vboxusers video
>

Revision history for this message
Aaron Johnson (ajohnson5050) wrote : Re: krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()

I had this same crash a few minutes ago while trying to open konqueror. Everything on the screen froze except for the mouse and I had to r-e-i-s-u-b out of it. I also had a similar crash a few days ago while trying to open konqueror. You can see my prev. bug report.

I'm using 64bit kubuntu 9.04. let me know if I can give you anymore info.

Revision history for this message
Aaron Johnson (ajohnson5050) wrote :

Same crash again while closing Firefox after making the above report. This time apport didn't catch it. Had to do the r-e-i-s-u-b again. I should also include that Kubuntu Intrepid 64 bit gave me the same constant crashes to the point where I decided not to even give it a shot for more than a few days.

Revision history for this message
Aaron Johnson (ajohnson5050) wrote :

And again. Same popup as in the above "krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()" without the screen freeze. Maybe I should never close firefox again. Just kidding - I'm going to killall firefox this time.

Changed in kdebase:
status: Confirmed → Fix Released
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

A fix has been committed for KDE 4.3 beta2 and for KDE 4.2.4, though it just missed tagging for 4.2.4 so we may want to cherry-pick that ourselves for the PPA packages.

Changed in kde4libs (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.2.90-0ubuntu1

---------------
kde4libs (4:4.2.90-0ubuntu1) karmic; urgency=low

  [ Jonathan Thomas ]
  * New upstream release:
    - Refresh kubuntu_56_langpacks_files.diff so that it applies
    Closes: (LP: #321281, #325009, #351038, #292669)

  [ Alessandro Ghersi ]
  * Update kdelibs5-data.install, kdelibs5.install, and kdelibs5-dev.install

 -- Alessandro Ghersi <email address hidden> Thu, 04 Jun 2009 03:45:15 +0200

Changed in kde4libs (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Still happening in KDE 4.3.0.

Changed in kde4libs (Ubuntu):
status: Fix Released → Triaged
Changed in kdebase:
status: Fix Released → Confirmed
Revision history for this message
Alan Jenkins (aj504) wrote :

Happened to me on Karmic (installed as alpha 4) after reproducing and reporting <https://bugs.kde.org/show_bug.cgi?id=206890> "Bug 206890: krunner doesn't reliably show newly installed applications krunner doesn't reliably show newly installed aplications"

The crash happened a minute or so *after* playing with krunner, and interrupted my fullscreen game of starfighter.

Revision history for this message
Alan Jenkins (aj504) wrote :

PS please ignore or delete the incorrect bug watch which Launchpad "helpfully" added after my comment above, without asking me.

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

I'm also affected.

Revision history for this message
nlaunch (nicolas-hy) wrote :

When starting Chromium game !
Screen change resolution and just after it many crash arrive !
And report bugs says pixmap error !
Perhaps same bug.

Changed in kde4libs (Ubuntu):
importance: Medium → High
summary: - krunner crashed with signal 7 in KPixmapCache::Private::mmapFile()
+ Various KDE apps crash with signal 7 in
+ KPixmapCache::Private::mmapFile()
description: updated
Revision history for this message
Freedom908 (picle709) wrote :

lucid A2 on 32 bit vsta
had firefox open on gnome - so didn't notice what happened

Revision history for this message
Craig Magina (craig.magina) wrote :

It happened when I clicked the "Appearance" entry in "System Settings."

Revision history for this message
Craig Magina (craig.magina) wrote :

Forgot to mention I am running 32-bit Lucid, fully updated as of right now (and having rebooted since the update).

Revision history for this message
Craig Magina (craig.magina) wrote :

Just hit it again with kwin when I tried to apply my display settings.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Upstream has a patch they've committed against trunk. In cooperation with upstream, I have been testing the patch for the better part of the week. It fixes the bug and has no known regressions. We definitely should get this in for 10.04.

Changed in kde4libs (Ubuntu):
assignee: nobody → Jonathan Thomas (echidnaman)
importance: High → Critical
milestone: none → ubuntu-10.04-beta-2
status: Triaged → In Progress
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Patch committed to bzr for the next packaging release.

Changed in kde4libs (Ubuntu):
status: In Progress → Fix Committed
Changed in kdebase:
status: Confirmed → Fix Released
Changed in kde4libs (Ubuntu Karmic):
milestone: none → karmic-updates
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → Jonathan Thomas (echidnaman)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.4.1-0ubuntu3

---------------
kde4libs (4:4.4.1-0ubuntu3) lucid; urgency=low

  [ Jonathan Thomas ]
  * Add kubuntu_72_kpixmapcache_discard_fix.diff to fix various crashes while
    toggling compositing or changing Plasma themes (LP: #321281)
    - Can be dropped in KDE 4.4.2
  * Add kubuntu_73_silence_kdebug.diff to fix applications being verbose when
    KDebug isn't enabled (LP: #540944)
    - Can be dropped in KDE 4.4.2

  [ Scott Kitterman ]
  * Manually remove mimetypes/kde.xml.podir that somehow crept into the
    diff.gz
 -- Scott Kitterman <email address hidden> Thu, 25 Mar 2010 14:21:27 -0400

Changed in kde4libs (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

I'd just recommend updating to Lucid or higher at this point.

Changed in kde4libs (Ubuntu Lucid):
importance: Critical → High
Changed in kde4libs (Ubuntu):
importance: Critical → High
Changed in kde4libs (Ubuntu Karmic):
assignee: Jonathan Thomas (echidnaman) → nobody
importance: Critical → Medium
status: In Progress → Won't Fix
Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.