[LUCID] 'Hardware Drivers' showing all drivers as active

Bug #562226 reported by Fido on 2010-04-13
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Alberto Milone

Bug Description

In the latest lucid, 'Hardware Drivers' is showing all three nvidia drivers as active immediately after installation. This means that the only option is to first "remove" the driver, and then install it. This also means that no "Proprietary Drivers available" message is being shown.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: jockey-gtk 0.5.8-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic i686
Architecture: i386
CurrentDmesg: [ 32.805384] ppdev: user-space parallel port driver
Date: Tue Apr 13 08:45:05 2010
EcryptfsInUse: Yes
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-7142
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=3dfe91fd-4c7f-4326-ba7a-3a79dff12be5 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: jockey
dmi.bios.date: 06/27/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7142
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.00
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd06/27/2006:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7142:pvr1.00:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7142:rvr1.00:cvn:ct3:cvr:
dmi.product.name: MS-7142
dmi.product.version: 1.00
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD

Fido (fedevera) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Confirmed using an installation from Ubuntu lucid-desktop-i386.iso dated 2010-04-16.

This has a severe impact on all NVidia Video card users, since you must remove a driver before you can install a driver. Just to verify this, I did find the driver is use is nouveau using:

find /lib/modules/ -type f -ls -iname '*.ko' | grep -E "/nvidia-current.ko|/nvidia-173.ko|/nvidia-96.ko|/fglrx.ko"

returns blank;

grep -E "LoadModule:.*\"nvidia|fglrx|nouveau\"" /var/log/Xorg.0.log

returns "nouveau".

Thanks for taking the time to make Ubuntu better!

Changed in jockey (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in jockey (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu):
status: Triaged → In Progress
Alberto Milone (albertomilone) wrote :

I have pushed a fix for this bug in this bazaar branch: lp:~ubuntu-core-dev/jockey/ubuntu

Changed in jockey (Ubuntu):
status: In Progress → Fix Committed
bwallum (rbw2) wrote :

Had same problem, now one green light and 2 grey showing as expected using nVidia recommended driver. The bug was repeatable yesterday on two machines (deactivate and reactivate) but appears to have cleared with recent updates.

However, if the recommended nVidia driver is activated the Usplash is thin lines of scrambled pixels. De activating the nVidia driver (restoring to default driver) brings back the expected Usplash and messaging. 100% repeatable, AMD64 Ubuntu lucid updated 10:30 GMT Sun 18th Apr

bwallum (rbw2) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.8-0ubuntu8

---------------
jockey (0.5.8-0ubuntu8) lucid; urgency=low

  * data/handlers/fglrx.py, nvidia.py:
    - Do not check the non null value of current_alternative and
      target_alternative. This caused jockey to skip the condition
      that we really wanted to test (i.e. do the two alternatives
      match?) and show the driver as enabled when the target
      alternative didn't exist (as the package hadn't been installed
      yet) (LP: #562226).
 -- Alberto Milone <email address hidden> Mon, 19 Apr 2010 10:36:10 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers