Wrong translation of "Greek Modern"

Bug #267513 reported by Thanos Lefteris on 2008-09-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
iso-codes
Unknown
Unknown
iso-codes (Debian)
Fix Released
Unknown
iso-codes (Ubuntu)
Low
Unassigned
language-selector (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: language-selector

In language-selector the translation of "Ancient Greek" and "Modern Greek" as "Αρχαία Ελληνικά" and "Σύγχρονα Ελληνικά" respectively makes those language entries appear in two separate places in the language list and in a position where Greek people don't expect them to be.

They should be translated as:

Greek, Modern -> Ελληνικά
Greek, Ancient -> Ελληνικά (Αρχαία)

I'm not sure where this language list translation is coming from, so I'll file it under language-selector, waiting for someone who knows.

The bug at alioth.d.o: https://alioth.debian.org/tracker/?group_id=30316&atid=413077&func=detail&aid=312565

Changed in language-selector:
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

I think that this bug is fixed

Savvas Radevic (medigeek) wrote :

Fixed in jaunty 9.04 alpha 4 updated

Changed in language-selector:
status: Confirmed → Fix Released
Simos Xenitellis  (simosx) wrote :

Thanks Savvas.
Could you please show in a screenshot where it also says Ancient Greek?
It is essentially the same screenshot as you already did, but it shows the three options that relate to the Greek language (shows only two now).

As far as I can see, there's no Greek Ancient in the "Install / Remove
Languages".
I'll update and let you know in a couple of hours :)

Savvas Radevic (medigeek) wrote :

Nope, no Greek (Ancient) found in the languages, not anymore at least!

Reverting back to confirmed, sorry. :)
It says Ελληνικά Σύγχρονα (=Greek Modern), which fixes the first part of the bug.
The reporter requested also to remove "Σύγχρονα" (=Modern).

So an update for jaunty, the bug reporter wishes to see:
Ελληνικά Σύγχρονα -> Ελληνικά

Changed in language-selector:
status: Fix Released → Confirmed
Savvas Radevic (medigeek) wrote :
description: updated
C de-Avillez (hggdh2) on 2009-02-26
Changed in iso-codes:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in iso-codes:
status: Unknown → New
Arne Goetje (arnegoetje) wrote :

Not a bug in language-selector.

Changed in language-selector (Ubuntu):
status: New → Invalid
Arne Goetje (arnegoetje) wrote :

Please fix the translation directly in Launchpad. We will take new translations from there.

https://translations.launchpad.net/ubuntu/jaunty/+source/iso-codes

When done, please leave a note here.
Thanks.

Savvas Radevic (medigeek) wrote :

Left new suggestions for the following translations:
iso-639: Template "iso-639" in Ubuntu Jaunty package "iso-codes"
iso-639-3: Template "iso-639-3" in Ubuntu Jaunty package "iso-codes"

Savvas Radevic (medigeek) wrote :

Greek, Modern -> Ελληνικά
This one is already fixed: Greek, Ancient -> Ελληνικά, Αρχαία

Nigel Babu (nigelbabu) wrote :

Is this issue still unfixed?

Changed in iso-codes (Ubuntu):
status: Triaged → Incomplete
Savvas Radevic (medigeek) wrote :

Still exists in 10.04 lucid and in latest upstream version 3.16.
Bug reported upstream: https://alioth.debian.org/tracker/index.php?func=detail&aid=312565&group_id=30316&atid=413077

Changed in iso-codes (Ubuntu):
status: Incomplete → Confirmed
Nigel Babu (nigelbabu) wrote :

Thanks for for linking the upstream bug and also forwarded upstream

Changed in iso-codes (Ubuntu):
status: Confirmed → Triaged
tags: added: patch-forwarded-upstream
Christian Perrier (bubulle) wrote :

We just asked the translator about his stance on this. I'm personnally balanced. One one hand, the standard includes the word "Modern" and I don't see any reason to drop it....unless the standard itself drops it. Which is indeed why my French translations says "Grec moderne (après 1453)". let's way for the translator's answer.

Simos Xenitellis  (simosx) wrote :

What we want here is to update the upstream translation for a package that is managed by Debian.
For this specific issue we had a discussion on the ubuntu-gr mailing list some time ago, with input from the Greek Debian l10n mailing list,
http://lists.debian.org/debian-l10n-greek/

We got agreement at that point for the translation change, but it appears that the change was not committed.
There is now a second (Greek) Debian developer that can help on this.

Savvas,
Can you locate the discussion on the ubuntu-gr/debian-l10n-greek mailing list and revive it?
Serafeim or Kostas should be able to commit this change directly.

no longer affects: iso-codes
description: updated
Christian Perrier (bubulle) wrote :

I fixed the *translation* in git, so it will be in the next release.

However, as already said many many times, I won't fix the English version: if you want it to be changed, then have the ISO 639 standards changed.

On 7 January 2012 18:35, Christian Perrier <email address hidden> wrote:
> I fixed the *translation* in git, so it will be in the next release.
>
> However, as already said many many times, I won't fix the English
> version: if you want it to be changed, then have the ISO 639 standards
> changed.
>

Thank you for your effort, much appreciated! :)

Changed in iso-codes (Debian):
status: New → Won't Fix
Changed in iso-codes (Debian):
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.