intel_microcode: prepend_earlyinitramfs: not found

Bug #1194370 reported by dino99 on 2013-06-25
324
This bug affects 65 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Dimitri John Ledkov
Saucy
Undecided
Dimitri John Ledkov
intel-microcode (Ubuntu)
High
Unassigned
Saucy
Undecided
Unassigned

Bug Description

Not sure about the package to be blamed

thats what i get with a new kernel installation:

update-initramfs: Generating /boot/initrd.img-3.10.0-0-generic
/usr/share/initramfs-tools/hooks/intel_microcode: 115: /usr/share/initramfs-tools/hooks/
intel_microcode: prepend_earlyinitramfs: not found
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

Note: earlier, i've seen a warning saying something like "initramfs is pointing nowhere", so it seems that initramfs need to be updated for pointing to the path now used.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: intel-microcode 1.20130222.3
ProcVersionSignature: Ubuntu 3.9.0-7.15-generic 3.9.7
Uname: Linux 3.9.0-7-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu2
Architecture: i386
Date: Tue Jun 25 08:01:32 2013
MarkForUpload: True
SourcePackage: intel-microcode
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :

intel-microcode requires initramfs-tools 0.113 to generate an early initramfs for kernel 3.9 and later.

It will fall back to standard initramfs support if prepend_earlyinitramfs() is not supported by initramfs-tools.

So, this bug should be a feature request for initramfs-tools to sync to the latest Debian upstream.

Changed in initramfs-tools:
status: New → Confirmed
dino99 (9d9) wrote :

Thanks Henrique,

initramfs has not been updated to 113, so saucy still use 107
Today i've installed the newest 3.10.0-1 kernel, and i've not seen any complaints: they seems having been silenced

No, it was not silenced... there's a bug in intel-microcode which disables early microcode updates by default. I will upload a fixed version to Debian shortly, which will migrate to Ubuntu in a few days.

So, intel-microcode will soon restart complaining about the lack of prepend_earlyinitramfs() in initramfs-tools in Ubuntu if the kernel is linux 3.9 or later.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-microcode (Ubuntu):
status: New → Confirmed
PeterPall (peterpall) wrote :

intel-microcode complains again:

intel-microcode: failed to prepend early firmware to initramfs
Seems like the bug in intel-microcode is fixed and only the task to upgrade initramfs is left.

dino99 (9d9) wrote :

On Sat, 17 Aug 2013, dino99 wrote:
> Hopes that report get more attention :
> https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1079605

It is a trivial backport of the changes between Debian initramfs-tools
v0.112 and v0.113. But someone from Canonical will have to do it.

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

dino99 (9d9) wrote :

Hello Canonical,

its time to sync and upgrade that package : available since mid Jun ; and Saucy will be out soon.

http://packages.debian.org/fr/sid/initramfs-tools

Rik Mills (rikmills) wrote :

Also seeing this on upgrade to saucy.

Raoul Bhatia (raoul-bhatia) wrote :

I'm also seeing this issue on my saucy system.

Looks like initramfs-tools in saucy is still 0.103?

Cheers,
Raoul

Popolon (popolon) wrote :

Same problem on 2013/09/30 update, this could not affect everyone, as probably ony few people understand what does intel-microcode package and there is no automatic selection.

OerHeks (oerheks) wrote :

i have met a person with this same issue,

only i notice a typo

/usr/share/initramfs-tools/hooks/intel_microcode

and the packagename is "intel-microcode"

maybe i am wrong, if so please neglect this message

Popolon (popolon) wrote :

This also affect : amd64 version and Linux kernel 3.11.0.x

Changed in intel-microcode (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High

update-initramfs: Generating /boot/initrd.img-3.11.0-12-generic
cryptsetup: WARNING: failed to detect canonical device of /dev/sda1
cryptsetup: WARNING: could not determine root device from /etc/fstab
/usr/share/initramfs-tools/hooks/intel_microcode: 136: /usr/share/initramfs-tools/hooks/intel_microcode: prepend_earlyinitramfs: not found
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

dino99 (9d9) on 2013-10-30
tags: added: trusty
Hassan El Jacifi (waver) wrote :

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.11.0-12-generic
/usr/share/initramfs-tools/hooks/intel_microcode: ligne 136: prepend_earlyinitramfs : commande introuvable
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

Virus (lanchpad) wrote :

update-initramfs: Generating /boot/initrd.img-3.12.0-031200-generic
/usr/share/initramfs-tools/hooks/intel_microcode: 136: /usr/share/initramfs-tools/hooks/intel_microcode: prepend_earlyinitramfs: not found
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

Red Ink (redink) wrote :

Confirmed broken on amd64 (presumably all archs):

brigandine ~ # lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

Debian upstream is now 115.

http://packages.debian.org/sid/initramfs-tools

Please fix in saucy.

tags: added: amd64
Richard (r-j-v-m-sterken) wrote :

Still the same in Xubuntu 13.10...amd64

E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1194370

tags: added: package-qa-testing
MicMor (info-michelmorisot) wrote :

Hello,

Is there no news, concerning this bug?

Thank You

MicMor (info-michelmorisot) wrote :

This problem annoying because, it me is prevented from activating pilot owner INTEL for my graphic card. I must use the order: sudo update-initramfs - U so that he takes into account kvm_intel. And it is there that I obtain, the error message indicated higher.

/usr/share/initramfs-tools/hooks/intel_microcode: 136: /usr/share/initramfs-tools/hooks/intel_microcode: prepend_earlyinitramfs: not found
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

mrDoctorWho (mrdoctorwho) wrote :

affects also 14.04

Tomasz Przybył (fademind) wrote :

Developers merge initramfs-tools to lastest working version?

Working fixed version for now is 0.114 (Debian testing) or 0.115 (Debian sid).
In Ubuntu current is 0.103.x with serious bug and intel microcode installer not working.

Wake Up guys.

MicMor (info-michelmorisot) wrote :

no news for this bug?

Jelle Foks (jellefoks) wrote :

If you don't mind losing these three ubuntu packages: console-setup kbd ubuntu-minimal

Then you can get rid of the 'prepend_earlyinitramfs: not found' message from update-initramfs by downloading the debian package from here: https://packages.debian.org/sid/all/initramfs-tools/download

... and installing it manually:

sudo dpkg -i --force-all initramfs-tools_0.115_all.deb
sudo apt-get -f install

NetBit73 (mmach) wrote :

#28 This does not work for me

/usr/share/initramfs-tools/hooks/intel_microcode: 136: /usr/share/initramfs-tools/hooks/intel_microcode: prepend_earlyinitramfs: not found
E: intel-microcode: failed to prepend early firmware to initramfs
W: intel-microcode: will try to use late initramfs update mode...

NetBit73 (mmach) wrote :

#22
they waiting for systed :)

On Fri, 28 Feb 2014, zupert wrote:
> I made the error disappear with following command - thanks to #13
>
> sudo ln -s /usr/share/initramfs-tools/hooks/intel_microcode /usr/share
> /initramfs-tools/hooks/intel-microcode

This can be very dangerous. Don't do it.

Some of the stuff in initramfs-tools is REALLY allergic to "-", and it can
break the initramfs in such a way that it will crash the next boot, and that
will be a *real* pain to fix if you don't have a backup initramfs that works
already installed in the system.

Also, you just caused the hook to be processed twice... once with a safe
name, and once with an usafe name.

When you notice something that looks like a character substitution bug
involving stuff that has special meanings like "-", "+", "=", space, tab,
".", etc., at least consider it might be there on purpose and read the
package changelog looking for hints:

intel-microcode (1.20120606.v2.2) unstable; urgency=medium

  * initramfs: work around initramfs-tools bug #688794.
    Use "_" in place of "+-." for the initramfs script name. This works
    around a PANIC during boot when the initramfs was created in a system
    with noexec $TMPDIR.

 -- Henrique de Moraes Holschuh <email address hidden> Tue, 09 Oct 2012 07:43:37
-0300

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

affects: initramfs-tools → initramfs-tools (Ubuntu)
Changed in intel-microcode (Ubuntu):
status: Triaged → Invalid
Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu4

---------------
initramfs-tools (0.103ubuntu4) trusty; urgency=medium

  * Cherrypick v0.113 changes (LP: #1194370):
    [ Henrique de Moraes Holschuh ]
    * [f59e716] implement early initramfs support (Closes: #712521)
    * [b8295f0] lsinitramfs(8): document failure to deal with early
      initramfs
 -- Dimitri John Ledkov <email address hidden> Mon, 03 Mar 2014 08:11:20 +0000

Changed in initramfs-tools (Ubuntu):
status: Fix Committed → Fix Released
MicMor (info-michelmorisot) wrote :

hello,

Thank you for resolving this error. An update is planned for her saucy? thank you

Dimitri John Ledkov (xnox) wrote :

On 4 March 2014 13:57, MicMor <email address hidden> wrote:
> hello,
>
>
> Thank you for resolving this error. An update is planned for her saucy? thank you
>

At this point, no further stable release updates are planned to
resolve this bug in earlier releases because it also depends on kernel
configuration update to enable support for early firmware.

Regards,

Dimitri.

> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1194370
>
> Title:
> intel_microcode: prepend_earlyinitramfs: not found
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1194370/+subscriptions

--
Regards,

Dimitri.

MicMor (info-michelmorisot) wrote :

Too bad, because this error does not allow me to install the intel drivers from their intel.

Dimitri John Ledkov (xnox) wrote :

On 5 March 2014 13:40, MicMor <email address hidden> wrote:
> Too bad, because this error does not allow me to install the intel
> drivers from their intel.
>

intel_microcode package is available from multiverse, and does work on
saucy (via late loading of the codes)

if update to that package is required, it would fall under SRU/hwe
requests, please file a separate bug report against that package.

it's good that this error is preventing package installation on stable
releases, as early firmware would not be loaded on boot with kernels
present in stable releases at the moment and thus drivers would not
work.

Regards,

Dimitri.

> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1194370
>
> Title:
> intel_microcode: prepend_earlyinitramfs: not found
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1194370/+subscriptions

--
Regards,

Dimitri.

Dimitri John Ledkov (xnox) wrote :

Matching kernel upload bug #1287903:

linux (3.13.0-16.36) trusty; urgency=low
[ Tim Gardner ]
  * [Config] CONFIG_MICROCODE_EARLY=y
 -- Tim Gardner <email address hidden> Mon, 03 Mar 2014 13:04:10 -0700

Dimitri John Ledkov (xnox) wrote :

Please do not open duplicate bug report, instead nominate the bug report for series. That is the correct workflow as per SRU process.

I've now nominated this bug for Saucy.

However, since saucy kernel does not support loading early firmware backporting initramfs-tools fix would break existing system since early firmware would be generated / included in the initramfs, yet kernel will not load it.

Backporting such change (kernel + initramfs) from Trusty to Saucy falls outside of SRU process, see https://wiki.ubuntu.com/StableReleaseUpdates

At the moment, in Saucy, intel-microcode correctly adds microcode into the initramfs and uses late loading of microcode.

Changed in initramfs-tools (Ubuntu Saucy):
status: New → Won't Fix
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in intel-microcode (Ubuntu Saucy):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers