[FFe] Please sync with the latest 0.113 from Debian testing

Bug #1079605 reported by dino99 on 2012-11-16
102
This bug affects 19 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Wishlist
Dimitri John Ledkov

Bug Description

With Raring, initramfs-tools is at 0.103 version, while 0.113 is available into Debian testing (0.112 in debian stable-bpo) .

 The main issue actually into RR is with nvidia driver, failing with error:

WARNING: could not open /tmp/mkinitramfs_kG4Wwd/lib/modules/3.6.6-030606-generic/modules.builtin: No such file or directory
(reported as : https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1075422 )

As a result, after nvidia installation, i can boot only in low graphic mode. This seems not affecting all nvidia users.

If that issue is confirmed by the main devs (see bug #1075422) , that bug is still not set with "high" priority (very annoying)

From 0.103 to 0.113 , lot of bugfixes have been made; so i hope 0.113 will be merged asap into SS.

details: http://ftp-master.metadata.debian.org/changelogs/main/i/initramfs-tools/unstable_changelog

dino99 (9d9) on 2012-11-16
tags: added: i386 raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2013-04-10
tags: added: upgrade-software-version
dino99 (9d9) wrote :

Latest Debian version: http://packages.debian.org/changelogs/pool/main/i/initramfs-tools/current/changelog.html

So the latest stable package is the 0.109, which fix lot of issues since the actual used 0.103 into Raring.
The main issue i ALWAYS get with a cold boot is : "ramdisk : incomplete write" (which is affecting lot of users, while googling around). So some default initramfs.conf settings sould be changed now too, as:
- using "xz" instead of "gzip"
- using "dep" instead of "most"

As that package (& the like) is important for booting, a sync with Debian Sid should be done before Raring freeze.

dino99 (9d9) on 2013-04-26
tags: added: saucy
DonnieD (donnied) on 2013-07-23
summary: - Please sync with the latest 0.109 from Sid
+ Please sync with the latest 0.113 from Debian testing
description: updated
tags: removed: raring

Will this update ship in saucy?

I still see Version 0.103 on my system...

Thanks,
Raoul

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
dino99 (9d9) wrote :

Please Canonical, update that package, its quite important. FFE requested.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=712521

summary: - Please sync with the latest 0.113 from Debian testing
+ [FFe] Please sync with the latest 0.113 from Debian testing
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-10-29
no longer affects: hundredpapercuts
Changed in initramfs-tools (Ubuntu):
importance: High → Wishlist
Dimitri John Ledkov (xnox) wrote :

The fix for the bug in question was cherry-picked and released in 13.04 (Ubuntu Raring).

If further fixes are required, please open new bugs.

Initramfs-tools cannot be synced into ubuntu, as it is significantly diverged from debian, but is at the moment cherry-picking fixes from debian.

Changed in initramfs-tools (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Dmitrijs Ledkovs (xnox)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.