indicator-session shows name as "[Invalid UTF-8]" for some users

Bug #874194 reported by Tom on 2011-10-14
190
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
High
Conor Curran
Unity Foundations
High
Conor Curran
indicator-session (Ubuntu)
High
Conor Curran
Oneiric
High
Unassigned

Bug Description

Description: Ubuntu 11.10
Release: 11.10
indicator-session:
  Installed: 0.3.6-0ubuntu2
  Candidate: 0.3.6-0ubuntu2
  Version table:
 *** 0.3.6-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

I use UIDs starting at 500, while login.defs specifies UID_MIN as 1000, so when I got to the login screen in GDM, I logged in as "other". The indicator applet showed my name as [Invalid UTF-8]. I changed UID_MIN to 500, restarted, and logged in by choosing my name from the menu. My name now shows correctly.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-session (Ubuntu):
importance: Undecided → High
Changed in indicator-session (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Ted Gould (ted)
summary: - indicator-session shows name as "[Invalid UTF-8]" when logging in as
- other
+ indicator-session shows name as "[Invalid UTF-8]" for some users
+ (dependsing on UIDMIN?)
summary: indicator-session shows name as "[Invalid UTF-8]" for some users
- (dependsing on UIDMIN?)
+ (depending on UIDMIN?)
Conor Curran (cjcurran) on 2011-10-20
Changed in indicator-session:
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → High
milestone: none → 0.3.8
Changed in indicator-session (Ubuntu Oneiric):
assignee: Ted Gould (ted) → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2011-10-20
Changed in unity-foundations:
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → High
milestone: none → oneiric-backlog
Conor Curran (cjcurran) on 2011-10-20
Changed in indicator-session:
status: New → Confirmed
Changed in unity-foundations:
status: New → Confirmed

MIN_UID fix/workaround did not work for me. I set mine to 500, too, but my user ID is 1101.

Linux saturn 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
michael:x:1101:2011:Michael:/home/michael:/bin/bash
ii lightdm-gtk-greeter 1.0.1-0ubuntu6 LightDM GTK+ Greeter
ii unity-greeter 0.1.1-0ubuntu1 Unity Greeter
ii indicator-session 0.3.7-0ubuntu1 Indicator showing session management, status and user switching.

$ dpkg -s indicator-session
Package: indicator-session
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 488
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Version: 0.3.7-0ubuntu1
Replaces: indicator-me, indicator-sus
Depends: libc6 (>= 2.3.6-6~), libcairo2 (>= 1.2.4), libdbus-glib-1-2 (>= 0.78), libdbusmenu-glib4 (>= 0.4.2), libdbusmenu-gtk3-4 (>= 0.4.2), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.26.0), libgtk-3-0 (>= 3.0.0), libgudev-1.0-0 (>= 147), libindicator3-6, libpango1.0-0 (>= 1.14.0), dconf-gsettings-backend | gsettings-backend, upower, gnome-settings-daemon
Recommends: indicator-applet (>= 0.2) | indicator-renderer
Suggests: lightdm
Breaks: indicator-me
Conflicts: gdm (<= 2.27.4-0ubuntu9), indicator-sus

Jacek Urbańczyk (burbon) wrote :

same here. Just upgraded to oneiric 11.10

jacek:x:1000:1000::/home/jacek:/bin/bash
UID_MIN 1000
GID_MIN 1000

Sebastien Bacher (seb128) wrote :

Could those having the bug:

- install d-feet
- run d-feet, use the file menu, connect to system bus
- go to org.freedesktop.org.Accounts on the left
- select their path corresponding to their UID on the right, i.e User1000
- go to Properties, select "RealName" and get the values of those lines?

could you also run "dpkg -l accountsservice"?

Do you use local or nfs users? Does the username is correctly displayed on the login screen (lightdm)?

Edgardo (edgardo-ieee) wrote :

Hi Sebastien,
I have this problem.
Users are local. Their names display correctly on the login screen.
I edited the /etc/login.defs file to change the minimum uid and gid to 500, to match the users of a file server accessed by this computer.
The Guest user shows correctly on the upper right after login.
The user I created during installation (it's uid is 1000), shows as [Invalid UTF-8] on the upper right after login.
Another user created later with uid 1006, also shows as [Invalid UTF-8] on the upper right after login.

I installed d-feet and started it. I don't see menus. Only a button "Add a bus tab using an address". Clicking on it brings a window to enter a "Bus Address" and connect. I don't know enough to understand this, but I could follow step-by-step instructions if you think it could be useful.

I run: dpkg -l accountsservice
It gives me 6 lines that I don't understand.
The first 5 seem to be a header. The last one says: ii accountsservice 0.6.14-1git1 query and manipulate user account information

Aaron Peromsik (aperomsik) wrote :

I use local users. User name is "aaron" and d-feet shows RealName as "Aaron Peromsik". uid of this user is 600.

dpkg -l accountsservice says
ii accountsservic 0.6.14-1git1 query and manipulate user account informatio

Messelink (pimmesselink) wrote :

After upgrade to 11.10 I'm having the same problem on one of my pc's. The users I want to use to login all have UID from 1000 and up and UID_MIN is set to 1000.

I don't know how to connect to the system bus with d-feet.

The output of sudo dpkg -l accountsservice is:
ii accountsservice 0.6.14-1git1 query and manipulate user account information

Peter Haworth (pmh1wheel) wrote :

I've been seeing this too, but I think the cause is slightly mis-stated above. My normal users are all above UID_MIN, but I was still seeing the problem. However, I found that I had a bunch of system accounts above UID_MIN (qmaild, qmails, and so on), which were also appearing on the login screen. I'm not running qmail on this system any more, so I deleted the accounts, and my name is now showing up where "Invalid UTF-8" was before.

Richard Peake (yourtechfriend) wrote :

Sebastien, Thanks for asking!

As requested, I did the following:
sudo apt-get install d-feet
from Dash, I called up d-feet, used the File menu -> Connect to System Bus
- go to org.freedesktop.org.Accounts on the left
- select their path corresponding to their UID on the right, i.e User1000 (mine was 1101)
- go to Properties, select "RealName" and get the values of those lines?
I had 2 lines for String RealName = Michael on each line; both the same.

michael@saturn:~$ dpkg -l accountsservice
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================
ii accountsservic 0.6.14-1git1 query and manipulate user account informatio

I use local users. The username IS correctly displayed on the login screen (lightdm) but I have [Invalid UTF-8] on the indicator bar once logged in.

About the same here:

On Mon, Oct 24, 2011 at 12:48 AM, Richard Peake
<email address hidden>wrote:

> Sebastien, Thanks for asking!
>
> As requested, I did the following:
> sudo apt-get install d-feet
> from Dash, I called up d-feet, used the File menu -> Connect to System Bus
> - go to org.freedesktop.org.Accounts on the left
> - select their path corresponding to their UID on the right, i.e User1000
> (mine was 1101)
>
mine is User1000

> - go to Properties, select "RealName" and get the values of those lines?
> I had 2 lines for String RealName = Michael on each line; both the same.
>
A single line, "RealName = Gil Harari"

>
> michael@saturn:~$ dpkg -l accountsservice
>

> Desired=Unknown/Install/Remove/Purge/Hold
> |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Description
> +++-==============-==============-============================
> ii accountsservic 0.6.14-1git1 query and manipulate user account
> informatio
>

$ dpkg -l accountsservice
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii accountsservic 0.6.14-1git1 query and manipulate user account
informatio

>
> I use local users. The username IS correctly displayed on the login
> screen (lightdm) but I have [Invalid UTF-8] on the indicator bar once
> logged in.
>
same for me.

I've changed my UID_MIN to 999, didn't change anything:
$ grep UID_MIN /etc/login.defs
UID_MIN 999

Thanks,
gil

>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/874194
>
> Title:
> indicator-session shows name as "[Invalid UTF-8]" for some users
> (depending on UIDMIN?)
>
> Status in The Session Menu:
> Confirmed
> Status in Unity Foundations:
> Confirmed
> Status in “indicator-session” package in Ubuntu:
> Confirmed
> Status in “indicator-session” source package in Oneiric:
> Confirmed
>
> Bug description:
> Description: Ubuntu 11.10
> Release: 11.10
> indicator-session:
> Installed: 0.3.6-0ubuntu2
> Candidate: 0.3.6-0ubuntu2
> Version table:
> *** 0.3.6-0ubuntu2 0
> 500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64
> Packages
> 100 /var/lib/dpkg/status
>
> I use UIDs starting at 500, while login.defs specifies UID_MIN as
> 1000, so when I got to the login screen in GDM, I logged in as
> "other". The indicator applet showed my name as [Invalid UTF-8]. I
> changed UID_MIN to 500, restarted, and logged in by choosing my name
> from the menu. My name now shows correctly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-session/+bug/874194/+subscriptions
>

d-feet -> File -> System Bus -> org.freedesktop.Accounts -> Object paths -> /org/freedesktop/Accounts/User1000 -> Interfaces -> org.freedesktop.Accounts.User -> Properties

shows among other entries

String RealName = Paul Crowley
String UserName = paul
UInt64 Uid = 1000

Local account, no NFS or anything. UID_MIN is 1000. Name looks correct on login screen.

Andrew Mair (andrew-mair) wrote :

I am getting similar to other users with [Invalid UTF-8] shown on indicator:

d-feet: File -> System Bus -> org.freedesktop.Accounts -> Object paths -> /org/freedesktop/Accounts/User1001 -> Interfaces -> org.freedesktop.Accounts.User -> Properties

String RealName = Andrew
String UserName= andrew
UInt64 Uid = 1001

Local account, no NFS. UID_MIN is 1000. Name looks correct on login screen.

Andrew Mair (andrew-mair) wrote :

Sorry, forgot:

andrew@mesh-01:~$ dpkg -l accountsservice
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii accountsservic 0.6.14-1git1 query and manipulate user account informatio

Conor Curran (cjcurran) on 2011-10-24
Changed in indicator-session:
status: Confirmed → In Progress
Changed in unity-foundations:
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

So one of the comment indicated it has to do with the number of users on the system, seems to happen when there are over 6 users to list

summary: indicator-session shows name as "[Invalid UTF-8]" for some users
- (depending on UIDMIN?)
Conor Curran (cjcurran) on 2011-10-25
Changed in indicator-session:
status: In Progress → Fix Committed
jhouse (jhouse) wrote :

Upgraded to 11.10 yesterday and have this problem. Have 7 (non-system) users.

Mikael Nordfeldth (mmn) wrote :

+1 on Sebastien Bacher: https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/874194/comments/14
"So one of the comment indicated it has to do with the number of users on the system, seems to happen when there are over 6 users to list"

I've got more than 6 users on one system with 11.10 (updated from 11.04) and that's the only system suffering the "[Invalid UTF-8]" bug.

Conor Curran (cjcurran) on 2011-10-28
Changed in indicator-session:
milestone: 0.3.8 → 0.3.7.1
Changed in unity-foundations:
status: In Progress → Fix Committed
Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in indicator-session (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Joan Tur (joantur) wrote :

I can confirm the "over 6 users" problem. I had 7 users and was affected by the "[Invalid UTF-8]" bug, but after deleting 1 user (and its files) and restarting the system it now shows the user's name!

Hope that helps.

Note: up to date 11.10 installed from scratch, reusing the /home partition.

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7.1-0ubuntu1

---------------
indicator-session (0.3.7.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-session shows name as "[Invalid UTF-8]" if there are
      more than 6 user accounts (LP: #874194)
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 11:55:38 -0400

Changed in indicator-session (Ubuntu):
status: Fix Committed → Fix Released
Ken VanDine (ken-vandine) wrote :

Steps to reproduce:
 1) add enough user accounts bring total to over 6
 2) logout and back in
 3) confirm user names are displayed in the session indicator

Changed in indicator-session (Ubuntu Oneiric):
milestone: none → oneiric-updates
assignee: Conor Curran (cjcurran) → nobody
Per Vikman (pelleve) wrote :

Recently upgraded from 10.04 to 11.10 by upgrading through the releases 10.10 and 11.04.

Accounts existing from original creation in 10.04:
- 6 accounts created using the GUI for accounts management all above UID 1000
- 1 password less Guest session
- 1 main admin account with UID manually set below 1000 in order not to show on log in screen

The six main user accounts (UID > 1000) all have indicator-session "Invalid UTF-8"
The passwordless Guest session has indicator-session "Guestsession"
The main admin account (UID < 1000) has indicator-session "Invalid UTF-8"

In addition there is now also an extra "Guest" user option with password prompt in the log in menu however it has never been configured that way from the beginning (i.e. "Guest" with psw + "Guestsession" without psw)

Only "Guestsession" appears in switch to other user options under indicator-session

Ken Bradshaw (ken-bradshaw) wrote :

Did all Ubuntu Auto-Updates last night 11/29.

If the fix was released before that, as I saw in the email that stated the fix was released, it
didn't fix my upgrade from 10.04 to 11.10.

I have less then 6-Users, one is UID of 997 and it still shows as [Invalid UTF-8].

I'm about to give up the upgrade and re-install the newest Version from the Live-CD, but I
have no warm fuzzy that will fix the issue.

Kees (kees-vanveen) wrote :

I've temporarily fixed it based on Conor Curran's fix, here's what I did:

    1 ) sudo apt-get build-dep indicator-session
    2) apt-get source indicator-session
    3 ) cd indicator-session-0.3.7
    4) # change the following line in ./src/users-service-dbus.h
        #define MAXIMUM_USERS 6
    to
       #define MAXIMUM_USERS 30
    5) dpkg-buildpackage -b -us -uc -rfakeroot
    6) sudo dpkg -i ../indicator-session-gtk2_0.3.7-0ubuntu1_i386.deb indicator-session_0.3.7-0ubuntu1_i386.deb

When you don't want the update manager to propose to update the indicator-session, edit the ./debian/changelog before making the package (step 5), e.g.

    indicator-session (0.3.7-0ubuntu2) oneiric-proposed; urgency=low

      * Temp fix Invalid UTF-8

     -- Your email <email address hidden> Mon, 31 Oct 2011 07:30:00 +0200

(Note that I've changed 0.3.7-0ubuntu1 to 0.3.7-0ubuntu2)

I've uploaded my i386 versions at: http://ubuntuone.com/131lB4SoVqqhsaKNznZn6Y and http://ubuntuone.com/3xsr6MpdgI6tJl63mEJxZw

Hello Tom, or anyone else affected,

Accepted indicator-session into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Kees (kees-vanveen) wrote :

I installed the proposed indicator-session 0.3.7.1-0ubuntu1.1, and can confirm that with 27 user accounts it shows the current username iso. Invalid UTF-8.

Thanks.

Solved for me too.
Thanks, Conor and everyone.

On Tue, Nov 1, 2011 at 8:55 AM, Kees <email address hidden> wrote:

> I installed the proposed indicator-session 0.3.7.1-0ubuntu1.1, and can
> confirm that with 27 user accounts it shows the current username iso.
> Invalid UTF-8.
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/874194
>
> Title:
> indicator-session shows name as "[Invalid UTF-8]" for some users
>
> Status in The Session Menu:
> Fix Committed
> Status in Unity Foundations:
> Fix Committed
> Status in “indicator-session” package in Ubuntu:
> Fix Released
> Status in “indicator-session” source package in Oneiric:
> Fix Committed
>
> Bug description:
> Description: Ubuntu 11.10
> Release: 11.10
> indicator-session:
> Installed: 0.3.6-0ubuntu2
> Candidate: 0.3.6-0ubuntu2
> Version table:
> *** 0.3.6-0ubuntu2 0
> 500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64
> Packages
> 100 /var/lib/dpkg/status
>
> I use UIDs starting at 500, while login.defs specifies UID_MIN as
> 1000, so when I got to the login screen in GDM, I logged in as
> "other". The indicator applet showed my name as [Invalid UTF-8]. I
> changed UID_MIN to 500, restarted, and logged in by choosing my name
> from the menu. My name now shows correctly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-session/+bug/874194/+subscriptions
>

Per Vikman (pelleve) wrote :

Solved for me as well. Installed oneiric-proposed indicator-session and
rebooted.
Good work!

tags: added: verification-done
removed: verification-needed
boulayj (boulayj) wrote :

Hi all,

I've upgraded ubuntu from 11.04 to 11.10
Same issue as everybody, but not fixed with the new indicator-session version .

Description:
I can't see the user on the login screen and the indicator applet shows the user name as [Invalid UTF-8]
I can't see the user in the users and groups administration

But I can login with this user.

UserId = 500
UID_MIN=500
$LANG=fr_FR.UTF-8

There is only one user declared on the system (so not more than 6)

I've installed d-feet and RealName is ok.
I've installed indicator-session 0.3.7.1-0ubuntu1.1, but it did not fix the issue :o((

Do you have any other idea ?

Kees (kees-vanveen) wrote :

In the bug description above, the UID_MIN in /etc/login.defs was changed to fix the problem. Is that something to try (or else change the uid from 500 to 1000).

The fix in the oneiric-proposed is specifically for more than 6 users, from what I remember.

boulayj (boulayj) wrote :

I had already changed UID_MIN to 500, because I encountered the same issue on Kubuntu 11.10 on my first migrated laptop.

And finally, it seems that the oneiric-proposed has fixed the bug !
I've just forgotten to reboot my laptop !

Many thanks to all for your investigation and to Conor for his fix ;o)

Ken Bradshaw (ken-bradshaw) wrote :

Originally did an upgrade from 11.04 to 11.10 and I saw that the hidden Log-In's were showing as "Invalid UTF-8"

So I tried the "UID_MIN to 500", doing that makes the Log-In's visible on the Log-In Menu when booting up. This is not what I want to do.

So I ripped out the whole install and reinstalled from Live CD 11.10, then did all the updates. Created the account, reassigned the UID/Group ID to 998, restarted, went to "Other" entered the Name & Password of the hidden account and when the desktop loads it still shows "Invalid UTF-8".

So long as I'm below 1000 for UID (what I want to do, to keep account hidden), the User's ID at the top-right of the desktop shows as "Invalid UTF-8". If I change it back to 1002 then log back into that account it shows the proper name.

Any suggestions on when a real patch is coming to fix this?

Ken

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7.1-0ubuntu1.1

---------------
indicator-session (0.3.7.1-0ubuntu1.1) oneiric-proposed; urgency=low

  * New upstream release.
    - indicator-session shows name as "[Invalid UTF-8]" if there are
      more than 6 user accounts (LP: #874194)
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 11:55:38 -0400

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Ken Bradshaw (ken-bradshaw) wrote :

I Installed "indicator-session - 0.3.7.1-0ubuntu1.1", Ubuntu Software also reports that it's installed.

After I installed, I restarted the computer logged into the hidden account and same result: [Invalid UTF-8]

I don't see this as a 100% resolved issue.

Maybe I'll try and re-establish a new hidden name account, but I don't give it much of a chance of working.

K

Per Vikman (pelleve) wrote :

I was a little premature in my comment #20 above. Seems as if the admin account UID < 1000 still has this issue. But this is described by other commenters in this bug and I do not have a problem in this particular account. My apologies.

Ken Bradshaw (ken-bradshaw) wrote :

Well, to verify previous results, again did all 11.10 updates this morning. Purged all accounts out, Restarted computer.
I Installed "indicator-session - 0.3.7.1-0ubuntu1.1", Ubuntu Software also reports that it's installed.

Re-created all user accounts, less then 6 Log-In Accounts at this time.

When the Account UID's/GID's are 1000 or higher name shows fine when logged into the account.

As soon as I reconfigure a specific account to have a UID/GID of "Less Then 1000" (998), it does hide the Log-In from
the standard Ubuntu Login Screen, which is what I want.

I then select "Other", & manually enter the name & password, Ubuntu starts up and still shows, [Invalid UTF-8].

It seems we have two issues that appear to be buried into one....
1: "More then 6-Users" [Invalid UTF-8]
2: "Hidden Users" [Invalid UTF-8]

I want a Hidden User that channels through "Other" and that's when I see the user as: [Invalid UTF-8]

Ken

Omer Akram (om26er) on 2012-01-22
Changed in indicator-session:
status: Fix Committed → Fix Released
Changed in unity-foundations:
status: Fix Committed → Fix Released
graemev (graeme-launchpad) wrote :

I'm seeing this in new (fresh) 11.10 install. The significant detail is I'm logged on as a user I created via 'useradd(8) , not via GUI ... looks like variou sbit of the desktop don't see this userid (or don't see it corrrectly)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions