user menu says [Invalid UTF-8]

Bug #834137 reported by Taylor "Ripps" LeMasurier-Wren on 2011-08-25
196
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Medium
Conor Curran
Unity Foundations
Medium
Conor Curran
casper (Ubuntu)
Undecided
Martin Pitt
Oneiric
Undecided
Unassigned
indicator-session (Ubuntu)
High
Ted Gould
Oneiric
Undecided
Unassigned

Bug Description

*****FOR THOSE EXPERIENCING THIS BUG ON AN UP-TO-DATE SYSTEM, PLEASE HEAD OVER TO bug 1130575 (as this one is fixed)************

https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/1130575

After the round of updates today, the user menu in the top-right corner says [Invalid UTF-8]. I presume this is supposed to show my current user name. My user name is simply 'ripps', so I don't know what's wrong.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Thu Aug 25 16:01:46 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-session
UpgradeStatus: Upgraded to oneiric on 2011-07-07 (49 days ago)

Related branches

Omer Akram (om26er) on 2011-08-25
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-session:
status: New → Confirmed
Vanillalite (vanillasky26) wrote :

I get the same exact look at Ripps. Says [Invalid UTF-8] where my User Name should be.

Miroslav Ranković (m.rankovic) wrote :

I just added another user and now my name is displayed correctly... It was [Invalid UTF-8] before.

Haw Loeung (hloeung) wrote :

Same here, I believe my system is configured to use en_AU.UTF-8

Conor Curran (cjcurran) wrote :

This should be fixed for the normal user session with release 0.3.3.2

Changed in indicator-session:
milestone: none → 0.3.3
status: Confirmed → Fix Released
Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-session:
assignee: nobody → Conor Curran (cjcurran)
Jacobsallan (jacobsallan) wrote :

This bug is marked fix-released. As of Sat Aug 27 20:32:37 PDT 2011 an updated version of Oneiric still has this problem.
Description: Ubuntu oneiric (development branch)
Release: 11.10
indicator-session_0.3.3.2-0ubuntu1.

In what revision of indicator-session is the fix released in?

I had just encountered this problem on a freshly-made LiveUSB session of Ubuntu 11.10 Beta 1 64-bit. I don't think this highly-visible error message would make a good impression on new users.

From the LiveUSB session:
ubuntu@ubuntu:~$ dpkg -s indicator-session | grep Version
Version: 0.3.3.2-0ubuntu1

Simon Eisenmann (longsleep) wrote :

Sorry i still get this issue with

dpkg -s indicator-session|grep Version
Version: 0.3.4.1-0ubuntu1

So this is not fixed for me!

Same here. Not fixed. Setting back to confirmed.

Nevermind, don't have privileges. Using fresh USB boot on version 0.3.4.2-0ubuntu1.

Conor Curran (cjcurran) on 2011-09-05
Changed in indicator-session:
status: Fix Released → Confirmed
milestone: 0.3.3 → none
milestone: none → 0.3.5
Changed in unity-foundations:
status: New → In Progress
milestone: none → oneiric-beta-2
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Changed in indicator-session:
importance: Undecided → Medium
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

Getting it there as well, on today's live CD with latest indicator-session, reverting the status.

Changed in indicator-session (Ubuntu):
status: Fix Released → In Progress
Conor Curran (cjcurran) on 2011-09-06
Changed in indicator-session:
milestone: 0.3.5 → 0.3.4
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

0.3.4.3 upload which adds this key: "com.canonical.indicator.session user-show-menu" that casper should set to false, it doesn't solve the fact that the indicator still display "invalid utf-8" in some cases

Conor Curran (cjcurran) on 2011-09-07
Changed in unity-foundations:
status: In Progress → Fix Released
Martin Pitt (pitti) on 2011-09-07
Changed in casper (Ubuntu):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.283

---------------
casper (1.283) oneiric; urgency=low

  * scripts/casper-bottom/22screensaver: Set gsettings key instead of gconf.
  * scripts/casper-bottom/44pk_allow_ubuntu: Drop old PolicyKit stuff, it's
    gone for a long time.
  * Drop scripts/casper-bottom/45disable_guest_account: We are not using gdm
    any more, and lightdm implements that differently.
  * Drop scripts/casper-bottom/47une_ubiquity, UNE/netbook-launcher are
    history.
  * Add scripts/casper-bottom/26disable_user_menu: Disable the user indicator
    menu. (LP: #834137)
 -- Martin Pitt <email address hidden> Wed, 07 Sep 2011 12:33:57 +0200

Changed in casper (Ubuntu):
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2011-09-07
Changed in unity-foundations:
status: Fix Released → In Progress
Changed in indicator-session:
status: Fix Released → In Progress
Conor Curran (cjcurran) wrote :

Tomorrows daily build should have this fixed for the live session. Will leave this bug open on the session menu, it should really protect itself regardless.

Conor Curran (cjcurran) on 2011-09-13
Changed in unity-foundations:
status: In Progress → Fix Released
entonjackson (aj-mysc) wrote :

Problem is still there. Happened after changing users uid and gid.

Yes problem still persists for me too.

In fact, I have changed my uid and gid to 500 -- as entonjeckson -- to stay compatible with other installations, I have on this machine ...

Simon Eisenmann (longsleep) wrote :

I do not get how this is related to the casper package, as i am not using a live CD and still getting this (no casper installed).

I should also mention that my user account is also not shown in the user switcher, nor the user account management and not in the lightdm login list (i have to type in my username to log in).

Though i think i have changed my user id a couple of months ago to 501.

This is in fact caused by the UID/GID.

It can be worked arround by putting the following into /etc/login.defs
   167 UID_MIN 500
   168 UID_MAX 60000
   169 # System accounts
   170 #SYS_UID_MIN 100
   171 #SYS_UID_MAX 999
   172
   173 #
   174 # Min/max values for automatic gid selection in groupadd
   175 #
   176 GID_MIN 500
   177 GID_MAX 60000

I have no idea why this is assigned to casper, I neither have that installed.

Jeremy Bicha (jbicha) wrote :

By the way, on new installs Fedora 16 will use uid 1000 for the first regular user like Ubuntu.

Simon Eisenmann (longsleep) wrote :

I can confirm that setting UID_MIN 500 in /etc/login.defs completely fixes this problem.

My user account did not show up in lightdm, user switcher and user accounts and also was shown as Invalid UTF-8 in the panel. This now all works fine.

The user ID is 501.

Ted Gould (ted) on 2011-09-27
Changed in indicator-session:
status: In Progress → Fix Released
Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
Hoeflerb (hoeflerb) wrote :

Just upgraded today from 11.04 to 11.10, and I'm experiencing this bug. UID is 1025. Checked login.defs and UID_MIN is 1000, as it should be. Lightdm and other dialogs (ex: User Accounts) show the user name(s) without a problem.

$ dpkg -s indicator-session|grep Version
Version: 0.3.6-0ubuntu2

$ env |grep LANG
LANG=en_US.UTF-8

Sam Pearson (sagepe) wrote :

Upgraded today from 11.04 to 11.10 and this is an issue for all user accounts. No UID/GIDs have been changed, all use the default assigned 1000+ ranges. LANG is en_GB.UTF-8.

Ace (linuxrawkstar) wrote :

I too upgraded today from 11.04 to 11.10 and this is an issue for all of my user accounts too. I haven't changed any user IDs or group IDs, nor have I added or removed or changed users or user group memberships. I didn't do anything but upgrade to 11.04 to 11.10. My installation is completely up to date and there's nothing left to do in the way of installing new updates -- so this bug isn't fixed. It's very much alive and kicking for me.

$ echo $LANG
en_US.UTF-8

Ace (linuxrawkstar) wrote :

*bump*
screenshot of the bug as displayed on my installation of oneric.

Same error for me on a fresh amd64 upgrade.
No error on a i386 netbook fresh upgrade.

Richard Peake (yourtechfriend) wrote :

Same situation as Ace (above)
I upgraded today from 11.04 to 11.10 and am experiencing the same problem here [Invalid UTF-8].

michael@saturn:~
$ grep michael /etc/passwd
michael:x:1101:2011:Michael:/home/michael:/bin/bash

$ dpkg -s indicator-session|grep Version
Version: 0.3.6-0ubuntu2

$ env | grep LANG
LANG=en_US.UTF-8

Contrary to Felix Möller (felix-derklecks) above, setting UID_MIN 500 in /etc/login.defs did NOT fix this problem.
$ grep UID_MIN /etc/login.defs
UID_MIN 500

Syver Enstad (syver-enstad) wrote :

Setting UID_MIN to less than my UID fixed problem for me

Changed in indicator-session (Ubuntu):
status: Fix Released → Triaged
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

ok, let's not reuse a close bug, there is bug #874194 about the Oneiric issue

Changed in indicator-session (Ubuntu):
status: Triaged → Fix Released
Changed in casper (Ubuntu Oneiric):
status: New → Invalid
Changed in indicator-session (Ubuntu Oneiric):
status: New → Invalid
Ken Pratt (kenpratt) wrote :

I see Fix-Released on 2011-10-17. I am using a fully updated 12.04 64 bit desktop distro and I still have the problem. User indicator shows:

[Invalid UTF-8]

instead of my geocs entry from /etc/passwd.

I use NIS so my passwd entry is

+kjpratt::::Ken Pratt:/mnt/home/users/kjpratt:

Perhaps that is related to this bug?

Ken Pratt (kenpratt) wrote :

For the above posting - the distro is Ubuntu 12.04.

no!chance (ralf-fehlau) wrote :

Same problem here on Ubuntu 12.04. Yesterday, the indicator-applet displayed the correct name. Todayit says [Invalid UT-8].

If anyone is still having this issue on an up-to-date supported Ubuntu version, please log a new bug like below:

ubuntu-bug indicator-session

post a link to the new bug as a comment. Otherwise, this bug is closed. :)

Andreas (andreas-kotowicz) wrote :

Problem still present in fresh 12.04.2 install. New bug submitted: https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/1130575

description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers