When the datetime-indicator's menu becomes visible, the Calendar isn't always focused on today's date

Bug #793450 reported by Thijs van Dijk on 2011-06-06
328
This bug affects 72 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Medium
Lars Karlitski
Unity Foundations
Low
Javier Jardón
libindicator
Fix Released
Medium
Lars Karlitski
indicator-datetime (Ubuntu)
Medium
Unassigned
libindicator (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 11.04
indicator-datetime 0.3.1-0ubuntu1, Ubuntu 11.10
indicator-datetime 0.3.94-0ubuntu2, Ubuntu 12.04
Ubuntu 12.10
indicator-datetime 12.10.3daily13.03.26-0ubuntu1, Ubuntu 13.04
Ubuntu 13.10

1) Log in
2) Run a session for a day or two
3) Open the calendar applet by clicking the clock. Although the date in the text field is correct, the graphic calendar still shows the date at which you either originally logged in, or clicked the calendar before.
4) Hide it, and show it once more. The calendar now shows the correct date.

The conflicting visual data can be very confusing if you only summon the calendar to find out what day it is. (I don't get much sunlight.)

This is the sequel to bug 649800, which was supposedly fixed in Ubuntu 11.04.

Related branches

komputes (komputes) on 2011-06-14
Changed in gnome-panel (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
affects: gnome-panel (Ubuntu) → indicator-datetime (Ubuntu)
Ted Gould (ted) wrote :

It appears that it's updating when the menu is closed, but not updating other times.

Changed in indicator-datetime:
status: New → Confirmed
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

bug #782336 is somewhat similar but after suspending

Ted Gould (ted) wrote :

Possible fix so that the date is updated when the menu opens instead of when it closes. Should be in my bugfix PPA in a little while.

  https://launchpad.net/~ted/+archive/bugfix

Tell me if that works.

komputes (komputes) wrote :

Thanks Ted. I've installed the package, rebooted, and opened a session. I'll wait until tomorrow and check to see which date is highlighted in the calendar.

komputes (komputes) wrote :

The package in Ted's PPA did not seem to correct the problem for me.

David Barth (dbarth) wrote :

David, can you clarify how you have tested the package and concluded that the fix was not working? Did you change the time to simulate a long running session, or did you wait for a day before using the indicator again?

David Barth (dbarth) wrote :

This bug is not on our list of SRU candidates for this cycle, which is maintained at: https://launchpad.net/unity/+milestone/3.8.18

We're reaching the point in the cycle where we had defined with the release team to stop proposing SRU fixes for Natty and only focus on Oneiric features and fixes at this stage.

Unless we get a way to quickly and systematically reproduce the problem, we won't be able to fix it for this cycle.

komputes (komputes) wrote :

I tested Ted's fix by waiting a day then clicking on the indicator-datetime applet. Has anyone else tested this fix and has reported that it works for them?

komputes (komputes) wrote :

David Barth,

The issue can be reproduced systematically. Set your clock to 11:59PM and wait for the date to change, click the calendar. On the first click it will highlight the incorrect date in the calendar.

Would we be able to get a proposed fix tested in Natty and provide feedback for Oneric?

Javier Jardón (jjardon) wrote :

Hello David, I cant reproduce this bug in the Oneiric package, what version of Ubuntu are you using?

Changed in indicator-datetime:
status: Confirmed → Incomplete
David Barth (dbarth) on 2011-08-26
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Javier Jardón (jjardon)
Changed in indicator-datetime:
assignee: nobody → Javier Jardón (jjardon)
Javier Jardón (jjardon) on 2011-08-30
Changed in indicator-datetime:
status: Incomplete → In Progress
David Barth (dbarth) on 2011-08-30
Changed in unity-foundations:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Javier Jardón (jjardon)
milestone: none → oneiric-beta-2
Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
status: In Progress → Fix Committed
Changed in unity-foundations:
status: In Progress → Fix Committed
Changed in indicator-datetime:
milestone: none → 0.2.94
Harm van Bakel (hvbakel) wrote :

I'm experiencing this same problem in Ubuntu Natty; is there any chance this fix could be backported?

Ted Gould (ted) on 2011-09-15
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.95-0ubuntu1

---------------
indicator-datetime (0.2.95-0ubuntu1) oneiric; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * Set default timezone on events without (LP: #837359)
    * Update docs to specify correct custom formats (LP: #775113)
    * Remove add event when using greeter (LP: #836521)
    * Fix gettext domain for builder files (LP: #845473)
    * Update date correctly when opening menu (LP: #793450)

  [ Didier Roche ]
  * debian/control:
    - bump the libglib build-dep
 -- Ted Gould <email address hidden> Thu, 15 Sep 2011 10:45:57 -0500

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Burkart Lingner (burkart) wrote :

Despite the message above that this bug has been fixed in indicator-datetime 0.2.95-0ubuntu1 it still exists for me in indicator-datetime 0.3.1-0ubuntu1 on Oneiric.

DavidBriscoe (idbrii) wrote :

I have indicator-datetime 0.3.1-0ubuntu1 and I see the bug as written up in duplicate bug 799465. (The text is wrong, but the highlighted number is right.)

I think I've seen the other way around as well.

At the moment, the text says Apr 9 even if I dismiss the indicator and open it again. (The date command shows Apr 11.) The uptime command shows I've been logged in for 3 days. (So Apr 9 is probably my most recent login.)

Marius B. Kotsbak (mariusko) wrote :

The bug is still there in Precise.

Jussi Lind (jussi-lind) wrote :

I experience this bug sometimes when I leave my computer on over the night. For the first time I open the calendar applet it still highlights the previous day, but the text is correct. Closing and opening the applet again updates the highlight.

Reed Loden (reed) wrote :

Still seeing this on 12.04 LTS.

Jussi Lind (jussi-lind) wrote :

Still happens on 12.10.

Aatish (aatish) wrote :

I'm still seeing this bug in 12.04

Package: indicator-datetime
Version: 0.3.94-0ubuntu2

I don't agree this is a low priority bug. This bug throws off new users when they need to look at today's date form some reason. I have helped 3 colleagues - business as well as tech - to switch from Windows to Ubuntu and almost all of them were un-pleasantly surprised by this bug.

Even if this was a low priority bug, I think it should be easy to fix.

Small and nice little improvements like these add up to make a noticable positive impact on the usability of Ubuntu/Unity desktop.

forgot to mention that I am still seeing this issue in 13.10

Matthew Paul Thomas (mpt) wrote :

Just reproduced this on 13.04. I doubt this was ever fixed.

description: updated
Changed in indicator-datetime (Ubuntu):
assignee: Javier Jardón (jjardon) → nobody
status: Fix Released → Confirmed
summary: - Calendar applet does not show today's date
+ Calendar doesn't show today's date until opened a second time today
Andre Tomt (andre-tomt) wrote :

I dont like doing "me too"'s, but I do see it as well across all of my computers after I upgraded to 13.10.

While not really important in itself it is one of those things that just gets to you and makes things feel very unfinished.

Miles Malerba (malerba89) wrote :

Yeah, I'm seeing this as well. This looks like the problem to me: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/indicator-datetime/trusty/view/head:/src/indicator-datetime.c#L282 The code to update the day of the week is commented out.

Misbach (matt-misbach) wrote :

This is a very visible bug that's been around for over two years. Can we up the priority?

Changed in indicator-datetime (Ubuntu):
importance: Low → Medium
description: updated
Per Vapp (vapper) wrote :

I just put wrong date on contract. To me it feels like High priority bug. Whats the use of calendar, if it shows you wrong date...

Marcus Sundman (sundman) wrote :

Mine now isn't updating even if I close and re-open the menu. The title correctly says it's January 2nd 2014, but the calendar shows December 2013 and highlights December 29th. Is this the same bug, or another related to the year switching? Or maybe a combination of both?
My indicator-datetime is up-to-date at 13.10.0+13.10.20131023.2-0ubuntu1 from saucy-updates.

timobaumann (timobaumann) wrote :

confirming the behaviour that Marcus Sundman sees: The calendar day never updates, not when closing and re-opening, not when coming back from sleep, not at midnight. (Don't know about rebooting which I rarely do.)

Charles Kerr (charlesk) wrote :

This new regression is happening because indicator-datetime-service no longer knows when the menu is being popped down because it's been decoupled from those GTK+ events after 13.10 de-GTK+-ified the indicator stack.

So we need to re-introduce some kind of notification mechanism like we used to have in about-to-show s.t. indicator-datetime-service will know to snap the calendar to the current date when the indicator's menu gets pulled down.

Adding also-affects unity, larsu is looking into u-p-s to see how much work it will take to get about-to-show working properly there.

If that proves to be more effort than we have time for right now, we could probably do an interim fix in IDO. indicator-datetime is IdoCalendarMenuItem's only customer, so we could change the contract between them for an IDO-and-datetime-specific fix. Obviously this a "plan b" option; it would be better to just fix about-to-show.

Changed in unity:
assignee: nobody → Lars Uebernickel (larsu)
Changed in indicator-datetime:
status: Fix Released → Triaged
assignee: Javier Jardón (jjardon) → Charles Kerr (charlesk)
milestone: 0.2.94 → none
importance: Low → Medium
Changed in unity:
importance: Undecided → Medium
Lars Karlitski (larsu) on 2014-01-29
affects: unity → libindicator
Changed in libindicator:
status: New → In Progress
Charles Kerr (charlesk) on 2014-01-29
Changed in indicator-datetime:
assignee: Charles Kerr (charlesk) → Lars Uebernickel (larsu)
status: Triaged → Fix Committed
Changed in libindicator:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-datetime at revision 296, scheduled for release in indicator-datetime, milestone Unknown

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 12.10.2+14.04.20140129-0ubuntu1

---------------
libindicator (12.10.2+14.04.20140129-0ubuntu1) trusty; urgency=low

  [ Colin Watson ]
  * Use named icons rather than (deprecated) stock items. (LP: #1262626)

  [ Lars Uebernickel ]
  * Don't treat deprecation warnings as errors and fix indicator-ng test
    for gtk 3.10. (LP: #1262626)
  * indicator-ng: support "submenu-action" on root menu items (LP:
    #793450)
 -- Ubuntu daily release <email address hidden> Wed, 29 Jan 2014 16:47:10 +0000

Changed in libindicator (Ubuntu):
status: New → Fix Released
Per Vapp (vapper) wrote :

Thank you for fixing, but how can I install and test fix on Ubunu 13.10?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.04.20140131-0ubuntu1

---------------
indicator-datetime (13.10.0+14.04.20140131-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Finally land this. Other, still open bugs will be fixed in
    subsequent commits. (LP: #793450)

  [ Sebastien Bacher ]
  * Use the correct location for datetime-dialog.ui. (LP: #1274046)

  [ Lars Uebernickel ]
  * Set calendar to the current date when the menu is popped up This
    makes use of the "submenu-action" attribute to get notified when the
    menu is popped up. Charles, if your big refactoring-branch should
    land before this, do you mind adapting this patch for that? Thanks .
    (LP: #793450)
 -- Ubuntu daily release <email address hidden> Fri, 31 Jan 2014 11:46:16 +0000

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Charles Kerr (charlesk) on 2014-02-05
Changed in libindicator:
status: Fix Committed → Fix Released
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Changed in unity-foundations:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2014-03-28
summary: - Calendar doesn't show today's date until opened a second time today
+ When the datetime-indicator's menu becomes visible, the Calendar isn't
+ always focused on today's date
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers