some indicators displayed twice

Bug #708243 reported by Ralf Hildebrandt on 2011-01-26
266
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
High
Ted Gould
Unity Foundations
Undecided
Ted Gould
indicator-application (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: indicator-network

$ ps auxwww|grep nm-applet
hildeb 3186 0.1 0.7 410956 31368 ? SLl 18:36 0:07 nm-applet --sm-disable
hildeb 7806 0.0 0.0 10400 924 pts/2 S+ 20:25 0:00 grep nm-applet

but still the applet ist displayed twice (see screenshot)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-network (not installed)
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
Date: Wed Jan 26 20:24:42 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: indicator-network

Related branches

I found that not only the nm-applet is shown twice, but the battery indicator, the network indicator and the Bluetooth indicator.

Duplicate indicators with DIFFERENT bluetooth status!

If I remove the indicator-applet and add it, I'm getting all the indicators only once.

Kalle Valo (kvalo) wrote :

nm-applet is in network-manager-gnome, moving the bug to that package.

affects: indicator-network (Ubuntu) → network-manager-applet (Ubuntu)

I think the description explains how it's not an issue in nm-applet but in indicator-applet, somehow it loads twice in the panel (other indicators are also affected).

affects: network-manager-applet (Ubuntu) → indicator-applet (Ubuntu)
Ted Gould (ted) on 2011-02-08
affects: indicator-applet (Ubuntu) → indicator-application (Ubuntu)
Changed in indicator-application (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in indicator-application:
status: New → Confirmed
importance: Undecided → High
tags: added: iso-testing
Robert Roth (evfool) on 2011-02-23
summary: - nm-applet displayed twice
+ some indicators displayed twice
Omer Akram (om26er) on 2011-03-06
Changed in indicator-application (Ubuntu):
status: Confirmed → Triaged
Ted Gould (ted) wrote :

It seems to be related to the number ApplicationAdded signals that happen between the call and the response to the GetApplications method call. Here's a bustle log of when I get two extra icons:

mc 1299870599 877264 96 :1.98 :1.106 /com/canonical/indicator/application/service com.canonical.indicator.application.service GetApplications
sig 1299870599 877608 85 :1.106 /com/canonical/indicator/application/service com.canonical.indicator.application.service ApplicationAdded
sig 1299870599 877706 86 :1.106 /com/canonical/indicator/application/service com.canonical.indicator.application.service ApplicationAdded
mr 1299870599 877859 87 96 :1.106 :1.98

Looks like we'll need a way to detect this case and ensure that we don't loose any items as well.

Changed in indicator-application:
assignee: nobody → Ted Gould (ted)
Ted Gould (ted) on 2011-03-11
Changed in indicator-application:
status: Confirmed → In Progress
mlaverdiere (mlaverdiere) wrote :

It seems that one easy and fast way to restore a panel without duplicated icons is to issue the following command within a terminal (or using Alt-F2?):

killall unity-panel-service

(once killed, unity-panel-serice appears to restart itself automatically).

kyleabaker (kyleabaker) wrote :

@mlaverdiere
While that may serve as a quick fix for alpha and beta testers, it is by no means a solution to the problem.

There is a branch opened for this bug (linked to above), but I've not had time to look into it to see how close it is to solving the problem. A better solution would be to not load duplicate indicators in the first place by possibly using a queue of some sort for initially called indicator items and removing them when they load.

Ted Gould (ted) on 2011-03-16
Changed in indicator-application:
status: In Progress → Fix Committed
mlaverdiere (mlaverdiere) wrote :

@kyleabaker
Of course, the killall unity-panel-service command to restore the panel when facing the problem is by no mean a solution to this bug, but just a way to quickly fix things without logging out/logging in or performing other time-consuming procedure . Obviously, a solution has to be found in order to prevent duplicated indicators loading (we're at the "fix committed" stage for this bug, so it seems that we do have a solution now).

That being said, if the problem was to happen again, the killall unity-panel-service may serve as a workaround, if used within a script automatically launched at startup, like it is proposed in a similar bug report (in that case, it was the killall gnome-panel command) for a previous Ubuntu version: https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/439448

Ted Gould (ted) on 2011-03-16
Changed in indicator-application:
milestone: none → 0.2.95
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.95-0ubuntu1

---------------
indicator-application (0.2.95-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Fix ordering of indicators
    ∘ No more duplication of indicators on the panel (LP: #708243)
    ∘ Using proper object on async call (LP: #734584)
    ∘ Protect from the accessible description being NULL. (LP: #724767)
  * Drop debian/patches/fix-null-string-to-variant-crash.patch
 -- Ted Gould <email address hidden> Wed, 16 Mar 2011 14:50:37 -0500

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
Ted Gould (ted) on 2011-03-16
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers