indicator-application-service crashed on logon

Bug #637202 reported by Anton Lykov on 2010-09-13
This bug affects 475 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
High
Karl Lattimer
Ayatana Ubuntu
High
Karl Lattimer
indicator-application (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: indicator-application

Crashed on logon.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: indicator-application 0.2.7-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Mon Sep 13 07:27:39 2010
ExecutablePath: /usr/lib/indicator-application/indicator-application-service
ProcCmdline: /usr/lib/indicator-application/indicator-application-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=ru_RU:ru:en_GB:en
 LANG=ru_RU.utf8
SegvAnalysis:
 Segfault happened at: 0x804b8ac: cmpb $0x0,(%edi)
 PC (0x0804b8ac) ok
 source "$0x0" ok
 destination "(%edi)" (0x3237313a) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: indicator-application
StacktraceTop:
 ?? ()
 ?? ()
 g_object_unref () from /usr/lib/libgobject-2.0.so.0
 ?? ()
 __libc_start_main () from /lib/libc.so.6
Title: indicator-application-service crashed with SIGSEGV in g_object_unref()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (bluetooth-applet:1564): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed
 (polkit-gnome-authentication-agent-1:1567): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1566): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (tracker-miner-fs:1556): Tracker-CRITICAL **: Could not execute sparql: Unable to insert multiple values for subject `urn:software-category:%2Fusr%2Fshare%2Fdesktop-directories%2Fpicasa.directory' and single valued property `nfo:fileLastModified' (old_value: '<untransformable>', new value: '<untransformable>')

Anton Lykov (lykovaa) wrote :

StacktraceTop:
 application_service_appstore_application_remove (
 application_service_appstore_dispose (object=0x91c8420)
 g_object_unref () from /usr/lib/libgobject-2.0.so.0
 main (argc=1, argv=0xbfb07eb4) at application-service.c:74

Changed in indicator-application (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: bugpattern-needed
Omer Akram (om26er) on 2010-09-18
visibility: private → public

grazie team ubuntu siette bravissimi! viva ubuntu

Sebastien Bacher (seb128) wrote :

The bug is collecting duplicates, could somebody in the dxteam work on it?

Changed in indicator-application (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Medium → High
Ted Gould (ted) wrote :

Unfortunately there doesn't seem to be enough information in the stack traces to figure out what is going on here. Could someone who's having it please try to get a Valgrind log of their indicator-application-service: https://wiki.ubuntu.com/Valgrind Thank you!

Ted Gould (ted) on 2010-09-29
Changed in indicator-application:
importance: Undecided → High
status: New → Triaged

I did have the bug, occurring when booting into the RC for the first time (on, shame on me, a production machine), but not after subsequent reboots, so I'm unable to reproduce.

I am wondering, is anyone who has had this bug still able to reproduce?

Download full text (8.3 KiB)

Hi. Can you help me with this problem ?

I have got Toshina Equium A300D - 13x and extern monitor Acer x223w. I been
tested all version Ubuntu and Kubutu 10.04 and 10.10 but all of them have
same trouble. Maverick 10.10 with mesa 7.9 is running best of them.

I made file for setup corect resolution on my monitor :
#!/bin/sh
xrandr --newmode "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051
1054 1087 -HSync +Vsync
xrandr --addmode VGA-0 1680x1050_60.00
xrandr --output LVDS --off
xrandr --size 1680x1050

This file is started with ubuntu but after some time is resolution damaged
and resolution is automatic setup on resolution which is provided by Ubuntu.
I have to start up again the file with my setup.

Ubuntu Maverick is running in satisfed level for me, but mine trouble are
with extern monitor. If I go to console via CTRL+ALT+F1 or F2 ... F6
anywhere I can see this information and my monitor is regulary flashing.

I think if I will able stop the process on the backround my screen
resolution stay stable. Or have any idea from you ?

Thank You, Matúš

Procedures from konsole:
(this still running and display is flashing every cca 45 min.)
Sep 29 22:12:08 ubuntu-mrn kernel: [ 3584.324430] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:12:18 ubuntu-mrn kernel: [ 3594.400774]
Sep 29 22:12:18 ubuntu-mrn kernel: [ 3594.455106]
Sep 29 22:12:18 ubuntu-mrn kernel: [ 3594.508366]
Sep 29 22:12:19 ubuntu-mrn kernel: [ 3594.562315]
Sep 29 22:12:19 ubuntu-mrn kernel: [ 3594.562319] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:12:29 ubuntu-mrn kernel: [ 3604.639242]
Sep 29 22:12:39 ubuntu-mrn kernel: [ 3614.708027]
Sep 29 22:12:39 ubuntu-mrn kernel: [ 3614.761870]
Sep 29 22:12:39 ubuntu-mrn kernel: [ 3614.816912]
Sep 29 22:12:39 ubuntu-mrn kernel: [ 3614.869768]
Sep 29 22:12:39 ubuntu-mrn kernel: [ 3614.869772] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:12:49 ubuntu-mrn kernel: [ 3624.940715]
Sep 29 22:12:49 ubuntu-mrn kernel: [ 3625.000506]
Sep 29 22:12:49 ubuntu-mrn kernel: [ 3625.056629]
Sep 29 22:12:49 ubuntu-mrn kernel: [ 3625.117293]
Sep 29 22:12:49 ubuntu-mrn kernel: [ 3625.117297] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:12:59 ubuntu-mrn kernel: [ 3635.188560]
Sep 29 22:12:59 ubuntu-mrn kernel: [ 3635.249480]
Sep 29 22:12:59 ubuntu-mrn kernel: [ 3635.311205]
Sep 29 22:12:59 ubuntu-mrn kernel: [ 3635.368655]
Sep 29 22:12:59 ubuntu-mrn kernel: [ 3635.368659] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:13:09 ubuntu-mrn kernel: [ 3645.451944]
Sep 29 22:13:09 ubuntu-mrn kernel: [ 3645.515674]
Sep 29 22:13:10 ubuntu-mrn kernel: [ 3645.579831]
Sep 29 22:13:10 ubuntu-mrn kernel: [ 3645.635591]
Sep 29 22:13:10 ubuntu-mrn kernel: [ 3645.635595] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:13:20 ubuntu-mrn kernel: [ 3655.706974]
Sep 29 22:13:20 ubuntu-mrn kernel: [ 3655.768028]
Sep 29 22:13:20 ubuntu-mrn kernel: [ 3655.831611]
Sep 29 22:13:20 ubuntu-mrn kernel: [ 3655.891336]
Sep 29 22:13:20 ubuntu-mrn kernel: [ 3655.891346] radeon 0000:01:05.0: HDMI
Type A-1: EDID block 0 invalid.
Sep 29 22:13:30 ubuntu-mrn kern...

Read more...

Colan Schwartz (colan) wrote :

> I am wondering, is anyone who has had this bug still able to reproduce?

I just got it. Confirming.

Changed in indicator-application (Ubuntu):
status: New → Confirmed
renormalist (ss5) wrote :

Confirming.

00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

Bruce Pieterse (octoquad) wrote :

Just got it as well. I found the following in daemon.log:

Nov 24 09:01:25 desa gdm-simple-greeter[1742]: Gtk-WARNING: /build/buildd/gtk+2.0-2.22.0/gtk/gtkwidget.c:5684: widget not within a GtkWindow
Nov 24 09:01:27 desa gdm-simple-greeter[1742]: WARNING: Unable to parse history: (null) 2#012
Nov 24 09:03:14 desa gdm-session-worker[1748]: GLib-GObject-CRITICAL: g_value_get_boolean: assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed

Odin Hørthe Omdal (velmont) wrote :

I don't get any crash notifications, but sometimes when I start my computer, the whole shebang is gone. It is very irritating. Find screenshot enclosed.

Ted Gould (ted) wrote :

Besides a valgrind log it would be useful to have the output from Unity or the applet. It seems like indicator-application-service is shutting down. Which is more likely the root cause of the issue.

Changed in indicator-application:
status: Triaged → Incomplete
David Barth (dbarth) wrote :

Not sure if the service is shutting down, or if an application is shutting down or flickers on the bus and as the application-service-appstore tries do dispose the reference it fails and crashes. That's from the analysis of crashers going through application_removed_cb

It may not fix the problem for specific app indicators, but being extra cautious when dealing with object references along the application_removed_cb path may help and prevent the whole service from crashing.

I think that's a worthwhile audit to perform on the existence codebase (natty) and see if a backport can then be provided to desktop for an sru candidate that reporters here could test.

Changed in indicator-application:
assignee: nobody → Karl Lattimer (karl-qdh)
Changed in indicator-application (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Karl Lattimer (karl-qdh)
milestone: none → natty-alpha-3
Ted Gould (ted) wrote :

Considering the next function up the stack is "application_service_appstore_dispose()" I'm pretty sure that it's shutting down. The appstore is only unreferenced in a single place:

http://bazaar.launchpad.net/~indicator-applet-developers/indicator-application/trunk/view/head:/src/application-service.c#L73

elrucu (elrucu) on 2011-01-28
Changed in indicator-application:
status: Incomplete → Opinion
Dario Bertini (berdario) wrote :

Opinion?
Is it only me to find this change a little bit nonsensical?
afaik, Opinion should be used when the topic and/or proposed solution
is controversial...

but this is a crash: either is does happen or it does not...
If we don't have enough information for prooceding with this bug i
think it would be better to leave it as Incomplete (and eventually let
it expire)

(I myself had this bug, but haven't had this crash lately, so i'm
unable to help with the details)

Omer Akram (om26er) on 2011-01-28
Changed in indicator-application:
status: Opinion → Incomplete
David Barth (dbarth) wrote :

@Karl: could you comment on the analysis of the issue and resolution status? Thanks

Changed in ayatana-ubuntu:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → High
Vadim Peretokin (vperetokin) wrote :

Not using Unity, got this on Maverick. Just logged in to see a crash report waiting for me (I did enable apport).

Karl Lattimer (karl-qdh) wrote :

are people still experiencing this bug, it's passed me by until now unforunately.

Dmitry Shachnev (mitya57) wrote :

I don't get this anymore, for a long time.

Bruce Pieterse (octoquad) wrote :

Haven't had it since my last bug report.

Karl Lattimer (karl-qdh) wrote :

Marked as fix released as no-one seems to get it any more.

Changed in indicator-application (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-application:
status: Incomplete → Fix Released
Changed in ayatana-ubuntu:
status: New → Fix Released

So the duplicate reported by Colan Schwartz on 2011-03-18 (10 days ago) doesn't count? .... Setting back to Triaged.

Changed in indicator-application (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
milestone: natty-alpha-3 → none
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

if you still have an issue open a new bug with a new stacktrace, it could be similar to you but a different crash

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
Zentai Andras (andras-zentai) wrote :

I just experienced a crash "indicator-application-service crashed with SIGSEGV in g_object_unref()" using Oneiric (11.10) AMD64 and Unity 2D.
I'm not sure if this is the same bug.
It happened only first time, no it would be really hard to reproduce.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers