Application Indicator users launched at start-up skip the applet and fall back instead

Bug #526499 reported by Vish
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
Medium
Unassigned
Ubuntu
Invalid
Undecided
Unassigned
indicator-application (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

When an application that uses Indicator Applications is launched at start-up it is often launched more quickly than the Indicator Applet, which means indicator-application-service isn't launched yet. Therefore the applications fall back to using a GtkStatusIcon.

Edited scrollback of a chat about this issue on #ayatana:
<qense> chrisccoulson, do you think bug #526499 can be solved with a "X-GNOME-Autostart-Delay"?
<chrisccoulson> qense - i'd prefer not to do that
<24chrisccoulson> that seems like a hacky solution
<chrisccoulson> i'd rather fix the real issue, which is that it falls apart if transmission starts before indicator-application-service
<qense> shouldn't the library launch the service over DBus?
<jpetersen_> qense, that bug also happens with other autostarted applications like gnome-settings-daemon and gnome-power-manager
<tedg> qense: Should the application start indicator-application-service?
<qense> tedg: here it is causing problems
<qense> but it might be desired behaviour when people remove the applet
<qense> from their panel
<tedg> qense: I was thinking no, as if they haven't got the applet, they're effectively voting no.
<tedg> qense: Plus there is no way to start applets externally.
<tedg> qense: We could start the service, but not do much with it.
<tedg> qense: This is another reason gnome-panel needs to die :)
<qense> that's true, but it would require the autostart applications to use the X-GNOME-Autostart-Delay key
<qense> which is a bit hacky
<qense> isn't there a way to give the service priority over other applications?
<tedg> qense: No, we need to fix it so that they'll wait a bit.
<tedg> qense: They already don't fallback immediately.
<tedg> qense: There's a bit of hysteresis so that if the service dies, the user shouldn't notice as it'll get restarted.
<tedg> qense: The applet will restart it immediately.
<qense> I've noticed that already. :) it's unkillable!
<qense> so a delay key it is, you say?
<tedg> qense: I think we should probably do it in the library really.

For a full transcript, please look at <http://irclogs.ubuntu.com/2010/02/23/%23ayatana.html>.

Related branches

Vish (vish)
description: updated
Revision history for this message
Sense Egbert Hofstede (sense) wrote :

Thank you for taking the time to report this issue. This is a general issue that affects all automatically launched applications using libappindicator. I'm assigning it to that package and will open an upstream task once I've added some more information to the description.

affects: transmission (Ubuntu) → indicator-application (Ubuntu)
Changed in indicator-application (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - Transmission doesnt use indicator-application if present in the startup
- applications
+ Application Indicator users launched at start-up skip the applet and
+ fall back instead
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

is anybody still getting that issue?

Revision history for this message
Sense Egbert Hofstede (sense) wrote :

In a duplicate report someone said the bug only occurred when using auto-login. Also, when testing this bug please keep in mind that Compiz delays desktop loading, that could influence the results.

Revision history for this message
Kjell L. (lkjell) wrote :

I think there is something wrong here. I want it to fall back to the GtkStatusIcon. But sometimes it does not fall back at all. Which means I do not get any icons since I use trayer and not gnome-panel.

Revision history for this message
Xhacker Liu (xhacker) wrote :

This bug affects me too.

Sometimes ibus icon displayed in the notification area, but not appindicator.

Xhacker Liu (xhacker)
Changed in transmission (Ubuntu):
status: New → Invalid
Revision history for this message
Vish (vish) wrote :

No need to spam the nice folks from transmission about this ;-)

affects: transmission (Ubuntu) → ubuntu
Ted Gould (ted)
Changed in indicator-application:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Aron Xu (happyaron) wrote :

Hi, is there any progress on this issue?

Revision history for this message
YunQiang Su (wzssyqa) wrote :

It effect ibus.

Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

I can confirm this effect ibus

Revision history for this message
Ted Gould (ted) wrote :

I committed what I think is a fix for this. Unfortunately I can't reproduce it consistently, so I don't know. But it hasn't happened for about a week for me now... I hope that means it's fixed for sure. I put a version "indicator-application_0.2.9-0ubuntu2~ppa2" with this fix in my bugfix PPA, I'd love to know if it works for other people as well: https://launchpad.net/~ted/+archive/bugfix

Revision history for this message
Xhacker Liu (xhacker) wrote :

Hi Ted, after I installed it, this issue seems disappear, thanks.
If you could provide a package for natty, I can do more test.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.90-0ubuntu1

---------------
indicator-application (0.2.90-0ubuntu1) natty; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * A race fix on the dbus name (LP: #526499)
    * Fixing the Watcher Interface
    * Fixes to build with GTK 2/3
    * Fixes to build with valac-0.12

  [ Ken VanDine ]
  * debian/control
    - Changed the valac build depends to valac-0.12
  * debian/python-appindicator.install
    - Make sure python2.6 and python2.7 files get included
  * debian/rules
    - Fix builds for multiple python versions
 -- Ken VanDine <email address hidden> Wed, 08 Dec 2010 00:42:58 -0500

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Xhacker Liu (xhacker) wrote :

Hi Ted, the bug seems not fixed in my natty. ibus and dropbox both fallback to normal notification area, while only network manager works well.
And I can't reopen the bug...

Revision history for this message
Xhacker Liu (xhacker) wrote :

By the way, this issue is not exist in my maverick with indicator ppa:ted/bugfix version.

Ted Gould (ted)
Changed in indicator-application:
status: Confirmed → Fix Released
Revision history for this message
Xhacker Liu (xhacker) wrote :

I'm afraid this bug is here again. (with Ubuntu natty)
Sometimes the ibus displayed in the normal notification area.
When I using Unity, sometimes there is no ibus icon.

Revision history for this message
Omer Akram (om26er) wrote :

Please open a new bug for the issue you are facing, there is no need to open an already fixed bug

affects: unity → null
Changed in null:
status: New → Invalid
Curtis Hovey (sinzui)
no longer affects: null
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints