Printing on hp printer has black background

Bug #553573 reported by Michael Kerwin on 2010-04-01
34
This bug affects 12 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

my HP color Laserjet cm1312cm nfi MFP pritner is printing black on lines that are not text.

affects: ubuntu → hplip (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.2-1ubuntu5

---------------
hplip (3.10.2-1ubuntu5) lucid; urgency=low

  [ Till Kamppeter ]
  * debian/patches/make-commafy-correctly-work-with-python-2.dpatch:
    Installation of the proprietary plug-in did not work with some locales
    (LP: #525901).
  * debian/hplip-cups.postinst, debian/hpijs.postinst: Switch back to HPIJS as
    default driver (migrate hpcups queues to HPIJS) as there are new problems
    with hpcups (LP: #553573, LP: #539708, LP: #538031, LP: #405116).

  [ Mark Purcell ]
  * Fix "can't add printer (Printer queue setup failed)" added debian/hplip.NEWS
    - CUPS requires user to be a member of lpadmin group. (Closes: #566692)
  * Add Recommends: avahi-daemon "HP Color Laserjet CM1312nfi" (Closes: #564520)
  * Add bug/presubj to hplip-cups, hplip-gui & hpijs
  * Add hplip-cups.NEWS
  * bug/script provide status message before hp-check
  * Patch hp-check to check for group membership of lp & lpadmin
 -- Till Kamppeter <email address hidden> Fri, 9 Apr 2010 21:26:18 +0200

Changed in hplip (Ubuntu):
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

The package uploaded now is not a fix but a workaround, it simply migrates hpcups-based queues to HPIJS.

Till Kamppeter (till-kamppeter) wrote :

A real fix could be the proposed fix of bug 539708, please try the fix as soon as it gets available. After installing the new Ghostscript you have to install a new print queue for your printer using the "hpcups" driver (install the hplip-cups package if it is not installed). Does this new queue print correctly? If yes, mark this bug a duplicate of bug 539708.

I was able to choose a different driver than the default they gave me when I
went back in cups and chose the postscript one and that one worked. But When
I first set up the printer it didn't give me the other choices.

Thanks,

Michael Kerwin
On Thu, Apr 29, 2010 at 9:53 AM, Till Kamppeter <email address hidden>wrote:

> A real fix could be the proposed fix of bug 539708, please try the fix
> as soon as it gets available. After installing the new Ghostscript you
> have to install a new print queue for your printer using the "hpcups"
> driver (install the hplip-cups package if it is not installed). Does
> this new queue print correctly? If yes, mark this bug a duplicate of bug
> 539708.
>
> --
> Printing on hp printer has black background
> https://bugs.launchpad.net/bugs/553573
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “hplip” package in Ubuntu: Fix Released
>
> Bug description:
> my HP color Laserjet cm1312cm nfi MFP pritner is printing black on lines
> that are not text.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/553573/+subscribe
>

Till Kamppeter (till-kamppeter) wrote :

The proposed fix for bug 539708 is available now. Please follow the instructions there to test it. Make sure you test with the hpcups driver and not with the hpijs driver.

Leo Milano (lmilano) wrote :

Hi Till

I just tested the hpcups driver from the proposed repository in my system (Kubuntu Lucid, HP Deskjet F380), and the bug is fixed. I no longer get the black background. I will also post the good news in bug 539708.

Great work everyone involved! Cheers,
-- Leo

Leo Milano (lmilano) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers