hp printer prints totally wrong - non-text lines are black rather than white

Bug #538031 reported by ZyroBlue on 2010-03-12
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

I today tried to print a pdf with my HP cp1515n, which I had installed automatically by printer-applet in current Kubuntu Lucid and got a page which had black instead of white between the - correctly printed - lines of text. I then tried printing a test page via hplip-gui - result is as follows up in the photo. Notice the black lines for example above "HPLIP Printer Test Page"?
I had another user of ubuntuusers.de double-checking: He owns an ink printer and this doesn't fail..

ProblemType: Bug
Architecture: i386
Date: Fri Mar 12 12:49:41 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100304)
Lpstat: device for HP-Color-LaserJet-CP1515n: hp:/usb/HP_Color_LaserJet_CP1515n?serial=00CNAT85QHPT
MachineType: ASUSTeK Computer Inc. F50SL
Package: hplip 3.10.2-0ubuntu1
Papersize: a4
PpdFiles: HP-Color-LaserJet-CP1515n: HP Color LaserJet cp1515n pcl3, hpcups 3.10.2
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=9bcfb143-e5ed-4634-971f-af5df48d5ed8 ro quiet splash
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: hplip
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 02/24/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 207
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: F50SL
dmi.board.vendor: PEGATRON CORPORATION
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr207:bd02/24/2009:svnASUSTeKComputerInc.:pnF50SL:pvr1.0:rvnPEGATRONCORPORATION:rnF50SL:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: F50SL
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

ZyroBlue (ferahgo-de) wrote :
Leo Milano (lmilano) wrote :

I just printed an email from gmail, using Chrome, and I got a full page in black. Solid black. This is using an HP F380 AIO. I tried again from Adobe (a previously saved PDF), same problem. This is in Lucid. The same printer works fine in Karmic.

ZyroBlue (ferahgo-de) wrote :

Now that you made me think about that issue again, I tried the following:
opened up hplip-gui, deleted the printer (red "-"), then added the very same printer again via the green "+" and now it works :)

Leo Milano (lmilano) wrote :

Ouch. Too bad. I was going to ask what driver you were using :-). My machine was using hpijs in karmic, and when I upgraded to Lucid it was picked up as hpcups, which was not working fine. From the KDE System Settings I reconfigured the printer to use hpijs (instead of the _recommended_ hpcups), and everything is fine.

Is this the default really? To use hpcups? Here, at least, it prints a full black block, which would empty an inkjet cartridge in just about a few pages (if the user doesn't realize). And those are expensive!

Terri (terribl) wrote :

I reinstalled (automatic rebuild) hplip from http://hplipopensource.com/hplip-web/index.html and it worked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.2-1ubuntu5

---------------
hplip (3.10.2-1ubuntu5) lucid; urgency=low

  [ Till Kamppeter ]
  * debian/patches/make-commafy-correctly-work-with-python-2.dpatch:
    Installation of the proprietary plug-in did not work with some locales
    (LP: #525901).
  * debian/hplip-cups.postinst, debian/hpijs.postinst: Switch back to HPIJS as
    default driver (migrate hpcups queues to HPIJS) as there are new problems
    with hpcups (LP: #553573, LP: #539708, LP: #538031, LP: #405116).

  [ Mark Purcell ]
  * Fix "can't add printer (Printer queue setup failed)" added debian/hplip.NEWS
    - CUPS requires user to be a member of lpadmin group. (Closes: #566692)
  * Add Recommends: avahi-daemon "HP Color Laserjet CM1312nfi" (Closes: #564520)
  * Add bug/presubj to hplip-cups, hplip-gui & hpijs
  * Add hplip-cups.NEWS
  * bug/script provide status message before hp-check
  * Patch hp-check to check for group membership of lp & lpadmin
 -- Till Kamppeter <email address hidden> Fri, 9 Apr 2010 21:26:18 +0200

Changed in hplip (Ubuntu):
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Terhi, can you post your PPD files (in /etc/cups/ppd/), your /etc/cups/printers.conf, the output of "hp-check -r" and of "lpstat -v -p" here? Thanks.

For everyone: The package uploaded now is not a fix but a workaround, it simply migrates hpcups-based queues to HPIJS.

Bferd (bradschroth) wrote :

This bug was not fixed in the package hplip - 3.10.2-1ubuntu5. Because that is the version that I have installed and I still have the black lines.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers