No real cupsddk package

Bug #472590 reported by Howard Bliss on 2009-11-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
cups (Ubuntu)
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned
policykit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

I upgraded to 9.10 from 9.04. I have two printers, a HP PSC 1315 (usb) and a HP Laserjet 1100a (parallel). I had both printers (and scanners) working normally under 9.04. After the upgrade to 9.10, HP Director showed errors for both printers; "unable to open device hp:/par/HP_Laserjet_1100?device=/dev/parport0" and "unable to open device hp:/usb/psc_1310_series>serial=CN44J1514CO2". Each icon had a red x in the upper left. I ran hp-check and it reported four errors and said to run sudo aptitude install --assume-yes cupsddk cupsddk-drivers and sudo aptitude install --assume-yes policykit policykit-gnome. I ran the suggested installs and repeated hp-check. It showed the same four errors but only suggested to install cupsddk and cupsddk-drivers. When I looked at cupsddk with System>Administration>Synaptic Package Manager (and online) it said "This is a dummy package to ease transition to new package name". How can I install a real cupsddk (or equivalent) and make these problems go away?

ProblemType: Bug
Architecture: i386
Date: Tue Nov 3 06:22:33 2009
DistroRelease: Ubuntu 9.10
Lpstat:
 device for HP-LaserJet-1100: hp:/par/HP_LaserJet_1100?device=/dev/parport0
 device for psc-1310-series: hp:/usb/psc_1310_series?serial=CN44J1514CO2
 device for psc-1310-series-: usb://hp/psc%201310%20series?serial=CN44J1514CO2
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: Compaq Presario 061 PJ506AA-ABA SR1215CL NA440
Package: cups 1.4.1-5ubuntu2
Papersize: letter
PpdFiles:
 psc-1310-series: HP PSC 1310 Series hpijs, 3.9.8
 HP-LaserJet-1100: HP LaserJet 1100 hpijs, 3.9.8
 psc-1310-series-: HP PSC 1310 Series hpijs, 3.9.8
ProcCmdLine: root=UUID=c7f85ab2-5722-4866-963a-de5e8e16d358 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-15.52-generic
SourcePackage: cups
Uname: Linux 2.6.28-15-generic i686
dmi.bios.date: 06/06/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 3.15
dmi.board.name: Kelut
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 2.02
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr3.15:bd06/06/2005:svnCompaqPresario061:pnPJ506AA-ABASR1215CLNA440:pvr0n41411CO101KELUT00:rvnASUSTekComputerINC.:rnKelut:rvr2.02:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: PJ506AA-ABA SR1215CL NA440
dmi.product.version: 0n41411CO101KELUT00
dmi.sys.vendor: Compaq Presario 061

Howard Bliss (hbbliss) wrote :
Till Kamppeter (till-kamppeter) wrote :

From CUPS 1.4.1 on, all functionality of CUPS DDK has moved into CUPS. So all files of the former cupsddk and cupsddk-drivers packages are on your system. PolicyKit changed to a new major release between Jaunty and Karmic. So it is possible that packaging changed and so the appropriate functionality is in different packages.

Changed in cups (Ubuntu):
status: New → Won't Fix
Till Kamppeter (till-kamppeter) wrote :

Can someone of the PolicyKit maintainers tell which packages are providing the functionality of the former policykit and policykit-gnome? Thanks.

Till Kamppeter (till-kamppeter) wrote :

Can someone at HP update hp-check to work correctly with the newest distros, like Karmic? There are changes in the packaging introduced with the newest PolicyKit and CUPS (1.4.x). Would be great to have it correct in 3.9.10.

On Tue, Nov 3, 2009 at 8:52 AM, Till Kamppeter <email address hidden>wrote:

> Can someone at HP update hp-check to work correctly with the newest
> distros, like Karmic? There are changes in the packaging introduced with
> the newest PolicyKit and CUPS (1.4.x). Would be great to have it correct
> in 3.9.10.
>
> --
> No real cupsddk package
> https://bugs.launchpad.net/bugs/472590
> You received this bug notification because you are a direct subscriber
> of the bug.
> I appreciate the responses, they are helping me to better understand the
> problem, however, I would really like to get my printers (and scanners)
> running now. Some piece of software somewhere needs what was in cupsddk and
> is not getting it. If I knew how I would like to fix this in my system. As
> a related aside, /dev/parport0 has root only permission. If the permission
> is changed to both root and the "user" the error for the HP 1100 (parallel)
> printer goes away. Is the usb printer similarly afflicted?
>

New Version hplip-3.9.12 in my repositoy, hp changelog says this bug is fixed
Please try it out!

Link : https://launchpad.net/~solard3ity/+archive/official

Changed in hplip:
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Thank you for making the new HPLIP available for testing. We will soon update to it in Lucid.

Changed in hplip:
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Changed in hplip (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers