Ubuntu

Can't print some emails and pictures to HP LaserJet 1200 series

Reported by Sergio Zanchetta on 2007-11-28
20
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
eog (Ubuntu)
Wishlist
Unassigned
Nominated for Hardy by Sergio Zanchetta
evolution (Ubuntu)
Wishlist
Unassigned
Nominated for Hardy by Sergio Zanchetta
foomatic-db (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Sergio Zanchetta
hplip (Ubuntu)
Low
Unassigned
Nominated for Hardy by Sergio Zanchetta
system-config-printer (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Sergio Zanchetta

Bug Description

Binary package hint: evolution

When I print print a mail or something else from evolution to both a HP Laserjet 1200 series (connected via usb) and a network printer (same printer HP LaserJet 1200 series) connected with a Windows 2000 PC, printer's light start blinking as it had a document ready to print but nothing come out. It keep on blinking until I switch off it.
Even if I print something else when blinking, nothing happens.

This occours with evolution firstly but also with other programs like evince and eog.

I noticed that the problem came up when printing image size is more than 1 M about.

I'm using Gutsy up-to-date, I don't know with Feisty because I was used to use Thunderbird before.

I think it should be fixed for Hardy, due to be a LTS release.

Sergio Zanchetta (primes2h) wrote :

Sorry, I just tested again now, and it works.
Probably some updates in last days fixed it.

By the way,has it been some updates in printing recently?

Sorry again.

If it occours again I'll reopen it.

Changed in evolution:
status: New → Fix Released
Changed in evolution:
status: Fix Released → New

UPDATE:

I attached the printer directly to my laptop.
Same problem.

I found out that the problem reported above occours when I print an email bigger than 1 M about.

Sergio Zanchetta (primes2h) wrote :

I thought that was fixed because printing an email smaller than 1M worked.

Sergio Zanchetta (primes2h) wrote :

P.S.: Size of 1 M is referred to print file size reported in "Document print status"

Sergio Zanchetta (primes2h) wrote :

After 1 minute from sending print job, a pop-up dialog appear in printer icon up-right on the desktop.

It says (in english should be)

"Printer error"
Printer HP_LaserJet_1200 : other

Printer keep on blinking but nothing happens

In System -> Administration .> Printing the printing status is "idle".

Sergio Zanchetta (primes2h) wrote :

/var/log/syslog

Nov 29 18:45:54 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/mlc.c 179: unable to read MlcReverseCmd header: Resource temporarily unavailable
Nov 29 18:45:54 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/musb.c 1515: invalid MlcCredit from peripheral, trying miser
Nov 29 18:46:39 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/mlc.c 179: unable to read MlcReverseCmd header: Resource temporarily unavailable
Nov 29 18:46:39 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/musb.c 1520: invalid MlcCredit from peripheral
Nov 29 18:46:39 entropy HP_LaserJet_1200?serial=00CNBF336637: ERROR: check device; will retry in 30 seconds...
Nov 29 18:47:54 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/mlc.c 179: unable to read MlcReverseCmd header: Resource temporarily unavailable
Nov 29 18:47:54 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/musb.c 1520: invalid MlcCredit from peripheral
Nov 29 18:47:54 entropy HP_LaserJet_1200?serial=00CNBF336637: ERROR: check device; will retry in 30 seconds...
Nov 29 18:49:09 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/mlc.c 179: unable to read MlcReverseCmd header: Resource temporarily unavailable
Nov 29 18:49:09 entropy HP_LaserJet_1200?serial=00CNBF336637: io/hpmud/musb.c 1520: invalid MlcCredit from peripheral
Nov 29 18:49:09 entropy HP_LaserJet_1200?serial=00CNBF336637: ERROR: check device; will retry in 30 seconds...

description: updated

UPDATE:
Some email are printed and other not (even small one) with evolution.
This is a very ODD and IRRITATING bug because I can't understand base principles of what happens.
In general it's impossible to print emails from evolution to HP 1200 LaserJet series.
But with few emails it works...

With EOG printing pics usually works but with a particular pic it doesn't.

I hope It'll be fixed soon because I can't use this printer.

Sergio Zanchetta (primes2h) wrote :

When I use the printer attached on my usb port it happens the same thing as reported in this post in ubuntuforums (not mine):

http://ubuntuforums.org/showpost.php?p=3912242&postcount=13

According to
https://wiki.ubuntu.com/PrintingBugInfoScript

I attach my printingbuginfo

description: updated
Till Kamppeter (till-kamppeter) wrote :

This is a hardware design problem of the HP LaserJet 12xx and 13xx printers. Their firmware contains a PostScript interpreter, but the printer's hardware resources (processor, default memory) are not powerful enough to use the device as a PostScript printer. As these printers also understand PCL you can move the rendering work load to the computer by choosing a PCL driver (using a printer setup tool like system-config-printer), like HPIJS for these printers. This is also the way to use it recommended by the OpenPrinting web site and probably the Windows driver talks PCL, too.

Alternatively, you can add memory to the printer to use it in PostScript mode.

The main fix has to be done in system-config-printer, choosing a non-PostScript driver for a printer with manufacturer-supplied PostScript PPD if the non-PostScript driver is recommended.

To the developers of Evolution and EOG I suggest to make these apps generating a more compact PostScript output when printing.

For the HPLIP error output check whether it still happens if the printer is used in PCL mode. It can be that the error output is a consequence of overflooding the printer's too small memory. Suggestion to the HPLIP developers: Give some clear error feedback if a printer runs out of memory resources.

Changed in eog:
importance: Undecided → Wishlist
status: New → Triaged
Changed in evolution:
importance: Undecided → Wishlist
status: New → Triaged
Changed in hplip:
importance: Undecided → Low
status: New → Incomplete
Changed in system-config-printer:
importance: Undecided → Medium
status: New → Triaged
Changed in evolution:
importance: Wishlist → Low
Changed in eog:
importance: Wishlist → Low
Sergio Zanchetta (primes2h) wrote :

@Tim

Thank you VERY MUCH for your clear explanation.
In fact I tried "HP LaserJet 1200 Foomatic/hpijs" driver and IT WORKS!!!
I knew that Windows use PCL driver, but during installation in system-config-printer the Postscript one was set as raccomended.

Moreover you gave nice hints to developers to enhance performances.

In addition I would like to suggest to set "HP LaserJet 1200 Foomatic/hpijs" as "raccomanded" in system-config-printer for HARDY (LTS), otherwise it'll be very hard printing for people with this printer.

Thank you again Tim.

Sergio Zanchetta (primes2h) wrote :

@Tim

That error output is gone, instead It comes up this when I print (It's normal probably :-) ):

Dec 12 15:07:19 entropy kernel: [24472.208000] audit(1197468438.892:34): type=1503 operation="file_mmap" requested_mask="mr" denied_mask="m" name="/usr/share/samba/upcase.dat" pid=8807 profile="/usr/sbin/cupsd"
Dec 12 15:07:19 entropy kernel: [24472.208000] audit(1197468438.892:35): type=1503 operation="file_mmap" requested_mask="mr" denied_mask="m" name="/usr/share/samba/lowcase.dat" pid=8807 profile="/usr/sbin/cupsd"
Dec 12 15:07:19 entropy kernel: [24472.772000] audit(1197468439.392:36): type=1503 operation="file_mmap" requested_mask="mr" denied_mask="m" name="/usr/share/samba/valid.dat" pid=8807 profile="/usr/sbin/cupsd"
Dec 12 15:07:20 entropy kernel: [24473.748000] audit(1197468440.392:37): type=1503 operation="inode_permission" requested_mask="rw" denied_mask="rw" name="/dev/tty" pid=8815 profile="/usr/sbin/cupsd"
Dec 12 15:07:20 entropy kernel: [24473.812000] audit(1197468440.392:38): type=1503 operation="inode_permission" requested_mask="rw" denied_mask="rw" name="/dev/tty" pid=8818 profile="/usr/sbin/cupsd"

First, my name is Till and not Tim.

Changing the recommendation to a PCL driver in system-config-printer is my intention. system-config-printer does not correctly reproduce the recommendation from OpenPrinting here.

Your result seems to confirm that the HPLIP errors are really due to overloading the printer's resources. So the task for the HPLIP developers here is to make the error output more clear.

Concerning the audit errors which you get now, they come from the AppArmor protection of CUPS. If you are still able to print via Samba to a printer connected to a Windows box, it is no problem. If not, you can turn off the AppArmor protection as a quick workaround:

sudo aa-complain cupsd

To turn it back on later do:

sudo aa-enforce cupsd

The AppArmor configuration of the current Hardy package of CUPS does not restrict the SMB backend any more, so the Samba-related errors will go away with a fully updated Hardy.

Changed in hplip:
status: Incomplete → Triaged
Sergio Zanchetta (primes2h) wrote :

Oops! I'm so sorry, "Till". :-)
My eyes are getting worse... ;-)))

I can print normally now, so no matter about AppArmour.

Thank you for nice explanation.
I really appreciated it!

Changed in system-config-printer:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 0.7.78+svn1799-0ubuntu1

---------------
system-config-printer (0.7.78+svn1799-0ubuntu1) hardy; urgency=low

  * New upstream release
     o Subversion snapshot r1799
     o Made assignment of PPDs to auto-detected printers more reliable,
       especially for Bluetooth and network printers. This is done by
       supporting weird auto-detection output of CUPS backends, as
       "Unknown" for make and model but useful info field, device ID
       for Bluetooth not identical with device ID for USB/parallel, no
       manufacturer name in make-and-model field, case-insensitive search
       when cleaning model name.
     o Handle the manufacturer name "KONICA MINOLTA" correctly (LP: #64046).
     o If the OpenPrinting database (foomatic-db) recommends a non-PostScript
       driver, use this driver, even if there is a vendor PPD for the
       PostScript mode (HP LaserJet 12xx/13xx, LP: #172550).
     o Allow listing of all files in file chooser dialog for selecting a
       custom PPD file (LP: #153585).
  * debian/control: Added missing dependencies: python-gnome2 and
    gnome-icon-theme (LP: #176929).

 -- Till Kamppeter <email address hidden> Mon, 07 Jan 2008 16:44:22 +0000

Changed in system-config-printer:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

that's not an application bug

Changed in evolution:
status: Triaged → Invalid
Changed in eog:
status: Triaged → Invalid
Sergio Zanchetta (primes2h) wrote :

What about this comment from Till?

"To the developers of Evolution and EOG I suggest to make these apps generating a more compact PostScript output when printing."
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/172550/comments/9

Could it be considered "wishlist" instead of "invalid" for eog and evolution?

Changed the entries for the apps to "Wishlist", if the POstScript is not generated by the apps themselves but by a library, please anyone who knows which library, modify the tasks appropriately. Thanks.

Changed in eog:
importance: Low → Wishlist
status: Invalid → Triaged
Changed in evolution:
importance: Low → Wishlist
status: Invalid → Triaged
Sebastien Bacher (seb128) wrote :

Do you have numbers on what they do now and how better you think they should do? How do you know that the example are just not something the printer can't handle and if the applications are not already well optimized?

Changed in eog:
status: Triaged → Incomplete
Changed in evolution:
status: Triaged → Incomplete
vmagnin (vincent-magnin) wrote :

I had exactly the same problem for more than one year (7.10, 7.04, 6.10...) with my HP Laserjet 1200 on parallel port. Each time I was printing more than a simple text, the printer seemed to be saturated... I tried several drivers but none was perfect. And the Postscript driver was "recommended"...

I just reinstalled my printer with the hpijs driver and it seems to work, even with big PDF files.

Thank you for this advice. I will not be forced anymore to print using another PC.

Vincent

The priority order of drivers recommended for the LaserJet 12xx/13xx was already changed in favor of the PCL drivers HPIJS and pxlmono in foomatic-db and foomatic-db-hpijs. Now HP is not using these Foomatic packages any more to generate their PPDs. Instead, they use the PPD generator of the CUPS DDK with their own data file. This does not contain any "recommended" tag and so system-config-printer defaults to the PostScript PPDs.

This means that this bug is now an upstream bug of HPLIP. The developers at HP have to fix it, for example by using "(recommended)" tags in their .drv file and removing the "(recommended)" tags from the appropriate PostScript PPDs. Printers which need these change are the HP LaserJet 12xx and 13xx models and perhaps also multi-function devices based on these printers if they do not have more memory by default.

For the time being and especially for Hardy I have implemented a workaround in system-config-printer. This will be available with the next system-config-printer package.

Problem: hpijs doesn't support 1200 dpi, pxlmono doesn't support the LaserJet 1320...

Question #1: What would be the required amount of memory to get the 1320 do proper PostScript?

Question #2: Is there a way to hack the hpijs or pxlmono based PPD files to do 1200 dpi on the 1320?

Sebastien Bacher (seb128) wrote :

that's not an application issue

Changed in evolution:
status: Incomplete → Invalid
Changed in eog:
status: Incomplete → Invalid

Matthias, the 1320 should also work with pxlmono, this relationship was probably simply forgotten to be added to the database. Please try it out by selecting the 1220 or the "Generic PCL-6/XL printer" as your printer model.

Changed in foomatic-db:
importance: Undecided → Medium
status: New → Incomplete
Changed in foomatic-db:
status: Incomplete → In Progress

Adding the 1320 to the list of pxlmono-supported printers upstream currently.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foomatic-db - 20080814-0ubuntu1

---------------
foomatic-db (20080814-0ubuntu1) intrepid; urgency=low

  * New upstream release
    o Renamed manufacturer name "okidata" to "Oki" to conform with the
      Adobe specifications for PPD files.
    o The HP LaserJet 1320 works with the "pxlmono" driver (LP: #172550).
    o Added printers from Lexmark, Toshiba, Oki, Epson, Sharp, Ricoh and
      OEM.
  * debian/rules: Add "*cupsFilter" line to accept PDF input data to the
    ready-made PPDs which use foomatic-rip.

 -- Till Kamppeter <email address hidden> Thu, 14 Aug 2008 18:24:15 +0200

Changed in foomatic-db:
status: In Progress → Fix Released
Changed in hplip:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments