[Hardy] LCD Brightness Applet doesn't work properly

Bug #191725 reported by Marcelo David on 2008-02-14
46
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Medium
hal (Ubuntu)
Undecided
Martin Pitt

Bug Description

LCD Brightness control using laptop keyboard shortcuts works perfect (Dell Inspiron 1501).
But LCD Brightness applet says "Brightness: 0%" always and if I attempt to scroll the bar to modify the brightness it freezes the whole gnome-panel at Hardy Alpha 4

Related branches

Miguel Ruiz (mruiz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I'm using Hardy Heron up to date and I followed the steps described above. The applet frozen my session and I had to restart the x-server :S

Thanks again and we appreciate your help.

Cheers!

Changed in gnome-power-manager:
status: New → Confirmed
mellery (mellery) wrote :

I see this on Hardy Alpha 5, there is also a transparent box that stays on my screen for a while, it flashes the brightness applet window before going away.

The sysfs battery change broke GetBrightness on dell latitude computers. The issue is there since ubuntu using this change, http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=4541abd23fd02118a1a7f8b825aed338d2a5d638 on 0.5.10, the current git version has the same bug

$ dbus-send --system --print-reply --dest=org.freedesktop.Hal `hal-find-by-capability --capability laptop_panel` org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

when running this command the hald log gets the error

"[20311]: 23:39:42.424 [D] addon-dell-backlight.cpp:231: Received GetBrightness DBUS call
process 20311: arguments to dbus_message_get_args() were incorrect, assertion "(error) == NULL || !dbus_error_is_set ((error))" failed in file dbus-message.c line 1667.
This is normally a bug in some application using the D-Bus library."

Reverting the change

$ dbus-send --system --print-reply --dest=org.freedesktop.Hal `hal-find-by-capability --capability laptop_panel` org.freedesktop.Hal.Device.LaptopPanel.GetBrightness
method return sender=:1.100 -> dest=:1.107 reply_serial=2
   int32 6

and the hald log has

"[20436]: 23:41:43.964 [D] addon-dell-backlight.cpp:231: Received GetBrightness DBUS call
[20436]: 23:41:43.968 [D] addon-dell-backlight.cpp:82: Reading 6 from the AC backlight register"

Thanks to Sjoerd Simons who figured the issue

addon-dell-backlight.cpp filter_function() is using

 AC = libhal_device_get_property_bool (halctx,
          "/org/freedesktop/Hal/devices/acpi_AC",
          "ac_adapter.present",
          &err);

or since the sysfs changes there is no "ac_adapter.present" key there and the same err variable is used when calling dbus_message_get_args later

*** Bug 14792 has been marked as a duplicate of this bug. ***

Martin Pitt (pitti) wrote :

This is actually a bug in the dell brightness backend of hal. The upstream fix works great, I'll applied it in bzr head.

Changed in gnome-power-manager:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Uploaded to my PPA, testing feedback appreciated:

  https://launchpad.net/~pitti/+archive

Changed in hal:
status: In Progress → Fix Committed

Hello Martin,
i've just tested the package of your PPA.

Changing the brightness still doesn't work with this patch. The only thing which change is that guidance-power-manager doesn't hang that long any more as before (when I move the slider for the brightness) and that there are no error messages printed any more (as reported in Bug #198071).

Please advise if there is anything I can test further to debug this problem. Thanks!

PS: Packages I've used:
hal 0.5.10+git20080301-1ubuntu1~p Hardware Abstraction Layer
libhal-storage1 0.5.10+git20080301-1ubuntu1~p Hardware Abstraction Layer - shared library for storage devices
libhal1 0.5.10+git20080301-1ubuntu1~p Hardware Abstraction Layer - shared library

NB: I have a Dell Latitude D620, maybe this bug depends on the model of the computer too.

Changed in hal:
status: Unknown → In Progress
Martin Pitt (pitti) wrote :

Christian, are you using the ~ppa3 packages? The last bit of the version information was cut off unfortunately. Can you please check with

  dpkg -s hal | grep ^Version

Thank you!

Sorry that the version was cut off.
Yes, I am using the ~ppa3 packages:

dpkg -s hal | grep ^Version
Version: 0.5.10+git20080301-1ubuntu1~ppa3

Martin Pitt (pitti) wrote :

Christian,

since the new hal seems to fix it for all Gnome users I spoke to so far, I think it would make sense to open a new bug report for your case, so that we can track it properly. Thank you!

I've already opened a bug for the Dell-related problem of not being able the set the brightness - see Bug #198071.

Could you have a look at it, please?

Changed in hal:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.2 KiB)

This bug was fixed in the package hal - 0.5.10+git20080301-1ubuntu1

---------------
hal (0.5.10+git20080301-1ubuntu1) hardy; urgency=low

  * Merge with Debian to pull in a current snapshot from upstream git head
    (upstream neglects doing a long-overdue 0.5.11 release). This pulls in two
    tons of bug fixes and reduces our insane stack of patches to a
    maintainable level again. (LP: #198295)
    - Uses MMC profile reading for CDs/DVDs. (LP: #66254)
  * Remove the following patches which are upstream now:
    - 01_proc_sys_batteries.patch
    - 02_sysfs_battery_serial.patch
    - 92_gxx43.patch
    - 94_batter-model_name.patch
    - 97_fix_power_info_via_sysfs.patch
  * Drop 80_allow_vfat_usefree.patch; Using 'usefree' VFAT mount option is not
    necessary with the current Hardy kernel any more.
  * Drop debian/patches/82_ignore_fixed_nonmedia.patch: Obsolete, GVFS treats
    fixed partitions correctly.
  * Tag and forward the subset of our remaining patches which have some kind
    of documentation and justification. Rename them to clean up patch order
    prefixes a bit.
  * 96_uinput_device_support.patch: Adapt to new upstream version.
  * Remaining Ubuntu changes:
   - debian/hal.init: Remove stray gparted-disable-automount.fdi on startup.
     Needs to be kept until Gnome #324220 is fixed properly.
     (LP #134712)
   - debian/hal.init: Unconditionally chown the directory in the init script.
     (LP #175525)
   - Ubuntu udev world order:
     + debian/hal.links: Remove rules symlink, we install the rules file
       directly into rules/.
     + debian/rules: Install udev rules into /etc/udev/rules.d/.
     + debian/hal.{preinst,postinst,postrm}: Transition code for changing the
       udev rule priority (see 0.5.8.1-3ubuntu7, needs to be kept until after
       Hardy's release).
   - debian/hal.preinst, debian/libhal1.preinst: Clean up doc directory
     symlinking when upgrading from Gutsy. Needs to be kept until after
     Hardy's release.
   - debian/rules: Enable MacBook (Pro) support on i386 and amd64. Add
     pciutils-dev build dependency.
   - debian/rules: Do not run stop init.d script for levels 1 and 6
     (TearDown).
   - debian/preferences.fdi: Disable automounting for fixed disks. On session
     startup it is not done anyway (since that disables the gnome-mount UI
     which would ask for authentication) and it leads to confusion when
     restarting hal while a session is running. (LP #138537)
   - Various bug fixes, see their patch headers:
     + 02_allow_ufs_ufstype.patch
     + 03_virtual_net_devices.patch
     + 04_read_brightness_not_actual_brightness.patch
     + 96_uinput_device_support.patch
     + ubuntu_01_ignore_single_slash_label.patch
   - 83_ssb_bus_support.patch: Add support for devices on the SSB bus; patch
     by Matthew Garrett (not applied upstream yet, this needs to update the
     spec, too).
   - 84_memstick_bus_support.patch: Add support for devices on the "memstick"
     bus; patch by Matthew Garrett (not reported upstream yet, this needs to
     update the spec, too).
   - 88_change_pm_quirk_policy.patch: Patch by Matthew Garret, undocumented,
     non-obvious purpose.
   - Use Polic...

Read more...

Changed in hal:
status: Fix Committed → Fix Released

I just wanted to let so. know that the applet isn't working on Acer TM 8100 series as well.

When you hover you get: "Cannot get laptop panel brightness"

Should I open a seperate bug? (I always use the Fn keys anyways, but maybe so else wants it to work)

der_vegi (m-may) wrote :

Same problem here as well on a Inspiron 1501, amd64 with all updates applied. Maybe we should reopen the bug?

Stiff (stiff.ru) wrote :

Was the fix released or not?
i have this problem on kubuntu hardy 32bit with dell inspiron 1501 laptop. When i press brightness buttons, the indicator of guidance-powermanager shows, but the brightness not changes.

Martin Pitt (pitti) wrote :

Stiff, der_vegi, please have a look at bug 198071, which describes a similar problem for Dell laptops.

There's a work around at
http://www.ubuntu1501.com

regards,

El Mie, 11 de Junio de 2008, 8:59 am, Stiff escribió:
> Was the fix released or not?
> i have this problem on kubuntu hardy 32bit with dell inspiron 1501 laptop.
> When i press brightness buttons, the indicator of guidance-powermanager
> shows, but the brightness not changes.
>
> --
> [Hardy] LCD Brightness Applet doesn't work properly
> https://bugs.launchpad.net/bugs/191725
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Unidad de Instrumentación Nuclear
Centro de Investigaciones Nucleares
Facultad de Ciencias - UdelaR

Changed in hal:
importance: Unknown → Medium
Changed in hal:
importance: Medium → Unknown
Changed in hal:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.