Kindle 2 HAL support

Bug #407875 reported by cyli on 2009-08-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Medium
hal-info (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal-info

When I connect my Kindle 2 via USB, HAL recognizes it as a USB mass storage device. It does not recognize it as an ejectable volume, however.

Kindle support (as a media player) was added to HAL in https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/230523, but that was only for the Kindle 1. The Kindle 2 has a different product ID, and thus is not recognized by HAL as a media player.

It seems a bit strange to me to classify the Kindle as a portable audio player - it certainly can play media, but so can PDAs (and the Kindle seems more like a PDA to me). Perhaps, given all the new ebook reader devices already out there and soon to be released, a new category may be needed. But as I am pretty unfamiliar with HAL, I cannot adequately evaluate the ramifications of these classifications. :) And since the Kindle 1 is supported by HAL as a media player, so I have added Kindle 2 support as a media player.

Rather than mess with any of the Kindle 1 stuff, I added a different match for the Kindle 2. The Kindle 2 needs to be ejected and not just unmounted (umounting it does nothing about the message on the Kindle that it needs to be ejected from the computer before being used - the Kindle remains in USB drive mode), and I am not sure if that is the case with the Kindle 1.

cyli (cyli) wrote :
cyli (cyli) wrote :
cyli (cyli) wrote :

Hmm... ok, this patch is probably not very useful. :( With this 10-usb-music-players.fdi change, I can eject the Kindle just fine, and the Kindle leaves USB drive mode, but I then get the following error on my screen (not on the Kindle):

Cannot eject volume
There was an error ejecting the volume or drive.

org.freedesktop.Hal.Device.UnknownError: An unknown error occured.

There doesn't SEEM to be a problem besides this error dialog, but I'm not sure how to interpret the hal.log.

I'm including the output from lshal, from running hald in debugging/verbose mode, and a snippet of my kern.log.

After I rebooted, I stopped hald, and then hald in non-daemon debug mode. Then I plugged in my Kindle 2, got the output from lshal, and ejected (via gnome-applets' disk-mounter applet) the Kindle. Then I stopped the debug-mode hald. The kern.log snippet is from about when I rebooted.

cyli (cyli) wrote :
cyli (cyli) wrote :
dylan taft (d13f00l) wrote :

Hi,
This needs a quirk in unusual_devs.h to force max sectors to 64
https://lists.one-eyed-alien.net/pipermail/usb-storage/2009-August/004789.html
It does work with that option, otherwise it will corrupt data or work erratically.

I never got around to submitting a patch upstream...but it was working fine.

I had it working in udev 145 on gentoo, but I'm on ubuntu now..
I am not sure if the device is being correctly detected with udev 147/the kerne in ubuntu server 9.10. It may be being detected with the wrong protocol, again.

I need to install kernel sources and mess with it...unless someone who is better with udev and kernel hacking wants to step in... :sigh:

Created an attachment (id=38260)
patch by cyli

From https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/407875

"""
When I connect my Kindle 2 via USB, HAL recognizes it as a USB mass storage device. It does not recognize it as an ejectable volume, however.

Kindle support (as a media player) was added to HAL in https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/230523, but that was only for the Kindle 1. The Kindle 2 has a different product ID, and thus is not recognized by HAL as a media player.

It seems a bit strange to me to classify the Kindle as a portable audio player - it certainly can play media, but so can PDAs (and the Kindle seems more like a PDA to me). Perhaps, given all the new ebook reader devices already out there and soon to be released, a new category may be needed. But as I am pretty unfamiliar with HAL, I cannot adequately evaluate the ramifications of these classifications. :) And since the Kindle 1 is supported by HAL as a media player, so I have added Kindle 2 support as a media player.

Rather than mess with any of the Kindle 1 stuff, I added a different match for the Kindle 2. The Kindle 2 needs to be ejected and not just unmounted (umounting it does nothing about the message on the Kindle that it needs to be ejected from the computer before being used - the Kindle remains in USB drive mode), and I am not sure if that is the case with the Kindle 1.
"""

Media player identification is handled in media-player-info these days which already has the kindle 2 http://cgit.freedesktop.org/media-player-info/commit/?id=0703bb7eb25e5590b828efe3f41b7f3259ad1ea6
The portable media player VS ebook reader is discussed in https://bugzilla.gnome.org/show_bug.cgi?id=627516 though at some point, a bug against media-player-info on this bug tracker might be needed.

tags: added: patch-forwarded-upstream

http://cgit.freedesktop.org/~dkukawka/hal-info/commit/?id=943e6a314caac4c8e8a0ccfc21c9de7060a19baa , gets merged later upstream.

commit 943e6a314caac4c8e8a0ccfc21c9de7060a19baa
Author: cyli <email address hidden>
Date: Thu Sep 9 14:04:48 2010 +0200

    add Kindle 2 as usb music player

    Added Kindle 2 as usb music player.
    lp#407875

Changed in hal:
importance: Unknown → Medium
status: Unknown → Fix Released
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Changed in hal:
importance: Medium → Unknown
Changed in hal:
importance: Unknown → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hal-info (Ubuntu):
status: New → Confirmed
lively (doratheexplorer) wrote :

I have a Kindle Fire which is not recognised in new distro at all. USB connection is good for charging only. The Fire was connecting to my laptop without issues in 11.04 & 11.10. My regular Kindle is connecting as expected and is now automatically opening media software which id did not before. This is a good improvement.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.