gwibber-service crashed with signal 5 in g_object_newv()

Bug #912628 reported by JG on 2012-01-06
284
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
High
Unassigned

Bug Description

This happened at boot after removing Gwibber.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber-service 3.3.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Jan 5 19:58:03 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 5
SourcePackage: gwibber
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gwibber-service crashed with signal 5 in g_object_newv()
UpgradeStatus: Upgraded to precise on 2012-01-03 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

JG (jdogzz-g5) wrote :

StacktraceTop:
 g_settings_set_property (object=<optimized out>, prop_id=<optimized out>, value=<optimized out>, pspec=<optimized out>) at /build/buildd/glib2.0-2.31.6/./gio/gsettings.c:471
 object_set_property (nqueue=0x3525e30, value=0x30b94f8, pspec=0x2ee6180, object=0x3604ed0) at /build/buildd/glib2.0-2.31.6/./gobject/gobject.c:1331
 g_object_constructor (type=<optimized out>, n_construct_properties=<optimized out>, construct_params=0x342e5f0) at /build/buildd/glib2.0-2.31.6/./gobject/gobject.c:1779
 g_object_newv (object_type=<optimized out>, n_parameters=51048368, parameters=<optimized out>) at /build/buildd/glib2.0-2.31.6/./gobject/gobject.c:1629
 g_object_new_valist (object_type=42046400, first_property_name=<optimized out>, var_args=0x7fffde42b5d8) at /build/buildd/glib2.0-2.31.6/./gobject/gobject.c:1746

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) on 2012-02-10
Changed in gwibber:
importance: Undecided → High
Bilal Shahid (s9iper1) wrote :

ession has been invalidated because the user has changed the password.
2011-12-31 08:20:39,078 - Gwibber Dispatcher - INFO - Loading complete: 181 - []
2011-12-31 17:03:18,914 - Gwibber Dispatcher - INFO - Network state changed to Online
2011-12-31 17:03:18,916 - Gwibber Dispatcher - INFO - Dispatcher Online, initiating a refresh
2011-12-31 17:03:19,037 - Gwibber Dispatcher - INFO - Network state changed to Offline
2011-12-31 17:03:19,038 - Gwibber Dispatcher - INFO - Dispatcher Offline, suspending operations
2011-12-31 17:03:27,116 - Gwibber Dispatcher - INFO - Network state changed to Online
2011-12-31 17:03:27,118 - Gwibber Dispatcher - INFO - Dispatcher Online, initiating a refresh
2011-12-31 17:03:37,958 - Gwibber Dispatcher - INFO - Facebook error OAuthException - Error validating access token: The session has been invalidated because the user has changed the password.
saying that you have changed the password can you check this again with the correct password ?

Changed in gwibber:
status: New → Incomplete
Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete
tags: added: bugpattern-needed
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Medium → High
visibility: private → public
Changed in gwibber:
status: Incomplete → Invalid
Changed in gwibber (Ubuntu):
status: Incomplete → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.0-0ubuntu3

---------------
gwibber (3.4.0-0ubuntu3) precise; urgency=low

  * Move the gsettings schemas from gwibber to gwibber-service (LP: #912628)
 -- Ken VanDine <email address hidden> Tue, 10 Apr 2012 10:57:05 -0400

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Bilal Shahid (s9iper1) on 2012-04-10
Changed in gwibber:
status: Invalid → Fix Released
Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.