Menu is displaying in wrong locale

Bug #217546 reported by Stephen Zurcher on 2008-04-15
26
Affects Status Importance Assigned to Milestone
Gweled
Low
Unassigned
gweled (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gweled

The Gweled menu items are appearing in another language (French?) than my locale (English). Rather than File, Edit, Help, I'm seeing Fichier, Édition, Aide. All dialogs appear with English text, only the menus themselves are mis-matched. This is the only program I have installed with this behavior to date.

Ubuntu release: 8.04
Package version: 0.7-2ubuntu5

Related branches

Guybrush88 (guybrush) wrote :

i can confirm that. i have all the menu names in french, in the "Fichier" menu i have the options called "Nouveau jeu" (french), "Score" (english) and "Esci" (italian). italian is my locale. the elements in the other menus are named in italian and when i open them they are in english

Changed in gweled:
status: New → Confirmed
techieMoe (techiemoe) wrote :

I can also confirm precisely the same problem. File, Edit, Help, etc show up as Fichier, Edition, Aide. Menu options under the Fichier (File) menu are also in the wrong language. I get "Nouveau jeu" rather than "New Game". English is my locale.

I just updated everything on Hardy this morning and installed Gweled not half an hour ago. (2:04pm CST)

Coathanger (ron-ridley) wrote :

It looks as if the ubuntu patches applied to the source gweled_0.7-2ubuntu5.diff.gz have the French phrases mixed in with the english. I guess the translatable=yes in the .glade file only works when all of the phrases to be translated are in the same language??

Would the attachment (with the fixed phrases) work out?

Coathanger (ron-ridley) wrote :

Attached is the patch per the MOTU contributing guidelines. Previously I had the whole patched ubuntu diff file.

I checked the hardy translation files to make sure they matched the changes in the patch.

That patch doesn't apply - but i've taken the work you've done, and applied it manually.

Thanks! I can't believe it's taken me this long to notice that it's been in french.

Changed in gweled:
status: Confirmed → Fix Released
Anders (andersja+launchpad-net) wrote :

Perhaps related to this bug - if I open Gweled on an all French system (on a fully patched Karmic) I'm getting all the menus in English...

Guybrush88 (guybrush) wrote :

same here with an italian system on an up-to-date karmic

Coathanger (ron-ridley) wrote :

It looks like what I originally posed was the way to manually hard-code the language fields in the .glade file. Attached is an updated diff file to be used if you want to build from source. This uses the glade "stock_items", which seem to have been removed as part of the patch when submitted earlier (for music option support).

#mkdir tmp
#cd tmp
#apt-get source gweled

Copy over the replacement diff.gz file on top of the distributed one and run the following commands:

#cd gweled-0.7
#sudo dpkg-buildpackage -uc -b
#sudo dpkg -i ../gweled_0.7-2ubuntu6_i386.deb

Test it and see if this finally fixes it.

*Disclaimer* - I don't usually do any gnome / gtk / glade development. I just wanted to fix this for my parents.

Coathanger (ron-ridley) on 2009-11-04
Changed in gweled (Ubuntu):
status: Fix Released → Confirmed
Daniele Napolitano (dnax88) wrote :

I've made gettext support for Gweled. But I will contact the upstream developer for release a new version.

Changed in gweled:
importance: Undecided → Low
status: New → Fix Committed
Changed in gweled:
milestone: none → 0.8
Changed in gweled:
status: Fix Committed → Fix Released
Changed in gweled (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Daniele Napolitano (dnax88) wrote :

Fixed in Ubuntu 10.10 Maverick.

Changed in gweled (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers