gvfsd-afp consumes 100% of processor cycles

Bug #951585 reported by alan@rait.org on 2012-03-10
420
This bug affects 94 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Undecided
Unassigned

Bug Description

Happens on an irregular basis on 12.04 and I think I've experienced it on 11.10.

For no reason gvfsd-afp starts up. Cooling fan kicks in, system becomes laggy. Easily cured using system monitor and killing the process. Someone on the Ubuntu Forum asked if I have a Mac on the network and the answer is yes, an iMac and there are shares on that machine I can access.

Have experienced this issue on my Acer Aspire 5742 and Compaq Mini 110

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Steve Jackson (aearenda) wrote :

I see this happening occasionally, some time after browsing an AFP share on a Mac using Nautilus on Ubuntu. I don't know what specifically triggers it to start. I have also experienced it on 11.10.

Steve Jackson (aearenda) wrote :

It just happened again. I had left the machine otherwise idle with an AFP share connected in Nautilus, showing on the screen. Attaching a process list - PID 13309 is the culprit - not sure what else is necessary. Syslog has nothing relevant, .xsessionerrors likewise.

Steve Jackson (aearenda) wrote :

Just noticed the OP names gvfsd-afp as the problem process - for me it turns out to be gvfsd-afp-browse. Maybe it's a different bug.

I was doing nothing more than browsing the web with firefox and it happened. I'm running gnome-shell on Ubuntu 11.10 and the only two apps I had open were gedit and firefox. I heard my proc fan spin up so I checked my process list and found gvfsd-afp using up 100% of one core.

Diogo Coelho (diogocoelho-ei) wrote :

Same symptoms here!

Raymond Brun (raymond-brun) wrote :

Same symptoms here!

Maddmaxx (maddmaxx666) wrote :

Same symptoms here! 12.04 64 bit

Ferran Basora (fcsonline) wrote :

Here, it is after browsing an AFP share on a Mac using Nautilus on Ubuntu.

Same symptoms here and I have no Mac. But I have a NAS (Synology) and yes, I'm accessing some shares on it.
One more word on accessing those shares. From a cold boot, I can access them from Nautilus simply by browsing my network (simple network at home), but after same times, after closing Nautilus or closing the laptop, when the laptop is back online I can't access those shares anymore even if they were still listed on the Nautilus network part... I still can access them typing something like smb://diskstation/homes for example. That happened this morning on now I'm seeing this process at 100%...

I'm on 12.04 64 bits (fully updated).

grisunase (grisunase) wrote :

My MacBook runs on 12.04, there are other Macs in the net. Fan speeds up, gvfs takes 100 % CPU power. Before I accessed data on an other Mac (running on Apple).

Same issue here. Several OS X machines on the network.

Didn't have to kill the process to fix the load issue. Simply ejecting the drive I was browsing helped.

However, should be able to keep the shared directory open without suffering load issues.

Steve Jackson (aearenda) wrote :

Problem continues on Quantal.

Daniel Ebbutt (blacksyke) wrote :

On 12.10 x64 here, the two AFP shares that were connected timed out while trying to eject to alleviate this problem - I had two gvfsd-afp processes loading two physical processors. Fixed by manually killing the processes, whereupon the two AFP shares disappeared from nautilus.

Albertononi (albertononi) wrote :

Same symptoms (Ubuntu 12.04) just after connecting to an iMac in a local network.

Mårten Behm (marten-behm) wrote :

I have the same problem on Lubuntu 12.10 (and earlier on 12.04 as well) 64 bit, connecting to a share on a Mac. Takes up one of two processors.

Matt Hansen (confuted) wrote :

Same symptoms here on a pretty fresh install of Ubuntu 12.10, connecting to a Synology DSM NAS. Behaved itself at first and I could browse my share - at some point overnight, two gvfsd-afp processes went to 100%.

Michael Baudino (gornack) wrote :

I can confirm I have the exact same bug with Lubuntu 12.10 x64 using PCManFM do connect a dynamically mounted afp share on a MacOSX in my LAN.

Exactly like @marten-behm, it seems.

Douglas Rees (vialick) wrote :

Running 12.10 in a house with several macs, was connected to mac mini through wifi router and noticed that performance dropped considerably after being connected for a while (also kept having to reconnect to the folders, and then kept timing out rather than letting me unmount one of the shares). Top showed 100% processor for it and I had to manually kill it

description: updated
joncamfield (jon-camfield) wrote :

I am also connecting to a Synology NAS and experiencing this after connecting to it via AFP. Even after unmounting/disconnecting, the CPU usage will remain at or climb up to 100%

12.04, 64bit

Hans Lemkes (hanslemkes) wrote :

I have also the same issue here! i am connecting to my Synology NAS and later i got 3 process with all 3 reaching out for maximal CPU!
2 times 'gvfsd-afp'
1 time 'gvfsd-browse'

There are no macs on this network.

i am running a ubuntu version 12.10, 64 bit

TinusXcentricus (t-no) wrote :

Same here on a Vaio i5 laptop running 12.04. Connecting to AFP share on Lion iMac through home network.
Transfer speeds are extremely low (700 kB/sec) and one of the processors is continuously running on 100%.

Andrew Moore (radmoore) wrote :

Same issue on Ubuntu 12.04; appears to be connected to mounting share on NAS (Synology).

guncharly (guncharly) wrote :

Same problem on 12.10 64 bits. When connecting in afp to Synology NAS, gvfsd-afp-browse process consume almost 100% of CPU, even after closing nautilus.

Calin Cerghedean (ccerghe1) wrote :

Also happening for me, on 12.10 64-bit XUbuntu, just after playing media from a NAS device. Exactly the same behavior: gvfsd-afp process consuming 100% of 1 CPU (luckily this is a multi-core processor, so I have 3 more idle CPUs.)

Rahmanc (rahmanc) wrote :

Also happens for me under a fresh install of Ubuntu 12.10 x64 (Quetzal) connecting to my MacBook running OS 10.7 (Lion). Even after all file transfer or browsing activity has stopped, both processors are pegged at 100% until I unmount the share. The last time it happened, I couldn't get the share to unmount and had to force-quit gvfs.

Rob Silva (resilvajr) wrote :

I noticed this as well on a fresh install of Mint. It was happening while I had a virtual Win7 directory mounted; once I unmounted that directory, gvfsd-afp stopped consuming 100%.

Baldwindc (baldwindc) wrote :

The issue occurs when you have a remote file system mounted. It does not matter if you are actively accessing the file system.

I am running Ubuntu 12.10. I was connecting to a mac share via ssh. Nautilus had mounted the drive for my current session.

^My two cents

Adili (wanyo) wrote :

I can confirm this on Mint and the only way to unmount the share is to kill the rogue gvfs process.

Adili (wanyo) wrote :

Just to clarify it's the gvfsd-afp process that needs terminating

Phil Colbourn (philcolbourn) wrote :

I have a Macbook on local network, but that does not cause issue by just being there.

Ubuntu 12.10 with 3.75 kernel from ppa - but it has been faulty on many kernels that I have used.

3.7.5-030705-generic #201301280206 SMP Mon Jan 28 07:07:29 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

For me (and what I know) it happens when I mount an AFP share from a Drobo-FS. Then it get gvfsd-afp-browse munching through 100%.

Only after I mount an AFP device.

Grant Kruger (grantkruger) wrote :

Just another addition to the chorus. Accessing OS X file servers seemed to cause the issue. CPU maxes out with a gvfsd-afp process for every folder I connected to via a bookmark. Simply ejecting all of these resulted in all gvfsd-afp processed terminating and the laptop returning to normal. However that is really not helpful as I might be editing a document on that server for some time, or browsing a folder or what have you.

m (91xmusic) wrote :

Running 13.04 released today (4/2/2013). gvfsd-afp is 100% of a single cpu. I am not a mac, but connected to one earlier via samba. I had the same issue on 12.10, but thought that switching to 13.04 might help. Nope.

I think the 100% cpu began after my connection expired and nautilus is working extra hard to reconnect?

luciano (budinomollo) wrote :

I've tried to install Mac OS X with Virtualbox and now i've exatly the same problem. More, i've tried more intallation and i've two task gvfsd-afp running 100% in two cores.

Note: i've ubuntu 12.04 lts, 64 bit with gnome shell

Same thing here on 13.04, gvfs-afp hogs the CPU and I have to pkill it every now and then.

kg4gon (kg4gon-gmail) wrote :

Happens to me with 13.04; I have to end my connection to my iMac, which is annoying if I have to access files.

same thing with mint 15 on kernel 3.10

tags: added: 15 mint
Wybe Minnebo (wybe-k) wrote :

I'm confirming this on 64 bits ubuntu 13.04 kernel 3.8.0-27-generic. It has not been on the same network as a mac may have accessed a synology nas through AFP, and tried to install virtualbox earlier this week. 3 out of 8 cpu cores alternate between 100% and normal usage.

Ilya Flyamer (flyamer) wrote :

Same here, no mac, but I have a Synology NAS. 13.10, kernel 3.8.0-31, i386

Benjamin Bach (benjaoming) wrote :

Just adding a curious note, that I'm experiencing the same as Ilya Flyamer connecting to a Synology NAS' SMB share. But actually, I'm even on a network now where the Synology is not available.

The_ERROR (spam-trash-2) wrote :

Seems to have something to do with disk full. At least, I had the problem with disk space.....

http://ubuntuforums.org/showthread.php?t=1421580

solution recommended on forum:

rm -rf ~/.local/share/gvfs-metadata
pkill gvfsd-metadata

Lionel Gaillard (wxrstudios) wrote :

I can avoid this problem by immediatly unmounting the AFP folder from Nautilus, right after I did what I wanted.
Since I regulary forget to do it, I added a launcher in my launchbar to kill this processus. I use it almost every day...

Adili (wanyo) wrote :

This bug is really annoying for anyone that connects to mac clients. One way around is to create smb shortcuts for each network connection as they are supported by mac clients too.

marcell (ki-ber) wrote :

same here.

Debian GNU/Linux 7 (wheezy)
i have NAS in LAN and after connecting to it it consumes 2 out of 4 cores up to 100%.
linux kernel: 3.2.0-4-amd64
gvfs: 1.12.3-4

Styno (styno) wrote :

For me too gvfsd-afp consumes 100% CPU after accessing a Synology NAS, but only after suspending the laptop (non-Mac) for the night and trying again the next day. Trying to access the share again using Nautilus gives a popup saying (translated) "Oops, something went wrong. Unhandled error: error while sending data: broken pipe". Only killing gvfsd-afp helps. I'm using Ubuntu 13.10.

Uri (urisharf) wrote :

Same here. Too bad it's impossible to use it after realising it was so easy to get it to work and access remote hosts from Nautilus...

Y. Leretaille (yleretaille) wrote :

Just happened here too. Ubuntu 13.10 on a Macbook Retina accessing a Synology NAS.
Nautilus hung up while browsing a folder on the NAS. After killing and restarting nautilus, gvsd-afp-browse stayed at 100% cpu. Ejecting the drive did not help. It was not possible anymore to access the NAS, when trying to mount it in the network view I got "Cannot acces [nas_name]: Error sending data: broken pipe". After killing gvsd-afp-browse, I was able to access the NAS again (I had to reenter the credentials).

Joe Racette (joeracette) wrote :

Ubuntu 13.10 accessing a Synology NAS. Like many others, accessing afp: file share worked fine. Next day after returning from sleep, the cooling fan is running and 2 gvsd processes are using 100% of one core. Try to access the share again returns "... Error sending data: broken pipe ..." error.

Mike H (mike-hill) wrote :

I ahve the same problem with Ubuntu 14.04. 100% CPU activity, and unable to unmount because of the broken pipe error.

noamik (spam-noamik) wrote :

This bug is still present in (X)Ubuntu 14.04. Happens to me when accessing my synology nas using Thunar. Doesn't seem to happen when accessing my samba 3 fileserver on a x86 server though.

Andrea Denzler (andreaplanet) wrote :

Same symptoms, Ubuntu 14.04 x64, after connecting to a Mac Mini in a local network.
100% CPU for gvfsd-afp. After trying to unmount it I got the error
"Ops Something went wrong. Unandled Error Message: Error Sending Data: Broken Pipe"
"Unable to unmount Torrent for Andrea Denzler on MiniLight. Timeout was reached".
I had to kill the process

mpouret (mpouret) wrote :

Same problem on ubuntu 14.04 64b connect to Synologie NAS = 100% CPU activity because of gvfs-afp and gvfs-browse. Some time I've diffulcty to unmount and have the message "unable to unmount because of the broken pipe error". I've to kill or reboot...

Same issu:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=680389
https://bugzilla.redhat.com/show_bug.cgi?id=1001320
https://bugzilla.gnome.org/show_bug.cgi?id=710490

William (wstass) wrote :

I run Ubuntu 14.04 on an X202E combined with CloudBox NAS after just having unmounted the NAS, gvsd-afpg-browse loads one CPU 100%. After killing the process the CPU runs down to idle load and fans slow down.

Tim (timstander) wrote :

i'm running 14.04 and it consumes 100% of the processors everytime i access a mac on the network. is there a solution?

Steve (svenoaks) wrote :

Turning off "Connect with AFP" on my iMac makes this bug go away for me. I can't seem to actually connect with SMB, though. I connect with SFTP (Remote Login) and it works fine, with no 100% CPU usage.

Nicolas Diogo (nicolasdiogo) wrote :

same problem here ...

it works fine .. until i logout from the network.
it hangs and consumes my CPU.

THE STRANGE THING..

this is a BUG on an important package from an end-user perspective, but unfortunately nobody is assigned to it.

kapare (kevyn-alexandre-pare) wrote :

Same here!

Here what the dev [1] suggest to do: "update to 1.20.3"

I'm at 1.20.1

dpkg -s gvfs-backends
Package: gvfs-backends
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1536
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Multi-Arch: foreign
Source: gvfs
Version: 1.20.1-1ubuntu1
Replaces: gvfs-common (<< 1.13)
Depends: libarchive13, libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libavahi-glib1 (>= 0.6.16), libbluetooth3 (>= 4.91), libc6 (>= 2.14), libcdio-cdda1 (>= 0.83), libcdio-paranoia1 (>= 0.83), libcdio13 (>= 0.83), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libexpat1 (>= 2.0.1), libgcrypt11 (>= 1.5.1), libglib2.0-0 (>= 2.37.3), libgphoto2-6 (>= 2.5.2), libgphoto2-port10 (>= 2.5.2), libgtk-3-0 (>= 3.0.0), libgudev-1.0-0 (>= 146), libimobiledevice4 (>= 1.1.5), libmtp9 (>= 1.1.6), libplist1 (>= 0.16), libsmbclient (>= 2:4.0.3+dfsg1), libsoup2.4-1 (>= 2.42.0), libxml2 (>= 2.7.4), dconf-gsettings-backend | gsettings-backend, gvfs (= 1.20.1-1ubuntu1), gvfs-daemons (= 1.20.1-1ubuntu1), gvfs-libs (= 1.20.1-1ubuntu1), gvfs-common (= 1.20.1-1ubuntu1), psmisc
Recommends: gnome-keyring
Suggests: obex-data-server, samba-common
Breaks: gvfs-common (<< 1.13)
Description: userspace virtual filesystem - backends
 gvfs is a userspace virtual filesystem where mounts run as separate
 processes which you talk to via D-Bus. It also contains a gio module
 that seamlessly adds gvfs support to all applications using the gio
 API. It also supports exposing the gvfs mounts to non-gio applications
 using fuse.
 .
 This package contains the afc, afp, archive, cdda, dav, dnssd, ftp,
 gphoto2, http, mtp, network, obexftp, sftp, smb and smb-browse backends.

[1]
https://bugzilla.gnome.org/show_bug.cgi?id=710490#c17

Bryce Nesbitt (bryce2) wrote :

Here's output of "sudo strace -p XXXXXX" where XXXXX is the process ID of the misbehaving gvfsd-afp:

recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)
recvfrom(7, "", 16, 0, NULL, NULL) = 0
poll([{fd=3, events=POLLIN}], 1, 0) = 0 (Timeout)

And "sudo gdb -p XXXX" followed by "bt"

(gdb) bt
#0 0x00007f766cb897eb in __libc_recv (fd=7, buf=0x23d86a0, n=16, flags=-1)
    at ../sysdeps/unix/sysv/linux/x86_64/recv.c:33
#1 0x00007f766d5e3bec in g_socket_receive_with_blocking ()
   from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#2 0x00007f766d5cb625 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#3 0x00007f766d5cd02b in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4 0x00007f766d5cc28b in g_input_stream_read_async () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5 0x000000000040c0c1 in ?? ()
#6 0x00007f766d5ccd5a in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#7 0x00007f766d5f08db in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#8 0x00007f766d5f08f9 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#9 0x00007f766d05fce5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f766d060048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f766d06030a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x000000000040b7c1 in ?? ()
#13 0x0000000000406b97 in ?? ()
#14 0x00007f766c7d6ec5 in __libc_start_main (main=0x406b40, argc=4, argv=0x7fff04eca8e8,
    init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff04eca8d8)
    at libc-start.c:287
#15 0x0000000000406bc9 in ?? ()

Bryce Nesbitt (bryce2) wrote :

(The prior backtrace is under Ubuntu 14.04LTS fully patched) gvfs Version: 1.20.1-1ubuntu1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.