Please Sync guile-1.6 1.6.8-6.4 (universe) from Debian testing (main)

Bug #485663 reported by Charlie_Smotherman on 2009-11-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
guile-1.6 (Ubuntu)
Wishlist
Unassigned

Bug Description

Please Synce guile-1.6 1.6.8-6.4 (universe) from Debian testing (main)

Support for lpia will be dropped in lucid so this change is no longer needed
:
 - debian/rules: add lpia to WORKING_QTHREADS_ARCHS.

Changelog entries since current lucid version 1.6.8-6.3ubuntu1:

guile-1.6 (1.6.8-6.4) unstable; urgency=low

  * Non-maintainer upload.
  * Fix FTBFS on kfreebsd-i386 by adding that architecture to the
    WORKING_QTHREADS_ARCHS variable in debian/rules, thanks to Petr
    Salinger (Closes: #533269).

 -- Cyril Brulebois <email address hidden> Mon, 29 Jun 2009 15:43:43 +0200

Changed in guile-1.6 (Ubuntu):
importance: Undecided → Wishlist
Fabrice Coutadeur (fabricesp) wrote :

Hi,

As lpia support will be dropped in Lucid, IIRC, it's not worth merging this package.
So let's just sync it.

Could you please convert this merge request into a sync request?

Thanks,
Fabrice

Changed in guile-1.6 (Ubuntu):
status: New → Incomplete
Changed in guile-1.6 (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
summary: - Please Merge guile-1.6 1.6.8-6.4 (universe) from Debian testing (main)
+ Please Sync guile-1.6 1.6.8-6.4 (universe) from Debian testing (main)
description: updated
Changed in guile-1.6 (Ubuntu):
status: In Progress → New
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
Charlie_Smotherman (cjsmo) wrote :

Fabrice

aahh! I was not aware of that, thanks for the hint :) Removed the attachments and converted to a sync request.

Best regards
Charlie Smotherman
(porthose)

Changed in guile-1.6 (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: New → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Hi,

It seems there is something wrong with this package as I'm not able to build it, as it hangs at the end of the building process:
...
dpkg-deb: building package `guile-1.6' in `../guile-1.6_1.6.8-6.4_i386.deb'.
dpkg-deb: building package `guile-1.6-dev' in `../guile-1.6-dev_1.6.8-6.4_i386.deb'.
dpkg-deb: building package `guile-1.6-libs' in `../guile-1.6-libs_1.6.8-6.4_i386.deb'.
dpkg-deb: building package `libqthreads-12' in `../libqthreads-12_1.6.8-6.4_i386.deb'.
dpkg-deb: building package `libguile-ltdl-1' in `../libguile-ltdl-1_1.6.8-6.4_i386.deb'.
make[1]: Leaving directory `/build/fabrice-guile-1.6_1.6.8-6.4-i386-rkDRtj/guile-1.6-1.6.8'
 dpkg-genchanges -b -mFabrice Coutadeur <email address hidden> >../guile-1.6_1.6.8-6.4_i386.changes
dpkg-genchanges: binary-only upload - not including any source code
dpkg-buildpackage: binary only upload (no source included)
^Csbuild received SIGINT -- shutting down

Could you check what's happening?

Thanks,
Fabrice

Changed in guile-1.6 (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Incomplete
Charlie_Smotherman (cjsmo) wrote :

umm not sure what the problem is. It builds fine for me, I am on karmic and I use pbuilder, on my wifes amd64 laptop. Please see build log.

Charlie_Smotherman (cjsmo) wrote :

oops wrong build log, but it still builds fine for me :)?field.comment=oops wrong build log, but it still builds fine for me :)

Changed in guile-1.6 (Ubuntu):
status: Incomplete → New
Charlie_Smotherman (cjsmo) wrote :

I updated my lucid pbuilder and tested the package again. Attaching a new buildlog

Fabrice Coutadeur (fabricesp) wrote :

testing again

Changed in guile-1.6 (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: New → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Sync request ack'd

Changed in guile-1.6 (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Triaged
Jamie Strandboge (jdstrand) wrote :

[Updating] guile-1.6 (1.6.8-6.3ubuntu1 [Ubuntu] < 1.6.8-6.4 [Debian])
 * Trying to add guile-1.6...
  - <guile-1.6_1.6.8-6.4.dsc: downloading from http://ftp.debian.org/debian/>
  - <guile-1.6_1.6.8-6.4.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <guile-1.6_1.6.8.orig.tar.gz: already in distro - downloading from librarian>
I: guile-1.6 [universe] -> guile-1.6_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> guile-1.6-dev_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> guile-1.6-doc_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> guile-1.6-libs_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> libqthreads-12_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> libguile-ltdl-1_1.6.8-6.3ubuntu1 [universe].
I: guile-1.6 [universe] -> guile-1.6-slib_1.6.8-6.3ubuntu1 [universe].

Changed in guile-1.6 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers