Ubuntu

totem shortens some strings and output errors

Reported by Baptiste Mille-Mathias on 2007-08-04
16
Affects Status Importance Assigned to Milestone
Totem
Fix Released
High
gtk+2.0 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: totem

There are truncated string in the UI of totem 's preferences.
If I start totem from terminal, I saw following errors:

(totem:9432): Gtk-WARNING **: Invalid input string

and when opening preferences, I have

Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

Complete backtrace is

no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1229015376 (LWP 15057)]

Gtk-WARNING **: Invalid input string
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread -1229015376 (LWP 15057)]
0xb7025d2b in IA__g_logv (log_domain=<value optimized out>,
    log_level=G_LOG_LEVEL_WARNING, format=0xb7c696f6 "Invalid input string",
    args1=0xbfd6a75c "��\f�\\\202\n��x\017�")
    at /build/buildd/glib2.0-2.13.7/glib/gmessages.c:493
493 /build/buildd/glib2.0-2.13.7/glib/gmessages.c: No such file or
directory.
        in /build/buildd/glib2.0-2.13.7/glib/gmessages.c
(gdb) thread apply all bt

Thread 1 (Thread -1229015376 (LWP 15057)):
#0 0xb7025d2b in IA__g_logv (log_domain=<value optimized out>,
    log_level=G_LOG_LEVEL_WARNING, format=0xb7c696f6 "Invalid input string",
    args1=0xbfd6a75c "��\f�\\\202\n��x\017�")
    at /build/buildd/glib2.0-2.13.7/glib/gmessages.c:493
#1 0xb7025fa9 in IA__g_log (log_domain=0xb7be4017 "Gtk",
    log_level=G_LOG_LEVEL_WARNING, format=0xb7c696f6 "Invalid input string")
    at /build/buildd/glib2.0-2.13.7/glib/gmessages.c:517
#2 0xb7a49157 in gtk_label_recalculate (label=0x81e1b98)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtklabel.c:2620
#3 0xb7a49213 in IA__gtk_label_set_use_underline (label=0x81e1b98, setting=1)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtklabel.c:3674
#4 0xb7a4de20 in gtk_label_set_property (object=0x81e1b98, prop_id=4,
    value=0xbfd6a8b8, pspec=0x81bc000)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtklabel.c:656
#5 0xb70ba1da in IA__g_object_set_property (object=0x81e1b98,
    property_name=0x81eab28 "use-underline", value=0x81fd034)
    at /build/buildd/glib2.0-2.13.7/gobject/gobject.c:697
#6 0xb7bad728 in gtk_widget_buildable_set_buildable_property (
    buildable=0x81e1b98, builder=0x80a3af0, name=0x81eab28 "use-underline",
    value=0x81fd034) at /build/buildd/gtk+2.0-2.11.6/gtk/gtkwidget.c:8892
#7 0xb796b2e0 in _gtk_builder_construct (builder=0x80a3af0, info=0x81fdea0)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtkbuilder.c:465
#8 0xb796c3a0 in builder_construct (data=0x809ca38, object_info=0x81fdea0)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtkbuilderparser.c:219
#9 0xb796dcf8 in end_element (context=0x819ac70,
    element_name=0x81f5d18 "object", user_data=0x809ca38, error=0xbfd6aab0)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtkbuilderparser.c:787
#10 0xb7023b82 in IA__g_markup_parse_context_parse (context=0x819ac70,
    text=0x818a820 "<?xml version=\"1.0\" ?>\n<!--*- mode: xml -*--><!DOCTYPE
glade-interface\n SYSTEM
'http://glade.gnome.org/glade-2.0.dtd'>\n<interface>\n\n<object
class=\"GtkDialog\" id=\"totem_preferences_window\">\n <propert"...,
    text_len=66628, error=0xbfd6ab40)
    at /build/buildd/glib2.0-2.13.7/glib/gmarkup.c:1602
#11 0xb796c730 in _gtk_builder_parser_parse_buffer (builder=0x80a3af0,
    filename=0x80a63f0 "/usr/share/totem/totem.ui",
    buffer=0x818a820 "<?xml version=\"1.0\" ?>\n<!--*- mode: xml -*--><!DOCTYPE
glade-interface\n SYSTEM
'http://glade.gnome.org/glade-2.0.dtd'>\n<interface>\n\n<object
class=\"GtkDialog\" id=\"totem_preferences_window\">\n <propert"...,
length=66628, error=0xbfd6ab40)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtkbuilderparser.c:948
#12 0xb796bb97 in IA__gtk_builder_add_from_file (builder=0x80a3af0,
    filename=0x80a63f0 "/usr/share/totem/totem.ui", error=0xbfd6ab78)
    at /build/buildd/gtk+2.0-2.11.6/gtk/gtkbuilder.c:656
#13 0x0808a1d2 in totem_interface_load_with_full_path ()
#14 0x0808a304 in totem_interface_load ()
#15 0x08062790 in main ()

it seems to be ubuntu specific after discussion with the upstream maintainer (see http://bugzilla.gnome.org/show_bug.cgi?id=461945)

I'll attach some screenshots

Related branches

Justin M. Wray (wray-justin) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Can you please provide version information for totem, as well as the version of Ubuntu you are running.

Thanks,
Justin M. Wray

Changed in totem:
status: New → Confirmed
assignee: nobody → wray-justin
status: Confirmed → Incomplete
Changed in totem:
status: Unknown → Invalid

You shouldn't watch this bug at the upstream set this bug as INVALID, and is not upstream.

Sebastien Bacher (seb128) wrote :

Looks like a translation issue

Changed in totem:
status: New → Unknown
importance: Undecided → Low
status: Incomplete → Triaged
Changed in totem:
assignee: wray-justin → nobody
Claude Paroz (paroz) wrote :

Don't think it's a translation issue. The fr.po is correct. And I've been able to reproduce the problem with a fresh SVN build (jhbuild).

Sebastien Bacher (seb128) wrote :

Could you add a comment upstream saying that it happens using SVN?

Claude Paroz (paroz) wrote :

Fixed upstream. It was a problem with GTK+ (GtkBuilder).

Changed in totem:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

Thanks for the work on it

Changed in totem:
status: Unknown → Fix Released
Changed in totem:
status: Fix Released → New
Changed in totem:
status: New → Fix Released
kaij74 (kaij74) wrote :

Still broken with several locales.

kaij74 (kaij74) wrote :

Example Finnish. Works fine with several English locales.

wlx (wangliangxu) wrote :

Still broken with zh_CN.UTF-8 locale.

Changed in gtk+2.0:
importance: Low → High
Sebastien Bacher (seb128) wrote :
Download full text (5.4 KiB)

gtk+2.0 (2.12.0-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    GtkTooltips
    - All widgets have been ported to the new tooltips code
    - Tooltips are disabled in touchscreen mode
    GtkBuilder
    - Support custom tabs in GtkPrintUnixDialog
    Bugs fixed:
    - 459561 critical warnings with custom tooltips
    - 461648 GdkWindowQueueItem::serial overflow
    - 463773 Openoffice and flash run into a deadlock when used with KDE
    - 468801 thunar segfaults when selecting targa image (LP: #127574)
    - 473441 [patch] Ungrab windows when gdk_window_destroy() is calle...
    - 473954 gnome-background-properties: crash on drag-n-drop to "Add...
      (LP: #128931)
    - 461945 totem outputs errors in terminal (LP: #129438, #130329)
    - 348493 _gdk_quartz_copy_to_image needs implementing for pixmaps
    - 405868 Missing implementation of gdk_window_get_geometry()
    - 441219 Do not allow moving cursor to separators
    - 447214 rename the tips_data_list field back
    - 451202 New tooltips API has too long default timeout (LP: #133919)
    - 451397 Use new tooltip API in gtk+
    - 452225 check and option mark drawing is a mess of inconsistency
    - 457642 tooltips on notebook's tab labels
    - 458088 Improve mouse cursor for paned widgets
    - 458102 GtkScrolledWindow doesn't redraw when gtk-scrolled-window...
    - 458280 remove set-toolip handler from menutoolbutton
    - 458298 broken cursor movement with inline selection
    - 459459 Missing implementation of gdk_window_set_decorations() an...
    - 459515 gtk_menu_key_press() buglets
    - 459566 update testtooltips
    - 459667 Missing implementation of gdk_window_set_keep_above and g...
    - 460272 GtkFrame publishes incorrect defaults for "label-xalign"
    - 460534 No expose events if input swamps main loop with scrolled ...
    - 461225 gtk_tree_view_set_tooltip_cell() documentation: cell
     -463907 'Recent Documents' is broken in gnome-panel 2.19.5 (LP: #131266)
     -464528 gdk_rectangle_union() and gdk_rectangle_intersect() shoul...
    - 465039 "keynav-failed" signal not emitted when treeview has just...
    - 467003 tooltips do not pick up theme changes
    - 467117 Documentation for the GtkPaned key binding signals
    - 467414 gtkcupsutil.c won't build with cups 1.3
    - 468055 Incorrect compose mapping for capital U with macron (LP: #113721)
    - 468245 Tooltip timer doesn't get reset when mouse leaves into ot...
      (LP: #135076)
    - 469214 Recently used blocks side-panel browsing until loaded
    - 469374 menu accelerators don't work
    - 469395 make dist failure
    - 471132 Highlighting a suggestion with the keyboard changes the U...
      (LP: #134304)
    - 471215 Cursor drawing broken
    - 472974 gtk-builder-convert doesn't set correctly the tab label f...
    - 472981 make gtk-builder-convert not remove some empty properties
    - 356630 Print to file dialog suggests "output.pdf" even for ps ou...
    - 447883 PATCH Documentation about SVN in HACKING and README.cvs-c...
    - 459340 GtkContainer API documentation refers deprecated gtk_widg...
    - 459732 build system: cups detection with only cups-config might ...
    - 460207 there a...

Read more...

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.