Too slow to use, and feature missing!

Bug #1307127 reported by EAB on 2014-04-13
108
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gthumb (Ubuntu)
High
Unassigned

Bug Description

I upgraded from 13.10 to 14.04 and noticed thereafter that gthumb was extremely slow at loading my images - so slow that it was totally unusable!
With images under 1MB in size it seems to do ok, but still has some lag in the viewer - but with images of about 10MB each the viewer is too slow to be of any use.
Additionally the "auto-enhance" feature seems to have disapeared!?
When running gthumb from the terminal I see this: http://paste.ubuntu.com/7244317/

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gthumb 3:3.3.1.is.3.2.7-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Apr 13 14:29:15 2014
InstallationDate: Installed on 2013-04-15 (362 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
SourcePackage: gthumb
UpgradeStatus: Upgraded to trusty on 2014-04-12 (0 days ago)

EAB (adair-boder) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gthumb (Ubuntu):
status: New → Confirmed
SB (emehntehtt) wrote :

I can confirm that Gthumb is slow for me as well, it lags a lot when browsing from image to image, small images are not an issue, but photos from my phone (about 1-2.5 MB in size) lag greatly. Other image viewers dont seem to have this problem. I am using 64-bit 14.04 installed from beta image and fully upgraded, using Unity desktop. I do not however have any errors when starting Gthumb from the console.

DistroRelease: Ubuntu 14.04
Package: gthumb 3:3.3.1.is.3.2.7-0ubuntu1
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3

reynaerde (reynaerde) wrote :

I also have this problem on 14.04 and the current version of gThumb. Versions 3.2.6 and 3.2.5 are extremely slow as well. I tested those from here: https://launchpad.net/ubuntu/trusty/i386/gthumb/

There is an upstream bug report (https://bugzilla.gnome.org/show_bug.cgi?id=726087) which describes the problem for version 3.3.1. We could of course wait for it to be fixed and then replace gThumb with the most recent version.

However, version 3.3 also introduced a new user interface that from the looks of it is optimized for touchscreen users. It has a dark, custom theme and has hardly any functions when used outside Gnome 3. It is for this reason that gThumb was reverted to version 3.2.7 on Trusty and is no longer included in Xubuntu as the default program image organizer.

Would it be possible to wait for the bug to be fixed and then patch the version of gThumb currently in the Trusty repositories? I am sure a lot of Xfce users would appreciate gThumb but then with the traditional user interface.

If not, does anybody know how to get an older version of gThumb working on Trusty? I tried installing the version from Saucy which is very fast, but fails to load thumbnails properly on Trusty.

reynaerde (reynaerde) wrote :

I forgot to add that I also get these errors when I run gThumb from a terminal:

(gthumb:31542): GLib-CRITICAL **: Source ID 745 was not found when attempting to remove it
(gthumb:31542): GLib-CRITICAL **: Source ID 748 was not found when attempting to remove it

They however only appear when gThumb generates thumbnails. When browsing images in full screen they do not pop up, but extremely slow image rendering persists. So I do not think they are related.

reynaerde (reynaerde) wrote :

I did some more testing and found that gThumb version 3.2.4 is also affected by the same bug. Image rendering is extremely slow. So the problem was introduced before or in version 3.2.4.

I also tested various other image viewers and gpicview renders images very slowly too. Since I never used gpicview under Saucy, I cannot say if this was introduced with Trusty. Eye of Gnome and Ristretto do not have the slow rendering problem.

B_a_C (bryncoles-lancs) wrote :

Just to say I am using Gthumb on Xubuntu 14.4 (updated from 13:10) and am experiencing the same problem. Images render incredibly slowls (and do not seem to render properly in full screen either).

Tpugliese (thomas-pugliese) wrote :

Changing the zoom quality from "High" to "Low" in Preferences seems to greatly improve load times. Desplite the setting being called "Low" quality, the images look almost the same as High quality.

Kari Haapanen (karsta62) wrote :

I can verify this as well, and big thanks Tpugliese. I almost gave up on gThumb but that workaround gave it some more time.

badidea (very-bad-idea) wrote :

The Low quality is a workaround for this issues. The version from Ubuntu 10.04 was much faster with similar high quality. Now, I switched to xnview, which in available in the GetDeb Apps from UbuntuUpdates.org. At least 10 times faster with the same quality.

Martin (martin816) wrote :

Tpuglieses workaround works for me as well, thanks!
I'm looking forward to a (hopefully) more useable gthumb in the next release of ubuntu - just like it was before...

Si Dedman (si-dedman) wrote :

I don't know if this made any difference since I did the low quality zoom hack, but I also turned off a ton of extensions which I never use. Not a proper solution but if you're not using them...?

Goth Queen (artistbraab) wrote :

I'm afraid I must confirm this too (Xfce, Trusty 14.04, gThumb 3.2.7). I too see a definite difference between large and small files/ photo loading time on 3 different machines with various capabilities (from i7 with 32GB to 2 Intel Atom dual with 1GB notebook). Hence, I switched for my photo browsing to Ristretto.

However, I also seem to see a big difference in loading times between images with, and images without full META data (e.g. camara make, exposure times, flash on/off, ISO). Is that just me or do others also have this experience?

Changed in gthumb (Ubuntu):
importance: Undecided → High
lidex (mh40) wrote :

The low quality zoom has no effect for me. Run from terminal i get a bunch of lines like this:
(gthumb:12928): GLib-CRITICAL **: Source ID 347 was not found when attempting to remove it

psyray (psyray) wrote :

When do this bug corrected ?
Gthumb is unusable....

Hi
I have been experiencing this bug for months, and occasionally. My impression is that it is a "simple" issue: I believe that upon start gthumb must be trying to read or write files it has not access to (for instance the sd card of your camera you had inserted one week before and from which you had displayed images...) and does not give up. Maybe the bug is even shared with nautilus (or whatever is used in gnome for accessing files) (gthumb should not look at these files, and nautilus shoud say they are not accessible).
When I launch gthumb *.png I would like gthumb to access ONLY the files I have requested (and possibly---but it would be even preferable not to---, some LOCAL files .thumbnails/....png in the same directory...)
Right now it is right to say that this fantastic program is unusable and could be deleted...
sorry

mjc (mjc-avtechpulse) wrote :

Version 3.4.2 has just been released with quite a few bug fixes. I am not sure how well it plays with non-gnome-shell environments, however, but perhaps someone can investigate...

Martin (martin3000) wrote :

3.4.3 still freezes on start.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.