Green vertical bars when using gstreamer-vaapi in Totem under Xorg

Bug #1826201 reported by Thabang on 2019-04-24
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Unknown
gstreamer-vaapi (Ubuntu)
Status tracked in Eoan
Disco
High
Sebastien Bacher
Eoan
High
Sebastien Bacher

Bug Description

* Impact
When the vaapi plugin is installed totem displays video with a green overlay

* Test case
- install gstreamer1.0-vaapi
- download https://bugs.launchpad.net/ubuntu/+source/gstreamer-vaapi/+bug/1826201/+attachment/5258573/+files/Bug_report.mp4
- open the video in totem

-> the video should look like a normal desktop and not a green one

* Regression potential
Check that different videos format play correctly, the vaapi plugin is not installed by default so it has limited risk for most users

-------------------

MP4 videos cannot be played using the video player (TOTEM). This might be an upgrade problem.
VLC and other video players are working fine but i prefer to use totem

I have attached a video recording showing the problem in detail. All was working fine before the upgrade.

PS : I understand this problem is not related to the package "ubuntu-release-upgrader" but i cannot change it without getting errors( Launchpad and Ubuntu-bug problem )

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubuntu-release-upgrader-core 1:19.04.16.1
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Wed Apr 24 13:32:53 2019
InstallationDate: Installed on 2018-06-12 (315 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180425.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: Upgraded to disco on 2019-04-20 (3 days ago)
VarLogDistupgradeTermlog:

Thabang (falconf) wrote :
tags: added: totem
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you give the output of that command
$ dpkg -l | grep gstreamer

Also what error do you get exactly when trying to open a video?

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
tags: added: cosmic2disco
affects: ubuntu-release-upgrader (Ubuntu) → totem (Ubuntu)
Thabang (falconf) wrote :
Download full text (3.9 KiB)

The error is that i only see a "green screen" when i open an mp4 video.

The output to $ dpkg -l | grep gstreamer
 is given below

ii gir1.2-gstreamer-1.0:amd64 1.15.90-1ubuntu1 amd64 GObject introspection data for the GStreamer library
ii gstreamer1.0-alsa:amd64 1.15.90-1 amd64 GStreamer plugin for ALSA
ii gstreamer1.0-clutter-3.0:amd64 3.0.27-1 amd64 Clutter PLugin for GStreamer 1.0
ii gstreamer1.0-fluendo-mp3:amd64 0.10.32.debian-1 amd64 Fluendo mp3 decoder GStreamer 1.0 plugin
ii gstreamer1.0-gl:amd64 1.15.90-1 amd64 GStreamer plugins for GL
ii gstreamer1.0-gtk3:amd64 1.15.90-1ubuntu1 amd64 GStreamer plugin for GTK+3
ii gstreamer1.0-libav:amd64 1.15.90-1 amd64 ffmpeg plugin for GStreamer
ii gstreamer1.0-packagekit 1.1.12-5 amd64 GStreamer plugin to install codecs using PackageKit
ii gstreamer1.0-plugins-bad:amd64 1.15.90-1ubuntu1 amd64 GStreamer plugins from the "bad" set
ii gstreamer1.0-plugins-base:amd64 1.15.90-1 amd64 GStreamer plugins from the "base" set
ii gstreamer1.0-plugins-base:i386 1.15.90-1 i386 GStreamer plugins from the "base" set
ii gstreamer1.0-plugins-base-apps 1.15.90-1 amd64 GStreamer helper programs from the "base" set
ii gstreamer1.0-plugins-good:amd64 1.15.90-1ubuntu1 amd64 GStreamer plugins from the "good" set
ii gstreamer1.0-plugins-ugly:amd64 1.15.90-1 amd64 GStreamer plugins from the "ugly" set
ii gstreamer1.0-pulseaudio:amd64 1.15.90-1ubuntu1 amd64 GStreamer plugin for PulseAudio
ii gstreamer1.0-tools 1.15.90-1ubuntu1 amd64 Tools for use with GStreamer
ii gstreamer1.0-vaapi:amd64 1.15.90-1 amd64 VA-API plugins for GStreamer
ii gstreamer1.0-x:amd64 1.15.90-1 amd64 GStreamer plugins for X11 and Pango
ii libgstreamer-gl1.0-0:amd64 1.15.90-1 amd64 GStreamer GL libraries
ii libgstreamer-plugins-bad1.0-0:amd64 1.15.90-1ubuntu1 amd64 GStreamer libraries from the "bad" set
ii libgstreamer-plugins-base1.0-0:amd64 1.15.90-1 amd64 GStreamer libraries from the "base" set
ii libgstreamer-plugins-base1.0-0:i386 1.15.90-1 i386 GStreamer libraries from the "base" set
ii libgstreamer-plugins-good1.0-0:amd64 1.15.90-1ubuntu1 ...

Read more...

Thabang (falconf) wrote :

Sorry i see the formatting is rough. I don't know how to properly insert code in Launchpad.

Sebastien Bacher (seb128) wrote :

Do you get the issue if you uninstall gstreamer1.0-vaapi?

Thabang (falconf) wrote :

Yes that solved the problem. I removed the package and all is working now.

Thank you for your assistance

pascalc (pascal-chevrel) wrote :

I am affected by the same problem after the upgrade 1o 19.04 and can confirm that removing gstreamer1.0-vaapi solved it for me as well,thanks!

affects: totem (Ubuntu) → gstreamer-vaapi (Ubuntu)
Changed in gstreamer-vaapi (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

I would like to find out if this is a general VAAPI problem or is indeed specific to gstreamer.

1. Please run 'vainfo' and send us the output.

2. Please run 'lspci -k' and send us the output.

3. Please try playing the video with 'mpv'. Tell us if that works and also send us the output it prints to the terminal.

Changed in gstreamer-vaapi (Ubuntu):
status: New → Incomplete
Thabang (falconf) wrote :
Download full text (5.7 KiB)

------ The output to $ vainfo is shown below --------

libva info: VA-API version 1.4.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.4 (libva 2.4.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Simple : VAEntrypointEncSlice
      VAProfileMPEG2Main : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileH264ConstrainedBaseline: VAEntrypointFEI
      VAProfileH264ConstrainedBaseline: VAEntrypointStats
      VAProfileH264Main : VAEntrypointVLD
      VAProfileH264Main : VAEntrypointEncSlice
      VAProfileH264Main : VAEntrypointEncSliceLP
      VAProfileH264Main : VAEntrypointFEI
      VAProfileH264Main : VAEntrypointStats
      VAProfileH264High : VAEntrypointVLD
      VAProfileH264High : VAEntrypointEncSlice
      VAProfileH264High : VAEntrypointEncSliceLP
      VAProfileH264High : VAEntrypointFEI
      VAProfileH264High : VAEntrypointStats
      VAProfileH264MultiviewHigh : VAEntrypointVLD
      VAProfileH264MultiviewHigh : VAEntrypointEncSlice
      VAProfileH264StereoHigh : VAEntrypointVLD
      VAProfileH264StereoHigh : VAEntrypointEncSlice
      VAProfileVC1Simple : VAEntrypointVLD
      VAProfileVC1Main : VAEntrypointVLD
      VAProfileVC1Advanced : VAEntrypointVLD
      VAProfileNone : VAEntrypointVideoProc
      VAProfileJPEGBaseline : VAEntrypointVLD
      VAProfileJPEGBaseline : VAEntrypointEncPicture
      VAProfileVP8Version0_3 : VAEntrypointVLD
      VAProfileVP8Version0_3 : VAEntrypointEncSlice
      VAProfileHEVCMain : VAEntrypointVLD
      VAProfileHEVCMain : VAEntrypointEncSlice

---- The output to $ lspci -k is shown below ------

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
 Subsystem: Dell Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers
 Kernel driver in use: skl_uncore
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
 Subsystem: Dell Skylake GT2 [HD Graphics 520]
 Kernel driver in use: i915
 Kernel modules: i915
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
 Subsystem: Dell Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem
 Kernel driver in use: proc_thermal
 Kernel modules: processor_thermal_device
00:14.0 USB controller: In...

Read more...

Daniel van Vugt (vanvugt) wrote :

'mpv' is not a video format, it is a video player.

Please run:

  sudo apt install mpv

and then use it to play your video(s):

  mpv YOURFILE.mp4

Tell us if that works and also send us the terminal text output it shows.

Sebastien Bacher (seb128) wrote :
Changed in gstreamer-vaapi (Ubuntu):
importance: Low → High
status: Incomplete → Triaged
Changed in gstreamer:
status: Unknown → New
Daniel van Vugt (vanvugt) wrote :

We haven't established for certain that this is a gstreamer-vaapi bug yet. Though it sounds likely.

Please follow the instructions in comment #10.

summary: - MP4 Video playback is broken in Ubuntu 19.04
+ Green vertical bars when using gstreamer-vaapi in Totem
tags: added: regression-release
Daniel van Vugt (vanvugt) wrote :

OK, I can reproduce the bug now. Only in Xorg sessions and not Wayland.

Although performance isn't great even when it is working so I strongly recommend using 'mpv' to play your videos instead. mpv will give you smoother playback with lower CPU.

summary: - Green vertical bars when using gstreamer-vaapi in Totem
+ Green vertical bars when using gstreamer-vaapi in Totem under Xorg
Daniel van Vugt (vanvugt) wrote :

Also gst-play-1.0 seems to work fine, and that does use gstreamer-vaapi.

So maybe the bug here is more Totem-specific in package 'gstreamer1.0-clutter-3.0'?

Changed in clutter-gst-3.0 (Ubuntu):
status: New → Triaged
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

These also have the bug:

  gst-play-1.0 --videosink clutterautovideosink
  gst-play-1.0 --videosink glimagesink

but these do not:

  gst-play-1.0 --videosink ximagesink
  gst-play-1.0 --videosink xvimagesink

That confirms the problem is not specific to totem or gstreamer1.0-clutter-3.0.

no longer affects: clutter-gst-3.0 (Ubuntu)
Changed in gstreamer-vaapi (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gstreamer-vaapi (Ubuntu):
status: Triaged → In Progress
Changed in gstreamer-vaapi (Ubuntu Disco):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gstreamer-vaapi (Ubuntu Eoan):
status: In Progress → Triaged
Changed in gstreamer-vaapi (Ubuntu Eoan):
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

Upstream has a patch that seems to work, you can install that package that includes it if you want to test as well
https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/ppa/+build/16722126/+files/gstreamer1.0-vaapi_1.15.90-1+test1_amd64.deb

The fix should be part of the incoming 1.16 SRU coming to Disco

Thabang (falconf) wrote :

OK thank you. everything now works as already mentioned.
The output from mpv when playing an mp4 video is shown below, if it is still required.

Playing: Dream.mp4
 (+) Video --vid=1 (*) (h264 1280x720 25.000fps)
 (+) Audio --aid=1 --alang=eng (*) (aac 2ch 44100Hz)
[vo/gpu/vaapi-egl] vaAcquireSurfaceHandle() failed (invalid VASurfaceID)
Using hardware decoding (vaapi).
VO: [gpu] 1280x720 vaapi[nv12]
AO: [pulse] 44100Hz stereo 2ch float
(Paused) AV: 00:12:43 / 00:59:58 (21%) A-V: 0.000

Daniel van Vugt (vanvugt) wrote :

Seb mentioned that he was going to patch the fix (into Ubuntu and likely Debian) soon. So reassigned.

Changed in gstreamer-vaapi (Ubuntu Disco):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in gstreamer-vaapi (Ubuntu Eoan):
assignee: Daniel van Vugt (vanvugt) → Sebastien Bacher (seb128)

the patch proposed by seb128 fixes the problem for me.
now please fix also https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1721248

Changed in gstreamer:
status: New → Fix Released
Changed in gstreamer-vaapi (Ubuntu Disco):
status: Triaged → Fix Committed
Changed in gstreamer-vaapi (Ubuntu Eoan):
status: In Progress → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer-vaapi - 1.16.0-1ubuntu1

---------------
gstreamer-vaapi (1.16.0-1ubuntu1) eoan; urgency=medium

  * debian/patches/git_color_conversion.patch:
    - backport an upstream commit to fix green bars showed on totem videos
      (lp: #1826201)

 -- Sebastien Bacher <email address hidden> Wed, 08 May 2019 13:53:17 +0200

Changed in gstreamer-vaapi (Ubuntu Eoan):
status: Fix Committed → Fix Released

Hello Thabang, or anyone else affected,

Accepted gstreamer-vaapi into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gstreamer-vaapi/1.15.90-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-disco
Daniel van Vugt (vanvugt) wrote :

A simple way to test the proposed fix for 19.04 is to download it directly:

https://launchpad.net/ubuntu/+archive/primary/+files/gstreamer1.0-vaapi_1.15.90-1ubuntu1_amd64.deb

Please tell us if it works for you.

Daniel van Vugt (vanvugt) wrote :

Fix verified on disco using gstreamer1.0-vaapi_1.15.90-1ubuntu1_amd64.deb

tags: added: verification-done-disco
removed: verification-needed-disco
tags: added: verification-done
removed: verification-needed
Changed in gstreamer-vaapi (Ubuntu Disco):
assignee: nobody → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer-vaapi - 1.15.90-1ubuntu1

---------------
gstreamer-vaapi (1.15.90-1ubuntu1) disco; urgency=medium

  * debian/patches/git_color_conversion.patch:
    - backport an upstream commit to fix green bars showed on totem videos
      (lp: #1826201)

 -- Sebastien Bacher <email address hidden> Wed, 08 May 2019 13:50:36 +0200

Changed in gstreamer-vaapi (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gstreamer-vaapi has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.