"Totem could not get a screenshot of the video. This is not supposed to happen; please file a bug report."

Bug #1721248 reported by corrado venturini on 2017-10-04
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mutter
New
Unknown
gnome-shell (Ubuntu)
Low
Unassigned
mutter (Ubuntu)
Low
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

https://gitlab.gnome.org/GNOME/mutter/issues/146

---

I try to get a screenshot from my video and totem shows a message saying it could not get a screenshot of the video and suggesting to open a bug. See attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: totem 3.25.90.1-0ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 4 14:54:16 2017
InstallationDate: Installed on 2017-09-29 (5 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
SourcePackage: totem
UpgradeStatus: No upgrade log present (probably fresh install)
XorgLog: Error: [Errno 2] No such file or directory: '/var/log/Xorg.0.log'

Same problem in Wayland and x11

Daniel van Vugt (vanvugt) wrote :

I suspect this is due to hardware acceleration (gstreamer-vaapi). We try to avoid buffer copies for the best efficiency, but that also means getting a screenshot is very difficult. The video image only exists in GPU memory and requires a lot of effort to read back. It's not surprising this doesn't quite work yet.

Similarly using Alt+PrtScn may fail to get a screenshot (without an error message). I think the reason for that is the use of wl_subsurface is something gnome-shell doesn't quite know how to screenshot yet(?)

Changed in totem (Ubuntu):
importance: Undecided → Low

Problem does not occur on ubuntu 16.04 installed in a different partition of same PC.

Problem also with cheese ... may be related?

corrado@corrado-p5-0930:~$ cheese

(cheese:4054): Gtk-WARNING **: Theme parsing error: cheese.css:7:35: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version
totem-video-thumbnailer couldn't open file 'file:///home/corrado/Videos/Webcam/2017-10-05-140813.webm'

** (cheese:4054): WARNING **: could not generate thumbnail for /home/corrado/Videos/Webcam/2017-10-05-140813.webm (video/webm)

corrado@corrado-p5-0930:~$

corrado@corrado-p5-0930:~$ totem

(totem:4344): GLib-CRITICAL **: g_key_file_load_from_file: assertion 'file != NULL' failed

(totem:4344): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)

** (totem:4344): WARNING **: Could not take screenshot: failed to retrieve or convert video frame
corrado@corrado-p5-0930:~$

problem does not occur (screenshot created ok) with a MPEG-4 video created by guvcview.

corrado@corrado-beta-4ott:~$ totem

(totem:2363): GLib-CRITICAL **: g_key_file_load_from_file: assertion 'file != NULL' failed

(totem:2363): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)
corrado@corrado-beta-4ott:~$

I still have the problem in Ubuntu Bionic
I ran totem under apitrace (apitrace trace --api gl totem 960x720.webm) and obtained a trace of the problem. I attach the trace hoping it will be useful. Let me know if you need more doc.
thanks

corrado@corrado-p6-bb-1114:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu2
  Candidate: 3.26.0-0ubuntu2
  Version table:
 *** 3.26.0-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p6-bb-1114:~$ inxi -Fx
System: Host: corrado-p6-bb-1114 Kernel: 4.13.0-16-generic x86_64
           bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.26.2 (Gtk 2.24.31)
           Distro: Ubuntu Bionic Beaver (development branch)
Machine: Device: desktop Mobo: ASRock model: H110M-G/M.2 serial: N/A
           UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU: Dual core Intel Core i3-7100 (-HT-MCP-)
           arch: Skylake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15648
           clock speeds: max: 3900 MHz 1: 3900 MHz 2: 3900 MHz 3: 3900 MHz
           4: 3900 MHz
Graphics: Card: Intel HD Graphics 630 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: i915
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 17.2.4 Direct Render: Yes
Audio: Card Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic
Network: Card: Intel Ethernet Connection (2) I219-V
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full
           mac: 70:85:c2:44:7b:86
Drives: HDD Total Size: 1000.2GB (6.4% used)
           ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
Partition: ID-1: / size: 32G used: 6.9G (24%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 236 Uptime: 10:20 Memory: 1393.5/7684.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.40
corrado@corrado-p6-bb-1114:~$

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Luca Ciavatta (cialu) wrote :

I have the same issue: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1732204
When I opened the bug, Launchpad didn't show me this one, so I made a new one.

This bug seems a duplicate of https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1732204
Note: I always have the problem with .webm videos and sometimes with .mp4
I have some very small (200-300kB) video to reproduce the problem, if needed I may attach them (zipped?)

Download full text (3.9 KiB)

running totem debug i see:
corrado@corrado-p6-bb-1114:~$ cd /media/corrado/dati1/linux/bugTotem
corrado@corrado-p6-bb-1114:/media/corrado/dati1/linux/bugTotem$ totem 640x480.webm --gst-debug-level=2
0:00:00.103055514 1946 0x55a593e3ef90 WARN basesrc gstbasesrc.c:3480:gst_base_src_start_complete:<source> pad not activated yet
0:00:00.103281487 1946 0x55a593e3ef90 WARN basesrc gstbasesrc.c:3480:gst_base_src_start_complete:<source> pad not activated yet
0:00:00.193641706 1946 0x7f413015ae30 WARN vaapidisplay gstvaapidisplay_wayland.c:202:gst_vaapi_display_wayland_bind_display: wayland: get display name
0:00:00.264296079 1946 0x55a593e3ef90 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent audio tags update with no changes
0:00:00.291577829 1946 0x55a593e3ef90 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent video tags update with no changes

(totem:1946): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)
0:00:02.526096542 1946 0x7f411008df20 WARN pulse pulsesink.c:702:gst_pulsering_stream_underflow_cb:<audio-sink-actual-sink-pulse> Got underflow
0:00:06.528133378 1946 0x55a59437ccf0 WARN basetransform gstbasetransform.c:1346:gst_base_transform_setcaps:<videoscale0> transform could not transform video/x-raw(meta:GstVideoGLTextureUploadMeta), format=(string)RGBA, width=(int)640, height=(int)480, framerate=(fraction)0/1, pixel-aspect-ratio=(fraction)1/1, interlace-mode=(string)progressive in anything we support
0:00:06.528449695 1946 0x55a59437ccf0 WARN basetransform gstbasetransform.c:1346:gst_base_transform_setcaps:<videoscale0> transform could not transform video/x-raw(meta:GstVideoGLTextureUploadMeta), format=(string)RGBA, width=(int)640, height=(int)480, framerate=(fraction)0/1, pixel-aspect-ratio=(fraction)1/1, interlace-mode=(string)progressive in anything we support
0:00:06.528631583 1946 0x55a59437ccf0 WARN basetransform gstbasetransform.c:1346:gst_base_transform_setcaps:<videoscale0> transform could not transform video/x-raw(meta:GstVideoGLTextureUploadMeta), format=(string)RGBA, width=(int)640, height=(int)480, framerate=(fraction)0/1, pixel-aspect-ratio=(fraction)1/1, interlace-mode=(string)progressive in anything we support
0:00:06.528730117 1946 0x55a59437ccf0 WARN basesrc gstbasesrc.c:2939:gst_base_src_loop:<appsrc0> error: Internal data stream error.
0:00:06.528768087 1946 0x55a59437ccf0 WARN basesrc gstbasesrc.c:2939:gst_base_src_loop:<appsrc0> error: streaming stopped, reason not-negotiated (-4)
0:00:06.528929725 1946 0x55a593e3ef90 ERROR default convertframe.c:373:gst_video_convert_sample: Could not convert video frame: Internal data stream error.
0:00:06.528982066 1946 0x55a59437ccf0 WARN basetransform gstbasetransform.c:1346:gst_base_transform_setcaps:<videoscale0> transform could not transform video/x-raw(meta:GstVideoGLTextureUploadMeta), format=(string)RGBA, width=(int)640, height=(int)480, framerate=(fraction)0/1, pixel-as...

Read more...

Done some more test installing Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171126)
on various partitions of same disk on my PC:
Problem does NOT occur with live session
Problem does NOT occur with an installation in us-english - installation default
problem DOES occur with an installation in italian - language italian locale italian
problem DOES occur with an installation in english-italian - language english locale italian
problem DOES occur with the above installation also changing locale to english:
corrado@corrado-p8-bb-1126:~$ inxi -S
System: Host: corrado-p8-bb-1126 Kernel: 4.13.0-16-generic x86_64 bits: 64
           Desktop: Gnome 3.26.2
           Distro: Ubuntu Bionic Beaver (development branch)
corrado@corrado-p8-bb-1126:~$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
corrado@corrado-p8-bb-1126:~$

After some more test with Ubuntu 17.10 and the last daily of Ubuntu 18.04 Bionic
On same hardware, different partitions:
If during the installation I'm connected to internet I HAVE the problem
If during the installation I'm NOT connected to internet I DO NOT HAVE the problem
Seems crazy?

Messages from totem run with --gst-debug-level=3
Test on my PC partition P8 Bionic 20171127 - installation done with NETWORK CONNECTED
Display Server: wayland - totem screensot ERROR

Messages from totem run with --gst-debug-level=3
Test on my PC partition P8 Bionic 20171127 - installation done with NETWORK CONNECTED
Display Server: x11 - totem screensot ERROR

Messages from totem run with --gst-debug-level=3
Test on my PC partition P9 Bionic 20171127 - installation done with NETWORK DISCONNECTED
Display Server: wayland - totem screensot OK

Messages from totem run with --gst-debug-level=3
Test on my PC partition P9 Bionic 20171127 - installation done with NETWORK DISCONNECTED
Display Server: x11 - totem screensot OK

inxi and avprobe output

Doug McMahon (mc3man) on 2017-11-30
summary: - Totem could not get a screenshot of the video
+ Totem could not get a screenshot of the video when using
+ gstreamer1.0-vaapi plugin on supported videos
Download full text (6.7 KiB)

Problem does not occur on a different hardware:

corrado@corrado-HP-aa-p5:~$ cd Videos/Webcam
corrado@corrado-HP-aa-p5:~/Videos/Webcam$ totem prova.webm --gst-debug-level=3

(totem:1656): Gdk-WARNING **: Native Windows taller than 65535 pixels are not supported
0:00:00.992734998 1656 0x55e608792d80 FIXME bin gstbin.c:4323:gst_bin_query: implement duration caching in GstBin again
0:00:01.083864260 1656 0x55e608792d80 WARN basesrc gstbasesrc.c:3480:gst_base_src_start_complete:<source> pad not activated yet
0:00:01.084194736 1656 0x55e608792d80 WARN basesrc gstbasesrc.c:3480:gst_base_src_start_complete:<source> pad not activated yet
0:00:01.262320048 1656 0x7f1310155370 WARN vaapidisplay gstvaapidisplay_wayland.c:202:gst_vaapi_display_wayland_bind_display: wayland: get display name
0:00:01.360976222 1656 0x7f1310155370 WARN decodebin gstdecodebin2.c:2503:connect_pad:<decodebin0> Couldn't set vaapidecodebin0 to PAUSED
0:00:01.407394394 1656 0x7f1310155370 FIXME videodecoder gstvideodecoder.c:928:gst_video_decoder_drain_out:<vp8dec0> Sub-class should implement drain()
0:00:01.423221458 1656 0x7f13140154a0 FIXME videodecoder gstvideodecoder.c:928:gst_video_decoder_drain_out:<vp8dec0> Sub-class should implement drain()
0:00:01.423298795 1656 0x7f13140154a0 FIXME videodecoder gstvideodecoder.c:928:gst_video_decoder_drain_out:<vp8dec0> Sub-class should implement drain()
0:00:01.674302205 1656 0x55e608792d80 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent audio tags update with no changes
0:00:01.676026515 1656 0x55e608792d80 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent video tags update with no changes
0:00:01.676449676 1656 0x55e608792d80 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent video tags update with no changes
0:00:01.676482551 1656 0x55e608792d80 WARN totem bacon-video-widget.c:2074:bvw_update_tags: Pipeline sent video tags update with no changes
0:00:02.473543034 1656 0x7f12fc1654d0 WARN pulse pulsesink.c:702:gst_pulsering_stream_underflow_cb:<audio-sink-actual-sink-pulse> Got underflow
0:00:02.514301848 1656 0x7f13140154a0 FIXME videodecoder gstvideodecoder.c:928:gst_video_decoder_drain_out:<vp8dec0> Sub-class should implement drain()
0:00:07.414802734 1656 0x55e608f83c00 FIXME default gstutils.c:3902:gst_pad_create_stream_id_internal:<appsrc0:src> Creating random stream-id, consider implementing a deterministic way of creating a stream-id
0:00:09.869019376 1656 0x7f13140154a0 FIXME videodecoder gstvideodecoder.c:928:gst_video_decoder_drain_out:<vp8dec0> Sub-class should implement drain()
corrado@corrado-HP-aa-p5:~/Videos/Webcam$ inxi -Fx
System: Host: corrado-HP-aa-p5 Kernel: 4.13.0-16-generic x86_64
           bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.26.1 (Gtk 3.22.25-0ubuntu0.1)
           Distro: Ubuntu 17.10
Machine: Device: laptop System: Hewlett-Packard product: HP 250 G3 Notebook PC v: 0991100000000000000600087 se...

Read more...

I have again the same problem on Ubuntu 18.04.
as before problem disappears removing gstreamer1.0-vaapi

corrado@corrado-p8-bb:~$ inxi -SCGx
System: Host: corrado-p8-bb Kernel: 4.15.0-10-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.26.2 (Gtk 3.22.28-1ubuntu1)
           Distro: Ubuntu Bionic Beaver (development branch)
CPU: Dual core Intel Core i3-7100 (-MT-MCP-) arch: Skylake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15648
           clock speeds: max: 3900 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics: Card: Intel HD Graphics 630 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) driver: i915 Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc4 Direct Render: Yes
corrado@corrado-p8-bb:~$ apt policy gstreamer1.0-vaapi
gstreamer1.0-vaapi:
  Installed: 1.12.4-1ubuntu1
  Candidate: 1.12.4-1ubuntu1
  Version table:
 *** 1.12.4-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p8-bb:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu5
  Candidate: 3.26.0-0ubuntu5
  Version table:
 *** 3.26.0-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.26.0-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
corrado@corrado-p8-bb:~$

Daniel van Vugt (vanvugt) wrote :

Starting in Ubuntu 17.10, totem (and some other apps like gnome-maps) use Wayland subsurfaces by default. This means the video (or maps) rectangle are able to redraw without redrawing the window decorations and saves a lot of CPU.

A side-effect of this is that screenshots didn't seem to work any more. However I believe that's just going to be a bug in gnome-shell/mutter, for not being able to screenshot its own Wayland subsurfaces.

Changed in mutter (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
tags: added: wayland

Done some more test: the problem seems restricted to Intel HD Graphics 620 used by Luca Ciavatta https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1732204
and my Intel HD Graphics 630.
I still have the problem on Ubuntu 18.10:
corrado@corrado-p9-cc-0506:~$ inxi -SCGx
System: Host: corrado-p9-cc-0506 Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc v: 7.3.0
           Desktop: Gnome 3.28.1 Distro: Ubuntu Cosmic CANIMAL (development branch)
CPU: Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Skylake rev: 9
           L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31296
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 802 4: 800
Graphics: Card-1: Intel HD Graphics 630 driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.19.6 driver: i915 resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.0.2
           direct render: Yes
corrado@corrado-p9-cc-0506:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu6
  Candidate: 3.26.0-0ubuntu6
  Version table:
 *** 3.26.0-0ubuntu6 500
        500 http://archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p9-cc-0506:~$ apt policy gstreamer1.0-vaapi
gstreamer1.0-vaapi:
  Installed: 1.14.0-1
  Candidate: 1.14.0-1
  Version table:
 *** 1.14.0-1 500
        500 http://archive.ubuntu.com/ubuntu cosmic/universe amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p9-cc-0506:~$

BUT NO PROBLEM WITH A DIFFERENT HARDWARE:
mao@mao-p3:~$ inxi -SCGx
System: Host: mao-p3 Kernel: 4.13.0-39-generic x86_64 bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.26.2 (Gtk 3.22.25-0ubuntu0.1) Distro: Ubuntu 17.10
CPU: Dual core Intel Core i3-4130 (-HT-MCP-) arch: Haswell rev.3 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 13568
           clock speeds: max: 3400 MHz 1: 898 MHz 2: 1335 MHz 3: 1334 MHz 4: 1300 MHz
Graphics: Card: Intel 4th Generation Core Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: i915 Resolution: 1680x1050@59.88hz
           OpenGL: renderer: Mesa DRI Intel Haswell version: 4.5 Mesa 17.2.8 Direct Render: Yes
mao@mao-p3:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu1
  Candidate: 3.26.0-0ubuntu1
  Version table:
 *** 3.26.0-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
mao@mao-p3:~$ apt policy gstreamer1.0-vaapi
gstreamer1.0-vaapi:
  Installed: 1.12.3-1ubuntu1
  Candidate: 1.12.3-1ubuntu1
  Version table:
 *** 1.12.3-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status
mao@mao-p3:~$

Daniel van Vugt (vanvugt) wrote :

Please report this bug to the Gnome developers here:
https://gitlab.gnome.org/GNOME/mutter/issues

Changed in mutter (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
no longer affects: totem (Ubuntu)

still in Ubuntu 19.04 with totem 3.26.2-1ubuntu2

description: updated
tags: added: disco
removed: artful
tags: added: bionic
Changed in totem (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in gnome-shell (Ubuntu):
status: Triaged → Confirmed
Changed in mutter (Ubuntu):
status: Triaged → Confirmed
summary: - Totem could not get a screenshot of the video when using
- gstreamer1.0-vaapi plugin on supported videos
+ "Totem could not get a screenshot of the video. This is not supposed to
+ happen; please file a bug report."
Changed in mutter:
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.