Loading a subtitled mkv file while already playing a subtitled mkv file makes the UI freeze

Bug #1827194 reported by mattiasje on 2019-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Unknown
gst-plugins-base1.0 (Ubuntu)
High
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

When you have been playing a subtitled mkv file for a while and try to load a new subtitled mkv file in the same instance of Totem, the UI freezes.

You must let the video play for a while for the problem to manifest. I don't know how long exactly, but ten minutes should do it. Loading file after file in quick succession works fine, and it doesn't happen if you seek forward in the file to go to a later time in the video. You have to actually watch the video for a while for it to happen.

This problem has been in Totem for the past several versions of Ubuntu, but in 19.04 the problem has slightly changed: Totem used to become completely unresponsive and you had to force quit it, but in 19.04 you can click the close button and it closes immediately. Other than that, the problem is the same: all you get is a frozen black screen.

This problem could affect other file formats as well, but subtitled Matroska files is what I've personally been affected by.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: totem 3.32.0-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed May 1 11:52:22 2019
InstallationDate: Installed on 2019-04-26 (4 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
SourcePackage: totem
UpgradeStatus: No upgrade log present (probably fresh install)
XorgLog: Error: [Errno 2] No such file or directory: '/var/log/Xorg.0.log'

mattiasje (mattiasje) wrote :
description: updated
mattiasje (mattiasje) on 2019-05-01
summary: - Loading a subtitled mkv file while already playing a subtitled mvk file
+ Loading a subtitled mkv file while already playing a subtitled mkv file
makes the UI freeze
Daniel van Vugt (vanvugt) wrote :

When totem is frozen please open a terminal and run:

  killall -ABRT totem

Now wait a while for a crash report to be written to disk. The totem window should vanish when it's done. Next, send the resulting crash report per these instructions:

  https://wiki.ubuntu.com/Bugs/Responses#Missing_a_crash_report_or_having_a_.crash_attachment

Changed in totem (Ubuntu):
status: New → Incomplete
mattiasje (mattiasje) wrote :

I used ubuntu-bug as per instructions. The first time ubuntu-bug crashed when I hit the Send button, upon a second attempt it might have been successful, but I'm not sure. The ubuntu-bug window closed immediately when I hit Send, without feedback from either from the ubuntu-bug UI or in the terminal. I'm not sure if the information can find its way to this particular bug report given that I was never asked to specify where it belongs. This is all rather confusing.

Upon further testing of Totem, I have discovered that what's triggering the issue is the subtitles being turned off. Simply open a file, turn the subtitles off, and try to load a new file. No need to wait.

Daniel van Vugt (vanvugt) wrote :

Please follow all the instructions in:

  https://wiki.ubuntu.com/Bugs/Responses#Missing_a_crash_report_or_having_a_.crash_attachment

and tell us what you find.

mattiasje (mattiasje) wrote :

Actually, this might be what you're looking for? The timestamp seems off though.

https://errors.ubuntu.com/oops/5303ab96-6c83-11e9-92de-fa163e6cac46

Daniel van Vugt (vanvugt) wrote :

That's certainly one totem crash, thanks :)

Unfortunately that one doesn't seem to be readable/retraceable. So please try repeating with more freezes and forced crashes.

Sebastien Bacher (seb128) wrote :

Could you add a video example to the bug maybe?

Those reports don't have useful stacktrace, could you try to get one following the steps on https://wiki.ubuntu.com/Backtrace#Already_running_programs

Note that the journal one one of those include totem warnings

'gst_caps_get_size: assertion 'GST_IS_CAPS (caps)' failed
gst_mini_object_unref: assertion 'mini_object != NULL' failed
gst_pad_set_caps: assertion 'caps != NULL && gst_caps_is_fixed (caps)' failed'

mattiasje (mattiasje) wrote :

Hopefully I'm adding the attachment correctly, and hopefully it contains some useful information.

I was unable to follow the instructions exactly as gdb would hang when pressing ctrl+c. I waited at least ten minutes but the prompt wouldn't appear. I had to kill totem outside of gdb to progress to where I could type in the backtrace command. Further, while the wiki suggests sudo should only be necessary for programs run with sudo, I was unable to attach the totem process without it. So that's what I did.

Sebastien Bacher (seb128) wrote :

the backtrace is not really that useful since it lacks debug symbols

Did you get any file in /var/crash following Daniel's recommendations?

Daniel van Vugt (vanvugt) wrote :

errors.ubuntu.com is timing out again today so I am unable to review the links in comment #7.

mattiasje (mattiasje) wrote :

Yes Sebastien, a .crash file appears in /var/crash/ if I killall -ABRT totem.

However, as there's so much talk of crashing, I want to stress that the entire program has not crashed. It still listens, and obeys, a click on the close button. I just noticed that you can even navigate the UI and even load a new (not subtitled) file and it'll play.

The issue comes from playing one subtitled video, trying to load a new (or the same) subtitled video, and the video portion of the UI getting stuck and the video not playing.

In previous versions of Ubuntu, trying this meant a full crash. Clicking the close button led to a wait for the force quit option. But now in 19.04, the program is alive. It just can't play the video. It's not an issue of the video being paused either, clicking the play/pause button does nothing and the seek bar can't be interacted with.

Daniel van Vugt (vanvugt) wrote :

Added a gst-plugins-good1.0 task, assuming the problem is related to /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmatroska.so

Changed in totem (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Thanks, it looks like it's neither new nor a regression then (in the sense of something that used to work and stopped). Ideally having an example would make easier to test/work on the issue but I guess most of subtitled videos are non free content and can't be easily shared here?

mattiasje (mattiasje) wrote :

Here's a sample video I found that I assume is OK to share a link to. Just open it, turn subtitles off, and finally open the same file in the same Totem window.

https://github.com/Matroska-Org/matroska-test-files/blob/master/test_files/test5.mkv

Sebastien Bacher (seb128) wrote :
Changed in totem (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in totem:
status: Unknown → Fix Released
affects: gst-plugins-good1.0 (Ubuntu) → gst-plugins-base1.0 (Ubuntu)
Changed in gst-plugins-base1.0 (Ubuntu):
importance: Undecided → High
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.