Ubuntu

gstreamer0.10-plugins-bad, (libgstvideoparsersbad.so), causes a failure to decode many common video files encoded as AVC 1 Baseline - L2.1, Baseline - L1.1 & others

Reported by Doug McMahon on 2012-04-04
546
This bug affects 124 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
gst-plugins-bad0.10 (Debian)
Fix Released
Unknown
gst-plugins-bad0.10 (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

Sponsors: Please start by uploading raring.debdiff

SRU Justification (for both Quantal and Precise):

[Impact]
Several H264 video files are playing back without video output in 12.04 and 12.10. Applications such as totem, totem-mozilla, banshee, minitube, gnome-sushi and transmageddon are affected.

[Testcase]
Download novideo2.mp4 and open it in totem. The bug shows it self as black screen video output. If it has correct video, the bug is fixed.

[Regression Potential]
The patch size is quite big. Recommend testing of several types for h264 files to make sure there are no regressions. However; the patch originates from upstream, and a lot of people are already using it without regressions (according to comment #73).

Given the number of users affected and duplicates of this bug, I would consider it worth the risk.

Please consider this for SRU.

=======

Current workaround:
The fix has been packaged in this PPA:
 https://launchpad.net/~diwic/+archive/gstreamer-h264-testing

sudo add-apt-repository ppa:diwic/gstreamer-h264-testing
sudo apt-get update
sudo apt-get dist-upgrade

Restart the affected application(s) and retry.
======

*Adjusted description so as not to show as email to non logged in people
Most affected files are <email address hidden>, <email address hidden> *

Those would be the most likely to fail to be decoded but certainly not limited to kust them.
These files are commonly found online though many users will have locally.
Also affected other than totem, totem youtube plugin, & banshee would be the mozilla-plugin & minitube.
Typically the audio will play with no video though sometimes neither

*Moving libgstvideoparsersbad.so to a .bak allows decoding to take place on the previously affected files, but *is not the recommended fix*

Upstream has provided a commit to fix in both gstreamer 1.0 & .10 (gst-plugins-bad0.10.23
Attached below is a patch taken from the 0.10.23 commit to be applied to 0.10.22 that's currently used in 12.04

Also attached is a cut small sample file, noting the file plays fine in all non gstreamer players & in all gstreamer players in 11.10 & earlier
The file should be playable in totem, banshee & firefox with totem-mozilla plugin installed but only audio is decoded

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libgstreamer0.10-0 0.10.36-1
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu3
Architecture: i386
Date: Tue Apr 3 21:33:08 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gstreamer0.10
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) on 2012-04-04
summary: - Fails to decode many common video files encoded as AVC 1 Baseline@L2.1,
- Baseline@L1.1
+ Fails to decode many common video files encoded as AVC 1 Baseline -
+ L2.1, Baseline - L1.1
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Also to note that this affects greatly minitube , though users of minitube should fet behind this bug
Bug 941586

Jack Dale (jack-dale) wrote :

totem and minitube not working properly for me as well.

Another sample video:
http://www.mediafire.com/download.php?ag2sgpp2bzm9bi7
works on VlC but not totem as well

Oh, and Dragon Player too!

Flavio Tordini (zarlino) wrote :

I can confirm this on 12.04. I add that sometimes, although more rarely, video is played without audio. IMO, this is a total showstopper for a media PC and should be marked as critical.

checos (checosasz) wrote :

Bug Confirmed in totem and minitube on Ubuntu 12.04, only audio no video for few seconds

Doug McMahon (mc3man) wrote :

Just to re-note
All the affected encoding will play back fine with gstreamer players using gstreamer0.10-ffmpeg = 0.10.12 & earlier

tags: added: regression-release
removed: i386
emptythevoid (emptythevoid) wrote :

Just updated from 10.04 to 12.04 last night, with all updates current, and this happens to me as well.

Hossein Atashi (atashi.h) wrote :

I think the problem is not exactly gstreamer related, although it affects most gstreamer-based players, and all non-gstreamer players work fine.
The reason I think it is not gstreamer-related is that the following command seems to successfully play the problematic files:

gst-launch-0.10 playbin uri=file:///<problematic file>

I assume gst-launch-0.10 will use the same gstreamer backend that totem and other gstreamer players as using. I have no clue why they fail and gst-launch works, but I thought this might help find out exactly where the problem comes from.

professordes (d-a-johnston-hw) wrote :

Indeed,

 gst-launch-0.10 playbin uri=file:///<problematic file>

works on all my "non-playing" files (on 64 bit 12.04)

Doug McMahon (mc3man) wrote :

Also affected would be the totem youtube plugin

It would seem likely that the files aren't being recognized as a supported format
If one was to take a non playable file, record it thru vlc it will then get a thumbnail & be playable
Vlc doesn't re-encode in record mode but does write a new header

description: updated
Hossein Atashi (atashi.h) wrote :

When running totem with "--gst-debug-level=1" from the commandline on these files, I get the following error (a lot of them):

0:00:00.722733943 5727 0x7f46680034f0 ERROR ffmpeg :0:: AVC: nal size 133916040
0:00:00.724185455 5727 0x7f46680034f0 ERROR ffmpeg :0:: no frame!
0:00:00.724581805 5727 0x7f46680034f0 ERROR ffmpeg :0:: AVC: nal size 23413146
0:00:00.724597030 5727 0x7f46680034f0 ERROR ffmpeg :0:: no frame!
0:00:00.724620078 5727 0x7f46680034f0 ERROR ffmpeg :0:: AVC: nal size 33046938
0:00:00.724632090 5727 0x7f46680034f0 ERROR ffmpeg :0:: no frame!

Also if you see the file properties in Totem, it seems to detect the format (H.264/AVC, MPEG4 AAC) successfully, but not the dimensions and frame rate.
I have no idea what these mean, it would be nice if a developer would comments on this.

doing as described here http://tagavalgal.blogspot.com/2011/11/quicktime-demuxer-not-found-in-ubuntu.html as someone mentioned in another bug report has solved this problem for most but not all of my videos. they will all play with the command $gst-launch playbin uri=file:'<file>'

Hossein Atashi (atashi.h) wrote :

Unfortunately this did not help my case, all of my files still have the same problem. But gst-launch could play them in the first place.

Unmensch (unmensch) wrote :

The only solution that worked for me was to remove gstreamer0.10-plugins-bad - then I could play mp4s, and they thumbnailed ok. Unfortunately, this also nixed minitube (which was not working well either).

Solution found here:
http://askubuntu.com/questions/126030/totem-not-playing-certain-videos-in-12-04

Hossein Atashi (atashi.h) wrote :

Thanks Unmensch, it worked for me perfectly. I don't know what we will miss by removing this but so far I haven't had any problems.

professordes (d-a-johnston-hw) wrote :

This works for me too:

(http://askubuntu.com/questions/126030/totem-not-playing-certain-videos-in-12-04)

i.e.

---------------------------------------------------------
"install only these

gstreamer0.10-ffmpeg and gstreamer0.10-plugins-ugly

and uninstall gstreamer0.10-plugins-bad"
---------------------------------------------------------

the other suggested fixes (other than playing by hand with
gst-launch-0.10 playbin uri=file:///<problematic file>
haven't)

Hossein Atashi (atashi.h) wrote :

I just realized that after removing these plugins, some MPEG-1 videos will not play anymore. But still I prefer having support for MP4, if I have to choose.

Doug McMahon (mc3man) wrote :

It would be worth seeing if this can be tracked to a particular .so(s) in the bad plugin - removing that plugin isn't going to be an ultimate solution

Doug McMahon (mc3man) wrote :

I believe it's the libgstvideoparsersbad.so
So with the bad plugin installed try this on 64 bit install

sudo mv /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak

On a 32 bit install something like

sudo mv /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak

If anyone else can confirm we can alter the bug description

Hossein Atashi (atashi.h) wrote :

I can confirm that this solves my problem, MP4 files start playing correctly and MPEG-1 files are not affected. We should still find out which downsides removing this file has. But so far I haven't had any problems. Thanks Doug.

Doug McMahon (mc3man) on 2012-05-08
summary: - Fails to decode many common video files encoded as AVC 1 Baseline -
- L2.1, Baseline - L1.1
+ gstreamer0.10-plugins-bad, (libgstvideoparsersbad.so), causes a failure
+ to decode many common video files encoded as AVC 1 Baseline - L2.1,
+ Baseline - L1.1 & others
description: updated
professordes (d-a-johnston-hw) wrote :

Yup, moving

 libgstvideoparsersbad.so

out of the way on a 32 bit install sorts things out for me. Will check on 64 bit machine at work tomorrow.
No obvious side effects yet.

Another thanks to Doug.

professordes (d-a-johnston-hw) wrote :

Moving

 libgstvideoparsersbad.so

works for me on a 64 bit install too....

horray that fixed it thanks Doug!

eden6000 (eden6000) wrote :

Moving libgstvideoparsersbad.so fixed the issue for me too

Doug McMahon (mc3man) wrote :

Filed upstream & there is now a fix committed, whether that will ever be seen in 12.04 ....

Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → Fix Released
emptythevoid (emptythevoid) wrote :

Thanks for this fix! Just applied it, and it worked for me as well. No ill effects so far. Brilliant!

Doug McMahon (mc3man) wrote :

What value there is to the videoparser plugin i don't know, you figure there may be some, why else include it. (no one who has removed it has reported any issue yet.

In a bit of a hack applied the 0.10 commit to the current source that ubuntu uses in 12.04 (0.10.22) & the videos affected now work fine with the videoparser plugin installed.
It doesn't appear Debian/Ubuntu have any interest in fixing this for 0.10.22 so removing the plugin may remain the best option for users to help themselves

Whether this continues to be an issue in 12.10 may depend on what source of gstreamer is used, hopefully a little consideration to this issue will be given in that regard

eden6000 (eden6000) wrote :

Thanks Doug...I really don't understand why the folks at Canonical don't give to bug like this one the right importance...another one is bug #780117, which is related to brasero...it's such a shame, you say your target is precision, come on, fix these BIG bugs...moreover the fixes are already there, you only have to make them available to everybody!

csola48 (mail-csordaslaszlo) wrote :

"On a 32 bit install something like
sudo mv /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak"

With the proposed solution in truth visible the picture ... until a time!
The program closes himself up :(
That is I do not believe in the fact that this is the real solution...

Doug McMahon (mc3man) wrote :

For those inclined to build the gst-plugins-bad0.10.22.3-2ubuntu2 source here is a patch for gsth264parse that seems to work ok here (also has a small gsth263parse change

Obviously it would be better if someone who knows (& cares) about gstreamer* took care of this in whatever manner deemed appropriate

The attachment "h264parse.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Doug McMahon (mc3man) on 2012-05-22
affects: gstreamer0.10 (Ubuntu) → gst-plugins-bad0.10 (Ubuntu)
Brian Jamieson (brianj1966) wrote :

Although moving libgstvideoparsersbad.so to a bak file restored my ability to play a MP4 file with Totem (Movie Player), another consequence of the bug (I think) remains.
That is, when right clicking on a MP4 file (via Nautilus) instead of a file properties window opening up I just get a message saying "Creating Properties window. You can stop this operation by clicking cancel."
This message seaming will stay there forever so when your patiance runs out you click cancel which makes the message go away but still no Properties dialogue box is ever presented thereby preventing me from using the "Open With" tab to to make VLC be used by default for MP4's.

Doug McMahon (mc3man) wrote :

The best solution here was to apply the patch I attached above in #33 to the10.22.3 bad plugin source & rebuild the package.
Then all works fine 12.04, nothing needs to be removed.

12.10 will be getting a new plugin version, likely 10.23, whether an issue remains to be seen, the current debian 10.23 does not include this commit but then again maybe this is a ubuntu only issue
(11.10 uses basically the same source as 12.04 & this issue didn't exist in 11.10

Nothing more to be done here for 12.04 - The bug has been reported in general, we've figured out which plugin is involved, I reported upstream, got a commit that works ,ect.
Either someone addresses this or they continue not to - otherwise if an interested party wanted to ppa a fixed plugin package they should do so as that may be they only true solution for 12.04

Max Bowsher (maxb) wrote :

Doug:

You appear to be discounting doing a proper Stable Release Update for 12.04. Why?

On 05/28/2012 09:44 AM, Max Bowsher wrote:
> Doug:
>
> You appear to be discounting doing a proper Stable Release Update for
> 12.04. Why?
>
I'm not "discounting", just don't see any indication here (in this
report), that anyone other than users like myself cares.
I'm not up on how to present this for a SRU, if you are please do so.

Flavio Tordini (zarlino) wrote :

I'd like to thank Doug for all his work on this bug. Also, can someone with the power to apply the patch and push updated packages let us know if this will ever be fixed for 12.04?

Jan Claeys (janc) wrote :

@Doug: you can find the SRU procedures at https://wiki.ubuntu.com/StableReleaseUpdates

Doug McMahon (mc3man) on 2012-06-20
tags: added: quantal
Techman (techman-) wrote :

Have the same issue with Totem. It will play certain MP4 videos, but not others. The videos that don't work play in VLC. I can still get sound in Totem, but no video whatsoever.

JaSauders (jasauders) wrote :

2 and 2 is 4, guys... not 5. This fix should undoubtedly be applied to 12.04.

Doug McMahon (mc3man) on 2012-07-01
description: updated
Doug McMahon (mc3man) wrote :

You really do have to wonder what the problem is here with fixing, both in 12.04 & ATM 12.10

IF anyone affected happens to have a Debian install, could they report if the issue exists there & which version of the plugin, either 0.10.22 or 0.10.23
Maybe if it's not broken in Debian then the bug maintainer doesn't care about here...

I guess I'll have to learn how to do a ppa & we'll take care of ourselves (or if anyone wants to ppa it, the patch in comment 33 is good for 0.10.22, for 0.10.23 I'll provide a link to commit if need be or rewrite the patch.

Mark Fraser (launchpad-mfraz) wrote :

Removing gstreamer0.10-plugins-bad has stopped me from playing certain videos in SMPlayer recorded on my phone:

Resolution 960 x 544
Aspect ratio 1.7647
Format H264
Bitrate 2117 kbps
Frames per second 90000.000
Selected codec ffh264vdpau

I get the first frame of video, but it the continues with audio only.

Bucic (bucic) wrote :

I guess those guys aim to beat kernel power regression absurdity when it comes to the ammount of time a fix is actually pushed through updates...

Tsu Jan (tsujan2000) wrote :

As a Debian user, I confirm that Doug's patch (in a bit modified form) fixes the issue for gstreamer-plugins-bad v0.10.23. Thanks Doug!

Doug McMahon (mc3man) wrote :

On 07/14/2012 12:50 PM, Tsu Jan wrote:
> As a Debian user, I confirm that Doug's patch (in a bit modified form)
> fixes the issue for gstreamer-plugins-bad v0.10.23. Thanks Doug!
>
I modified the orig. upstream 0.10.23 commit for use in the 0.10.22
source used in Ubuntu 12.04 , for .23 the orig. likely would need no mod.

If you are able & or inclined to file a Debian bug against this then
possibly the bug maintainer for the bad plugin would finally pay some
attention (if anybody is maintaining the plugin, maybe
Sebastian Dröge ??
This has gone on so long it's become a bit absurd to say the least...

Tsu Jan (tsujan2000) wrote :

> ... for .23 the orig. likely would need no mod.

Strange! The upstream commit you mentioned isn't (fully?) applied to gstreamer-plugins-bad v0.10.23-6 in Debian. When I said I modified your patch a bit, I meant I removed a few parts that were already applied (but hadn't fixed the issue).

I'll file a Debian bug soon if there isn't any.

Doug McMahon (mc3man) wrote :

The orig. is here, the patch attached brought Ubuntu's .22 version up to .23 in /gst/videoparsers/gsth264parse* & gst/videoparsers/gsth263parse.c which as tested here was the best way to go & worked to fix completely

http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?h=0.10&id=845d8dc844225557440dd12d22299fad941d8dfb

If you find or file a Debian bug post a link back

Tsu Jan (tsujan2000) wrote :
Doug McMahon (mc3man) wrote :

On 07/15/2012 04:08 AM, Tsu Jan wrote:
> Here is my Debian bug report:
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681652
>
> ** Bug watch added: Debian Bug tracker #681652
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681652
>
Thanks for that, hopefully this may help jumpstart some official fixes
for those using Ubuntu or Debian that don't want to re-build the plugin

Doug McMahon (mc3man) wrote :

This just came thru on quantral -
gst-plugins-bad0.10 (0.10.22.3-2ubuntu4) quantal; urgency=low

  * Add patch glib-single-include to only include glib.h, not individual
    headers, the facility for which was dropped in glib 2.32. Fixes i386
    FTBFS.

 -- Iain Lane <email address hidden> Thu, 26 Jul 2012 14:02:12 +0100

Another opportunity to address & fix this wasted....

Tsu Jan (tsujan2000) wrote :

No reply from the Debian maintainer yet! The patch works perfectly and I've encountered no problem at all.

Doug McMahon (mc3man) wrote :

hi Tsu Jan
well at least we've tried...
Browsing the 10 branch commits after 5/19 I saw another commit for h264parse, this time in /gst-libs/gst/codecparsers. So added that also just because....

Also as a heads up on totem-3.4 which is now in 12.10. Seems to have an even worse break on parsing .mov & .mp4 in the totem-mozilla plugin. Sorta related to this though a different bug, Bug 1028755

Märt Põder (boamaod) wrote :

For me the fix referred to in comment 49 above didn't work, but the fix described at http://ubuntuforums.org/showpost.php?p=12118375&postcount=6 did the trick. I tried to apply the referred patch (with small changes) to latest package source from Precise (0.10.22.3-2ubuntu2).

Doug McMahon (mc3man) wrote :

Comment 49 was just for reference as to commit that fixed in the .10 branch as it was on that date, 05/17
Note that Ubuntu uses the .22 version, Debian the .23 release so the commit by itself will not do the job
The small how-to I put up on UF is for Ubuntu users of 12.04 who have become tired of this continuing nonsense. Have a slightly improved one for 12.04/12.10 that I may attach to that thread if this doesn't get fixed in 12.10

Anyway current list of affected apps -
totem & totem-mozilla
banshee
minitube
gnome-sushi
transmageddon

Changed in gst-plugins-bad0.10 (Debian):
status: Unknown → New
Ioannis Vranos (cppdeveloper) wrote :

OS tested: Ubuntu 12.04 32-bit.

1. I uninstalled the packages:

gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
libgstreamer-plugins-bad0.10-0

2. I installed the packages:

gstreamer-tools (0.10.36-1ubuntu1)
libglib2.0-dev (2.32.3-0ubuntu1)
libglibmm-2.4-dev (2.32.0-0ubuntu1)
libgstreamer-plugins-base0.10-dev (0.10.36-1ubuntu0.1)
liborc-0.4-dev (1:0.4.16-1ubuntu2)
libgstreamer0.10-dev (0.10.36-1ubuntu1)
valgrind (1:3.7.0-0ubuntu3)

3. I downloaded and compiled:

http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-0.10.23.tar.xz

from the page: http://gstreamer.freedesktop.org/src/gst-plugins-bad

and now everything works perfectly.

I think it is high time, the new gstreamer-010-plugins-bad, and gstreamer0.10-plugins-bad-multiverse, version 0.10.23, were created and provided as an update for Ubuntu 12.04 and 12.10, as soon as possible!

Ioannis Vranos (cppdeveloper) wrote :

Another approach can be, Ubuntu 12.04/12.10 providing Ubuntu 11.10's gstreamer bad plugin version, that works OK.

Marc Deslauriers (mdeslaur) wrote :

Although Ubuntu-Sponsors is subscribed to this bug, there doesn't seem to be any actionable items here.

Since this package is in universe, it is community-supported.

For this fix to get into Precise, someone has to:

1- Create a merge request or a debdiff to get the appropriate fix into Quantal. Since Quantal is past feature freeze, and the same version of gst-plugins-bad0.10 is in Quantal, the bug most likely will exist there also.
2- Create a merge request or a debdiff to get the same fix SRUed into Precise. Once the fix has been accepted into Quantal, it can be included in Precise.

I am unsubscribing ubuntu-sponsors for now. Please resubscribe the ubuntu-sponsors group once a debdiff has been attached to this bug and it will be handled promptly.

Thanks!

Changed in gst-plugins-bad0.10 (Ubuntu Precise):
status: New → Confirmed
oroboros (oroboros-n) wrote :

I apologize, but I followed the instructions in #57 to the detail, without problems (installed all the programs and compiled the gst-plugins-bad-0.10.23 without a hitch) and then tried playing a standard video file with the Movie Player program. It has the same issue, broken dependencies.

I tried looking up the Synaptic Package Manager to see which package was broken but it couldn't find anything.

Help!

I'm using Ubuntu 12.04.

I can playback the video files with mplayer2 or others, but not with the default application. Because the gstreamer/ffmpeg doesn't work, I can't convert video files to a different format.

I see there are more recent versions of gst-plugins-bad here:
http://gstreamer.freedesktop.org/src/gst-plugins-bad/?C=M;O=D

Doug McMahon (mc3man) wrote :

On 09/09/2012 10:17 PM, oroboros wrote:
> I apologize, but I followed the instructions in #57 to the detail,
> without problems (installed all the programs and compiled the gst-
> plugins-bad-0.10.23 without a hitch) and then tried playing a standard
> video file with the Movie Player program. It has the same issue, broken
> dependencies.
>
> I tried looking up the Synaptic Package Manager to see which package was
> broken but it couldn't find anything.
>
> Help!
>
> I'm using Ubuntu 12.04.
>
> I can playback the video files with mplayer2 or others, but not with the
> default application. Because the gstreamer/ffmpeg doesn't work, I can't
> convert video files to a different format.
>
> I see there are more recent versions of gst-plugins-bad here:
> http://gstreamer.freedesktop.org/src/gst-plugins-bad/?C=M;O=D
>
Those instructions are of no value here, basically amount to just
removing the bad plugin. (installing the bad plugins where Totem, ect
won't find..
I'd suggest your issue is something else, maybe open a support thread at
ask ubuntu or ubuntu forums

Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.23-7ubuntu1

---------------
gst-plugins-bad0.10 (0.10.23-7ubuntu1) quantal; urgency=low

  * Resynchronize with Debian wheezy (LP: #1051153). Remaining changes:
    - debian/gstreamer-plugins-bad.install
      don't include autoconvert, camerabin, dtmf, jpegformat, liveadder,
      rtpmux, and shm, we include them in -good.
    - Fix the short description of libgstreamer-plugins-bad.
    - Drop files from the split library and dev-package that were moved to
      -good.
    - Add patch cherrypicked from upstream commit 53735eaa to add a "realtime"
      profile to vp8.
    - Drop ltmain_as_needed patch and do this through dh-autoreconf.
    - Add patch glib-single-include to only include glib.h, not individual
      headers, the facility for which was dropped in glib 2.32.
    - Break and Replace transmageddon versions which contained GstVP8Enc.prs;
      we're shipping it here now.
  * Add upstream fix-h264-parsing.patch, which fixes a regression in H264
    support. Thanks Doug McMahon for reporting and identifying the fix
    (LP: #973014)
  * Set speed=7 in vp8-realtime-preset.patch

gst-plugins-bad0.10 (0.10.23-7) unstable; urgency=low

  * debian/patches/*opus*:
    + Backport Opus plugin patches from upstream GIT to fix major
      problems with handling of Opus streams. This caused invalid
      files to be created and assertions on valid files (Closes: #683919).

gst-plugins-bad0.10 (0.10.23-6) unstable; urgency=low

  * debian/rules,
    debian/gstreamer-plugins-bad.install:
    + Build the cdaudio plugin on kfreebsd too (Closes: #675973).

gst-plugins-bad0.10 (0.10.23-5) unstable; urgency=low

  * debian/build-deps.in:
    + Drop unconditional libcdaudio build dependency.
      It's not available on hurd.

gst-plugins-bad0.10 (0.10.23-4) unstable; urgency=low

  * debian/build-deps.in,
    debian/gstreamer-plugins-bad.install:
    + Build OPUS plugin and drop CELT plugin (Closes: #674653).
  * debian/control.in,
    debian/gstreamer-sdl.install,
    debian/build-deps.in:
    + Drop SDL plugin, it's in a bad state and nothing uses it (Closes: #669552).

gst-plugins-bad0.10 (0.10.23-3) unstable; urgency=medium

  * debian/patches/0001-vp8enc-fix-target-bitrate-config-with-libvpx-1.1.0.patch:
    + Patch from upstream GIT to fix encoding with libvpx 1.1.0.
  * debian/build-deps.in:
    + Drop build-dependency on lv2core, not necessary anymore.

gst-plugins-bad0.10 (0.10.23-2) unstable; urgency=low

  [ Timo Aaltonen ]
  * control, gstreamer-plugins-bad.install:
    - Drop libmusicbrainz4-dev from the build-depends, don't try to
      install libgsttrm.so. The old API hasn't worked for a long time.
      (Closes: #657011)

  [ Sebastian Dröge ]
  * debian/build-deps.in:
    + Really don't build-depend on the old musicbrainz library.
  * debian/build-deps.in,
    debian/rules,
    debian/gstreamer-plugins-bad.install:
    + Drop SPC plugin because the library is going away (Closes: #667918).
  * debian/build-deps.in:
    + Build-depend on libpng-dev instead of libpng12-dev (Closes: #662364).
    + Build-depend on libpulse-dev as libsdl-dev is missing this
      dependency (Cl...

Read more...

Changed in gst-plugins-bad0.10 (Ubuntu Quantal):
status: Confirmed → Fix Released
eden6000 (eden6000) wrote :

Well done! Will there be a backporting for Precise too?

Doug McMahon (mc3man) wrote :

I believe there is some confusion as to what will fix this, totally my fault for not being a bit more verbose & for that most sorry

It's not enough to just take the 0.10.23 release & current Debian patches & apply commit of http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?h=0.10&id=845d8dc844225557440dd12d22299fad941d8dfb

  gsth264parse.c & gsth264parse.h need to be advanced to the time of the above commit for that commit to work or advanced to after that commit

Attached is a redo of the fix-h264-parsing patch that will fix 0.10.23 release source, how this will fly not sure.

Many thanks to Jeremy Bicha for trying to fix this & very sorry that I wasn't as clear as needed..

Changed in gst-plugins-bad0.10 (Ubuntu Quantal):
status: Fix Released → New
status: New → Confirmed
eden6000 (eden6000) wrote :

It still isn't fixed in Precise, is it?

Matthias Niess (mniess) wrote :

Will this be fixed for precise?

eden6000 (eden6000) wrote :

Any news on if this will be fixed for precise? Can we collaborate somehow?

David Henningsson (diwic) wrote :

I can confirm that no_video4.mp4 does not have a video output on Quantal as of today, and after applying really-fix-h264-parsing.patch the same file has video output. I'm attaching a debdiff for quantal.

Ioannis Vranos (cppdeveloper) wrote :

H264 video files play now after the fix, however H.264 / AVC still don't play.

--
Ioannis Vranos

http://cppsoftware.binhoster.com

Ioannis Vranos (cppdeveloper) wrote :

H264 video files play now after the update in 12.04.1, however H.264 / AVC still don't play.

David Henningsson (diwic) wrote :

I can also confirm that the same file does not play on 12.04, and after applying h264parse.patch the same file does play with video. Attaching debdiff for precise SRU.

description: updated
description: updated
David Henningsson (diwic) wrote :

Hi Doug (and others), and thanks for your long and sustained work on this issue. I've tried to do what I can to make sure this fix goes into 12.04 and 12.10.

I have a question: From where do your patches originate? Did you write everything yourself? Did you diff two versions, and if so, which ones?

Doug McMahon (mc3man) wrote :

David -
For 12.04 the patch was the diff between gsth264parse.c & gsth264parse.h from the .22 source used in 12.04 & those 2 files from .23 branch RIGHT after the commit to fix.

For 12.10 the patch is the diff from gsth264parse.c & gsth264parse.h in the .23 Release & gsth264parse.c & gsth264parse.h in the .23 branch right after the commit

So I used this snapshot from the 0.10.23 branch to get gsth264parse.c & gsth264parse.h to get fixed files
gst-plugins-bad-845d8dc844225557440dd12d22299fad941d8dfb.tar.gz
(from link to the .23 commit in comment 64

So to repeat concerning the current badplugin in 12.10 -
It contains the commit to fix but doesn't have the additional needed changes to gsth264parse.c & gsth264parse.h that occurred between the 0.10.23 Release & the time of the commit to fix -

As far as 12.04 -
Basically what's being done to to upgrade gsth264parse.c & gsth264parse.h to the code as of 0.10.23 right after the commit to fix, ie. 05/17
(I've used the patched build extensively in 12.04 with no issue as have at least 100 other users thru a how-to patch & build thread in UF forum

description: updated
David Henningsson (diwic) wrote :

Doug, thanks for the answer. Any reason you're not putting it up in a PPA until this has gone into an SRU? I can setup a PPA for this issue if you don't want to, or don't know how to.

Changed in gst-plugins-bad0.10 (Ubuntu Precise):
importance: Undecided → High
Changed in gst-plugins-bad0.10 (Ubuntu Quantal):
importance: Undecided → High
Doug McMahon (mc3man) wrote :

On 10/12/2012 05:24 AM, David Henningsson wrote:
> Doug, thanks for the answer. Any reason you're not putting it up in a
> PPA until this has gone into an SRU? I can setup a PPA for this issue if
> you don't want to, or don't know how to.
>
David, having never done a ppa did take a look at doing but there was
something that couldn't quite understand.
I think if you could provide one it would be a good way to get some
further testing though I'm confident it does fix the affected encodings
without breaking any existing support.
There is a way for users to 'pre-test' files that currently show no
video, all affected files will display video when the plugin is
disabled. (moving libgstvideoparser.so to a .bak
Files that continue to not display video after the mv are not this bug.

I've a list of potentially affected apps in comment #56, may vary
slightly from 12.04 to 12.10. As far as totem-mozilla it can be helped
by this but currently is broken on .mov & some .mp4 (just got an
upstream fix for this the other day
Bug 1065324

David Henningsson (diwic) wrote :

Updated quantal.debdiff, the old one contained some unrelated changes

David Henningsson (diwic) wrote :

Okay, I've now made a ppa and uploaded to it; so as soon as the automatic builds have finished, just add https://launchpad.net/~diwic/+archive/gstreamer-h264-testing for easy testing.

BlueCase (bluecase) wrote :

Great..
PPA gestreamer bad version working on my PCs

Doug McMahon (mc3man) wrote :

Atm only have 12.10 though am confident 12.04 should also be fine
Tested with the affected apps in 12.10 & all are ok -
totem
banshee
minitube
transmageddon
Fixes totem-mozilla for these encodings in conjunction with the recent mov commit in totem-git
 ( http://git.gnome.org/browse/totem/commit/?id=4a10b7662895d1ed72db62a438372862d4c65a98

YannUbuntu (yannubuntu) wrote :

#77 working for me on 12.10

anarresti (nuno-anarresti) wrote :

PPA solved it for me on 12.04.

I had this problem for so long and had tried
all the solutions out there unsuccessfuly.

Thank you so much, Doug, for your hard work and persistence,
and thank you David for creating the PPA.

description: updated
David Henningsson (diwic) wrote :

Raring debdiff

description: updated
Doug McMahon (mc3man) wrote :

If Raring moves to gstreamer1.0 then we'd be ok as this was fixed in 1.0 at the the same time as the .23 commit.
(I assumed raring would be using 1.0 instead of staying with the .10 gst

David Henningsson (diwic) wrote :

@Doug: I just looked and raring has both sets of packages, i e, there is one package named "gst-plugins-bad0.10" and another named "gst-plugins-bad1.0".
Which one is going to be the default remains to be seen; but the upload to raring is also a prerequisite to SRUing it into quantal and precise at this point.

todaioan (alan-ar06) on 2012-11-27
Changed in gst-plugins-bad0.10 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.23-7ubuntu2

---------------
gst-plugins-bad0.10 (0.10.23-7ubuntu2) raring; urgency=low

  [ Dmitrijs Ledkovs ]
  * Restore ubuntu changelog entries.

  [ David Henningsson ]
  * Really fix h264 parsing. Thanks to Doug McMahon and other people
    commenting in (LP: #973014) for providing this fix.
 -- David Henningsson <email address hidden> Wed, 10 Oct 2012 12:01:06 +0200

Changed in gst-plugins-bad0.10 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gst-plugins-bad0.10 (Debian):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

uploaded precise, quantal versions to -proposed, unsubscribing sponsors.

Changed in gst-plugins-bad0.10 (Debian):
status: Confirmed → Fix Released

Hello Doug, or anyone else affected,

Accepted gst-plugins-bad0.10 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gst-plugins-bad0.10/0.10.22.3-2ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gst-plugins-bad0.10 (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in gst-plugins-bad0.10 (Ubuntu Quantal):
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Hello Doug, or anyone else affected,

Accepted gst-plugins-bad0.10 into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gst-plugins-bad0.10/0.10.23-7ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Doug McMahon (mc3man) wrote :

Works fine here in 12.10

tags: added: verification-done
removed: verification-needed
Doug McMahon (mc3man) wrote :

Also good here in 12.04

Fixed for me in Quantal.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.22.3-2ubuntu2.2

---------------
gst-plugins-bad0.10 (0.10.22.3-2ubuntu2.2) precise-proposed; urgency=low

  * Fix problems with h264 parsing (LP: #973014). Thanks to Doug McMahon.
 -- David Henningsson <email address hidden> Wed, 10 Oct 2012 12:22:05 +0200

Changed in gst-plugins-bad0.10 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.23-7ubuntu1.1

---------------
gst-plugins-bad0.10 (0.10.23-7ubuntu1.1) quantal-proposed; urgency=low

  * Really fix h264 parsing. Thanks to Doug McMahon and other people
    commenting in (LP: #973014) for providing this fix.
 -- David Henningsson <email address hidden> Wed, 10 Oct 2012 12:01:06 +0200

Changed in gst-plugins-bad0.10 (Ubuntu Quantal):
status: Fix Committed → Fix Released
David Henningsson (diwic) wrote :

Seems like we did it, finally! \o/
Thanks to everyone involved for your contributions!

I just downloaded vimeo mp4 file but nothing show, just audio.
Ubuntu 13.04 / 64

dpkg shows that I have the 0.10.23-7 version:

ssamayoa@ssamayoa-u13:~$ dpkg -l | grep gst.*bad
ii gstreamer0.10-plugins-bad:amd64 0.10.23-7ubuntu2 amd64 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-bad-multiverse 0.10.21-1ubuntu1 amd64 GStreamer plugins from the "bad" set (Multiverse Variant)
ii gstreamer1.0-plugins-bad:amd64 1.0.6-1ubuntu1 amd64 GStreamer plugins from the "bad" set
ii libgstreamer-plugins-bad0.10-0:amd64 0.10.23-7ubuntu2 amd64 GStreamer shared libraries from the "bad" set
ii libgstreamer-plugins-bad1.0-0:amd64 1.0.6-1ubuntu1 amd64 GStreamer development files for libraries from the "bad" set

Nobody else has this problem?

Regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.