Ubuntu

German translation of editing screen legend considered harmful!

Reported by Raphael J. Schmid on 2010-05-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Ubuntu German Translators
Lucid
High
Colin Watson

Bug Description

Binary package hint: grub

The original English version of the GRUB2 editing screen legend contains the vital information "Press Ctrl-x to boot [...]". It's even coloured yellow as to convey its importancy. The German translation of that legend, however, omits that information. In my opinion this is a critical bug as it effectively prevents the user from being able to rescue his system should the need arise.

SRU justification:

IMPACT: As above. I've had to help several confused users unable to work out how to edit the boot menu and make their changes take effect.

DEVELOPMENT BRANCH: We picked up a corrected translation as part of a general translation update in Maverick. I've backported this one change from it.

PATCH: http://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu/lucid/grub2/lucid/revision/1971

TEST CASE: Install in German, and hold Shift while booting to display the GRUB menu (or, if in KVM, edit /etc/default/grub, comment out both GRUB_HIDDEN_TIMEOUT* lines, run 'sudo update-grub', and reboot). Edit a menu entry. Check that the legend includes a comment about Ctrl-x (Strg-X in German).

REGRESSION POTENTIAL: None that I can think of.

(I'd love to fix this myself, if somebody could give me a hand and say where and how to change it?)

Steve Langasek (vorlon) on 2010-05-14
affects: grub (Ubuntu) → grub2 (Ubuntu)
Daniel Neel (dneelyep) on 2010-06-14
Changed in grub2 (Ubuntu):
assignee: nobody → Ubuntu German Translators (ubuntu-l10n-de)
Colin Watson (cjwatson) on 2010-06-23
Changed in grub2 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Colin Watson (cjwatson) wrote :

This is fixed in maverick, and should be fixed with the next language-pack pull into lucid-updates. However, I think for safety's sake we should fix the broken version in the package as well.

Changed in grub2 (Ubuntu Lucid):
status: New → Triaged
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
Changed in grub2 (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) on 2010-06-30
Changed in grub2 (Ubuntu Lucid):
status: Triaged → In Progress
milestone: none → ubuntu-10.04.1
Colin Watson (cjwatson) on 2010-06-30
description: updated

Accepted grub2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in grub2 (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

I tested the update, and the translation is still the old one. The problem is that grub-install is not automatically run after the language pack update, so /boot/grub/locale/de.mo is still out of date. After running "grub-install /dev/sda" it works.

Martin Pitt (pitti) wrote :

However, it should fix it for new installs, and there is little that we can do about it at this point in lucid, so let's accept it as it is.

Colin Watson (cjwatson) on 2010-07-22
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98-1ubuntu7

---------------
grub2 (1.98-1ubuntu7) lucid-proposed; urgency=low

  * Update harmfully incorrect German translation of menu legend, which
    omitted mention of pressing Ctrl-x to boot (LP: #580178).
  * Rearrange postinst install_devices logic so that preparatory code is run
    only once and the while loop only encloses actual asking of questions,
    and so that the question being asked is always marked for redisplay when
    going round the while loop again (LP: #580408).
  * Only offer partitions containing /, /boot, or /boot/grub for
    grub-install; installing to other partitions may have harmful effects
    such as making Windows unbootable, and installing GRUB to every single
    partition is likely to result in confusion anyway (LP: #576724).
 -- Colin Watson <email address hidden> Wed, 30 Jun 2010 14:37:47 +0100

Changed in grub2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers