windows option not shown

Bug #402795 reported by Jonathan Riddell on 2009-07-22
106
This bug affects 10 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Undecided
Unassigned
grub2 (Ubuntu)
High
Colin Watson
Karmic
High
Colin Watson

Bug Description

Binary package hint: grub2

Grub does not show the boot menu option for Windows, despite it being in the config file.

Related branches

Jonathan Riddell (jr) wrote :
Felix Zielcke (fzielcke) wrote :

With what version is this?
There were a few bugs in the parser but they should be fixed in the karmic version of grub2.
I just tried your config with current Debian sid grub2 (1.96+20090721-3) and all menuentries in the config were shown.
Maybe it helps to rename $root in the drivemap calls to ${root}
With the old parser $root didn't work correctly.

Am Mittwoch, den 22.07.2009, 06:01 +0000 schrieb Felix Zielcke:
> With what version is this?
> There were a few bugs in the parser but they should be fixed in the karmic version of grub2.

Oh sorry I was wrong. The karmic version doestn't contain them.

> I just tried your config with current Debian sid grub2 (1.96+20090721-3) and all menuentries in the config were shown.
> Maybe it helps to rename $root in the drivemap calls to ${root}
> With the old parser $root didn't work correctly.
>

--
Felix Zielcke

Dave Morley (davmor2) on 2009-07-22
Changed in grub2 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Seems this is fixed in a later version (sid), so I consider this triaged.

Changed in grub2 (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Undecided → High
status: Confirmed → Triaged
Changed in grub2 (Ubuntu Karmic):
milestone: none → karmic-alpha-4
Robbie Williamson (robbiew) wrote :

I'm running the latest grub2 package and see my Windows option just fine. What does the output of 'sudo update-grub2' show?

Felix Zielcke (fzielcke) wrote :

Am Mittwoch, den 22.07.2009, 16:08 +0000 schrieb Robbie Williamson:
> I'm running the latest grub2 package and see my Windows option just
> fine. What does the output of 'sudo update-grub2' show?
>

This wouldn't help. His windows entrys are in the grub.cfg already.
update-grub just generates grub.cfg it doestn't do anything else.
And update-grub2 just calls update-grub (which actually now calls
grub-mkconfig)

--
Felix Zielcke

Jari Kankaala (jari-kankaala) wrote :

I've just installed Karmic Koala alpha 3 and had the same problem, ie Windows not showing up in grub menu. I just ran 'sudo update-grub2' and that fixed the problem. Guess there is a bug in the installer.

Jon Arnold (jonarnoldsemail) wrote :

That command also fixed it for me. I backed up the fresh configuration from the installer (grub.cfg.old) and compared it to the one after running 'sudo update-grub2' (grub.cfg.new) and the command seemed to have added my Windows partition the "os-proper section" as well as having it in the "otheros" section. I have attached the two cfg files.

So, the command definitely works as a workaround (should probably be posted on the Alpha 3 release notes), and the behavior could possibly be implemented into the installer.

Jon Arnold (jonarnoldsemail) wrote :
Felix Zielcke (fzielcke) wrote :

Am Donnerstag, den 23.07.2009, 19:20 +0000 schrieb Jon Arnold:
> That command also fixed it for me. I backed up the fresh configuration
> from the installer (grub.cfg.old) and compared it to the one after
> running 'sudo update-grub2' (grub.cfg.new) and the command seemed to
> have added my Windows partition the "os-proper section" as well as
> having it in the "otheros" section. I have attached the two cfg files.
>
> So, the command definitely works as a workaround (should probably be
> posted on the Alpha 3 release notes), and the behavior could possibly be
> implemented into the installer.
>

Right I forgot that Colin Watson backported my fix for the old parser.
So I was right in #2 that changing $root to ${root} fixes the problem.
(I don't use Ubuntu only Debian)

I didn't fix this in Debian's grub-installer because the grub2 Version
which enabled drivemap without the parser fixes their was uploaded to
experimental not unstable and the next unstable upload which finally
enabled it contained the parser fixes.

--
Felix Zielcke

Changed in grub2 (Ubuntu Karmic):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Taylor Jasko (tjasko) wrote :

I can also confirm that running the command "sudo update-grub2" fixes it.

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-3-generic
Found initrd image: /boot/initrd.img-2.6.31-3-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda1
done

Detected my Windows 7... even though it sees it as Vista.

hpr7rowwjn (hpr7rowwjn) wrote :

I encounter the same bug and using 'sudo update-grub2' command doesn't help at all!!
I have installed Windows 7 on my machine and the grub2 bootloader doensn't add it to the menu.

I've tried that command and it just added duplicate copies of the already Ubuntu, Ubunu (recovery) Memtest, menu entries.

And for some reason now I can't open the grub.cfg file in the default text editor... it just crashed. I already reported the problem but I don't what the cause is -> I'm new to Ubuntu/GNU/Linux world.

How can I manually add entries into the Grub2 bootloader? I'm not familiar with it.. in the older version of Grub there was menu.lst file but now you are not allowed to edit grub.cfg.

hpr7rowwjn (hpr7rowwjn) wrote :

Updates:

I had to rename $root in the drivemap calls to ${root}.

Now the grub2 menu list is working properly. Ignore my previous comment.

I can confirm that Gnome64's solution worked for me. The details were:

Step 1 - cd /etc/grub.d
Step 2 - sudo gedit 30_otheros
Step 3 - search and replace $root with ${root}
Step 4 - Save 30_otheros
Step 5 - sudo update-grub2
Step 6 - sudo reboot

My test system has Windows XP, Jaunty, Karmic alpha 3, and Intrepid Kubuntu but I have only checked booting into Windows and Karmic.

Felix Zielcke (fzielcke) on 2009-07-26
Changed in grub2 (Debian):
status: New → Fix Released
Ben S. Knowles (adricnet) wrote :

I also saw this. On a new (re)install of karmic amd64 from the live cd daily build fetched a few hours ago I did not have the option for booting Windows, but after booting karmic once and running the sudo update-grub2 command (as well as updating kernel and other packages with apt) it displays and boots Win7 (labeled as Vista loader) fine.

In fact I'm posting from Win7/Chrome because although X/gdm worked allright in the live CD, it does not in the install .. but anyway :)

JosephB (joseph-bouchard) wrote :

If you have problems getting your Windows installation to detect, try installing the os-prober package. It should detect your Windows installation automatically:

# sudo apt-get install os-prober
# sudo update-grub2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.96+20090725-1ubuntu1

---------------
grub2 (1.96+20090725-1ubuntu1) karmic; urgency=low

  * New upstream version.
    + Fixes offering Windows (LP: #402795)
    + Fixes Vista/Win7 fails to boot (LP: #402154)
    + Fixes installation onto VFAT (LP: #401971)
  * Merge from debian unstable, remaining changes:
    + debian/control:
      - Depend on rather than Suggest os-prober; Ubuntu version does not
        suffer from the mount problem that prevents Debian from marking this
        Depends.
    + debian/default/grub:
      - Adjust for default Ubuntu boot options.
      - Use new GRUB_CMDLINE_LINUX_DEFAULT option to set "quiet splash" for
        default items only. These options won't be set in single user mode.
    + debian/legacy/update-grub:
      - Apply Ubuntu branding: title, recovery mode, quiet option, and tweak
        how memtest86+ is displayed.
      - Use UUIDs where appropriate.
    + debian/patches/03_ubuntu_grub_standards:
      - Remove GNU/Linux from default string.
    + debian/patches/10_crashkernel.patch:
      - add crashkernel= options if kdump and makedumpfile
        is available (part of the kernel-crashdump spec)
  * Update 10_crashkernel.patch for changes upstream.
  * Drop 999_os-prober_drivemap_root.diff, upstream.

 -- Mario Limonciello <email address hidden> Thu, 30 Jul 2009 12:41:19 -0500

Changed in grub2 (Ubuntu Karmic):
status: Triaged → Fix Released
Tux (peter-hoogkamer) wrote :

I have just installed the latest karmic 64 bits release from today (31-07-09) and still have this problem. Running Karmic on a Acer Aspire 5051 AWXMi with dual boot windows xp and karmic koala. After following suggenstions in this bug report I managed to get my xp installation detected, which wasn't directly after install. Steps followed:
Step 1 - Install os-prober package
Step 2 - cd /etc/grub.d
Step 3 - sudo gedit 30_otheros
Step 4 - search and replace $root with ${root}
Step 5 - Save 30_otheros
Step 6 - sudo update-grub2
Step 7 - sudo reboot
(Adjusted list form Grant Paton-Simpson)

lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

uname -a
Linux dikkiedik 2.6.31-4-generic #23-Ubuntu SMP Mon Jul 27 18:39:59 UTC 2009 x86_64 GNU/Linux

apt-cache policy grub2
grub2:
  Geïnstalleerd: (geen)
  Kandidaat: 1.96+20090611-1ubuntu4
  Versietabel:
     1.96+20090611-1ubuntu4 0
        500 http://nl.archive.ubuntu.com karmic/universe Packages

hpr7rowwjn (hpr7rowwjn) wrote :

I have only replaced $root with ${root} and after that everything went fine.

On Sat, Aug 1, 2009 at 12:40 AM, Tux <email address hidden> wrote:

> I have just installed the latest karmic 64 bits release from today
> (31-07-09) and still have this problem. Running Karmic on a Acer Aspire 5051
> AWXMi with dual boot windows xp and karmic koala. After following
> suggenstions in this bug report I managed to get my xp installation
> detected, which wasn't directly after install. Steps followed:
> Step 1 - Install os-prober package
> Step 2 - cd /etc/grub.d
> Step 3 - sudo gedit 30_otheros
> Step 4 - search and replace $root with ${root}
> Step 5 - Save 30_otheros
> Step 6 - sudo update-grub2
> Step 7 - sudo reboot
> (Adjusted list form Grant Paton-Simpson)
>
> lsb_release -rd
> Description: Ubuntu karmic (development branch)
> Release: 9.10
>
> uname -a
> Linux dikkiedik 2.6.31-4-generic #23-Ubuntu SMP Mon Jul 27 18:39:59 UTC
> 2009 x86_64 GNU/Linux
>
> apt-cache policy grub2
> grub2:
> Geïnstalleerd: (geen)
> Kandidaat: 1.96+20090611-1ubuntu4
> Versietabel:
> 1.96+20090611-1ubuntu4 0
> 500 http://nl.archive.ubuntu.com karmic/universe Packages
>
> --
> windows option not shown
> https://bugs.launchpad.net/bugs/402795
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “grub2” package in Ubuntu: Fix Released
> Status in grub2 in Ubuntu Karmic: Fix Released
> Status in “grub2” package in Debian: Fix Released
>
> Bug description:
> Binary package hint: grub2
>
> Grub does not show the boot menu option for Windows, despite it being in
> the config file.
>

Felix Zielcke (fzielcke) wrote :

Am Freitag, den 31.07.2009, 21:40 +0000 schrieb Tux:
> I have just installed the latest karmic 64 bits release from today (31-07-09) and still have this problem.
> grub2:

> Geïnstalleerd: (geen)
> Kandidaat: 1.96+20090611-1ubuntu4
> Versietabel:
> 1.96+20090611-1ubuntu4 0
> 500 http://nl.archive.ubuntu.com karmic/universe Packages
>

You are still using the broken grub2 package.
On cdimage.ubuntu.com I can only find the alpha-3 images, but none which
is created yesterday/today, so it still has the broken package in it.
Upgrade your system and make sure you reinstall grub2 to MBR then it
should be fixed.

--
Felix Zielcke
Proud Debian Maintainer

Tux (peter-hoogkamer) wrote :

Hi Felix,

There was indeed an grub update yesterday. Installed it and everything is fine.

2009/8/1 Felix Zielcke <email address hidden>:
> Am Freitag, den 31.07.2009, 21:40 +0000 schrieb Tux:
>> I have just installed the latest karmic 64 bits release from today (31-07-09) and still have this problem.
>> grub2:
>
>>   Geïnstalleerd: (geen)
>>   Kandidaat: 1.96+20090611-1ubuntu4
>>   Versietabel:
>>      1.96+20090611-1ubuntu4 0
>>         500 http://nl.archive.ubuntu.com karmic/universe Packages
>>
>
> You are still using the broken grub2 package.
> On cdimage.ubuntu.com I can only find the alpha-3 images, but none which
> is created yesterday/today, so it still has the broken package in it.
> Upgrade your system and make sure you reinstall grub2 to MBR then it
> should be fixed.
>
> --
> Felix Zielcke
> Proud Debian Maintainer
>
> --
> windows option not shown
> https://bugs.launchpad.net/bugs/402795
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in grub2 (Ubuntu Karmic):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Katsudon (katsudon) wrote :

Upgrade to the most current version did not help me.

Changed in grub2 (Debian):
status: Fix Released → New
Changed in grub2 (Ubuntu Karmic):
status: Fix Released → New
Felix Zielcke (fzielcke) wrote :

Am Samstag, den 15.08.2009, 16:47 +0000 schrieb Katsudon:
> Upgrade to the most current version did not help me.

So your grub.cfg contains a windows entry which isn't shown or is there
no windows entry at all?
If the latter then it would be a different bug.
If the first then make sure you either choose the right device in the
debconf prompt where to install grub or just run grub-install yourself
to make sure it's really updated.

Opoho (opoho) wrote :

Suffering from this bug I found another glitch.
With french support this other OS is automatically recognized under "Windows XP Édition familiale". The special character is not properly set: it's not readable in nano and it doesn't work in the GRUB menu (the line is not shown). Changing it for a proper "É" doesn't make GRUB happy but with an "E" it's OK.

Katsudon (katsudon) wrote :

My apologies, apparently something went wrong with the upgrades and some patches were not applied at the very beginning. Now everything is fine.

@Opoho: please file a separate bug report

Changed in grub2 (Debian):
status: New → Fix Released
Changed in grub2 (Ubuntu Karmic):
status: New → Fix Released
Felix Zielcke (fzielcke) wrote :

Am Sonntag, den 16.08.2009, 03:16 +0000 schrieb Opoho:
> Suffering from this bug I found another glitch.
> With french support this other OS is automatically recognized under "Windows XP Édition familiale". The special character is not properly set: it's not readable in nano and it doesn't work in the GRUB menu (the line is not shown). Changing it for a proper "É" doesn't make GRUB happy but with an "E" it's OK.
>

Something similar has been already reported as bug #406142

Opoho (opoho) wrote :

@ Katsudon, Felix Zielcke
Indeed, #406142 is the right bug for the problem I encountered.

guillermo (grd22001) wrote :

yesterday I make an update to grub2 in an ubuntu karmic dev version and can't see any more the boot loader:
to solve this problem I leave the steps here:

step 1: sudo gedit /etc/grub.d/30_otheros
step 2: search and replace $root with ${root}
step 3: update-grub2
step 4: sudo gedit /boot/grub/grub.cfg
step 2: search and replace set timeout=0 with timeout=5

to complete the needed steps, don´t edit the /boot/grub/grub.cfg directly (as it says in it´s header)
you have to edit the /etc/grub.d/30_os-prober

Replace
  if sleep$verbose --interruptible ${GRUB_HIDDEN_TIMEOUT} ; then
    set timeout=0
With
  if sleep$verbose --interruptible ${GRUB_HIDDEN_TIMEOUT} ; then
    set timeout=5

Finally do the update-grub2 and check if the change arrived in /boot/grub/grub.cfg at the place mentioned in the post before

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers