32-Bit UEFI bootloader support needed

Bug #1341944 reported by ClairelyClaire on 2014-07-15
This bug affects 69 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Nominated for Wily by TJ
grub2 (Ubuntu)
Nominated for Wily by TJ
live-build (Ubuntu)
Nominated for Wily by TJ
ubiquity (Ubuntu)
Nominated for Wily by TJ

Bug Description

As of now, Ubuntu and other major Linux distributions do not support the use of a 32-bit EFI bootloader on UEFI machines. This has become extremely problematic due to the popularity of Intel Atom-based tablets and compact laptops. Atom-based devices are generally limited in storage space (32GB or 64GB eMMC is common), and as a result these devices almost universally ship with Windows 8.1 32-bit installed (winsxs consumes a significant amount of storage space in order to support 32-bit binaries in a 64-bit environment). By design, UEFI must use the same architecture used by the bootloader.

While most modern computers indeed use a 64-bit UEFI implementation due to the fact that new computers generally ship with a 64-bit operating system (be it OS X or Windows 8.1), Atom-based devices do *not* use a 64-bit operating system or UEFI implementation. This is by design.

Intel released a new Atom iteration (Bay Trail) in late 2013 and has indicated that they will continue to develop and release Atom CPUs due to consumer market demand. At the time of this filing there are a number of Atom-based tablets and compact laptops/netbooks being actively sold and marketed by major OEMs including Dell, HP, ASUS, and Acer. None of these devices have 64-bit UEFI firmware. It is also important to note that these Atom CPUs are 64-bit, but explicitly require a 32-bit UEFI bootloader.

The current Linux kernel in Ubuntu 14.04 does support booting the 64-bit signed kernel from a 32-bit Grub EFI bootloader. I can confirm this on at least two 32-bit UEFI devices, the ASUS Transformer T100TA and the Acer Aspire Switch 10. Unfortunately, the lack of official 32-bit EFI bootloader support in Ubuntu makes accomplishing this far from trivial and beyond the capacity of many users new to Linux as an alternative to Microsoft Windows.

This bug is currently marked as a security vulnerability due to the fact that as of now, it is necessary to compile Grub2 32-bit EFI manually in order to boot Linux. This negates the digital signature check that allows keeping Secure Boot enabled on modern UEFI-based machines.

Considering the above, it is very important to include a 32-bit UEFI bootloader as an update to Grub2 in Trusty and all future releases of Ubuntu.

information type: Private Security → Public Security

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Public Security → Public
Jay Davis (fenwayjay) wrote :

I can confirm this affects me as well. I have an Acer Switch 10 and an Asus T100. Both of them have the same Intel Atom 64-bit processor, but require a 32-bit bootloader in order to boot. These machines are UEFI only and have no legacy BIOS support.

I was able to get Ubuntu 64-bit installed and running by following the workaround detailed on http://www.jfwhome.com/2014/03/07/perfect-ubuntu-or-other-linux-on-the-asus-transformer-book-t100/ but after careful review, it seems that simply adding a 32-bit grubia32.efi or equivalent to the 64-bit livecd alongside the 64-bit version of the loader, half the problem is solved. Then it's just a matter of making grubia32 a default part of the distribution alongside the 64-bit version. UEFI is designed to load the appropriate .efi for the expected architecture, and because these low-cost devices ship with 32-bit Windows 8.1 to save space on the device by eliminating WoW64, the UEFI on these devices expects a 32-bit bootloader. Linux (including Ubuntu 14.04 and possibly earlier) supports booting a 64-bit OS from a 32-bit bootloader.

Anecdotally, I learned from a friend of mine that they weren't able to install Ubuntu on their Core 2 Duo MacBook because the UEFI on their MacBook wouldn't load the 64-bit version of grub. Turns out some MacBooks are UEFI-only, have 64-bit CPUs, but require a 32-bit bootloader just like these newer Atom tablets. I suggested he try following the workaround listed above.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Jost Menke (jmenke) wrote :

I can confirm that the new Odys Wintab 10 is also affected. Link to the product page: http://www.odys.de/web/tablet-pc_wintab10_de.html

ClairelyClaire (clairelyclaire) wrote :

This is going to continue to be a problem. Its breadth will increase as more and more people attempt to install Ubuntu on any Atom-based device.

The Intel Atom platform by design uses a 32-bit UEFI environment. These devices ship with 32-bit Windows 8.1 installed, because 64-bit Windows uses significantly more disk space and most Atom devices have limited storage capacity (32GB or 64GB; sometimes as little as 16GB).

Can anyone from the dev team comment on this?

karan (karanpatwardhan) wrote :

Even I can confirm the above mentioned bug..
I have recently purchased a NotionInk CAIN Tablet
It has the latest Intel Atom Z3735D Quad Core(Bay Trail) Processor
The tablet(Hybrid) comes pre-installed with 32-bit Windows 8.1

I have tried booting the 64 bit Ubuntu but it doesnt boot because of the above mentioned bug.

The manual compiling of the 32 bit grub2 bootloader is the only option left as of now which i'll explore in the coming days.

But it'll be better if the 32bit distributions can come with a preinsatalled with 32bit UEFI bootloader as day by day more number of tablets with such requirement are getting released and we would love to see our favourite Linux distribution running on these tablets..

Thank You..

Jost Menke (jmenke) wrote :

FYI, there are 2 Debian Boot CDs with 32 bit UEFI support:


debian-wheezy-i386-efi-test4.iso and debian-wheezy-amd64-i386-MA-efi-test4.iso will usually boot just fine on 32 bit UEFI machines that have no legacy mode. Maybe Steve McIntyres work can be adapted to create 32 bit UEFI install media for Ubuntu.

PS: This is probably a duplicate of https://bugs.launchpad.net/ubuntu-cdimage/+bug/1025555

Th.G (thogios) wrote :

Bug confirmed on HP Envy X2

Jay Davis (fenwayjay) wrote :

Bug #1025555 deals specifically with the 32-bit version of Ubuntu, therefore this is not necessarily a duplicate of #1025555. This bug report is about installing 64-bit Ubuntu on 64-bit machines with 32-bit UEFI only. I am unmarking 1025555 as a duplicate, as that seems to be complicating the issue.

All that needs to happen here is the 64-bit Ubuntu installer needs to simply install both the 32-bit and 64-bit Grub UEFI binaries, which UEFI by design supports natively. I have tested this and can confirm that by installing both 32- and 64-bit Grub on these machines, I can boot a 64-bit Ubuntu OS. (64-bit Grub is not required to boot, but the key is that they can coexist in the UEFI directories.)

Phillip Susi (psusi) wrote :

"The current Linux kernel in Ubuntu 14.04 does support booting the 64-bit signed kernel from a 32-bit Grub EFI bootloader. I can confirm this on at least two 32-bit UEFI devices, the ASUS Transformer T100TA and the Acer Aspire Switch 10. Unfortunately, the lack of official 32-bit EFI bootloader support in Ubuntu makes accomplishing this far from trivial and beyond the capacity of many users new to Linux as an alternative to Microsoft Windows."

Are you certain? Collin Watson remarked the other day at a UDS discussion about this issue that it is not possible to boot a 64 bit kernel on a 32 bit uefi since it would not be able to make calls into the 32 bit uefi firmware. Can you provide a syslog of such a boot?

I have an Acer Switch 10 with a 32-bit UEFI. I installed 32-bit UEFI GRUB and was able to boot 64-bit Ubuntu. It definitely was not 32-bit Ubuntu - I was specifically using a 64-bit installer/LiveCD.

I can confirm definitively that a machine with 32-bit firmware can absolutely boot a 64-bit operating system.

ETA: whether or not the 64-bit OS can make calls to the 32-bit UEFI doesn't prevent the OS from booting.

Hash: SHA1

On 11/18/2014 12:00 PM, ClairelyClaire wrote:
> ETA: whether or not the 64-bit OS can make calls to the 32-bit
> UEFI doesn't prevent the OS from booting.

Actually, it does. It has to call on the UEFI firmware to obtain the
system memory map. Then of course, the installer has to make uefi
calls to point the boot catalog at grub.

So, you booted the 64 bit cd, and manually installed 32 bit grub? And
that worked fine, including being able to run efibootmgr? If so then
I guess the kernel is smart enough to thunk the 32 bit firmware calls
and so adding the 32 bit signed grub to the 64 bit cd should be fairly

Version: GnuPG v2.0.17 (MingW32)


That's what we've been saying since this ticket - and others like it - was filed.

It is *confirmed* to be possible to install a 32-bit UEFI GRUB and install and boot a 64-bit kernel. It's been done multiple times, right now by manually compiling and using a 32-bit UEFI GRUB bootloader. I can't speak to the technical reasons *why* it works, but it absolutely, positively, definitely does work.

dan pinto (danpinto8) wrote :

I can confirm being able to boot into an Ubuntu 14.10 64bit live usb by manually adding a 32bit compiled grub2 on my Asus x205ta which has a 64bit Bay Trail Atom CPU but only supports 32bit EFI.

It was able to install ubuntu until the bootloader part. It installed a 64bit EFI bootloader but that wouldn't work. I then tried adding the same efi I used on the livecd but I just get stuck at grub when I select it via rEFInd. I attempted to follow some instructions online to load linux from grub but was unsuccessful.

It would be great to add 32bit UEFI support. My guess is that at minimum you would need to add a 32bit EFI on the livedisk and in the grub2 installation stage add a check for 32bit only EFI and install 32bit grub with correct grub configuration. Everything else seemed to worked fine in the live usb stage when I tested.

I will try see if I can get the grub config figured out on my end this weekend but I'll need to learn how to set up grub2.

Larry Lamb (larryl) wrote :

So... it would be really nice if someone that was able to make this work post the steps used to find success. As others have posted-- these atom machines are not going away. I just purchased an ASUS X205TA for $139 and others will sell for $99 very soon. These are great machines for field work with battery life exceeding 11 hours even using Windows 8.1. While I have loaded numerous 64-bit servers-- I have not messed with changing the grub loader and could use a nice step-by-step instruction doc. My preference would be a guide for Mint Linux but I assume that adapting from one base to another would not be impossible. As for an individual compile I assume that takes away the updates from the repositories and in either case care would need to be taken to avoid grub updates. I would even be willing to make a contribution to the person that gets this to work for everyone. Again-- these atom processrs are not going away and are very attractive based on price and portability. Rebuttal? Takers?

dan pinto (danpinto8) wrote :

In case anyone wants to see an easy guide for getting a 32bit EFI grub working:


It worked perfectly for me.

Michel-Ekimia (michel.ekimia) wrote :

Does anybody working on this ?

Maybe we could just realeaded a 14.04.1 updated spin ?

I am a little shocked to be honest that no Linux distribution - and especially Ubuntu - hasn't caught up to this. Especially since those Intel Atom Laptops and Tablets are so very popular! Makes we wonder how committed they still are and why this is ignored?

This seems such a simple thing to fix and it is not done! Why aren't all Ubuntu Live-CDs able to boot 32-bit UEFI hardware by now?

Steven Beer (webneo82) wrote :

Same problem here with new ASUS F205TA Notebook. BIOS supports only 32 Bit UEFI boot.

There are soooo many people with know how, who can make it run: https://www.happyassassin.net/fedlet-a-fedora-remix-for-bay-trail-tablets/

Why can't Ubuntu?

After many tests I am really happy with this Fedora distribution called Fedlet on my Dell Venue 8 Pro. Wifi, Sound, everything is working! Please please please make this happen for Ubuntu :D

Steven Beer (webneo82) wrote :

Same problem with Zotac ZBOX pico mini, unable to install a Debian based distribution like Ubuntu because no bootia32.efi loader is available on boot media.

Steven Beer (webneo82) wrote :

Why Intel Bay Trail computers have only 32 Bit UEFI firmware... due to a bug which was corrected in Windows:


userdce (userdce) wrote :

Here is work from Debian developer and it installs Debian on X205:


I've got a Dell Venue 8 Pro (with an Atom Z3735G) and I'm willing to test. Feel free to get in touch with me when there is support for 32bit UEFI. I really hope we could do this even for Vivid.

sgrandi (stefano-grandi) wrote :

I've got an aspire switch 10 and I have the same issue.

lchensiang (lchensiang) wrote :

I've the same issue. I'm using voyo mini PC http://en.myvoyo.com/index.html
I tried to install Ubuntu 13.10, 14.10 and 15.05 and follow the method mention from the website, but result is same unable to boot from emmc.

I able to make Ubuntu boot from USB and installed to the emmc, but no matter how I change the efi and shell command it still not able to boot from emmc. I checked from the shell it seems every thing ok but could not understand why it could not boot from emmc.

The eMMC supported latest version 4.5, the ISP PCI device as B0D3F0 (Linux). Secure Boot is disable and secure mode is custom.

I'd also like to add my voice on having someone look into it. All it should require is running grub-mkimage a second time with -o bootia32.efi -O i386-efi.
To summarize instructions found elsewhere to fix this yourself:
Install grub-efi-ia32-bin
Run something like (a bit unsure about which modules are actually needed):
grub-mkimage -o bootia32.efi -O i386-efi -p /EFI/BOOT ntfs hfs appleldr boot cat efi_gop efi_uga elf fat hfsplus iso9660 linux keylayouts memdisk minicmd part_apple ext2 extcmd xfs xnu part_bsd part_gpt search search_fs_file chain btrfs loadbios loadenv lvm minix minix2 reiserfs memrw mmap msdospart scsi loopback normal configfile gzio all_video efi_gop efi_uga gfxterm gettext echo boot chain eval ls test sleep png gfxmenu
Then somehow get the bootia32.efi on the boot media in the location where the bootx64.efi is located (normally under BOOT/EFI on some FAT16 partition).

Sorry, the command needs to be without "-p /EFI/BOOT" (that only applies if the grub.cfg is there instead of in /boot/grub).
grub-mkimage -o bootia32.efi -O i386-efi ntfs hfs appleldr boot cat efi_gop efi_uga elf fat hfsplus iso9660 linux keylayouts memdisk minicmd part_apple ext2 extcmd xfs xnu part_bsd part_gpt search search_fs_file chain btrfs loadbios loadenv lvm minix minix2 reiserfs memrw mmap msdospart scsi loopback normal configfile gzio all_video efi_gop efi_uga gfxterm gettext echo boot chain eval ls test sleep png gfxmenu

jokker (david-las-solanas) wrote :


Just bought an Acer Switch 10, same issue... No way to boot anything. Anyone successful so far?
Tried to disable everything related to booting in the BIOS, downgraded BIOS, used rufus + jessie ISO...
Bought an OTG adaptor to have usb stick directly on the tablet micro usb port... NOTHING WORKED.
The whole purpose of buying this machine was to actually get Kali 2.0 on it... OUCH.
Should I be patient and wait for distros to get compatible one day, or just return the device?

As a reference and a potential solution to some: The Debian 64-bit netinstall image (but only that one for some reason!) works with a 32-bit UEFI.

@jokker: You can boot 64-bit Ubuntu on the Switch 10 (or any other Bay Trail Atom device) using 32-bit GRUB. You will need to compile GRUB yourself. The easiest way to accomplish this is to copy the 32-bit UEFI bootloader from a GParted LiveCD to your Ubuntu LiveUSB media, turn off Secure Boot on your tablet, and boot Ubuntu. From there you can download the source for GRUB and compile it for 32-bit.

You can also leave Secure Boot off and just install Ubuntu using the GRUB from GParted, but I don't recommend this - Secure Boot is an important feature of your computer that aids in preventing malicious code from executing pre-boot (e.g. during initial POST operations). If you compile GRUB for Ubuntu specifically it will use a signed bootloader that Secure Boot recognizes as trusted.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
TJ (tj) on 2015-08-29
Changed in grub2 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in live-build (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Zanna (rose-anna-bleasdale) wrote :

I feel real silly that I bought the Asus X205TA with the intention of installing Ubuntu for the first time (Linux for the first time! I'm a beginner) without investigating the problems. I got the USB I made to boot by copying the boot loader file as advised but I have spent almost a week trying to get an install to boot. I've yet to find any instructions on how to fix it that are simple enough for me to follow, although I've learned a huge amount in these few days! Wondering if I should just download the 32bit image (I wiped the disk so I have no OS but the live version on USB - i prefer this dismal situation to using the horror that is windows 8) which would presumably work?

The 32-bit image will only work with Secure Boot turned off and legacy or CSM boot enabled in your device's UEFI. I don't remember off the top of my head if the X205TA offers this ability, but I'm pretty sure it does.

You might be better off using Windows until 64-bit Ubuntu is stable, tbh. Windows 8 *really* isn't that bad, and you can upgrade to Windows 10 pretty much immediately, which will alleviate some of your concerns (like how different the Start screen looks compared to the old Start menu).

Zanna (rose-anna-bleasdale) wrote :

Thanks for replying! I have now fixed it, finally managed to learn enough to follow the guides effectively. Clear info on this thread helped to orient me so thank you! The aversion I feel to Windows is really really strong. Everything about the Ubuntu environment I've experienced makes me happy. Despite the issues, I'm extremely glad I switched, and my struggle has been mainly edifying rather than frustrating. I'm looking forward to fixing up other issues on the device. That said, this bug would have sent less committed users back to Windows.

Changed in debian-installer (Ubuntu):
importance: Undecided → High
Changed in live-build (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in debian-installer:
status: Unknown → New
Shih-Yuan Lee (fourdollars) wrote :

ASUS EeeBook X205TA only supports 32-bit UEFI.

Daar (dan-akbarov) wrote :

For install Ubuntu on the tablet oysters T104W also needs ia32 UEFI loader.

Виталий (7opex0) wrote :

Same thing on DEXP Ursus 10w. No IA-32 support by GRUB2

bjc (bjcatgm) wrote :

The Acer ONE S1002 has the same 64 bit atom processor with 32 bit uefi, now with 32 bit windows 10 installed. The saga continues.

This affects the Macbook 2,1 as well

Carsten Schlote (schlote) wrote :

Faced the problem today on a cheap surfpad from TrekStor. It is the "TrekStor SurfTab wintron 7.0".

I had to copy the right EFI loader from a debian stick to my ubuntu install stick.

Wouldn't it be much easier, when Ubuntu would just provide both EFI loaders, which in turn use the same boot.cfg file?

Brian Johnson (jbb-rose) wrote :

This also affects the Nextbook Flexx 11.6" tablet. I'm able to boot Ubuntu Studio 15.10 from USB, after adding a 32-bit grub executable. I can then install to a MicroSD card in the external slot, but the final installation or update of grub fails, and the result isn't bootable. Still trying to figure out how to properly install 32-bit grub on the MicroSD... no luck yet.

Zanna (rose-anna-bleasdale) wrote :

Today, using a USB that I made to live boot Ubuntu 16.04 (i posted in a bootia32.efi file, but i didn't try to boot first, so maybe it wasn't necessary as it was when i installed 14.04) on my Asus X205TA, I ran the installer (erasing the disk) and allowed it to restart. The installation booted! So apparently xenial is now shipping with this mystical 32bit UEFI bootloader. Awesome!

carlix (carlixlinux) wrote :

The file bootia32.efi is necessary I used it to boot Ubuntu 16.04, I have bought my acer aspire switch 10 and I can't boot after install it!!!

Shih-Yuan Lee (fourdollars) wrote :

Using ubuntu-16.04-desktop-amd64.iso + the ia32 EFI GRUB from the multi-arch Debian ISO can workaround this issue.

Zanna (rose-anna-bleasdale) wrote :

Confirmed, you have to replace the bootia32.efi when making USB, BUT when you install from USB with the following method, it does boot:
Select: Try Ubuntu without installing
On the desktop click: Install Ubuntu
In the options choose: Erase the disk and install Ubuntu
(that option may not be desirable for all users!)

carlix (carlixlinux) wrote :

If Debían hace support, why not Ubuntu?

Timo Kangas (timo-kangas) wrote :

Problem have been seen and analysed pretty well about year ago. No solution from Ubuntu group. Cloest one is this http://askubuntu.com/questions/392719/32-bit-uefi-boot-support. My point is that you have to be very advanced Linux user to use this workaround.

Can anyone recommend an other Linux distro?

carlix (carlixlinux) wrote :

Debian testing multiarch work out of the box

Shih-Yuan Lee (fourdollars) wrote :

Regrading Debian multiarch, I can only boot into amd64 kernel instead of i386 kernel.
Is anyone able to boot into i386 kernel by UEFI BIOS 32-bit?

antidrugue (antidrugue) wrote :

This as been mentioned earlier in this thread (see comment #7), but just to clarify :
* Debian Jessie i386 does work nicely on the Asus X205TA (cf. https://wiki.debian.org/InstallingDebianOn/Asus/X205TA)
* Debian Jessie has been working since January 5, 2015 (cf. http://cdimage.debian.org/cdimage/unofficial/efi-development/jessie-upload2/) on the Asus X205TA

So 32 bits distributions DO WORK on this machine. In the case of Debian Jessie, the installer works perfectly except for wifi. You just need to update the kernel after the initial installation -- like this for example : sudo apt-get install -t jessie-backport linux-image-686 and you're done. Nothing difficult or special.

Not sure why the UEFI 32-bit is such an issue on Ubuntu. The Debian installer has been supporting this architecture for 18 months now. I've been running Debian Jessie 32 bits on an Asus X205TA for these 18 months and all is well. Don't why "fourdollars" is not able to boot Debian Jessie 32 bits, perhaps simply a wrongly formatted image ? Don't know about Debian Testing, but Debian Stable (Jessie) just works, 32 bits and 64 bits without any workaround.

As far as other distros go - can anyone confirm if any distros other than Ubuntu have the signed kernel and UEFI bootloader required to ensure Secure Boot can remain enabled on the machine? Not everyone will necessarily be bothered by needing to disable Secure Boot, but some OEMs make it pretty arduous to do so.

AFAIK Ubuntu is the only distro that has the certs to sign the things for Secure Boot checks.

Timo Kangas (timo-kangas) wrote :

This is a very serious issue, at least for me. I bought Asus Aspire Switch 10 E and I've been fighting to install Linux to it. This has been the closest one as a solution http://www.jfwhome.com/2014/03/07/perfect-ubuntu-or-other-linux-on-the-asus-transformer-book-t100/ , but bootia32.efi is a one issue. I can't make a proper one because I have 12.04 in current laptop (because it is old and due to the graphics I can't update it). I tried also one mentioned behind the link Anyway, I was able to get to the phase where in GRUB you manually define the kernel and then you boot the machine. Everything started promising, but then it stops to error message "mount: can't find root in /etc/fstab". I checked the fstab and it looked OK. But when I checked the /dev directory there were no mmcblk-devices, only in boot-USB had them.

I also tried to use Debian-distro which is mentioned in this discussion, but it won't boot up because of the security issue. BIOS of the machine has place where is said that enable all UEFI-boots as secure but I couldn't change it.

So my hope is that we will get this mixed distro from Ubuntu.

carlix (carlixlinux) wrote :

Any progress?

Timo Kangas (timo-kangas) wrote :

Sorry to say but this type of problem solving pushes me towards ... Pishes me off.

Timo Kangas (timo-kangas) wrote :

Sorry about the typo, should be pisses me off..

Ben (ben-mueller1998) wrote :

Really wish this could get fixed for 16.10- I'm already running Ubuntu Touch/Unity 8 on my phone, but this bug is keeping me from transitioning my tablet over to Ubuntu. Sure, I can get it working with Debian as it's built into the multiboot installer at this point, but only Unity 8 can truly do the touch interface usably in my experience. It's quite confusing that this is working fine upstream in Debian but not here in Ubuntu. Can anyone explain why this is?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.