Ubuntu i386 images (install media) cannot boot in UEFI mode

Bug #1025555 reported by YannUbuntu on 2012-07-17
216
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Jonathan

Bug Description

RATIONALE:
Ubuntu 32bit (i386) images (install media) cannot boot in UEFI mode.

CONSEQUENCE:
Ubuntu-32bit installer will always try to install Ubuntu in non-UEFI mode (will not create/populate ESP and will install grub-pc). Please note that this is a consequence, and that this is not a bug in GRUB/Ubiquity.

AFFECTS:
- all users willing to install Ubuntu in dualboot with an UEFI system (generally pre-installed Windows8), on either 32 or 64bit UEFI machine.
- all users willing to install Ubuntu on a 32bit EFI computer without legacy boot support

============== Workaround ======================

If you have a 64bit UEFI machine, please use Ubuntu-64bit (=use an amd64 ISO).

If you have a 32bit UEFI machine, please:

1) install Ubuntu-32bit (i386 ISO), then convert your installed Ubuntu in UEFI mode. (see https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode ). Note: this is possible only if the firmware allows Legacy boot on install medium.

2) if your 32bit machine has a UEFI-only firmware, please also post exact Manufacturer, OEM, make, brand and model number as a comment on this bug report.
Currently known UEFI-only 32bit machines are Intel Atom 32bit System-on-a-chip based machines, such as phones & tablets as listed on: https://en.wikipedia.org/wiki/Atom_(system_on_chip)
Please note explicit Intel Atom CPU architecture has not been supported in Ubuntu for a while know. The Atom system-on-chip is a new & upcoming type of processors that are not supported by Ubuntu at the moment and further work is required to bring up an Ubuntu port to such machines. At the moment those machines have no Ubuntu ports known to be in progress.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Evertjan Garretsen (egarretsen) wrote :

i agree with the conclusions of the bug reporter

brayan bautista (braybaut) wrote :

esto afectara muchisimo bueno si ya se puedo solucionar lo de windows 8 que no dejaba arrancar un live de linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2012-10-16
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Balazs Pere (perebal-sze) wrote :

I have an ACER W510 tablet with intel Atom Z2760, which is a 32-bit CPU. This device uses UEFI, but I can only install 32-bit ubuntu on it. What can I do?

Balazs Pere (perebal-sze) wrote :

Any suggestion? Will there be 32bit Ubuntu which I can install on a 32bit arch with UEFI?

FredL (f-lahuis) wrote :

Tried making a 12.10 live usb for the ACER W510, which uses UEFI and has no legacy boot, but without success, I find this quite embarrassing for ubuntu that after half a year the importance is still listed as Undecided and no one is assigned to it. There must be many more people affected who are just put of ubuntu by this.

YannUbuntu (yannubuntu) on 2013-01-25
summary: - Ubuntu32bits is incompatible with EFI computers
+ Ubuntu32bits is incompatible with recent (UEFI) computers

Reported the issue with the download page in bug #1121692, as, bafflingly, the "also affects project" button here appears to have no way of selecting projects on Launchpad.

Colin Watson (cjwatson) wrote :

There's nothing we can do about this in GRUB. 64-bit UEFI systems require a 64-bit OS.

Ubiquity possibly ought to warn about this; except that in order to get as far as Ubiquity you must have either explicitly or implicitly switched the firmware into BIOS compatibility mode, which means that it no longer looks like UEFI to Ubiquity! Catch-22.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Won't Fix
status: Won't Fix → Invalid
Colin Watson (cjwatson) wrote :

On your point 2, if you could even run the 32-bit installer then it must *by definition* be possible to disable UEFI mode.

FredL (f-lahuis) wrote :

A main and serious problem is that there are pc's/notebooks with recent CPUs which are 32 bit which cannot be run in legacy mode, so they only support EFI. An example of that is the ACER W510 mentioned before. I cannot believe that is the only one and more will likely appear in the (near) future. So I think it would make most sense to make sure the 32bit iso does support EFI properly just like the 64 bit one.

YannUbuntu (yannubuntu) wrote :

According to #13, we cannot mark this bug "Invalid" for GRUB. For information, other computers use the same 32-bit CPU (Atom Z2760) as the ACER W510: Samsung Smart PC, Asus VivoTab Smart, HP Envy x2, Lenovo Lynx...

Concerning #12, booting the Ubuntu CD/USB in Legacy mode does not imply that the firmware is setup to boot the HDD in Legacy mode. (see example here: https://help.ubuntu.com/community/UEFI#Set_up_the_BIOS_in_EFI_or_Legacy_mode ). Nor that the firmware allows to disable UEFI for the boot on HDD.

Changed in grub2 (Ubuntu):
status: Invalid → Confirmed

On my HP Envy X2, the BIOS does no longer offer Legacy Mode. It's UEFI (32bit) only

Zach Busser (zach-busser) wrote :

I have the same problem as Marcus in #15. My HP Envy X2 is 32 bit UEFI only. I can't even boot the LiveCD, even using rEFInd or 32 bit GRUB2 compiled with EFI support.

FredL (f-lahuis) on 2013-03-12
description: updated
GSAY (george-say) wrote :

Hi I am a new Ubuntu user! I just loaded 12.10 desktop amd64. The installation went well, but when I tried to boot into the program. I was redirected into a command prompt. Please help?

Dimitri John Ledkov (xnox) wrote :

@george-say Please use support options from http://www.ubuntu.com/support before commenting on existing bug reports. This bug report may not be relevant to your case at all.

Dimitri John Ledkov (xnox) wrote :

"""
3) Installing grub-efi from an already installed Ubuntu32 creates /efi/ubuntu/boot.efi , and /efi/ubuntu/grubia32.efi . Both EFI entries fail.
"""

And how exactly was that done? 32bit installer does not create UEFI partition to correctly place efi bootloader image.
Thus to test this one has to do manual paritioning while installing 32bit installer, leave a small partition (e.g. 200MB) at the front of the disk, formatted as FAT (EFI) partition and only then install grub-efi and I would then expect the UEFI boot in 32bits to work.

I have a MacBook early 2006 edition, which is 32bit EFI-only boot with an option for bios emulation. And I have used grub-efi (grub2 that is) successfully with it in the distant past. (~Hardy time)

It is true that we do not have 32bit UEFI bootable installation media. And we have no plans on fixing that, as on the other end of the stick older 32-bit BIOS-only computers may fail to boot when detecting gpt/multiparition CD images with dual bios/uefi boot stack.

I highly daubt it's a bug in grub2-efi, and ubiquity has support for efi. The bug here is against ubuntu-cdimage project that we don't generate any 32-bit uefi capable installation media. But i'd like to see a significant market share of 32bit-only-UEFI machines before we do introduce such an image.

summary: - Ubuntu32bits is incompatible with recent (UEFI) computers
+ Ubuntu i386 images are not compatible with recent (UEFI) computers
Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-cdimage:
status: New → Confirmed
description: updated
description: updated
description: updated

Why would a bios only 32 bit machine fail to boot simply because there happens to be a directory named "efi" on the cd image with some files in it? It shouldn't know or care that the disc is efi bootable.

FredL (f-lahuis) wrote :

I also don't understand the reluctance to release 32 efi compatible media. The 64 bit media are well tested, support traditional bios hardware, efi only and efi legacy. Why would this be different for 32 bit. Leaving it with the (often non-expert) users to install it themselves with several hooks and pitfalls seems a bit weak to me from the side of ubuntu. I am a semi-experienced Linux user, but I am reluctant to do this myself.

As Dmitrijs sas "The bug here is against ubuntu-cdimage project that we don't generate any 32-bit uefi capable installation media. But i'd like to see a significant market share of 32bit-only-UEFI machines before we do introduce such an image."

What do you see as a significant markershare. There is a clear problem, a clear demand from several users, a fair number of hardware affected ... I'd say that sounds significant enough.

If it helps to launch a ticket to ubuntu-cdimage then we can of course do so.

FredL (f-lahuis) wrote :

PS . btw. ubuntu runs perfectly fine (though a bit slow) through the emulator under windows 8 on my ACER W510. So I think there is no problem with Ubuntu itself and these machines. It's indeed only the installation support which is not up to par.

On 18 April 2013 00:15, Phillip Susi <email address hidden> wrote:
> Why would a bios only 32 bit machine fail to boot simply because there
> happens to be a directory named "efi" on the cd image with some files in
> it? It shouldn't know or care that the disc is efi bootable.
>

Well there is also GPT partition table and a second EFI partition on
the image as well.
You can inspect it with `kpartx -a *.iso`. That can choke.....
I'd love to for not a single machine to regress by failing to boot the
i386 image with added UEFI support.

Regards,

Dmitrijs.

Dimitri John Ledkov (xnox) wrote :

On 18 April 2013 08:43, FredL <email address hidden> wrote:
> I also don't understand the reluctance to release 32 efi compatible
> media. The 64 bit media are well tested, support traditional bios
> hardware, efi only and efi legacy. Why would this be different for 32
> bit. Leaving it with the (often non-expert) users to install it
> themselves with several hooks and pitfalls seems a bit weak to me from
> the side of ubuntu. I am a semi-experienced Linux user, but I am
> reluctant to do this myself.
>
> As Dmitrijs sas "The bug here is against ubuntu-cdimage project that we
> don't generate any 32-bit uefi capable installation media. But i'd like
> to see a significant market share of 32bit-only-UEFI machines before we
> do introduce such an image."
>
> What do you see as a significant markershare. There is a clear problem,
> a clear demand from several users, a fair number of hardware affected
> ... I'd say that sounds significant enough.
>

The emphasis was on "32bit-only". Most of the UEFI booting by default
machines are 64bit and thus they should be using the amd64 install
media which is fully supported.
Most of the 32-bit machines are BIOS only today. (7 year old macbooks
are EFI by default, but still had BIOS boot available after Mac OS
upgrade)
In this bug report the Atom-System-on-a-Chip was identified as a 32bit
platform with UEFI-only boot option. Supporting such platform would
require creating a new install media.
I am considering to spit that task as a separate request to support
those machines.
For all other machines, they are 64-bit capable and should be using
amd64 media that works for them starting with 12.10 and 12.04.2 LTS
releases.
I don't follow, why should we adapt and create a second install media
for UEFI+64bit machines at the expense of regressing and failing to
boot older i386-bios machines.
Atom-System-on-a-Chip systems don't have an install media at the
moment, but they also were never yet supported, so it's not a
regression but a desirable feature request.

Regards,

Dmitrijs.

On a hard disk the EFI system partition is a separate partition, but I did not think this was the case on removable media. I thought for CDs you just got an /EFI directory within the normal iso9660 filesystem.

I thought the the partition table is part of the new hybrid cd stuff and is only used when you dd the image directly to a flash drive, and isn't required to boot the installer in EFI mode.

On 18 April 2013 15:29, Phillip Susi <email address hidden> wrote:
> On a hard disk the EFI system partition is a separate partition, but I
> did not think this was the case on removable media. I thought for CDs
> you just got an /EFI directory within the normal iso9660 filesystem.
>
> I thought the the partition table is part of the new hybrid cd stuff and
> is only used when you dd the image directly to a flash drive, and isn't
> required to boot the installer in EFI mode.
>

I'm not sure when/where it's needed, but it is present on the ISO. And
thus i'd expect it to be present on the burned CD/DVD and hence the
concern that older 32-bit BIOS can trip on that.

Regards,

Dmitrijs.

Steve Langasek (vorlon) wrote :

On Thu, Apr 18, 2013 at 02:29:10PM -0000, Phillip Susi wrote:
> On a hard disk the EFI system partition is a separate partition, but I
> did not think this was the case on removable media. I thought for CDs
> you just got an /EFI directory within the normal iso9660 filesystem.

> I thought the the partition table is part of the new hybrid cd stuff and
> is only used when you dd the image directly to a flash drive, and isn't
> required to boot the installer in EFI mode.

That "new hybrid CD stuff" is an integral part of all of our image builds;
and adding EFI into the mix on 32-bit definitely carries a high risk of
regressing currently-supported configurations, either as CD or as HD.

How so? The BIOS doesn't even look at the partition table when it's on a cd, and seeing an unknown partition type on a HD has never concerned the bios either.

On Thu, Apr 18, 2013 at 06:55:14PM -0000, Phillip Susi wrote:
> How so? The BIOS doesn't even look at the partition table when it's on
> a cd, and seeing an unknown partition type on a HD has never concerned
> the bios either.

In fact, it's not actually the USB boot that's the problem, but CD boot.
Because UEFI CD booting is handled using El Torito multicatalog support -
there are legacy 32-bit BIOSes that don't implement this part of the El
Torito standard correctly, and fall over hilariously when more than one boot
catalog is present. So adding UEFI to the i386 images would introduce
regressions that it's not worth tracking down.

We need a fork for this, grub2/i386-efi by default creates invalid entries.

Changed in grub2 (Ubuntu):
status: Invalid → Opinion

This fork will be modified for only loading linux and chainloader kernels, and only in UEFI mode. Remember:C language was crippled from B.

sudodus (nio-wiklund) wrote :

This bug is related to

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1173527

'Make the Ubuntu and flavours i386 (32-bit) version check for UEFI, and if found, bail out and advice to download and install the 64-bit version.'

sean (seanreynoldscs) wrote :

I have a legitimate issue with this as well.
I just bought a Dell Latitude 10 with the intended purpose of trying out ubuntu's more touch friendly features on my new atom 32bit processor.

As all dells now come with EFI instead of BIOS i'm suck until the 32bit Grub is adapted to support EFI.

I can get the 64bit ISO on a thumbdrive to be recognized by the Dell Latitude 10 inch tablet.
But when I select it to boot, it just goes to windows.

I can also get the 32bit ISO on a thumbdrive to be recognized by the Dell Latitude 10 inch tablet.
But when I select it to boot, it just goes to windows.

I believe this is an issue with Ubuntu's lack of EFI support on their 32bit ISO, and Also intels lack of Legacy support on their new Tablet.

Is there a beta version we can begin testing?

Does anyone know if you can turn off EFI on the Dell Latitude 10?

The Latitude 10 is the cheapest tablet with an intel atom processor. It seems an ideal candidate for pushing this bug up to the front.

FredL (f-lahuis) wrote :

I am a bit annoyed with Ubuntu. I had hoped that going to Ubuntu 13 32bit EFI support would be provided but ....... Why it such a big deal to provide a 32bit EFI iso?

Hidayat Yusuf (mhidayat-fx) wrote :

I have asus vivotab and seems like the only linux dist that support 32 bit of UEFI implementation is Debian EFI test CD.

i found a guide here: http://it-stuff-i-needed.blogspot.com/2013/05/my-progress-on-installing-ubuntulinux.html

but i am unable to load the kernel thus having only the grub selection page and then nothing else.

hope someone manage to get ubuntu to boot with the atom clover trail.

vaskoiii (vask) wrote :

If UEFI boot on a 32bit processor is not easily possible with linux I will be stuck with windows 8.

More Info:
Laptop: HP Envy x2
Desired Scenario: Dual booting ubuntu with windows 8

Changed in grub2 (Ubuntu):
status: Opinion → Confirmed
Steve Langasek (vorlon) wrote :

http://mjg59.dreamwidth.org/26734.html for further explanation of the problems with trying to support 32-bit UEFI.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-cdimage:
status: Confirmed → Won't Fix
Dimitri John Ledkov (xnox) wrote :

@vorlon
but ubuntu community could build a usb only d-i image to support booting those targets. As for example http://www.minnowboard.org/ does fall into this category of devices as well.

Jonathan (miareggeti) wrote :

I have heard that for EFI systems "shim" is used. "Chroot"-ing and installing shim should fix it.

I also have a solution for the GPT situation. Creating a new image for "32-bit EFI systems" could fix the problem (separating BIOS images from UEFI images).

Changed in grub2 (Ubuntu):
status: Invalid → Confirmed
Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
Jonathan (miareggeti) on 2013-09-01
Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
Jonathan (miareggeti) on 2013-09-01
summary: - Ubuntu i386 images are not compatible with recent (UEFI) computers
+ Ubuntu i386 images are not compatible with 32-bit UEFI computers

All new intel atom computers are UEFI and 32-bit.
Customers dissatisfied with windows 8 might be more likely to switch to ubuntu, if compatible.

Jonathan (miareggeti) on 2013-09-02
tags: added: intel-atom uefi
Jonathan (miareggeti) on 2013-09-02
affects: ubiquity (Ubuntu) → ubiquity
Dimitri John Ledkov (xnox) wrote :

all ubiquity bugs are only tracked in Ubuntu-Ubiquity package.

affects: ubiquity → ubiquity (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

grub-efi-ia32 is package and available, thus there is nothing needed from the grub2 package.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Jonathan (miareggeti) wrote :

WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I have only tested this when booting only ubuntu. Dual-booting has not been tested by this.
If you plan to dual-boot, then USE AT YOUR OWN RISK!!!!!!!!!!!!!!!!

==============================Workaround==============================

Note: Read ALL the instructions before preforming this, up to the set of ==== signs.

First, MAKE A FULL DISK BACKUP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Then enable "CSM" (Compatibility Support Module) or Legacy (BIOS) mode. If you do not have this option available, then this workaround will not work :( .
Boot an Ubuntu 12.04 32-bit disk. Use GParted to WIPE EVERYTHING (create a new partition table). This action can NOT be undone. Make a new partition labeled "EFI" (about 200 MB of space, FAT32 format). After the formatting completes, mount it:

sudo mount /dev/sda1 /mnt

Add a folder called "boot". This folder will be empty.
Add a folder called "EFI". Add a sub-folder called "Ubuntu". Leave it empty.
Unmount (the command is called umount, not a spelling error):

sudo umount /dev/sda1

Start the installer. Choose the "Something Else" option. Add a new "swap" partition (make it the size of your memory). Then make a new "ext4" partition with mount-point of "/". Then click the partition labeled "EFI" and select "Change". For the mount point, type in "/boot/efi" (without quotes). Click "Install now"
Ignore warnings about making a BIOS partition, or elimination of files in /etc, /usr, /var... This will not affect the EFI partition.
Reboot, remove CD/DVD when prompted. Keep legacy mode ON.
Once ubuntu has booted from the HDD (or SSD), install "Synaptic". Then launch synaptic (enter password when prompted). Use it to install "grub-efi-ia32". This will install/uninstall other programs as well. Click apply.
Wait...
Reboot. Turn legacy/CSM to OFF. Problem (should be) solved.
---
If ubuntu doesn't boot, then press a key like F9, F12, ESC, or another key to choose which device to boot. Choose "Boot from EFI file" Select a drive labeled "EFI". Select EFI. Select Ubuntu. Select "grubia32.efi" or "boot.efi". Let ubuntu boot.
---
If you are dropped to an EFI shell, do the same as above, except type "exit" (without quotes) instead of pressing a key.
---
Anything else goes wrong, use your backup to restore to its original state.
======================================================================

Jonathan (miareggeti) wrote :

I shall make a "debootstrap" based installation and remaster the image with relinux.

Changed in ubiquity (Ubuntu):
assignee: nobody → Jonathan (miareggeti)
status: Confirmed → In Progress
Changed in grub2 (Ubuntu):
status: Invalid → In Progress
assignee: nobody → Jonathan (miareggeti)
Changed in ubuntu-cdimage:
assignee: nobody → Jonathan (miareggeti)
Steve Langasek (vorlon) wrote :

> I shall make a "debootstrap" based installation and remaster the image
> with relinux.

That's fine, but that is not an Ubuntu fix for this bug because such an image will not be an official Ubuntu image; and it does not change the fact that this is *not a bug in the grub2 package*.

Changed in grub2 (Ubuntu):
status: In Progress → Invalid
assignee: Jonathan (miareggeti) → nobody
Changed in ubiquity (Ubuntu):
status: In Progress → Confirmed
Phillip Susi (psusi) wrote :

It also is not a bug in Ubiquity.

Changed in ubiquity (Ubuntu):
assignee: Jonathan (miareggeti) → nobody
status: Confirmed → Invalid
Jonathan (miareggeti) wrote :

The installer should have a warning about not installing this on UEFI PCs (if they plan to convert the install to UEFI).

Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
Phillip Susi (psusi) wrote :

The installer doesn't know the machine is UEFI capable if it was booted in legacy mode. Also they can install in legacy mode and convert later; it is just booting the installer that does not work in uefi mode.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
YannUbuntu (yannubuntu) wrote :

@Phillip: please see Bug #1228737

Jonathan (miareggeti) wrote :

Originally posted by Phillip Susi (psusi):

> The installer doesn't know the machine is UEFI capable if it was booted in legacy mode. Also they can install in legacy mode and convert later; it is just booting the installer that does not work in uefi mode.

*****
Please read this (Bug #105094940):

> So if the liveCD/USB is booted in UEFI mode (= /sys/firmware/efi exists when running Ubiquity), it does not always imply that the UEFI firmware is setup to boot the HDD in UEFI mode.

> 1) if there is an ESP with Windows EFI file, and no Legacy Windows boot files (bootmgr+boot/BCD), the firmware is setup to boot the HDD in UEFI mode, so Ubiquity must install grub-efi

Either way, ubiquity looks to see if /sys/firmware/efi exists in the live media. It should look for a FAT32 partition (with a boot flag), AKA an EFI partition, mount it, and check for any EFI files.

If efi-exists, then un-mount it, install grub-efi in the target system, and add a line in FStab for the efi-partition.
If no efi files are found, or if there is no EFI partition, install grub-pc.

Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
Jonathan (miareggeti) wrote :

This is also not a bug in grub-pc.

Changed in grub2 (Ubuntu):
status: Invalid → Confirmed
Jonathan (miareggeti) wrote :

Instead, it is a bug in grub-efi. However, since grub-efi-ia32 and grub-efi are binary packages, then this has to be marked as affecting grub2.

Steve Langasek (vorlon) on 2013-09-24
no longer affects: grub2 (Ubuntu)
no longer affects: ubiquity (Ubuntu)
sean (seanreynoldscs) wrote :

Calling it a bug or not a bug is semantics.

The fact is that you cant install ubuntu on the latest ATOM motherboards from manufacturers such as Dell because they dont have legacy boot modes, they are not 64 bit and they are EFI.

So if you want Ubuntu to work on the latest tablets, it needs to be addressed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jonathan (miareggeti) wrote :

This not only applies to the latest Intel ATOM motherboar.ds

affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jonathan (miareggeti) wrote :

Sorry, it's motherboards, not motherboar.ds!!!

Steve Langasek (vorlon) wrote :

This is NOT A BUG IN UBIQUITY. A 32-bit UEFI-only machine cannot *boot* any of the existing install media, which has nothing to do with the installer. Stop messing with the bug state.

no longer affects: ubiquity (Ubuntu)

Work for me, I used a Lenovo G480, model 20149, Intel B380. I use in dual-boot whith Windows 8 OEM 64bits single language.
After install I used "boot repair" and work perfectly.

V字龍(Vdragon) (vdragon) wrote :

The reason I'm affected by this bug is I'd lilke to make a UEFI, CSM-not-enabled machine boot my 32-bit ubuntu system(which I installed on an external USB HDD) normally without touching motherboard firmware settings..

Unless grub-efi can only run on 64-bit hardware, there must be something wrong in grub-efi to only support x86-64 architecture but not i386

YannUbuntu (yannubuntu) wrote :

Henry, this bug is not about grub-efi but about the 32bit ISO that cannot boot in UEFI mode.
grub-efi supports 32bit, but it is not installed by default by the Ubuntu32bit installer.

In your case, you can do like Rosinaldo (above):
1) install Ubuntu-32bit on your computer. (it will install in non-UEFI mode, so you cannot boot normally in it at this point)
2) run Boot-Repair from a live-disk (it will install grub-efi 32bit in your Ubuntu install)
3) now you should be able to boot normally into your installed Ubuntu (in UEFI mode)

Download full text (3.6 KiB)

The intel atom board in the dell Inspiron tablet does not let you install
in non-UEFI mode.

On Saturday, October 19, 2013, YannUbuntu wrote:

> Henry, this bug is not about grub-efi but about the 32bit ISO that cannot
> boot in UEFI mode.
> grub-efi supports 32bit, but it is not installed by default by the
> Ubuntu32bit installer.
>
> In your case, you can do like Rosinaldo (above):
> 1) install Ubuntu-32bit on your computer. (it will install in non-UEFI
> mode, so you cannot boot normally in it at this point)
> 2) run Boot-Repair from a live-disk (it will install grub-efi 32bit in
> your Ubuntu install)
> 3) now you should be able to boot normally into your installed Ubuntu (in
> UEFI mode)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1025555
>
> Title:
> Ubuntu i386 images are not compatible with 32-bit UEFI computers
>
> Status in Ubuntu CD image build software:
> Won't Fix
>
> Bug description:
> 64bits EFI computer (with GPT disk) with pre-installed 64bits Windows7.
> AND 32bits EFI computer without legacy boot support
>
> 1) Installing Ubuntu 12.04 64bit creates a valid
> /efi/ubuntu/grubx64.efi entry. At reboot, the GRUB menu appears and
> allows to boot Ubuntu.
>
> 2) Installing Ubuntu 12.04 32bits installs grub-pc, which creates no
> EFI entry. Ubuntu can't be booted (except if it is possible to
> deactivate EFI mode).
>
> 3) Installing grub-efi from an already installed Ubuntu32 creates
> /efi/ubuntu/boot.efi , and /efi/ubuntu/grubia32.efi . Both EFI entries
> fail.
>
> 4) Installing grub-efi in an already installed Ubuntu32 in chroot via
> an Ubuntu64 live-CD ( so that grub-efi has access to EFI variables)
> also creates two invalid EFI entries (/efi/ubuntu/boot.efi , and
> /efi/ubuntu/grubia32.efi ).
>
> CONCLUSION:
> - grub-efi 32bits always creates invalid entries.
> - Installing Ubuntu32 bits on an EFI system should be blocked by
> Ubiquity (the Ubuntu installer). In this case, Ubiquity should ask the user
> to install Ubuntu64 instead.
> - the Download page should warn that the 32bits ISO is not compatible
> with recent (EFI) computers
>
> === Workarounds ==
>
> If you have UEFI-only machine, please use amd64 (64-bit) images. That
> image will most likely work for you as your machine is highly likely a
> 64-bit one.
>
> If you truly have 32-bit-only CPU and UEFI-only machines please post
> exact Manufacturer, OEM, make, brand and model number as a comment on
> this bug report.
>
> Currently known machines that are affected are Intel Atom 32-bit
> System-on-a-chip based machines, such as phones & tablets as listed on:
> https://en.wikipedia.org/wiki/Atom_(system_on_chip)
>
> Please note explicit Intel Atom (CPU) architecture has not been
> supported in Ubuntu for a while know. The Atom system-on-chip is a new
> & upcoming type of processors that are not supported by Ubuntu at the
> moment and further work is required to bring up an Ubuntu port to such
> machines. At the moment those machines have limited stock, high
> pricetag and no Ubuntu ports known to be in progress.
>
> ...

Read more...

YannUbuntu (yannubuntu) on 2013-10-19
description: updated
summary: - Ubuntu i386 images are not compatible with 32-bit UEFI computers
+ Ubuntu i386 images (install media) cannot boot in UEFI mode
YannUbuntu (yannubuntu) wrote :

Hello Sean,
can you access a Ubuntu-32bit live session ? in other words, can you boot your Ubuntu-32bit install medium and choose "Try Ubuntu" ?

No it won't let you get that far.

Sent from my NSA wiretapped Phone

> On Oct 19, 2013, at 11:41 AM, YannUbuntu <email address hidden> wrote:
>
> Hello Sean,
> can you access a Ubuntu-32bit live session ? in other words, can you boot your Ubuntu-32bit install medium and choose "Try Ubuntu" ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1025555
>
> Title:
> Ubuntu i386 images (install media) cannot boot in UEFI mode
>
> Status in Ubuntu CD image build software:
> Won't Fix
>
> Bug description:
> RATIONALE:
> Ubuntu 32bit (i386) images (install media) cannot boot in UEFI mode.
>
> CONSEQUENCE:
> Ubuntu-32bit installer will always try to install Ubuntu in non-UEFI mode (will not create/populate ESP and will install grub-pc). Please note that this is a consequence, and that this is not a bug in GRUB/Ubiquity.
>
> AFFECTS:
> - all users willing to install Ubuntu in dualboot with an UEFI system (generally pre-installed Windows8), on either 32 or 64bit UEFI machine.
> - all users willing to install Ubuntu on a 32bit EFI computer without legacy boot support
>
>
> ============== Workaround ======================
>
> If you have a 64bit UEFI machine, please use Ubuntu-64bit (=use an
> amd64 ISO).
>
> If you have a 32bit UEFI machine, please:
>
> 1) install Ubuntu-32bit (i386 ISO), then convert your installed Ubuntu
> in UEFI mode. (see
> https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode
> )
>
> 2) if your 32bit machine has a UEFI-only firmware, please also post exact Manufacturer, OEM, make, brand and model number as a comment on this bug report.
> Currently known UEFI-only 32bit machines are Intel Atom 32bit System-on-a-chip based machines, such as phones & tablets as listed on: https://en.wikipedia.org/wiki/Atom_(system_on_chip)
> Please note explicit Intel Atom CPU architecture has not been supported in Ubuntu for a while know. The Atom system-on-chip is a new & upcoming type of processors that are not supported by Ubuntu at the moment and further work is required to bring up an Ubuntu port to such machines. At the moment those machines have limited stock, high pricetag and no Ubuntu ports known to be in progress.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-cdimage/+bug/1025555/+subscriptions

YannUbuntu (yannubuntu) wrote :

Thank you Sean.
In cases like yours (32bit machine with firmware that cannot Legacy boot on install medium), there is absolutely no way to install&use Ubuntu unless this bug gets fixed.
As Ubuntu devs do not want to maintain an official 32bit ISO that can be booted in UEFI mode, your only hope is a contributor building an unofficial one.

For our info, please could you attach pictures of your firmware menus?

description: updated
Renaud (renaud15000) wrote :

Hi, Windows 8 32-bit is installed on my netbook and i can not install any other system because there is no BIOS, there is only an UEFI 32 bit.

Manufacturer : Packard Bell
Model : Easynote (EN)ME69BMP
Processor : Intel Celeron N2805 (64-Bit)
UEFI version : Insyde Corp V 2.07 32-Bit, 11/11/2013

If you need more information contact me via the link "contact this user" on my profil.

Shaya Potter (spotter) wrote :

I'd note that in the description for the bug it states

"At the moment those machines have limited stock, high pricetag and no Ubuntu ports known to be in progress."

I'd note that the new bay trail tablets can be had for $200 or less (the dell venue 8 pro has been readily available at $200 recently).

YannUbuntu (yannubuntu) wrote :

thanks Shaya, I removed that sentence.

description: updated

I just bought an HP Envy X2, it is a 32bit Intel Atom system with UEFI boot only (no legacy mode).

Please add support for this kind of systems, even if it is a netinstall or minimal image.

Thanks,

Alex.

Current generation Intel Atom-based tablets use a 64-bit processor a 32-bit UEFI firmware. In order to run Ubuntu (32-bit or 64-bit) on one of these machines, Grub2 MUST be provided in a 32-bit binary.

It is categorically false that one cannot install 32-bit or 64-bit Ubuntu on a machine with a 32-bit UEFI implementation. I'm stting here writing this comment on that exact configuration - an Acer Aspire Switch 10 with a Bay Trail Intel Atom CPU and a 32-bit UEFI firmware. I had to compile Grub2 myself in order to get it working, and I'm still working out wrinkles in it, because manually configuring Grub2 to load an OS is a giant PITA.

At this point, there are a number of popular devices from major OEMs that use a 32-bit UEFI implementation, and contrary to what some devs have insisted in this thread, there is zero technological limitation to providing a 32-bit Grub2 binary with the official Ubuntu release.

Colin Watson (cjwatson) wrote :

It's not about whether we provide a 32-bit UEFI GRUB; we do, it's in the grub-efi-ia32 package. The thing that's troublesome is making the i386 images include BIOS/UEFI hybridisation without breaking systems with inadequate El Torito implementations in their BIOSes, which is a rather thornier problem.

I can't really speak to other devices that I don't own and haven't tried Ubuntu on, but on the one I have (Acer Aspire Switch 10), the UEFI intelligently uses the 32-bit Grub EFI if it's there. It's also possible to use the 32-bit Grub EFI with the amd64 images.

My concern is more that in this bug report, multiple devs have made it clear that they have chosen to actively refuse to even consider adding 32-bit EFI support to Ubuntu. At this point, while there may be other issues at play WRT supporting 32-bit EFI on mulltiple different devices (I'll be happy to help test that, btw, I work at a computer store and can test liveCD booting on a variety of 32-bit EFI devices with Atom CPUs), the issue is that (a) there are devs claiming it's impossible to boot an amd64 Ubuntu build on 32-bit EFI (it isn't) and (b) there aren't enough commodity devices with 32-bit EFI to make the effort worthwhile (also false; there are a variety of 32-bit EFI devices with Atom CPUs in the consumer OEM market, and their price point is making them very, very popular with both consumers and businesses).

It seems very short-sighted to flat-out refuse to work on 32-bit EFI support for Ubuntu.

Also, not sure if I can edit my above comment, so I also want to add that in the Bay Trail Atom hardware I've used, none of them have a hybrid or CSM-compatible UEFI. It's all straight UEFI now.

The only OEMs left that are using hybrid environments are major companies that make hardware for enterprise environments.

Is the ia32 Grub package available in apt or does it have to be added manually?

Saurabh Rawat (eklavya) wrote :

Hi,

I bought a new HP x2 with baytrail hardware. It is 64 bit capable and all the 64 bit images work fine. The problem comes when some projects like kubuntu active and neon5 for sme unknown reasons only have 32 bit images.

Testing Kubuntu Active is important because earlier we didn't have easily accessible (cheap) x86 tablets, now with the market flooded with windows 8 hybrids/tablets, we can do it.

Having no way to run thses as live disks is a problem, I wish they made 64 bit images available or we could boot 32 bit images on UEFI only systems.

My 2 cents.

Regards,

Saurabh Rawat

Jost Menke (jmenke) wrote :

Odys WinTab 10 (Bay Trail Tablet) is also affected. 32 Bit UEFI, no legacy support. Product page:

http://www.odys.de/web/tablet-pc_wintab10_de.html

Jost Menke (jmenke) wrote :

FYI, there are 2 Debian Boot CDs with 32 bit UEFI support:

http://cdimage.debian.org/cdimage/unofficial/efi-development/upload4/

debian-wheezy-i386-efi-test4.iso and debian-wheezy-amd64-i386-MA-efi-test4.iso will usually boot just fine on 32 bit UEFI machines that have no legacy mode. Maybe Steve McIntyres work can be adapted to create 32 bit UEFI install media for Ubuntu.

V字龍(Vdragon) (vdragon) wrote :

Hi, there's a new "Lemel Lemel" Intel solution TV stick pre-installed Windows 8 that uses 32-bit UEFI, Ubuntu should really reconsider support them.
http://www.nownews.com/n/2014/10/13/1453235

Workaround:
1. Make sure GPT & EFI system partition available
2. Install Ubuntu using debootstrap
3. setup /boot/efi, / filesystem in /etc/fstab
4. install grub-efi package

V字龍(Vdragon) (vdragon) wrote :

Grub x86 32bit standalone EFI application that can use to boot Ubuntu and it's live installation media
https://drive.google.com/file/d/0B3e9XCL1ZWE8M2pYRmNOLVVNeVk/view?usp=sharing

V字龍(Vdragon) (vdragon) wrote :

UPDATE: the official product name mentioned in #77 should be "Lemel Compute Stick", as far as I can see there are two ways to install 32-bit Ubuntu.

Is is important to point out a couple things with content of this actual bug report:

* Bay Trail Atom SOCs are NOT 32-bit. They are 64-bit with a 32-bit UEFI implementation.
* Intel has contributed an enormous amount of effort to the 3.17 kernel and has specifically aided in comprehensive support of the Bay Trail Atom product line.
* Atom is not special architecture and doesn't have particularly complex hardware, nor is it a nonstandard component in consumer hardware - with that in mind, why are the Ubuntu developers considering forking or porting Ubuntu? The improved support in the 3.17 Linux kernel should be a very strong indicator that Ubuntu's mainline release should be able to support Atom-based devices.

I very much appreciate that the developers are finally researching adding proper support for Atom (and, more importantly, 32-bit UEFI), but I think it's absolutely critical that the appropriate information and semantics be included in this bug report and any other documentation regarding this hardware.

StridAst (stridast76) wrote :

pipo w2 windows tablet is effected. 32 bit UEFI and no legacy. bay trail cpu

this is a long standing bug that really should be addressed =/ 32 bit UEFI systems are NOT going away, by now the number of devices using this setup has substantially increased, and shows no signs of stopping anytime soon. Considering everyone hates windows 8 and 8.1 why would anyone want to use windows on such a device if there was a viable alternative.

so far, all we have is intensive workarounds, with buggy installations, yet many of us, (me included) are trying to install ubuntu still, just because to many of us, even a buggy ubuntu install, that takes forever to figure out how to do, is still better then windows 8.1

@ #77 any better info on how to install with debootstrap? I'll google that and try to figure things out, but why would it be easier then installing from USB with a bootia32.efi file and trying to manually configure grub? (which is admittedly quite a bit harder done then said)

Piotr Maliński (riklaunim) wrote :

It's not rocket science. The ISO just needs to support 32-bit UEFI for GRUB and install with that support. I did that for Lenovo Flex 10 http://www.rkblog.rk.edu.pl/w/p/how-cool-lenovo-flex-10-netbook-and-how-install-linux-32-bit-uefi-system/ and it works :)

And for touch screens Windows 8/8.1 is ahead of Linux (not counting specialized UIs like Ubuntu Touch).

dortonway (yapavlenkov-8) wrote :

Piotr Maliński (riklaunim), I don't see such option to run from flash on my Samsung Ativ Smart, and in "BIOS" in "Boot override" section - too :(
https://www.dropbox.com/s/yx6e01ujqtbnuop/IMG_20141102_023952.jpg
https://www.dropbox.com/s/nja1wfh2vxov3ms/IMG_20141102_023836.jpg?dl=0

Piotr Maliński (riklaunim) wrote :

Strange. Boot override options show up after something else was used for booting. If it doesn't show options to boot to other UEFI devices then maybe it's locked to windows only. Or maybe somewhere in that BIOS-alike settings app there is an option to allow it.

Jay Davis (fenwayjay) wrote :

The devs are severely overthinking this problem and are getting hung up on blog posts, opinions and other nonsense. The problem affects installing the 64 bit version of Ubuntu on 64 bit CPUs that only have 32 bit UEFI support and no legacy BIOS support. All that needs to happen is the grub install for 64 bit for UEFI needs to include both 32 bit and 64 bit binaries. The UEFI spec defines exactly how to have them coexist without issue. Why so much resistance when there's such a simple fix that impacts nothing else in any significant way?

Colin Watson (cjwatson) wrote :

It's true that it's easier than we previously thought now that it would
appear that we only principally need to be concerned with systems that
have a 64-bit CPU and 32-bit firmware; there was confusion about this in
the past. That means we get to dodge the problem of certain 32-bit-only
systems that fail to boot images with multiple El Torito boot images.

However, it's not quite as trivial in practice as Jay Davis suggests in
comment #85, when you actually look at the specific tasks we need to
perform. We need two pieces of information before we can make this
work:

 * An interface to discover from userspace whether the system was booted
   using 32-bit or 64-bit UEFI (this is needed in order to install the
   correct GRUB platform packages on the target system; such an
   interface may exist but we do not currently know what it is)

 * Resolution of a claim by Dimitri John Ledkov that CONFIG_EFI_MIXED
   isn't currently working properly on either Ubuntu or Fedora with a
   64-bit kernel, 32-bit firmware, and 32-bit boot loader; he's going to
   follow that up with folks at Intel

We should also make sure that Secure Boot support is in place, both
because it may end up being functionally required on some systems, and
because it makes our code considerably more robust if 32-bit and 64-bit
UEFI work essentially the same way.

Once we have these, then the steps are:

 * Make grub-installer use the interface above to decide which GRUB
   platform packages to install

 * Fix the grub2 packaging to build linuxefi for grub-efi-ia32 as well
   (I just pushed the necessary changes to Debian's grub2 git
   repository)

 * Modify shim to build 32-bit binaries as well, and get them signed

 * Modify shim-signed.postinst to use --target=i386-efi rather than
   --target=x86_64-efi where necessary

 * Modify debian-installer to add binaries from grub-efi-ia32-bin to the
   amd64 images it produces

 * Modify Ubuntu's debian-cd branch to put a 32-bit UEFI image in the
   right place (may require coordinated changes with the previous item;
   debian-installer currently emits grub/efi.img, which isn't very
   specific)

That's past the threshold of changes where we can reasonably just wing
it, so I believe Adam Conrad is going to look into expensing a suitable
system with the aim of being able to test this properly as we make the
necessary changes. I certainly hope we can make this happen for Ubuntu
15.04.

FredL (f-lahuis) wrote :

This is not what the original posted problem was about, that deals with 32 bit images on 32 EFI only architecture.

Jay Davis (fenwayjay) wrote :

FredL (#87), then this is NOT a duplicate of bug #1341944.

Dimitri John Ledkov (xnox) wrote :

@cjwatson

It also would be nice to request 32bit build of OVMF - then qemu-kvm VM can be used to test this (32-bit firmware + 64-bit capable CPU).

I filed such a request to Steve Langasek before on Debian BTS.

Andrew Clausen (clausen) wrote :

The bug is currently marked WONTFIX, even though Colin Watson indicated in comment #86 that he hopes this can be fixed for Ubuntu 15.04. Please mark the bug correctly (as IN PROGRESS or ASSIGNED or CONFIRMED). Thanks.

So, uh, any updates on this? Since the status wasn't changed, we can assume that this won't be included in 15.04?

carlix (carlixlinux) wrote :

Same problem with acer aspire 10 switch

Bug 1341944 is open, high priority, and tagged with all the related projects.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers