Comment 15 for bug 1341944

Revision history for this message
dan pinto (danpinto8) wrote :

I can confirm being able to boot into an Ubuntu 14.10 64bit live usb by manually adding a 32bit compiled grub2 on my Asus x205ta which has a 64bit Bay Trail Atom CPU but only supports 32bit EFI.

It was able to install ubuntu until the bootloader part. It installed a 64bit EFI bootloader but that wouldn't work. I then tried adding the same efi I used on the livecd but I just get stuck at grub when I select it via rEFInd. I attempted to follow some instructions online to load linux from grub but was unsuccessful.

It would be great to add 32bit UEFI support. My guess is that at minimum you would need to add a 32bit EFI on the livedisk and in the grub2 installation stage add a check for 32bit only EFI and install 32bit grub with correct grub configuration. Everything else seemed to worked fine in the live usb stage when I tested.

I will try see if I can get the grub config figured out on my end this weekend but I'll need to learn how to set up grub2.