initrd boot fails when memory more than 4G

Bug #9096 reported by Nathan Myers on 2004-10-14
This bug report is a duplicate of:  Bug #8301: Bootloader does not start the kernel. Edit Remove
6
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
High
Tollef Fog Heen

Bug Description

During boot from the default amd64 installation kernels, if there is more than
4G of RAM (I have 8G), the initrd step reports that there is not enough memory
to continue. Booting with "mem=2G" allowed booting to proceed.

This problem did not occur in the 8-Oct-2004 snapshot.

Matt Zimmerman (mdz) wrote :

Can you provide the exact text of the error message?

You say the October 8th CD worked; which one failed?

Nathan Myers (ncm) wrote :

The failure is occurring with a system installed from the released 4.10 image.
Exact text is

  ...
  initrd /initrd.img-2.6.8.1-3-amd64-k8-smp
     [Linux-initrd @ 0xdbb77000 0x469000 bytes]

  Error 28: Selected item cannot fit into memory.

This occurs with any amd64 kernel. (I haven't tried any 386 kernels.)
Adding boot options "mem=6G" or "mem=8096M" allows booting to proceed
normally.

Hardware is a dual Opteron 2.2GHz, Tyan motherboard, 8G RAM, Broadcom
gigabit ethernet, SII SATA disk, Nvidia 5200 video.

Nathan Myers (ncm) wrote :

Change component id to "grub", as the error message appears to come from
grub/stage2.

Matt Zimmerman (mdz) wrote :

This looks like bug #8301 / bug #8608, which was already fixed.

There is no released 4.10 image. What is the exact URL of the ISO you downloaded?

Nathan Myers (ncm) wrote :

It's the version that I downloaded immediately when it was announced yesterday
on LWN: http://lwn.net/Articles/106407/.

The link on that page points to a different page than it did yesterday, though,
and the
file names differ. I installed from a file named warty-amd64.iso with md5sum
d7406b032482e22d696fbaebc2ffe562, which differed from the 8 Oct. snapshot of
the same name with sum a9b7d6567b599132c18ab6c15553c6ce, and from what is
currently there with sum 31bf30d904f1efd0b922f322205db89d and named
warty-rc-install-amd64.iso. There was a tantalizing hint that the image I had
installed from was actually a 15-September snapshot. Somebody needs to be more
careful about the download site, I think.

Confusing, what? Anyway, I did an "apt-get dist-upgrade", which grabbed a lot
of packages (mostly gstreamer), and (crucially) did a grub-install. All is now
well.
 Thanks.

This bug has been marked as a duplicate of bug 8297.

Matt Zimmerman (mdz) wrote :

Confirmed that the md5sum you gave matches the (old) preview release CD:

./releases/warty/preview/MD5SUMS:d7406b032482e22d696fbaebc2ffe562 warty-amd64.iso

Sebastien Bacher (seb128) wrote :

This bug has been marked as a duplicate of bug 8301.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.