gparted does not detect sdb

Bug #60868 reported by Paul Coleman on 2006-09-17
94
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: gparted

Edgy's gparted does not detect the second sata sdb drive. It is detected by Dapper's gparted and is mountable in edgy.

Jeff Greene (jeffgreene) wrote :

This happened with me also, I have confirmed it is a problem with Edgy and not GParted here:
http://bugzilla.gnome.org/show_bug.cgi?id=357384

Changed in gparted:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) on 2006-09-27
Changed in gparted:
assignee: nobody → kamion
importance: Undecided → High
Vassilis Pandis (pandisv) wrote :

I can confirm this as well. I worked around it with "gparted /dev/sdb" from a command line.

I just tried the graphical edgy installer and it didn't detect /dev/hdb!
It's listed in the possible install sources and if you select "use whole disc" it works, but you can't set the partitions by hand. It only finds hda in this case. (which is my windows HD ...)

Jeff Greene (jeffgreene) wrote :

In that case, stop the installer and run GParted manually by typing: gparted /dev/hda /dev/hdb which will detect both drives. Partition it manually with gparted and then try running the installer again. You won't be able to make partition changes to /dev/hdb, but I believe you will be able to install it that way..

Colin Watson (cjwatson) wrote :

gparted (0.2.5-1.1ubuntu10) edgy; urgency=low

  * Improve code to distinguish between devices and partitions so that it no
    longer assumes that /dev/hdb, /dev/sdb, etc. are partitions (closes:
    Malone #60868).

 -- Colin Watson <email address hidden> Tue, 3 Oct 2006 13:52:23 +0100

Changed in gparted:
status: Confirmed → Fix Released
Vincent (vinnl) wrote : HowTo

I just wanted to post how I managed to set the mount points of my partitions, because it took me a while (and a few installs) to find it out. I hope it helps someone.

First I partitioned my hard disk in a terminal window with "sudo gparted /dev/hdb". Then I started the installer, and selected "Manually Edit Partition Table". It did not recognize /dev/hdb but I just clicked "Forward". There I found out I could set the mount points! Wow!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers