Call to undefined function get_gosa_version()

Bug #370505 reported by Nick Barcet on 2009-05-01
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gosa (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gosa

upon installing GOSa, accessing http://localhost/gosa returns the following error:

Fatal error: Call to undefined function get_gosa_version() in /usr/share/gosa/include/php_setup.inc on line 80

Nick Barcet (nijaba) wrote :

This error occurs on Jaunty. Other versions untested.

Nathan Eriksmoen (neriksmoen) wrote :

I was able to access it after modifying a few files:

1) /usr/share/gosa/html/index.php

old:
  require_once ("../include/php_setup.inc");
  require_once ("functions.inc");

new:
  require_once ("../include/functions.inc");
  require_once ("../include/php_setup.inc");

2) /usr/share/gosa/include/php_setup.inc

old:
  /* Do smarty setup */
  require("/usr/share/php/smarty/lib/Smarty.class.php");

new:
  /* Do smarty setup */
  require("/usr/share/php/smarty/Smarty.class.php");

Ace Suares (acesuares) wrote :

it is in Karmic too.

Confirmed in my Januty install, and Nathan's fix works. Thanks Nathan!

Changed in gosa (Ubuntu):
status: New → Confirmed
Kal McFate (kmcfate) wrote :

Fix works in karmic as well.

I am using Karmic. I applied the fixes Nathan Eriksmoen posted, but now I get a new error:

Fatal error: Call to undefined function print_array() in /usr/share/gosa/include/class_dhcpPlugin.inc on line 206

I would like to confirm that this exists in Ubuntu 9.10 too. After applying the fixes posted by Nathan Eriksmoen I got this:

Fatal error: Call to undefined function print_array() in /usr/share/gosa/include/class_dhcpPlugin.inc on line 206

Is there any solution to this?

Grateful for help

Pramathesh

Roland Orre (roland-orre) wrote :

So, now I've been struggling with LDAP too long. This gosa obviously doesn't work.
Is LDAP really completely unusable?
What administration tool should one use for LDAP really?
I'm in urgent need of a network authentification system, but nowhere I'm able to find
any kind of doc saying simply what to do.
The doc at
http://doc.ubuntu.com/ubuntu/serverguide/C/openldap-server.html
wasn't really helpful as it stays at too low level.

It would be great if one could get hints about how to administrate the system already at the installation (e.g. in synapse), and how come that this gose system is not even possible to run?
OK, it's from universe so one shouldn't expect it to be tested.
Sorry if my comments were out of subject, but nowhere I can find a simple doc saying what simple network authentification system to use, and how to sync the info with shadow and passwd, and here I see that one month has passed, without further comments on how to fix the problem to make gose runnable.

I was tying to install gosa(apt-get install gosa gosa-schema ldap-utils) in Karmic(9.10) and got the following error:
 "Fatal error: Call to undefined function get_gosa_version() in /usr/share/gosa/include/php_setup.inc on line 80"

So I tryed the Nathan`s fix and got the following error:
"Fatal error: Call to undefined function print_array() in /usr/share/gosa/include/class_dhcpPlugin.inc on line 206"

After that, i tryed to instal the slapd alone, and:
The OpenLdap, In Karmic(9.10) , there is a problem in the scrpits installation.
It is not asking the "admin password", and any other question of the initial set of questions on the installation.
I believe that is because the changes on the conf. files of the sladp (there is no more slapd.conf).

There is thread on UbuntuForum that has the solution to this problem:
http://ubuntuforums.org/showthread.php?t=1313472
    I followed the procedure and when i do an ldapsearch, it answers good.

    P.S.: There is already a bug report about the "OpenLDAP server instructions out of date":
    https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/459403

After a had putted the slapd to run correctly, I got back to GOSA, and again I got th following error:
Fatal error: Call to undefined function print_array() in /usr/share/gosa/include/class_dhcpPlugin.inc on line 206

Andrew Schulman (andrex) wrote :

This appears to be caused by bug #487537. The solution is to upgrade to a more recent version of gosa. The gosa developers kindly provide .deb package files at http://oss.gonicus.de/pub/gosa/debian-lenny/.

Andrew Schulman (andrex) wrote :

A clarification: to get the newer gosa debs from upstream, create /etc/apt/sources.list.d/gosa containing the single line

deb http://oss.gonicus.de/pub/gosa/debian-etch/ ./

(Equivalently, go to System > Administration > Software Sources > Other software > Add, and enter the above line as the APT line.) Then update, and you can install gosa 2.6.9, where this problem is fixed.

For the problem in the Instalation of GOSA
Fatal error: Call to undefined function print_array() in /usr/share/gosa/include/class_dhcpPlugin.inc on line 206
for delete gosa the comand is:
apt-get purge --remove gosa

is an error of database of ldap. do you need coment the archive in:

 sudo joe /etc/apt/sources.list
in the end add this:
deb http://oss.gonicus.de/pub/gosa/debian-etch/ ./

and add the enter o space, next need update the repositories and do:
apt-get update

for final step:
apt-get install gosa
this instalation has 2 questions this answers is YES

Changed in gosa (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers