gnome-terminal auto-restores its size

Bug #1040885 reported by Jean-Baptiste Lallement
580
This bug affects 117 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Medium
gnome-terminal (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

Occurs on Quantal and Raring

TEST CASE
1. Press CTRL+ALT+T to launch a terminal
2. Press CTRL+SHIFT+T to open a new tab
3. Make sure the second tab is active and resize the window (Alt+Middle mouse button or Windows handles)
4. Click on the desktop

ACTUAL RESULT
Size of the terminal is restored to its initial size. It doesn't occur if the window is resized while first tab is active.

EXPECTED RESULT
The terminal doesn't autoresize with the user clicks on the desktop

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-terminal 3.5.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu1
Architecture: amd64
Date: Thu Aug 23 23:21:07 2012
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to quantal on 2012-01-31 (204 days ago)

Related branches

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Para Siva (psivaa)
tags: added: rls-q-incoming
Didier Roche (didrocks)
tags: added: rls-q-notfixing
removed: rls-q-incoming
Revision history for this message
DavidJB (davidjb) wrote :

Seems for me if I change to the first terminal tab, resize and change focus, the size stays consistent if I come back and then change tabs. Any further resizes after this are then resized back to the state after the first resize.

Revision history for this message
_dan_ (dan-void) wrote :

Happens here aswell.

Revision history for this message
David A Sinck (bugs+ubuntu) wrote :

seems resolved for me after recent update/upgrade on 6-Nov-2012

Revision history for this message
_dan_ (dan-void) wrote :

No, still happens, for me at least.

Revision history for this message
David A Sinck (bugs+ubuntu) wrote :

... and it's back on later upgrade. Not sure the circumstances but for a bit at least it *was* good.

Changed in gnome-terminal:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

Reported upstream, with more findings and a workaround patch, at http://bugzilla.gnome.org/show_bug.cgi?id=688959

Revision history for this message
Jeremy Nickurak (nickurak) wrote :

FYI, this was already reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=685507, which I just marked yours a duplicate of (and pointed out the "workaround patch").

Revision history for this message
Sébastien Pierre (sebastien-type-z) wrote :

Still happens for me 2012-11-30

Revision history for this message
Feisar (f3isar) wrote :

Yeah, I'm fully updated and still get this. Two tabs, resize, click anywhere else and the terminal jumps back to the default size.

Revision history for this message
Egmont Koblinger (egmont-gmail) wrote :

The official mainstream fix is at
http://git.gnome.org/browse/gnome-terminal/commit/?id=611e93f2f8c0c18ed8d365ecb850258e8d5c9c12

Given how annoying this bug is (and how small and trivial the patch is), could you guys please consider backporting the fix to Quantal?

Revision history for this message
asimsalam (asimsalam) wrote :

Is there any news on Egmonts request for backport to Quantal?
For folks like myself who spend most of their time on a terminal window, this has significiant impact.

Changed in gnome-terminal:
status: Confirmed → Fix Released
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

I apparently move terminal windows less than other people :) So coming to raring soon, backport for quantal sounds like a good idea. If you want to do it, branch lp:ubuntu/quantal/gnome-terminal, add the patch and test that it works (bzr builddeb + dpkg -i), propose for merging back to that branch and see https://wiki.ubuntu.com/StableReleaseUpdates#Procedure.

Revision history for this message
Alexander Karlstad (alexander.karlstad) wrote :

Has the fix been pushed to quantal? Do I need to add quantal-proposed? I'm still having issues with this.

Revision history for this message
MC Return (mc-return) wrote :

This bug is still valid on Raring.

tags: added: raring
description: updated
Revision history for this message
Ákos Maróy (akos-maroy) wrote :

this is still not working on 12.10 :(

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Patch works fine here (patched gnome-terminal 3.6.0 in 12.10 with patch @ https://git.gnome.org/browse/gnome-terminal/patch/src/terminal-window.c?id=611e93f2f8c0c18ed8d365ecb850258e8d5c9c12). I'll report back if I hit some regressions ..

Revision history for this message
Marius Gedminas (mgedmin) wrote :

I built a patched gnome-terminal in my PPA: https://launchpad.net/~mgedmin/+archive/ppa

Revision history for this message
Codagnoni (codagnoni) wrote :

Patch didn't work for me (gnome-terminal 3.6.0 in 12.10 with the patch from comment #18).

I've uploaded a video showing the problem with the patched gnome-terminal, please view it @ http://youtu.be/gKcnYiWcSCw

Revision history for this message
Øyvind Stegard (oyvinst) wrote : Re: [Bug 1040885] Re: gnome-terminal auto-restores its size

Codagnoni <email address hidden> writes:

> Patch didn't work for me (gnome-terminal 3.6.0 in 12.10 with the patch
> from comment #18).
>
> I've uploaded a video showing the problem with the patched gnome-
> terminal, please view it @ http://youtu.be/gKcnYiWcSCw

You need to do a "killall gnome-terminal" or start new gnome terminal
with "--disable-factory" before testing. The new binary isn't actually
loaded, but just spawns a new window in the already running (old)
binary, due to gnome-terminal using factory.

Øyvind

Revision history for this message
Codagnoni (codagnoni) wrote :

Living and learning.

Patch DID work now (gnome-terminal 3.6.0 in 12.10 with the patch from comment #18).

Thanks.

Revision history for this message
Tory (tory-andrew-law) wrote :

I still had this problem in in 13.04, I applied the patch from comment #12, built from source, and now it is working as it should.

Revision history for this message
pureblood (freeseek) wrote :

I can confirm the problem still exist in the final release of Ubuntu Raring and it is indeed very annoying.

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Fix is included in upstream gnome-terminal 3.6.2:
http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/3.6/gnome-terminal-3.6.2.news

It's also the only fix in addition to some translation updates. So an upgrade to gnome-terminal 3.6.2 in Ubuntu 13.04 would be nice..

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu Quantal):
status: New → Confirmed
Changed in gnome-terminal (Ubuntu Raring):
status: New → Confirmed
Revision history for this message
Mike (sugarhigh4242) wrote :

Yes, I'm also seeing this on 13.04.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.6.1-0ubuntu5

---------------
gnome-terminal (3.6.1-0ubuntu5) saucy; urgency=low

  * debian/patches/00_git_fix_geometry_on_focusout.patch:
    - backport an upstream patch to not resize the geometry when having tabs
      on focus out (LP: #1040885)
 -- Didier Roche <email address hidden> Thu, 18 Jul 2013 09:51:40 +0200

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
wzzrd (maxim) wrote :

Can this please be built for and / or backported to Raring?

Julian Taylor (jtaylor)
Changed in gnome-terminal (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in gnome-terminal (Ubuntu Raring):
status: Confirmed → Triaged
Iain Lane (laney)
Changed in gnome-terminal (Ubuntu Raring):
status: Triaged → In Progress
Changed in gnome-terminal (Ubuntu Quantal):
assignee: nobody → Iain Lane (laney)
status: Triaged → In Progress
Changed in gnome-terminal (Ubuntu Raring):
assignee: nobody → Iain Lane (laney)
Revision history for this message
Iain Lane (laney) wrote :

Uploaded to Quantal and Raring, thanks for the patches.

Changed in gnome-terminal (Ubuntu Raring):
assignee: Iain Lane (laney) → nobody
Changed in gnome-terminal (Ubuntu Quantal):
assignee: Iain Lane (laney) → nobody
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Jean-Baptiste, or anyone else affected,

Accepted gnome-terminal into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-terminal/3.6.1-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-terminal (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-terminal (Ubuntu Quantal):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted gnome-terminal into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-terminal/3.6.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Kyle Gordon (kylegordon) wrote :

This appears to resolve the issue for me, on Raring with package version 3.6.1-0ubuntu4.1

tags: added: verification-done
tags: removed: verification-needed
Revision history for this message
humboink (humboink) wrote :

confirmed fix for me on gnome-terminal/raring-proposed (3.6.1-0ubuntu4.1)

Revision history for this message
Julian Taylor (jtaylor) wrote :

fixed for me in gnome-terminal (3.6.0-0ubuntu1.1) quantal-proposed

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.6.0-0ubuntu1.1

---------------
gnome-terminal (3.6.0-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches/00_git_fix_geometry_on_focusout.patch:
     - backport an upstream patch to not resize the geometry when having tabs
       on focus out (LP: #1040885)
 -- Julian Taylor <email address hidden> Wed, 02 Oct 2013 19:11:49 +0200

Changed in gnome-terminal (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.6.1-0ubuntu4.1

---------------
gnome-terminal (3.6.1-0ubuntu4.1) raring-proposed; urgency=low

  * debian/patches/00_git_fix_geometry_on_focusout.patch:
     - backport an upstream patch to not resize the geometry when having tabs
       on focus out (LP: #1040885)
 -- Julian Taylor <email address hidden> Wed, 02 Oct 2013 19:11:49 +0200

Changed in gnome-terminal (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.