[network-admin] bad format of /etc/hosts make slow Gnome Startup if no lan connection is on with static IP

Bug #80827 reported by Iacopo Masi on 2007-01-21
16
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned

Bug Description

I think this bug is similar to #9718 and #78493.
Because the issue generated are very similar.
My problem was that when the Pc was not connect to the LAN, gnome startup and all gnome apps where huge slowly. I just find that It was a network problem, because if I was connected didn't happened.
I found the way to solve the isse:
I think network-admin (the tool that I use to set my net) makes a bad format con /etc/hosts.
I comment all the line about IPv6 and add my hostname in sequence of localhost, then I restart gnome without LAN support and it goes fast. See file attachmente for more details.
http://librarian.launchpad.net/5799584/hosts

This bug is reported from me and anther Italian user. So I'm not alone. Morever read this entry in the forum

http://www.ubuntuforums.org/showthread.php?t=317242

I took from there the solution.
Tested on a Desktop PC with ubuntu 6.10 ed Laptop with 6.10 in private LAN.

Sincerly,
lizardking

The slow login/desktop bug appears to have been around for a while. The bug is reported in edgy & feisty and they are mostly unconfirmed and mostly of undecided importance. Although I'm very happy with feisty, I am finding this bug a bit bothersome so I thought I'd do some research through the bug archives.

I think this bug has been reported numerous times. The bug list that follows, I think are reports of effectively the same bug.

Bug #78263 - claims workaround (feisty)
Bug #78493 (edgy)
Bug #79466 (edgy)
Bug #80827 - claims workaround (edgy)
Bug #92997 - claims workaround (feisty)
Bug #94048 (feisty)
Bug #110616 (feisty?)
Bug #110775 (feisty)
Bug #110187 - reports slow desktop as a side effect of other network config issues. (feisty)
---------------
Bug #95264 - Maybe related (not clear) (feisty)
Bug #93447 - Maybe related (not clear) (edgy)
---------------
It seems most discussions are blaming this bug on one or more of:
Network-manager
avahi
hosts file
resolve file
static IP addresses
no network connection.

I can't vouch for the claimed workarounds - but I intend on investigating them further.

The person who solves this one will likely 'kill a number of bugs with one stone'.

I hope I'm not being too forward by presenting such a list but I am rather keen to see this bug solved. I hope this list helps to unify further discussion & prompts some further thought on the matter.

(note: I have posted it to all above bug reports so that all are in the loop)

Add Bug #79661 (edgy) to above list.

Caroline Ford (secretlondon) wrote :

Is this still a problem in the current hardy?

Changed in gnome-system-tools:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in gnome-system-tools:
status: Incomplete → Invalid
udippel (udippel) wrote :

New to ubuntu, but not to Linux, I can confirm this for the latest hardy release, fully updated.
I came to this post through the problem of being not able to set WiFi with static addresses. Since the machine could not connect, it was missing a LAN connection. then everything at startup would be done with around 10 seconds of idle time in between, logon screen, background, panel, as well as starting a simple terminal.

Changed in gnome-system-tools:
status: Invalid → New

I experienced this problem in Feisty & found that a small change to /etc/hosts file fixed the problem. (sorry I can no longer remember the details).
I have upgraded to every release since without re-occurrence of this issue. I presently use Hardy.

Changed in gnome-system-tools:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

please open a new bug report rather than re open a really old one, thanks.

Changed in gnome-system-tools:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers