[packaging] gnome-software provides a broken symlink of /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so on Ubuntu 16.04

Bug #1573052 reported by V字龍(Vdragon) on 2016-04-21
146
This bug affects 37 people
Affects Status Importance Assigned to Milestone
GNOME Software
Fix Released
Undecided
Unassigned
gnome-software (Ubuntu)
Low
johan
Xenial
Low
Unassigned

Bug Description

```
$ file /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so
/usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: broken symbolic link to libgs_plugin_xdg_app_reviews.so.0.0.0
```

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
Uname: Linux 4.5.0-buo-ren-vanilla-intel-ivybridge-optimized x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 21 21:44:09 2016
InstallationDate: Installed on 2016-01-07 (104 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: gnome-software
UpgradeStatus: Upgraded to xenial on 2016-04-07 (13 days ago)

V字龍(Vdragon) (vdragon) wrote :
Changed in gnome-software (Ubuntu):
importance: Undecided → Low
Matthias Klumpp (ximion) wrote :

Should be resolved upstream already (and therefore be fixed with the next bugfix release).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
V字龍(Vdragon) (vdragon) wrote :

I wonder why this bug report is set as bug #1573453's duplicate...which doesn't seem anyway better than this one.

V字龍(Vdragon) (vdragon) wrote :

Manually fixing it. Please leave a message if there's any error.

Peter Pfeiffer (pfeiffep) wrote :

vdragon not certain the actual time that you're working on this, at 12:51 EDT April 23 I experienced this fault.
BTW thanks for working on it!
Regards,
Pete

Peter Pfeiffer (pfeiffep) wrote :

vdragon April 23 - 12:51 edt I experienced this

林博仁 (buo-ren-lin) wrote :

@Peter
Hi, for the "Manually fixing it." I mean the duplicated status mentioned in #4. I'm currently lacking the required skill and time to fix the actual bug.

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
林博仁 (buo-ren-lin) wrote :

@Sebastien Hi, mind sharing which branch the fix is committed in?

art-udav (art-udav) wrote :

ftp://fr2.rpmfind.net/linux/fedora/linux/updates/testing/24/x86_64/g/gnome-software-3.20.1-1.fc24.x86_64.rpm

Download (64 bit). Unpack. Copy the replacement of a Root libgs_plugin_xdg_app_reviews.so in the folder /usr/lib/gs-plugins-9/

art-udav (art-udav) wrote :

For the X86 ftp://fr2.rpmfind.net/linux/fedora/linux/updates/testing/24/i386/g/gnome-software-3.20.1-1.fc24.i686.rpm

Download (64 bit). Unpack. Copy the replacement of a Root libgs_plugin_xdg_app_reviews.so in the folder /usr/lib/gs-plugins-9/

art-udav (art-udav) wrote :

Download (X86) Unpack. Copy the replacement of a Root libgs_plugin_xdg_app_reviews.so in the folder /usr/lib/gs-plugins-9/

ftp://fr2.rpmfind.net/linux/fedora/linux/updates/testing/24/i386/g/gnome-software-3.20.1-1.fc24.i686.rpm

Radha Krishnan (maverickct) wrote :

the above fix is not working

Sebastien Bacher (seb128) wrote :

it's fixed upstream in https://git.gnome.org/browse/gnome-software/log/?h=gnome-3-20 which is the stable serie

Navjot (navjotjsingh) wrote :

Working now.

Peter Pfeiffer (pfeiffep) wrote :

I just checked - here's syslog entries after anoth failure
Apr 28 10:08:45 Dell-1749 org.gnome.Software[2627]: (gnome-software:7894): GsPlugin-WARNING **: Failed to get changelog for ubuntu-mate-desktop version 1.154 from changelogs.ubuntu.com: Cannot connect to destination
Apr 28 10:08:45 Dell-1749 org.freedesktop.Notifications[2627]: ** (mate-notification-daemon:14169): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-0Fa9o5rU99: Connection refused
Apr 28 10:08:48 Dell-1749 dbus[782]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Apr 28 10:08:49 Dell-1749 org.freedesktop.fwupd[782]: (fwupd:14187): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Apr 28 10:08:49 Dell-1749 dbus[782]: [system] Successfully activated service 'org.freedesktop.fwupd'

Egon Holtz (egonholtz) wrote :

Hello everyone...

I tried to open the rpmfind.net link but didn't work for me...

Someone can tell me how to fix this problem?

Matthias Klumpp (ximion) wrote :

It's not a problem and there is nothing to fix here.
This message is just to inform you that a module for reviews&ratings has failed to load. This would be an issue, but since Ubuntu is using a different module for the exact same feature, which disables the other one (that failed to load), there is no issue here at all.
This is resolved anyway in the next gnome-software, so the only thing you need to do is wait.
You can just ignore the message, as it isn't indicating any issue on Ubuntu.

Canale Grande (canalegrande) wrote :

Link is not working. Is this the right answer? Nothing to fix here?

Han (elberro) wrote :

Same for me with Ubuntu Gnome 16.04 / Gnome 3.18

It is not possible to open Gnome-Software. There is just no window appearing.

Matthias Klumpp (ximion) on 2016-05-11
Changed in gnome-software:
status: New → Fix Released
Changed in gnome-software (Ubuntu):
status: Fix Committed → Triaged
status: Triaged → Fix Committed
Edson (edsonn3to) wrote :

Excuse me, I'm a complete beginner, but ... What is the solution? I use Ubuntu GNOME 16.04 ... left me wait for the next version?

Matthias Klumpp (ximion) wrote :

This thing is a red herring - whatever issue you are experiencing, it doesn't have anything to do with the broken symlink. If you want to silence this message, you could just delete the symlink, if you want. Otherwise, simply ignore it.

SunBear (sunbear-c22) wrote :

I also have the same failure notice in my syslog.

May 18 10:08:28 Eliot gnome-session[1871]: (gnome-software:2295): Gs-WARNING **: failed to open plugin /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: cannot open shared object file: No such file or directory

Action taken:
$ cd /usr/lib/gs-plugins-9
$ ls -la
Found that the link is broken(the link is in red colour). Neither can I find the filelibgs_plugin_xdg_app_reviews.so.0.0.0
lrwxrwxrwx 1 root root 37 Apr 28 16:40 libgs_plugin_xdg_app_reviews.so -> libgs_plugin_xdg_app_reviews.so.0.0.0

Looking forward to receiving this bug fix.

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
Matthias Klumpp (ximion) wrote :

Nominated for Xenial, because this warning message seems to irritate many people.
Can be fixed when convenient (by just removing that symlink or applying the upstream patch which renames the plugin and builds it properly without versioned name).

Will Cooke (willcooke) on 2016-05-23
tags: added: desktop-trello-import
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu Xenial):
status: New → Confirmed
Miguel (eynos23) on 2016-05-29
Changed in gnome-software (Ubuntu Xenial):
status: Confirmed → Fix Released
Changed in gnome-software (Ubuntu):
status: Fix Released → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: Fix Released → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- William Hua <email address hidden> Fri, 17 Jun 2016 09:47:49 +0100

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released

Hello V字龍(Vdragon), or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

the updated version doesn't display the warning, setting to verification-done

tags: added: verification-done
removed: verification-needed
JOSE (joseccz) wrote :

The status says "Fix Released"... Can somebody please tell me where is it? I have been religiously updating my Xubuntu 16.04 LS and the problem still persist.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to 16.04, with the world's longest version number.
  * Update Vcs-Bzr for the stable release

gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- Iain Lane <email address hidden> Fri, 17 Jun 2016 10:11:30 +0100

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

johan (johan-ms-7267) on 2016-11-29
Changed in gnome-software (Ubuntu):
assignee: nobody → johan (johan-ms-7267)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers