Ubuntu

Activities search does not complete recent documents anymore

Reported by Michal Rudolf on 2012-04-01
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

In Gnome 3.2/Ubuntu 11.10, typing recent document name displayed the document in suggested programs/files to open.
This no longer happens in 3.4/12.04.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-shell 3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
ApportVersion: 2.0-0ubuntu2
Architecture: i386
Date: Sun Apr 1 11:17:18 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to precise on 2012-03-31 (0 days ago)

Michal Rudolf (mrudolf) wrote :
Jeremy Bicha (jbicha) wrote :

I believe this is because gnome-documents 0.4 is not in Ubuntu 12.04, so I'm marking this a duplicate of bug 966772.

gnome-documents 0.4 is in the GNOME3 PPA if you want to try that.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Daniel (kimpire) wrote :

I installed gnome-documents 0.4 manually, and I still have this bug.

Just upgraded to Precise and can confirm that the bug doesn't seem to be fixed - or isn't related to gnome-documents. Recent Documents don't show up in the Gnome Search, neither in LibreOffice.

Ubuntu 12.04
gnome-documents 0.4.1-1
gnome-shell 3.4.1-0ubuntu2

Unfortunately is a "feature". From https://bugzilla.gnome.org/show_bug.cgi?id=670150, I cite:

"kill the latter [the GtkRecent engine], even though the rest of finding+reminding applications are not ready
yet"

Great.

"The new brakes will make this car much more safe. Remove the old ones, even if the new will be installed next month".

This is a big point in favor of Unity...

Jeremy Bicha (jbicha) wrote :

Romano, I believe you're mistaken. That bug is about removing "recent files" now that recent documents are shown in the Activities Overview search.

I think the Documents search integration works in Fedora 17 with GNOME 3.4.

Daniel (kimpire) wrote :

> "The new brakes will make this car much more safe. Remove the old ones, even if the new will be installed next month".

Or, as Futurama put it, "I take lungs now, gills come next week."

Jeremy, what is the Activities Overview search?

Jeremy Bicha (jbicha) wrote :

The Activities Overview is what the GNOME docs team calls the GNOME version of Unity's dash, what you see when you throw your mouse to the top left corner of the screen, or alternatively if you tap the Super/Windows key.

Daniel (kimpire) wrote :

That's the bug being talked about here, no? Recent documents are *not* shown in the Activities Overview search.

Yes --- that's the problem.

Maybe it's not a global gnome shell problem, only the ubuntu packaging... I have 12.04, upgraded from 11.10. gnome-document has not been installed in the upgrade; now I have installed it but the shell still doesn't show any "recent" document in the overview.

Is there a way to check where the problem is using command-line (or lg?)

Looks like a global Gnome Shell bug - I experience the same problem running Fedora 17 Beta.

Robotron (robotron) wrote :

If I'm not mistaken then in Gnome 3.4 relies document search in the Shell on the Gnome Documents and Gnome Documents relies on the Tracker. If you see nothing in Gnome Documents the Shell finds also nothing except apps, Nautilus places and optionally contacts.

It seems like a Tracker bug, I'm affected by this one https://bugzilla.gnome.org/show_bug.cgi?id=663149

G9283 (b8732) wrote :

"I take lungs now, gills come next week." hahahaha! Brilliant.

Seriously, importantance is "Undecided"?

Changed in baltix:
importance: Undecided → Medium
alecive (alecive) wrote :

It seems I'll return to Unity :(

wensveen (wensveen) wrote :

Confirming this on Debian sid (unstable). Gnome-documents and tracker are properly installed.
I really don't understand the push towards 3.4 with loss of features (this is not the only package). Little disgruntled (but I'll be fine :) )

aaron-bru (aaron-bru) wrote :

wow this a brutal regression as far as I'm concerned. Makes me want to consider Unity.
Are there any decent workarounds at the moment?

https://extensions.gnome.org/extension/62/journal/ is not bad, except for you can't search it, and it requires a separate tab. (Ctrl+PgDn also switches tabs in the Activities Overview, or try Ctrl+Alt+Tab)
(you might also want to try https://extensions.gnome.org/extension/33/jump-lists/ to ease the pain...)

ntdoherty (ntdoherty) wrote :

I can confirm this bug in both Fedora 17 i686 and Ubuntu running Gnome desktop...also agree that this makes me want to go back to Unity as I spend 90% of computer time on documents.

Just wish Unity had that 'flip up into corner -> show all windows on workspace' thing. I know there's a keyboard shortcut, but I like that about gnome 3.

markb (mark-blakeney) wrote :

@ntdoherty Unity does have that functionality, Enable scale addons plugin in Compiz. Also enable window titles on all windows and add the text plugin. Change Unity launcher to auto hide and activate on top left hot corner.

darteaga (darteaga) wrote :

Document search worked for me briefly right after restarting the computer. Stopped working after that.

aaron-bru (aaron-bru) wrote :

Is this supposed to be working now? I upgraded t0 12.10 / shell and nautilus 3.6 and it now shows files that are directly in my home folder (non recursive), but does not search my recent documents

Jeremy Bicha (jbicha) wrote :

Aaron, do you have gnome-documents installed?

aaron-bru (aaron-bru) wrote :

No I do not,
I understand that gnome-documents uses tracker, isn't there a way to use this with just zeitgeist? I liked how it was before in 11.10 where files that you've used before would show up, that way you don't need an indexer scanning the hard drive.
If I have to use tracker, what's the point in having zeitgeist?

Jeremy Bicha (jbicha) wrote :

GNOME apps can now include search providers for gnome-shell. Files (nautilus) 3.6 provides files search, Contacts provides contacts search, Documents provides documents search.

Tracker & Zeitgeist are two different technologies. Tracker indexes your files, including stuff you haven't yet opened. Zeitgeist keeps a record of when you use apps and files so that it can show you stuff you've used recently or frequently.

If you don't like tracker, you can use Unity which provides a similar but different experience without needing to install Documents or Tracker.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) wrote :

I'm closing this bug because it works fine in Ubuntu 12.10. To get files search results (instead of just documents search), you'll need to use Nautilus 3.6 from the GNOME3 PPA, but that won't be necessary in Ubuntu 13.04 which will be available next April.

darteaga (darteaga) wrote :

I reopen the bug because iIn ubuntu 12.10 with gnome 12.10, I get files search with nautilus but not yet document search from Gnome Documents.

Changed in gnome-shell (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
status: Invalid → Confirmed
darteaga (darteaga) wrote :

Sorry, I meant Ubuntu 12.10 with Gnome 3.6

Changed in baltix:
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → Mantas Kriaučiūnas (mantas)
Jacob Henderson (lmeditato) wrote :

This bug is still in 12.10. Document search does not complete in a consistently. I have had tracker re-index my files, and they all show in Documents, but overview search does not seem to find them consistently.

darteaga (darteaga) wrote :

I can confirm the above. Document search works occasionally in the activities overview (I cannot reproduce the conditions), but it doesn't work for me 99% of the time.

Any hints, or workarounds?

Bucic (bucic) wrote :

Can it be resolved on 12.10 by installing the latest GS from PPA?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.