Ubuntu dock won't start after Dash to dock uninstalled

Bug #1726935 reported by frenchy82 on 2017-10-24
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-ubuntu-dock (Ubuntu)
High
Didier Roche
Artful
Undecided
Unassigned

Bug Description

[ Impact ]

Uninstall Dash to dock without deactivating will not restore ubuntu dock

[ Test Case ]

* Install this version from proposed
* Log out/in in again to load new code
* Install or enable dash to dock via Tweaks or any other 3rd party tool
-> Ubuntu Dock should disappears, Dash to Dock is shown
* Uninstall dash to dock without disabling it
-> Ubuntu Dock should appears once Dash to Dock vanishes

[ Regression Potential ]

The impacted code is the code already doing the detection, but basing on running extensions rather than the gsettings key. So, it doesn't impact other code.

-------

On the attached file, We can see that the value "dash to dock" is still present in this key despite its uninstallation.

I need to select the "use default" switch for the dock to reappear in the gsetting key / org / gnome / shell / enabled-extensions

frenchy82 (cartes) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1711617, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Unduplicating, this is a separate issue.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
Didier Roche (didrocks) on 2017-10-25
description: updated

Hello frenchy82, or anyone else affected,

Accepted gnome-shell-extension-ubuntu-dock into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-ubuntu-dock/0.7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Ads20000 (ads20000) wrote :

This works (0.7.1)!! :D Thanks Didier! Can now switch Dash to Dock on and off from the GNOME Extensions website and it works seamlessly!

The only flaw is that someone who has already run into this bug will have to logout, login, AND ALSO turn Dash to Dock on and off in GNOME Extensions (or turn it off in GNOME Tweak) to get the Ubuntu Dock back. Also, turning off Dash to Dock on the website does turn it off on the system but doesn't flick the switch in GNOME Tweak, this may be a wider bug, however.

tags: added: verification-done-artful
removed: verification-needed-artful
tags: added: verification-done
removed: verification-needed
Ads20000 (ads20000) wrote :
Ads20000 (ads20000) wrote :

No scratch that, that's caused by enabling and disabling Dash to Dock and Dash to Panel simultaneously.

frenchy82 (cartes) wrote :

ubuntu dock 0.7.1 solve the problem for me too.

I can now uninstall dash to dock and ubuntu dock will be active

thanks a lot

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-ubuntu-dock - 0.7.1

---------------
gnome-shell-extension-ubuntu-dock (0.7.1) artful; urgency=medium

  * Fix Ubuntu dock won't start after Dash to dock uninstalled (LP: #1726935)
  * Cherry-pick couple of upstream Dash to Dock fixes: (LP: #1727242)
    - warning fix with latest mozjs.
    - expose the dash to dock main object for other extensions to pick it up.

 -- Didier Roche <email address hidden> Wed, 25 Oct 2017 10:51:28 +0200

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell-extension-ubuntu-dock has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers