gnome-settings-daemon crashed with SIGSEGV in g_simple_async_result_complete()

Bug #832603 reported by Bilal Shahid on 2011-08-24
This bug affects 1381 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Critical
gnome-settings-daemon (Ubuntu)
Critical
Rodrigo Moya
Oneiric
Critical
Rodrigo Moya

Bug Description

random rash after upgrade

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.1.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
Date: Wed Aug 24 13:41:30 2011
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x81ebf6d: mov 0x8(%edx),%edx
 PC (0x081ebf6d) ok
 source "0x8(%edx)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libmedia-keys.so
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: Upgraded to oneiric on 2011-08-24 (0 days ago)
UserGroups:

Bilal Shahid (s9iper1) wrote :
visibility: private → public

StacktraceTop:
 on_bus_gotten (source_object=0x0, res=0x8560538, manager=0x8577818) at gsd-media-keys-manager.c:2048
 g_simple_async_result_complete (simple=0x8560538) at /build/buildd/glib2.0-2.29.16/./gio/gsimpleasyncresult.c:749
 complete_in_idle_cb (data=0x8560538) at /build/buildd/glib2.0-2.29.16/./gio/gsimpleasyncresult.c:761
 g_idle_dispatch (source=0x8554d00, callback=0x1f1280 <complete_in_idle_cb>, user_data=0x8560538) at /build/buildd/glib2.0-2.29.16/./glib/gmain.c:4780
 g_main_dispatch (context=0x85049d0) at /build/buildd/glib2.0-2.29.16/./glib/gmain.c:2439

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

You might want to upgrade to g-s-d 3.1.5-0ubuntu5 & see if the crash still occurs

Pedro Villavicencio (pedro) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → New
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
importance: Medium → High
tags: added: iso-testing
Tillman Reck (till-t) wrote :

just after installing oneiric to harddisk. crash occurs after starting software center

b3th3r5 (girlofdragons28) wrote :

bug happened after upgrade restart. after clicking on setting icon in upper right hand corner.

streetpunk234 (spatiegames) wrote :

Occured after first boot of todays daily build in Virtual Box

Franco Bombi (franco.bombi) wrote :

after a fresh install on a TravelMate 6593 at the first reboot

Rodrigo Moya (rodrigo-moya) wrote :

Which g-s-d version is this with? Does it still happen with 3.1.5 or 3.1.90?

Jonathan Lange (jml) wrote :

Who are you asking? How would I tell? It feels like I've filed half-a-dozen g-s-d crashes over the last week. I had a crash today with 3.1.5-0ubuntu6. Was it this one? Who can say?

Pedro Villavicencio (pedro) wrote :

Last dupe is with g-s-d is from 3.1.5, 3.1.90 is still on the queue it should be in the archive after beta freeze

Juanje Ojeda (juanje) wrote :

This is happening to me with the version 3.1.5-0ubuntu6

Che Dean (dean-che) wrote :

After a fresh install on Eee PC 1011px

Dave Russell (drussell) wrote :

Still getting this crash with:

$ dpkg-query --show gnome-settings-daemon
gnome-settings-daemon 3.1.90-0ubuntu3

Le 03/09/2011 12:14, Dave Russell a écrit :
> Still getting this crash with:
>
> $ dpkg-query --show gnome-settings-daemon
> gnome-settings-daemon 3.1.90-0ubuntu3
>
réponse

duchene@duchene-EASYNOTE-PB47Q00702:~$ dpkg-query --show
gnome-settings-daemon
gnome-settings-daemon 3.1.90-0ubuntu3

Mike (bild85) wrote :

This occurred for me after I rebooted following a failed 'system-update -d'. See bug 840387 for details.

David Tigue (dtigue) wrote :

I got this after a reboot on a cr-48.

gnome-settings-daemon 3.1.90-0ubuntu3

daemox (daemox) wrote :

I just got this after updating on amd64.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Rodrigo Moya (rodrigo-moya) → Chris Coulson (chrisccoulson)
Rodrigo Moya (rodrigo-moya) wrote :

Can anyone paste his/her ~/.xsession-errors file here? This crash happens because the _stop method is being called while the dbus operations are still in progress, so I wonder why this is happening.

My .xsession-errors file

Jeroen T. Vermeulen (jtv) wrote :

Then it may be something to do with the ridiculous amounts of CPU dbus-daemon seems to gobble up.

As for my .xsession-errors, for me the last page is all lines like this one:

unity-2d-launcher: [WARNING] void LauncherApplicationsList::onRemoteEntryUpdated(QString, QMap<QString, QVariant>): Application sent an update but we don't seem to have it in the launcher: "application://nautilus.desktop"

Shaji N V (nvshaji) wrote :

my .xsessions-errors file.

Changed in gnome-settings-daemon:
status: New → Incomplete
dsn0wman (josgray) wrote :

Attaching ~/.xsession-error file

Bernd Schlapsi (bernd-sch) wrote :
tags: added: rls-mgr-o-tracking
jason (jasonrisenburg) wrote :

it crashed upon start up, after updateing/upgrading.

Miguel Gaspar (ghaspias) wrote :

No updating here, just trying the live ubuntu 11.10 beta amd64 cd, and logged with the unity 2d session.

Chris Coulson (chrisccoulson) wrote :

Assigning to Rodrigo, as he'd already started to look at this one

Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Chris Coulson (chrisccoulson) → Rodrigo Moya (rodrigo-moya)
bnet (brian-nettles) wrote :

I received the error when launching the Ubuntu Software Center after upgrading. My xession-error file is attached.

brian@DEXTER:~$ dpkg-query --show gnome-settings-daemon
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 23169 package 'sphinx-0.9.8-svn':
    error in Version string 'r1112-1': version number does not start with digit
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 31315 package 'visualrinse.com.swfshot.d14e253fc1be9f74f8b9a60f9e92bd0a60acf5e1.1':
    error in Version string 'v0.1': version number does not start with digit
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 38605 package 'googlebuzzdesktop.e35e1619c3b072b5d85c7ed08b22547a2d47447f.1':
    error in Version string 'Beta1': version number does not start with digit
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 57664 package 'flickroom.7a385545159204287f941528e627f38ad4ecb7c0.1':
     error in Version string 'v0.60': version number does not start with digit
gnome-settings-daemon 3.1.91-0ubuntu5

brian@DEXTER:~$ uname -a
Linux DEXTER 2.6.35-22-generic-pae #35-Ubuntu SMP Sat Oct 16 22:16:51 UTC 2010 i686 i686 i386 GNU/Linux

brian@DEXTER:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric

Sebastien Bacher (seb128) wrote :

is that still an issue?

Jeroen T. Vermeulen (jtv) wrote :

I'm still getting the crash dialogs, yes, and clicking Cancel makes more and more of them come.

Andrew Somerville (andy16666) wrote :

My advice: focus on the LTS, and forget about 11.10 before you lose all your users.

Bilal Shahid (s9iper1) wrote :

i my case this issue is solved and here are no more crash

Mark Cariaga (mzc) wrote :

Same here. I cannot reproduce the bug with recent patches to beta1. Looking
forward for beta2 and rc
On Sep 20, 2011 10:40 AM, "Muhammad bilal shahid" <email address hidden>
wrote:
> i my case this issue is solved and here are no more crash
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (838573).
> https://bugs.launchpad.net/bugs/832603
>
> Title:
> gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
>
> Status in Gnome Settings Daemon:
> Incomplete
> Status in “gnome-settings-daemon” package in Ubuntu:
> Triaged
> Status in “gnome-settings-daemon” source package in Oneiric:
> Triaged
>
> Bug description:
> random rash after upgrade
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: gnome-settings-daemon 3.1.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> Date: Wed Aug 24 13:41:30 2011
> ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
> ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> ProcEnviron:
> SHELL=/bin/false
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x81ebf6d: mov 0x8(%edx),%edx
> PC (0x081ebf6d) ok
> source "0x8(%edx)" (0x00000008) not located in a known VMA region (needed
readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-settings-daemon
> StacktraceTop:
> ?? () from /usr/lib/gnome-settings-daemon-3.0/libmedia-keys.so
> g_simple_async_result_complete () from
/usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: gnome-settings-daemon crashed with SIGSEGV in
g_simple_async_result_complete()
> UpgradeStatus: Upgraded to oneiric on 2011-08-24 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/gnome-settings-daemon/+bug/832603/+subscriptions

Kate Stewart (kate.stewart) wrote :

Its still a problem I think.
- Clean install of Natty
- Update Natty to latest fixes
- update-manager to update to Oneiric

Have marked bug #855721 as duplicate of this one. Fresh logs for debugging are there.

Kate Stewart (kate.stewart) wrote :

Bringing up a terminal (cntl-alt-t) and then executing "compiz --replace", got system back to functioning.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: High → Critical
Mark Cariaga (mzc) wrote :

So it looks like the bug is isolated to folks that are updating to 11.10.
Thanks kate for the update :)
On Sep 21, 2011 10:45 AM, "Kate Stewart" <email address hidden> wrote:
> ** Changed in: gnome-settings-daemon (Ubuntu Oneiric)
> Importance: High => Critical
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (838573).
> https://bugs.launchpad.net/bugs/832603
>
> Title:
> gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
>
> Status in Gnome Settings Daemon:
> Incomplete
> Status in “gnome-settings-daemon” package in Ubuntu:
> Triaged
> Status in “gnome-settings-daemon” source package in Oneiric:
> Triaged
>
> Bug description:
> random rash after upgrade
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: gnome-settings-daemon 3.1.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> Date: Wed Aug 24 13:41:30 2011
> ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
> ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> ProcEnviron:
> SHELL=/bin/false
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x81ebf6d: mov 0x8(%edx),%edx
> PC (0x081ebf6d) ok
> source "0x8(%edx)" (0x00000008) not located in a known VMA region (needed
readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-settings-daemon
> StacktraceTop:
> ?? () from /usr/lib/gnome-settings-daemon-3.0/libmedia-keys.so
> g_simple_async_result_complete () from
/usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: gnome-settings-daemon crashed with SIGSEGV in
g_simple_async_result_complete()
> UpgradeStatus: Upgraded to oneiric on 2011-08-24 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/gnome-settings-daemon/+bug/832603/+subscriptions

Rodrigo Moya (rodrigo-moya) wrote :

Kate, mzc: what g-s-d version do you have installed? This should be fixed in 3.1.91 or 3.1.92, don't remember which one.

Kate Stewart (kate.stewart) wrote :

Rodrigo, 3.1.92-0ubuntu1

David Duffey (dduffey) wrote :

Just did an 11.04 to Oneiric beta 2 upgrade and hit this same bug after logging in.

Emilien Klein (emilien-klein) wrote :

Installed Oneiric Beta 2 (no update) in VirtualBox, installed all updates, restarted computer, left it without doing anything and after like 30 seconds I get this crash report.

Jan Rathmann (kaiserclaudius) wrote :

I just had the same experience as Emilien describes one post before. Freshly installed Oneiric Beta 2, on real hardware though (no virtualisation!).
I'm attaching my xsession-errors

Mark Cariaga (mzc) wrote :

it looks like this bug has been fixed by gnome-settings-daemon
3.1.92-0ubuntu3

On Sat, Sep 24, 2011 at 12:38 PM, Jan Rathmann <email address hidden>wrote:

> I just had the same experience as Emilien describes one post before.
> Freshly installed Oneiric Beta 2, on real hardware though (no
> virtualisation!).
> I'm attaching my xsession-errors
>
> ** Attachment added: ".xsession-errors"
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/832603/+attachment/2454540/+files/.xsession-errors
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (838573).
> https://bugs.launchpad.net/bugs/832603
>
> Title:
> gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
>
> Status in Gnome Settings Daemon:
> Incomplete
> Status in “gnome-settings-daemon” package in Ubuntu:
> Triaged
> Status in “gnome-settings-daemon” source package in Oneiric:
> Triaged
>
> Bug description:
> random rash after upgrade
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: gnome-settings-daemon 3.1.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> Date: Wed Aug 24 13:41:30 2011
> ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
> ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> ProcEnviron:
> SHELL=/bin/false
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x81ebf6d: mov 0x8(%edx),%edx
> PC (0x081ebf6d) ok
> source "0x8(%edx)" (0x00000008) not located in a known VMA region (needed
> readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-settings-daemon
> StacktraceTop:
> ?? () from /usr/lib/gnome-settings-daemon-3.0/libmedia-keys.so
> g_simple_async_result_complete () from
> /usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
> UpgradeStatus: Upgraded to oneiric on 2011-08-24 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-settings-daemon/+bug/832603/+subscriptions
>

nanog (sorenimpey) wrote :

its not fixed for me with:
ii gnome-settings-daemon 3.1.92-0ubuntu3

McMagno (massimo-magnani) wrote :

For me too, not fixed with gnome-settings-daemon 3.1.92-0ubuntu3 (64 bits) and mine is a 100% fresh install, no update from previous versions.

Thanks

Kjow (antispammoni) wrote :

I have this bug on Ubuntu 11.10 - amd64 - on a Acer Aspire 7741G

I have this bug in gnome-settings-daemon-3.2.0-ubuntu1 on Ubuntu 11.10.

Petri Kutvonen (kutvonen) wrote :

Also I have this bug in a fresh install of 11.10 beta2 (amd64) upgraded with latest packages on 2011-09-27 11:30-11:45 UTC on a Samsung NC110/NC210.

Chris Jones (jones-home) wrote :

Because of a problem with fglrx I have had to reinstall from scratch. I found that I could not reinstall from Ubuntu beta 2 or daily builds and have had to reinstall natty then upgrade. (if it might give any clue to the current bug the oneric install could not start the screen with or without fglrx installed) I have therefore just installed all latest updates/upgrades at 11:22hrs BST 27-9-2011 and

AMD Radeon 6450, Intel 64 bit processor (E6750), iiyama Prolite E2473HDS monitor (1920x1080). Would also like to be using my second monitor Sony SDM-X75F/K (1280x1024) but having difficulty.

Thanks, as always

Chris

Justin (justin-wzy) wrote :

applied the latest updates today but the problem persists..

David Gomes (davidgomes) wrote :

Well, I can also confirm that this is occuring on Ubuntu 11.10 beta2.

nochka85 (nochka85) wrote :

Same here... just after login on beta2 up to date

Still get the crash after login.

David Tigue (dtigue) wrote :

I am having this error on 11.10 beta 2 as well. Also, I am getting a system
error every time I boot. Network Manager refuses to remember my wireless
keys.

On Tue, Sep 27, 2011 at 9:37 AM, David Gomes <email address hidden>wrote:

> Well, I can also confirm that this is occuring on Ubuntu 11.10 beta2.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/832603
>
> Title:
> gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-settings-daemon/+bug/832603/+subscriptions
>

--
*David A. Tigue*
<email address hidden>

Stephen Early (steve-greenend) wrote :

Same problem, fresh install of 11.10 beta 2; updated and it's still an issue. Package version 3.2.0-0ubuntu1

fresh install on Acer AspireOne 722, updated; sometime, the netbook freeze.

just updated the packages, lenovo edge 15, P6100 processor

Mark Cariaga (mzc) wrote :

After a fresh install (beta2), I have disabled backports before updating the
patches. This probably made the difference why I'm not able to reproduce
this bug.
On Sep 27, 2011 3:31 PM, "Guillaume Romagny" <email address hidden>
wrote:
> just updated the packages, lenovo edge 15, P6100 processor
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (838573).
> https://bugs.launchpad.net/bugs/832603
>
> Title:
> gnome-settings-daemon crashed with SIGSEGV in
> g_simple_async_result_complete()
>
> Status in Gnome Settings Daemon:
> Incomplete
> Status in “gnome-settings-daemon” package in Ubuntu:
> Triaged
> Status in “gnome-settings-daemon” source package in Oneiric:
> Triaged
>
> Bug description:
> random rash after upgrade
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: gnome-settings-daemon 3.1.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> Date: Wed Aug 24 13:41:30 2011
> ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
> ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
> ProcEnviron:
> SHELL=/bin/false
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x81ebf6d: mov 0x8(%edx),%edx
> PC (0x081ebf6d) ok
> source "0x8(%edx)" (0x00000008) not located in a known VMA region (needed
readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-settings-daemon
> StacktraceTop:
> ?? () from /usr/lib/gnome-settings-daemon-3.0/libmedia-keys.so
> g_simple_async_result_complete () from
/usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: gnome-settings-daemon crashed with SIGSEGV in
g_simple_async_result_complete()
> UpgradeStatus: Upgraded to oneiric on 2011-08-24 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/gnome-settings-daemon/+bug/832603/+subscriptions

Nathan Skillen (nskillen) wrote :

bug happened on ubuntu 11.10 32-bit guest in vmware workstation 8.0.0 build 471780 host os win 7 64-bit

Rainer Rohde (rainer-rohde) wrote :

Crashed right after logging in ...

Petri Kutvonen (kutvonen) wrote :

Enabling or disabling oneiric backports shouldn't make any difference because the oneiric backports are empty (as far as I can see).

mzc wrote:
> After a fresh install (beta2), I have disabled backports before updating the
> patches. This probably made the difference why I'm not able to reproduce
> this bug.

Additionally, I can confirm the existence of this bug with gnome-settings-daemon-3.2.0-ubuntu1 also in i386 with both real and virtual (VBox) hardware.

Crashed right after installing latest updates, rebooted, logging in...

David Henningsson (diwic) wrote :

I got this as well, and gave the resulting CoreDump an analysis.

In on_bus_gotten, manager->priv->introspection_data is NULL. This can happen if gsd_xrandr_manager_stop/gsd_media_keys_manager_stop/etc is called between register_manager and on_bus_gotten.

As I'm not a gnome expert, please review the attached patch before applying - and if you think it makes sense, extend it to do media_keys_manager, power_manager, etc as well. It also adds an explicit ref/unref to make sure the manager is not a dangling pointer at this point, but I doubt this is needed.

Rodrigo Moya (rodrigo-moya) wrote :

David, this fix is just for the symptom, not the real problem, which is why _stop is being called. I'm still looking at the best way to fix it, which so far seems to use the _sync version of g_bus_get, to avoid undesired callbacks, or keep a way to cancel the ongoing dbus call.

Rodrigo Moya (rodrigo-moya) wrote :

Is anyone experiencing this crash consistently (i.e. more than just once when upgrading)? If so, can you please try my patch? To do so:

$ bzr branch lp:~ubuntu-desktop/gnome-settings-daemon/ubuntu test-gsd-fix
$ cd test-gsd-fix
$ bzr bd -- -b

after building, packages will be in ../build-area, so please install those and have a try. For other people, I'd appreciate some testing also, to make sure nothing breaks with the fix.

The attachment "50_fix_on_bus_gotten_crash.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Jan Rathmann (kaiserclaudius) wrote :

@Rodrigo
Allthough I could not reproduce the crash on my installed system at the moment, I tried your patch and could not see any regressions so far.

Jan Rathmann (kaiserclaudius) wrote :

I did another test to see if your patch eliminates the "inital" g-s-d crash that happened when I first logged into a fresh Oneriric installation. What I have done was chrooting into a fresh installation (= that was never booted before) and installing the patched gnome-settings-daemon package (that I had prepared before). Then I booted the fresh system the first time, and... your patch seems to help, no g-s-d crash anymore :-)

Rodrigo Moya (rodrigo-moya) wrote :

Jan, thanks for trying it! Let's wait for some more comments before uploading it though

I have tried it, too, on an Asus eeePC 900 (i386) and on my Lenovo notebook (amd64). On both machiones it is only the regression test (no first login after upgrade). On both machines the gnome-settings-daemon is stable, no other crashes of g-s-d.

Kim Tyler (ktyler) wrote :

Hi - tried bzr command to branch and cd - OK

kit284@eeepc:~/test-gsd-fix$ bzr bd -- -b
bzr: ERROR: unknown command "bd"

Any thoughts

Rodrigo Moya (rodrigo-moya) wrote :

Kim: yes, you need to install bzr-builddeb

David Henningsson (diwic) wrote :

No regressions found here either.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Rodrigo Moya (rodrigo-moya) wrote :

No regressions found here neither, so I'll submit the package with the patch and then let's hope nobody else gets the crash

Rodrigo, I did an update from Natty to Oneiric on an old HP 32-bit notebook now and followed your instructions of comment #67 right before rebooting. After reboot I logged in and no crash of gnome-settings-daemon. It is fixed. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.2.0-0ubuntu3

---------------
gnome-settings-daemon (3.2.0-0ubuntu3) oneiric; urgency=low

  * debian/patches/00git_fix_async_dbus_crash.patch:
    - Fix async DBus calls crashes (LP: #832603)
  * debian/patches/49_fix_suspend_media_key.patch:
    - Rebased
 -- Rodrigo Moya <email address hidden> Wed, 28 Sep 2011 17:14:53 +0200

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Fix Released
Kim Tyler (ktyler) wrote :
Download full text (3.3 KiB)

kit284@eeepc:~/test-gsd-fix$ bzr bd -- -b
Building using working tree
Building package in merge mode
Purging the build dir: /home/kit284/build-area/gnome-settings-daemon-3.2.0
Looking for a way to retrieve the upstream tarball
Upstream tarball already exists in build directory, using that
Building the package in /home/kit284/build-area/gnome-settings-daemon-3.2.0, using debuild -b
 dpkg-buildpackage -rfakeroot -D -us -uc -b
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor):
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions
dpkg-buildpackage: source package gnome-settings-daemon
dpkg-buildpackage: source version 3.2.0-0ubuntu3
dpkg-buildpackage: source changed by Rodrigo Moya <email address hidden>
 dpkg-source --before-build gnome-settings-daemon-3.2.0
dpkg-buildpackage: host architecture i386
dpkg-source: warning: patches have not been applied, applying them now (use --no-preparation to override)
dpkg-source: info: applying 00git_dont_restore_brightness.patch
dpkg-source: info: applying 00git_fix_reference_leaks.patch
dpkg-source: info: applying 00git_fix_async_dbus_crash.patch
dpkg-source: info: applying 02_missing_libs.patch
dpkg-source: info: applying 05_disable_corner_tapping.patch
dpkg-source: info: applying 06_use_application_indicator.patch
dpkg-source: info: applying 10_smaller_syndaemon_timeout.patch
dpkg-source: info: applying 16_use_synchronous_notifications.patch
dpkg-source: info: applying 20_migrate_background_uri.patch
dpkg-source: info: applying 40_xres_lcddefault.patch
dpkg-source: info: applying 42_onlyshowin_unity.patch
dpkg-source: info: applying 43_disable_locale_settings.patch
dpkg-source: info: applying 45_suppress-printer-may-not-be-connected-notification.patch
dpkg-source: info: applying 46_share_rr_screen.patch
dpkg-source: info: applying 47_delay_pa_connect_to_idle.patch
dpkg-source: info: applying 48_register_client_before_idle_callbacks.patch
dpkg-source: info: applying 49_fix_suspend_media_key.patch
dpkg-checkbuilddeps: Unmet build dependencies: cdbs debhelper (>= 5) gnome-pkg-tools dh-autoreconf autotools-dev intltool (>= 0.37.1) libdbus-glib-1-dev (>= 0.74) libglib2.0-dev (>= 2.26.0) libgtk-3-dev (>= 3.0.0) libgconf2-dev (>= 2.6.1) libnotify-dev (>= 0.7.0) libxt-dev libxi-dev libfontconfig1-dev libxext-dev libx11-dev libgnomekbd-dev (>= 2.91.90) libxklavier-dev (>= 5.0) libgstreamer0.10-dev (>= 0.10.1.2) libgstreamer-plugins-base0.10-dev (>= 0.10.1.2) gsettings-desktop-schemas-dev libgnome-desktop-3-dev (>= 3.1.5) libpulse-dev (>= 0.9.16) libcanberra-gtk3-dev libcups2-dev libpolkit-gobject-1-dev libappindicator3-dev (>= 0.3.0) libupower-glib-dev libcolord-dev (>= 0.1.12) liblcms2-dev
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)
debuild: fatal error at line 1348:
dpkg-buildpackage -rfakeroot -D -us -uc -b failed...

Read more...

Rodrigo Moya (rodrigo-moya) wrote :

Kim: yes, the package has been uploaded, so just wait for the update to show up when upgrading your system.

But just for the record, the failure you are getting is because you're missing all the packages it complains about. So just install those and you'll be fine

Jeff Licquia (jeff-licquia) wrote :

Can confirm the fix. With 0ubuntu2, got the crash. Upgraded just gnome-settings-daemon, logged out, then back in, and no crash.

Agreed. 0ubuntu2 Bug #832603 confirmed fix on my 11.10 beta2 amd64. Several reboots, login, and logout and unable to recreate bug.

Nicholas Sharp (nsharpent) wrote :

Confirmed fix after update.

Kim Tyler (ktyler) wrote :

confirm no crashes - now have another problem:-

Background graphic now displaced down and right. Right click on actual background works OK. Right click on non-background (initially black, holds last image of window over that part of background) does nothing - no menu.

Fonts still corrupted in terminal, panels and applications. (different corruption every bootup)

damormino (david-amormino) wrote :

I had the same problem as Kim (#84) - background displaced.

I had been using a proprietary nVidia graphics driver which was installed using Additional Drivers (jockey-gtk).
I removed/deactivated this driver, and restarted. The problem is gone.

I had also done 'sudo apt-get purge ubuntu-restricted-extras' and 'sudo apt-get autoremove' at the same time as removing the driver, so these may have contributed, but my guess is removing the proprietary driver was the difference.

My system is:
 Ubuntu Oneiric beta (1 or 2?) with current updates
 amd64
 Intel NM10 chipset
 Atom D525 processor
 nVidia Next Generation Ion GPU

Kim, damormino, I have also the displaced background since the updates of today, but on two 32-bit boxes with Intel graphics. There is no driver alternative to work around the problem.

Kim Tyler (ktyler) wrote :

I am using unity 2d now, and the background is OK.(fault in normal ubuntu unity) I have intel graphics adapter (eeepc 1000HD)

Background problem is fixed, was bug 862743.

Kim Tyler (ktyler) wrote :

updated packages, restarted system. Logged in with ubuntu unity desktop. system locked up solid - had to hold down power button to close it down.

Restarted, logged in again, system working fine. No crashes, desktop background in correct place and right mouse click working OK.

Appears to be fixed.

Bilal Shahid (s9iper1) wrote :

kim and all people who commented about the background blackish after update , are right i also confirm that i have added my info in this bug
 bug/862743.

Changed in gnome-settings-daemon:
status: Incomplete → Confirmed
Changed in gnome-settings-daemon:
status: Confirmed → Fix Released
Rainer Rohde (rainer-rohde) wrote :

This just happened to me today when working with Libre Office Impress. I pressed F5 to start a slide-show, and the screen froze for a moment. The Ambiance theme was dropped to whatever the underlying default is for a couple of seconds, then everything seemed to have recovered.

I noticed, however, that my selected icon theme was dropped to the default theme from my selected Faenza theme, but only inside Nautilus windows, but not in the Unity Launcher or Dash.

Federico (fkremer-terra) wrote :

Al salir de evince, revisando un documento .pdf, arrojó este error.

Rainer Rohde (rainer-rohde) wrote :

Funny that "F5" now messes up the icon theme, even though it is supposed to (on my MacBookPro 5,2) change the keyboard backlight. This is rather frustrating.

Felix Adamczyk (felixad) wrote :

Happend just when I want to change to backlight of my MacBook Air keyboard. The key is the F5 key. But for the F5 functionality I also had to press Fn. It happens under Ubunt 12.04 with the newest updates. This is a new bug. In the past, I works fine.

Kieran Hogg (xerosis) wrote :

I've just experienced this bug too.

k0mpjut0r (k0mpjut0r) wrote :

I've experienced this bug too - I have a MacBookPro 8,2, with the latest updates. I was trying to lower the intensity of the keyboard backlight (on the F5 key, but to get a real F5 I have to press Fn+F5). My theme disappeared, scrollbars and buttons reverted to "old look".

Rainer Rohde (rainer-rohde) wrote :

My experience is the same as those mentioned in comment #96.

Nickolay Ihalainen (ihanick) wrote :

gnome-settings-daemon crashed with SIGSEGV in g_simple_async_result_complete on
MacBookPro 8.1, every time I press keyboard backlight manipulation keys (f5-f6).
Latest 12.04
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

Is the bug fixed in 12.04 too and I should report a different bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.