a program is still running but i want shut down anyway

Bug #313228 reported by Akdo on 2009-01-02
118
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Session Menu
Invalid
Undecided
Unassigned
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Intrepid by Pedro Villavicencio
Nominated for Karmic by Jack Leigh

Bug Description

On the intrepid when I want shut down my computer , an "Untitled window" appear ( bug 1 ), it ask me if I want shut down because some programs are still running... Ok thanks but the description is always an unknown program (bug 2 ) very helpless !!
Sometimes there are none programs running, but daemon are, update-notifier, bluetooth manager, jockey-gtk , tracker and even vino-server are the source ( Bug 3 ) of this "Untitled window" apparition.

But I'm an advanced user and when I select shut down, I want that Ubuntu Shut Down anyway !! There are no check box (Bug4 ) to shut down anyway in all cases.

So what can I do to help you?

goto (gotolaunchpad) wrote :

Hello,
actually there should be a button "quit anyway" or similar. Could you make a screenshot and upload it here? Thanks.

Changed in fast-user-switch-applet:
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

Re-assigning to gnome-session

Happens also to me, very often on my EEE Pc, and sometimes on my Acer laptop. There is an option to shutdown anyway, but if I close the laptop lid it is easy to not notice the dialog and accidentally leave the laptop running. Therefore it would be nice to have the "shutdown anyway" as a permanent selection, or something. It would also be nice to find out which program is causing this problem by failing to shut down, but the dialog says only "unknown program".

Sebastien Bacher (seb128) wrote :

don't describe several issues on the same bug, there is http://bugzilla.gnome.org/show_bug.cgi?id=546755 about the unclear error dialog, is your issue that dialog or the lack of option to not let softwares ask if you want to store changes etc?

Changed in gnome-session:
assignee: nobody → desktop-bugs
importance: Undecided → Low
zwaardmeester (zwaardmeester) wrote :

This happenes sometimes to me too. Ubuntu 8.10, Gnome 2.24.1.
Screenshot is attached.

zwaardmeester (zwaardmeester) wrote :

And a dump of "ps -aux" just before logging out.

Philip Peitsch (philip-peitsch) wrote :

Redhat appear to have a fix for this: https://bugzilla.redhat.com/show_bug.cgi?id=486393

Philip Peitsch (philip-peitsch) wrote :

That was not the same issue... sorry about the wrong lead

wijit (awijit) wrote :

Acer TravelMate 4720
Ubuntu 9.04
According to menof's description and zwaardmeester' screenshot, I have exactly the same problem. I just saw it the first time yesterday - June10th but paid small attention to it as I believed that it was a true warning. After testing by shutting the system down, reopening it and immediately shutting down the warning window kept appearing. This bug should not associate with the today's update which I committed this morning but one of those - about 2 or 3 days ago - was suspected. I wrote this and sent a screenshot image to confirm the bug.

wijit (awijit) wrote :

I wrote this to correct and add more information to my 20090611 writing.
None of ubuntu updates were suspected as the "Untitled Windows" does not always appear. Normally, I access the internet via a built-in LAN adapter. Just when I want to print some things I plug an RJ45 in for a connection to the computer to which the printer attaches. The "Untitled Windows" appears only on the day I print some things.

another_sam (anothersam) wrote :

This happened to me now for the first time. I've been using Ubuntu 9.04 Desktop during 3 weeks, shutting down the machine once or two times a day without this problem.

bastafidli (ubuntu-bastafidli) wrote :

This happens to me consistently every time on fully patched Jaunty 9.04. If there is any information I can provide please let me know.
This is also related to http://bugzilla.gnome.org/show_bug.cgi?id=546755

Jack Leigh (leighman) wrote :

Happens to me/is noticeable since the introduction of xsplash

tags: added: ubuntu-boot-experience
Jack Leigh (leighman) wrote :

If you logout -> 'logout anyway' then back in etc, it is no longer a problem .'. presumably only starting at start-up

tags: removed: ubuntu-boot-experience
Jack Leigh (leighman) wrote :

it's pretty majorly impacting on my boot experience :/

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: gnome-session 2.28.0-0ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:2375): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2375): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2482): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2477): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Changed in gnome-session (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

This problem occurs for me only some of the time when I try to shut down. I have zero interest in what is still running, I just want my machine to actually shut down when I tell it to and not make me click some "shut down anyways" button. I, for one, don't like my laptop battery dying just because I didn't think to wait for a SECOND shutdown button to appear.

At the very least, there should be a countdown for shutting down the machine if no action is taken.

Jack Leigh (leighman) wrote :

Can anyone confirm that this has been fixed either by installing one of the updates today (from Karmic proposed?)
or by doing gconf-editor -> apps -> indicator-session and setting suppress_logout_restart_shutdown to true (which turns the shutdown confirmation off)?
I did one of these and it seems to have fixed it =D

Jack Leigh (leighman) wrote :

Hmm... seems I was wrong...
Damn bugs! :P

David Barth (dbarth) wrote :

I don't see why it's related to the session menu. gnome-session is managing that part, and I don't think the way we're managing session shutdown calls can help resolve that issue. Intrinsically, the menu shouldn't have to care about that.

Changed in indicator-session:
status: New → Invalid
Liviuz (livio-ba) wrote :

It happens also with Ubuntu 10.10
I've never seen it on previous versions.
A program is still running:
"Unknown" / "Not responding"

Owen (owen-ozone) wrote :

Happening to me on maverick too, why "Unknown program" surely we can find something slightly more useful about a process than this pointless message.
It happens to me after unity and everything else is closed down so I have no way of finding what processes are even running. If I choose not to shut down I'm left with an empty screen

I have once tried to debug this in gnome-session (which is a pain for
non-gnomerati) and found that somehow there was a dbus client in the
inhibiters list. Unfortunately all the details (such as the originating
process id) were empty, null or zero. I did find at the time, however,
that this never happened on a re-launched X session (say after forced
logout and re-login)

This made me think that it could be due to particularly fast boot. Is
your system fast to boot up? Mine boots maverick in 5 to 6 seconds (on
dual SSDs)

There might even be something astray from the gnome-greater that is left
hanging around in the desktop session. Another gnome issue on my box
that is _definitely_ timing dependent is that my gdm greeter will hardly
ever show all the user images. In fact it will usually display the first
2 (out of 4) but frequently none. I've similarly tried to debug that
behaviour but haven't found a cause. The code is overly complex due to
the dynamic zoom effects, yet the callback for the list box population
is correctly called all the time. Apparently there is some early face
condition on my fast system causing the user images to be unavailable. [1]

What prompted me to write this up here was the fact that this bug has
gone for a long time without any substantial clues so I reckon I'd just
offer my humble 0.02$

Oh, perhaps other users affected by this bug can use d-feet to debug the
state of dbus gnome session with the hung process.

Seth

[1] Sorry for the off topic rant. I will file a separate bug for this once.

-----
Sent from a phone that is smart enough to allow me to successfully send
SMS messages.

Kupfer (tamas-kadas) wrote :

The "program is still running. shut down anyway" dialog appears to me too, but only after using Firefox. When I don't open FF at all in a session, I don't get the dialog either.
Sometimes when I close FF and try to reopen it, I get a message that firefox-bin is still running, and my cursor is busy, so I have to wait for the browser to close properly before restarting it. Obviously I'm just guessing, but something like that must be going on with the shut down situation. When I'm shutting down fast after closing FF, I sometimes get the dialog and sometimes don't, but I surely don't get it when I wait a little after closing the browser and only then inititiate a shut down.

jay armstrong (jayarmstrong) wrote :

The app, Tangerine, consistently causes this and is listed as "unknown". Uninstalling it solves the problem, whether I've started firefox or not.

I see one of two bugs in this issue:
1. Tangerine not identifying itself
2. gnome-session not identifying it

Seth (bugs-sehe) wrote :

On 06/01/2011 03:30 AM, jay armstrong wrote:
> The app, Tangerine, consistently causes this and is listed as "unknown".
> Uninstalling it solves the problem, whether I've started firefox or not.
>
> I see one of two bugs in this issue:
> 1. Tangerine not identifying itself
> 2. gnome-session not identifying it
>

Brilliant find! Removing tangerine from the gnome 'Startup Applications'
list sovled the issue indeed.

Note that for one user, the 'tangerine' entry had already been disabled
(unchecked) _but_ I had to remove an entry listed as 'Unknown Program'
(or 'Unknown Application' ... don't remember sorry) as well. Inspecting
the details of that entry (by clicking the Edit button) showed that it
was linked to the tangerine executable as well!

Thanks, Jay, this helps a lot. I reckon not directly for tangerine
users, which I'm not, but at least this longstanding (!!!) annoyance has
been pinpointed and it will be easy to fix, I feel, tahnks again,

Seth

TomasHnyk (sup) wrote :

I have never had Tangerine installed and have suffered from this bug, so I think this maybe should be reported as a bug in tangerine (for reporting something wrong to gnome-session or whatever).

Paul Suquet (suquet-paul) wrote :

Never seen this before installing Natty; I'm always up-to-date; currently running 11.04 32bit on my Thinkpad and I now get this message before quitting, EVERY SINGLE TIME.

I've been an Ubuntu user since 7.04 and this is the absolute first time I've seen this.

I've attached a screencap of said bug.

Paul Suquet (suquet-paul) wrote :

I may add, I don't use the UNITY interface, I use classic Ubuntu session.

I have a similar problem. After clicking the "shutdown anyway" option the window goes away but the system does nothing. So I have to choose 'shut down' again and then it goes off. I usually have this problem when clementine gets slow and weird.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.