Activating suspend from power button menu does not work

Bug #1041137 reported by Jussi Pakkanen on 2012-08-24
178
This bug affects 37 people
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Medium
ubuntu-nexus7
Undecided
Alex Chiang
gnome-session (Ubuntu)
Undecided
Martin Pitt
Quantal
Undecided
Unassigned

Bug Description

When I click the power button on my laptop, the suspend/reboot/shutdown menu shows up. Selecting "suspend" does nothing. The other buttons work.

Suspend works if you activate it by closing the lid or by selecting suspend from the top right corner menu.

SRU TEST CASE: See description above; pressing the "suspend" button in the dialog that pops up after pressing the power button should actually suspend the machine.

SRU PATCH: http://git.gnome.org/browse/gnome-session/commit/?id=e7cbff3fb381c , landed in raring and upstream yesterday.

REGRESSION POTENTIAL: None of the upower methods (that is, suspend and hibernation) worked in gnome-session before as the client object has never been initialized. Now it does, which should not only fix the power button, but also automatic suspend on configured timeout. The latter might be a surprise for some users which have configured suspend after some idle time; but then again, that is an actual bug fix as well.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-session 3.5.5-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Fri Aug 24 13:59:28 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64+mac (20120220)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: gnome-session
UpgradeStatus: Upgraded to quantal on 2012-08-06 (17 days ago)

Jussi Pakkanen (jpakkane) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Justin Nichols (jnichols21) wrote :

I concur, as of 8/27/2012 with all the latest updates, 12.10 has this bug on my Samsung Series 9 np900x4c ultrabook.

Jussi Pakkanen (jpakkane) wrote :

Conversely, reboot does not work when activated from the corner menu but does work from the power button menu.

Eric Shattow (eshattow) wrote :

Also happens to me. Ubuntu 12.10 on i386.
1. Press physical power button on Dell 1420n laptop computer
2. Menu appears, select "Suspend"
3. Expect computer to suspend (which does work from gear-like Unity menu and Suspend option)
What actually happens is computer does not suspend, also appears output in $HOME/.xsession-errors:
gnome-session[1921]: libupower-glib-CRITICAL: up_client_get_can_suspend: assertion `UP_IS_CLIENT (client)' failed

Bruno Santos (bsantos) wrote :

I get this after a few suspend cycles. It stops working with that error message on .xsession-errors.

Same problem with the same xsession-error: HP/Compaq NC4200, Ubuntu 12.10

Diego (gran-diego) wrote :

Same here, Dell Latitude E4300 laptop , and tree desktops (one Intel Core2 Quad/ASUS mobo and two AMD Phenom II x4/Gigabyte mobo). All off them on AMD64.

Matt Fischer (mfisch) wrote :

We have this on the Nexus7 tablet and I've seen it on my HP Elitebook laptop, I think it's safe to say this is not a hardware dependent issue.

Alex Chiang (achiang) on 2012-11-05
tags: added: mobile nexus7
Alex Chiang (achiang) on 2012-11-05
Changed in ubuntu-nexus7:
assignee: nobody → Alex Chiang (achiang)
importance: Undecided → High
status: New → Confirmed
Changed in gnome-session (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
tags: added: regression-release
Алексей (riadwaw) wrote :

By the way, if hibernation is enabled, it doesn't work via this menu too.

Diego (gran-diego) wrote :

The error shown in syslog, in hibernation failure is
libupower-glib-CRITICAL: up_client_get_can_hibernate: assertion `UP_IS_CLIENT (client)' failed

Martin Pitt (pitti) wrote :

For the record, this can be triggered without the power button with

gdbus call -e -d org.gnome.SessionManager -o /org/gnome/SessionManager -m org.gnome.SessionManager.Shutdown

That's easier to do in tests. I have not yet found yet how to synthesize XF86PowerOff with xte (or otherwise).

Martin Pitt (pitti) on 2012-11-13
Changed in gnome-session (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.6.2-0ubuntu2

---------------
gnome-session (3.6.2-0ubuntu2) raring; urgency=low

  * Add 04_consolekit_init_upower.patch: GsmConsoleKit: Properly initialize
    upower client. (LP: #1041137)
 -- Martin Pitt <email address hidden> Tue, 13 Nov 2012 11:21:28 +0100

Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
Chris J (chriscf) wrote :

Can we get this backported to Quantal please? I don't think this is something that users should be waiting 6 months for the next upgrade to get fixed.

Martin Pitt (pitti) wrote :

Sure, no problem.

Changed in gnome-session (Ubuntu Quantal):
status: New → In Progress
Martin Pitt (pitti) wrote :

Uploaded to raring-proposed queue for SRU team review.

description: updated
Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → Fix Released
Alex Chiang (achiang) wrote :

Thanks pitti!

Changed in ubuntu-nexus7:
status: Confirmed → Fix Released
importance: High → Undecided
Asif (vadud3) wrote :

Same problem on HP compaq 6730b running Ubuntu 12.10 64bit. Pressing power button and select Suspend from the menu
does not suspend. Suspend from the cog (gear) menu works fine.

Error message shows up in both .xsession-errors and syslog.

gnome-session[2736]: libupower-glib-CRITICAL: up_client_get_can_suspend: assertion `UP_IS_CLIENT (client)' failed

Nov 16 16:54:00 ghar-iqbala gnome-session[2736]: libupower-glib-CRITICAL: up_client_get_can_suspend: assertion `UP_IS_CLIENT (client)' failed

iqbala@ghar-iqbala:~$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
iqbala@ghar-iqbala:~$ sudo apt-cache policy gnome-session
[sudo] password for iqbala:
gnome-session:
  Installed: 3.6.0-0ubuntu1
  Candidate: 3.6.0-0ubuntu1
  Version table:
 *** 3.6.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
iqbala@ghar-iqbala:~$

Until official update lands to Ubuntu 12.10 Quantal here's gnome-session patched with official fix for bug #1041137

https://launchpad.net/~marko-techytalk.info/+archive/gnome-session

Diego (gran-diego) wrote :

Marko's solution works for me. Thanks!

Hello Jussi, or anyone else affected,

Accepted gnome-session into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-session/3.6.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-session (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

gnome-session in quantal-proposed fixes this issue.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.6.0-0ubuntu1.1

---------------
gnome-session (3.6.0-0ubuntu1.1) quantal-proposed; urgency=low

  * Add 04_consolekit_init_upower.patch: GsmConsoleKit: Properly initialize
    upower client. This fixes the Suspend button to actually work in the
    dialog brought up by pressing the Power button. (LP: #1041137)
 -- Martin Pitt <email address hidden> Wed, 14 Nov 2012 16:13:00 +0100

Changed in gnome-session (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.