Screensaver just detects idle time on one screen

Bug #87317 reported by Anders on 2007-02-23
120
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Medium
Unassigned
Nominated for Dapper by liju
Nominated for Jaunty by TJ

Bug Description

I've got a dual screen setup (running Nvidia's drivers and two monitors off one graphics card). When I work on one screen exclusively for the screensaver timeout amount of time, the screensaver starts dimming the screen regardless. Quick fix is to move mouse onto the other screen, which instantly stops the dimming and resets the 'countdown'. Surely the screensaver or whatever algorithm detecting idle time should be able to detect activities on whatever is the 'non primary' screen?

Anders (andersja+launchpad-net) wrote :

Xorg.conf for assisted troubleshooting

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. With which version and desktop of Ubuntu did you notice this issue? Thanks in advance.

Anders (andersja+launchpad-net) wrote :

Latest Feisty Beta, default Ubuntu/GNOME

Anders (andersja+launchpad-net) wrote :

Curiously, this remains an issue with the latest Hardy Heron.

Anders,

Did you do an upgrade of your Gutsy install or do a fresh (clean) install of Hardy?

Changed in gnome-screensaver:
importance: Undecided → Medium
Anders (andersja+launchpad-net) wrote :

Greg; I'm still on my initial install of Ubuntu, (started at Dapper 6.06) continuously upgraded to the latest and greatest... It'd be great if someone with a fresh install of Hardy could attempt to check this bug too...

This issue sounds very similar to bug 91498 . Both are about gnome-screensaver not acting based on information for the second monitor with nVidia drivers.

Maybe someone could test this with a liveCD of Hardy? http://releases.ubuntu.com/releases/8.04/

Frank Harper (frank-harper) wrote :

I have just done a fresh install of Hardy and can confirm that the problem is exactly the same. One thing that might be important is that the monitors are configured as separate X screens rather than using Twinview.

It might not make any difference, but I'm using the drivers directly from NVIDIA (version 169.12) because my GPU wasn't recognized by Hardy as being compatible.

Christian Wyglendowski (dowski) wrote :

I am running Gutsy and have this same issue. Like Frank Harper, my monitors are configured as separate X screens (not using Twinview).

The same problem here, but using an Ati X1400 card with dual-head setup (using two X screens).

Phasmus (phasmus) wrote :

I have the same trouble (and it's getting rather irksome). I'm running a fully updated 'stock' Gutsy with a GeForce 6800 on NVidia drivers. My monitors are configured as separate X screens.

My Ubuntu-forum searching found another similarly afflicted: http://ubuntuforums.org/showthread.php?t=436775

Vincent Gerris (v-gerris) wrote :

I can confirm this bug on my fresh install of 8.04 (Hardy Heron) running dual monitors with NVIDIA driver.
Using two seperate screens.

After updating to Ubuntu 8.10 and creating a new xorg.conf , the problem persists.

Gnome-screensaver seems to be causing more trouble, for example with focus on tsclient, but that is another story.
https://bugs.launchpad.net/ubuntu/+source/tsclient/+bug/48108
Thought I'd mention it, it might be related.

My xorg.conf is attached, please pm if you need more info.
For now, I just removed the gnome-screensaver package.

NVidia driver version is 177.80.

Matt Collins (mjc506) wrote :

Still an issue on a clean install of 8.10

There's quite a few issues with gnome-screensaver! Most seem to be (ime) to do with detecting mouse movement, if that helps anyone!

I can confirm this issue with ubuntu 8.10 (upgraded all the way from 7.04).

Aaron Plattner (aplattner) wrote :

I just noticed this problem and the fix seems pretty trivial, though I'm no GDK expert. I'll try to put together a PPA build later today.

Reed Meyer (rdm-tripadvisor) wrote :

Hi, I see that Aaron has posted a candidate patch. I'm not familiar with the bug cycle / code release process in the Ubuntu community. What does it take to get this patch pushed live? Is any user testing needed first? Count me among those looking forward to a release. Thanks.

Michael B. Trausch (mtrausch) wrote :

Reed,

If you could test it, that would be awesome. Having positive feedback will help to move the bug's progress forward and get the fix committed somewhere. I am no longer able to test such things since I don't have a multi-headed display system anymore. :-/

yacwroy (yacwroy) wrote :

I added the patch (took a while to figure out how).
No problems, works as stated.
No more locks when only using secondary monitor for a while.
No crashes or anything weird.
Haven't done any specific testing though.

TJ (tj) wrote :

Tested Aaron's patch with Jaunty and it appears to be working fine. I've repackaged the patch in a debdiff and am nominating for Jaunty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.24.0-0ubuntu5

---------------
gnome-screensaver (2.24.0-0ubuntu5) jaunty; urgency=low

  * Prevent screen-saver activation when X screens other than 0 are
    not idle. Packaged from Aaron Plattner's original (LP: #87317)

 -- TJ <email address hidden> Fri, 27 Feb 2009 10:23:26 +0000

Changed in gnome-screensaver:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers